Merge branch 'f16'
This commit is contained in:
commit
b6ff1d47f3
1
.gitignore
vendored
1
.gitignore
vendored
@ -49,3 +49,4 @@ cups-1.4.4-source.tar.bz2
|
|||||||
/cups-1.5b2-source.tar.bz2
|
/cups-1.5b2-source.tar.bz2
|
||||||
/cups-1.5rc1-source.tar.bz2
|
/cups-1.5rc1-source.tar.bz2
|
||||||
/cups-1.5.0-source.tar.bz2
|
/cups-1.5.0-source.tar.bz2
|
||||||
|
/cups-1.5.2-source.tar.bz2
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
diff -up cups-1.4.8/filter/image-gif.c.CVE-2011-2896 cups-1.4.8/filter/image-gif.c
|
|
||||||
--- cups-1.4.8/filter/image-gif.c.CVE-2011-2896 2011-06-20 21:37:51.000000000 +0100
|
|
||||||
+++ cups-1.4.8/filter/image-gif.c 2011-08-19 11:33:37.547911212 +0100
|
|
||||||
@@ -648,11 +648,13 @@ gif_read_lzw(FILE *fp, /* I - File to
|
|
||||||
|
|
||||||
if (code == max_code)
|
|
||||||
{
|
|
||||||
- *sp++ = firstcode;
|
|
||||||
- code = oldcode;
|
|
||||||
+ if (sp < (stack + 8192))
|
|
||||||
+ *sp++ = firstcode;
|
|
||||||
+
|
|
||||||
+ code = oldcode;
|
|
||||||
}
|
|
||||||
|
|
||||||
- while (code >= clear_code)
|
|
||||||
+ while (code >= clear_code && sp < (stack + 8192))
|
|
||||||
{
|
|
||||||
*sp++ = table[1][code];
|
|
||||||
if (code == table[0][code])
|
|
||||||
@@ -661,8 +663,10 @@ gif_read_lzw(FILE *fp, /* I - File to
|
|
||||||
code = table[0][code];
|
|
||||||
}
|
|
||||||
|
|
||||||
- *sp++ = firstcode = table[1][code];
|
|
||||||
- code = max_code;
|
|
||||||
+ if (sp < (stack + 8192))
|
|
||||||
+ *sp++ = firstcode = table[1][code];
|
|
||||||
+
|
|
||||||
+ code = max_code;
|
|
||||||
|
|
||||||
if (code < 4096)
|
|
||||||
{
|
|
@ -1,6 +1,6 @@
|
|||||||
diff -up cups-1.5.0/backend/dnssd.c.avahi-2-backend cups-1.5.0/backend/dnssd.c
|
diff -up cups-1.5.2/backend/dnssd.c.avahi-2-backend cups-1.5.2/backend/dnssd.c
|
||||||
--- cups-1.5.0/backend/dnssd.c.avahi-2-backend 2011-08-05 15:04:46.182591844 +0100
|
--- cups-1.5.2/backend/dnssd.c.avahi-2-backend 2012-02-06 11:09:08.318644741 +0100
|
||||||
+++ cups-1.5.0/backend/dnssd.c 2011-08-05 15:05:13.868710181 +0100
|
+++ cups-1.5.2/backend/dnssd.c 2012-02-06 11:09:08.326644641 +0100
|
||||||
@@ -15,14 +15,21 @@
|
@@ -15,14 +15,21 @@
|
||||||
*
|
*
|
||||||
* Contents:
|
* Contents:
|
||||||
@ -779,7 +779,7 @@ diff -up cups-1.5.0/backend/dnssd.c.avahi-2-backend cups-1.5.0/backend/dnssd.c
|
|||||||
-
|
-
|
||||||
- datalen = *data++;
|
- datalen = *data++;
|
||||||
-
|
-
|
||||||
- if (!datalen || (data + datalen) >= dataend)
|
- if (!datalen || (data + datalen) > dataend)
|
||||||
- break;
|
- break;
|
||||||
-
|
-
|
||||||
- datanext = data + datalen;
|
- datanext = data + datalen;
|
||||||
@ -841,9 +841,9 @@ diff -up cups-1.5.0/backend/dnssd.c.avahi-2-backend cups-1.5.0/backend/dnssd.c
|
|||||||
/*
|
/*
|
||||||
* 'sigterm_handler()' - Handle termination signals...
|
* 'sigterm_handler()' - Handle termination signals...
|
||||||
*/
|
*/
|
||||||
diff -up cups-1.5.0/cups/http-support.c.avahi-2-backend cups-1.5.0/cups/http-support.c
|
diff -up cups-1.5.2/cups/http-support.c.avahi-2-backend cups-1.5.2/cups/http-support.c
|
||||||
--- cups-1.5.0/cups/http-support.c.avahi-2-backend 2011-06-10 23:06:26.000000000 +0100
|
--- cups-1.5.2/cups/http-support.c.avahi-2-backend 2011-09-26 20:46:46.000000000 +0200
|
||||||
+++ cups-1.5.0/cups/http-support.c 2011-08-05 15:05:13.870710117 +0100
|
+++ cups-1.5.2/cups/http-support.c 2012-02-06 11:09:08.327644629 +0100
|
||||||
@@ -43,6 +43,10 @@
|
@@ -43,6 +43,10 @@
|
||||||
* http_copy_decode() - Copy and decode a URI.
|
* http_copy_decode() - Copy and decode a URI.
|
||||||
* http_copy_encode() - Copy and encode a URI.
|
* http_copy_encode() - Copy and encode a URI.
|
||||||
@ -998,7 +998,7 @@ diff -up cups-1.5.0/cups/http-support.c.avahi-2-backend cups-1.5.0/cups/http-sup
|
|||||||
|
|
||||||
if ((options & _HTTP_RESOLVE_STDERR) && !uri)
|
if ((options & _HTTP_RESOLVE_STDERR) && !uri)
|
||||||
_cupsLangPrintFilter(stderr, "ERROR", _("Unable to find printer."));
|
_cupsLangPrintFilter(stderr, "ERROR", _("Unable to find printer."));
|
||||||
@@ -1895,6 +1974,116 @@ http_resolve_cb(
|
@@ -1914,6 +1993,116 @@ http_resolve_cb(
|
||||||
#endif /* HAVE_DNSSD */
|
#endif /* HAVE_DNSSD */
|
||||||
|
|
||||||
|
|
||||||
@ -1113,5 +1113,5 @@ diff -up cups-1.5.0/cups/http-support.c.avahi-2-backend cups-1.5.0/cups/http-sup
|
|||||||
+
|
+
|
||||||
+
|
+
|
||||||
/*
|
/*
|
||||||
* End of "$Id: http-support.c 9820 2011-06-10 22:06:26Z mike $".
|
* End of "$Id: http-support.c 10017 2011-09-26 18:46:46Z mike $".
|
||||||
*/
|
*/
|
||||||
|
@ -1,15 +1,3 @@
|
|||||||
diff -up cups-1.5.0/cups/http.c.driverd-timeout cups-1.5.0/cups/http.c
|
|
||||||
--- cups-1.5.0/cups/http.c.driverd-timeout 2011-10-10 17:03:54.181458460 +0100
|
|
||||||
+++ cups-1.5.0/cups/http.c 2011-10-10 17:04:01.452321912 +0100
|
|
||||||
@@ -1314,7 +1314,7 @@ httpGets(char *line, /* I - Line to
|
|
||||||
* No newline; see if there is more data to be read...
|
|
||||||
*/
|
|
||||||
|
|
||||||
- while (!_httpWait(http, http->blocking ? 30000 : 10000, 1))
|
|
||||||
+ while (!_httpWait(http, http->blocking ? 70000 : 10000, 1))
|
|
||||||
{
|
|
||||||
if (http->timeout_cb && (*http->timeout_cb)(http, http->timeout_data))
|
|
||||||
continue;
|
|
||||||
diff -up cups-1.5.0/scheduler/ipp.c.driverd-timeout cups-1.5.0/scheduler/ipp.c
|
diff -up cups-1.5.0/scheduler/ipp.c.driverd-timeout cups-1.5.0/scheduler/ipp.c
|
||||||
--- cups-1.5.0/scheduler/ipp.c.driverd-timeout 2011-10-10 17:03:41.801690962 +0100
|
--- cups-1.5.0/scheduler/ipp.c.driverd-timeout 2011-10-10 17:03:41.801690962 +0100
|
||||||
+++ cups-1.5.0/scheduler/ipp.c 2011-10-10 17:03:41.861689834 +0100
|
+++ cups-1.5.0/scheduler/ipp.c 2011-10-10 17:03:41.861689834 +0100
|
||||||
|
@ -1222,10 +1222,10 @@ diff -up cups-1.5b2/scheduler/client.c.lspp cups-1.5b2/scheduler/client.c
|
|||||||
--- cups-1.5b2/scheduler/client.c.lspp 2011-05-31 18:29:01.327890576 +0200
|
--- cups-1.5b2/scheduler/client.c.lspp 2011-05-31 18:29:01.327890576 +0200
|
||||||
+++ cups-1.5b2/scheduler/client.c 2011-05-31 18:29:01.364890113 +0200
|
+++ cups-1.5b2/scheduler/client.c 2011-05-31 18:29:01.364890113 +0200
|
||||||
@@ -44,6 +44,7 @@
|
@@ -44,6 +44,7 @@
|
||||||
* valid_host() - Is the Host: field valid?
|
* valid_host() - Is the Host: field valid?
|
||||||
* write_file() - Send a file via HTTP.
|
* write_file() - Send a file via HTTP.
|
||||||
* write_pipe() - Flag that data is available on the CGI pipe.
|
* write_pipe() - Flag that data is available on the CGI pipe.
|
||||||
+ * client_pid_to_auid() - Get the audit login uid of the client.
|
+ * client_pid_to_auid() - Get the audit login uid of the client.
|
||||||
*/
|
*/
|
||||||
|
|
||||||
/*
|
/*
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff -up cups-1.5.0/cups/ppd-cache.c.ps-command-filter cups-1.5.0/cups/ppd-cache.c
|
|
||||||
--- cups-1.5.0/cups/ppd-cache.c.ps-command-filter 2011-11-04 13:10:34.405729542 +0000
|
|
||||||
+++ cups-1.5.0/cups/ppd-cache.c 2011-11-04 13:11:58.502184096 +0000
|
|
||||||
@@ -1272,7 +1272,8 @@ _ppdCacheCreateWithPPD(ppd_file_t *ppd)
|
|
||||||
|
|
||||||
if (filter)
|
|
||||||
cupsArrayAdd(pc->filters,
|
|
||||||
- "application/vnd.cups-command application/postscript 0 -");
|
|
||||||
+ "application/vnd.cups-command application/postscript 100 "
|
|
||||||
+ "commandtops");
|
|
||||||
}
|
|
||||||
|
|
||||||
if ((ppd_attr = ppdFindAttr(ppd, "cupsPreFilter", NULL)) != NULL)
|
|
@ -1,6 +1,6 @@
|
|||||||
diff -up cups-1.5b1/backend/snmp-supplies.c.snmp-quirks cups-1.5b1/backend/snmp-supplies.c
|
diff -up cups-1.5.2/backend/snmp-supplies.c.snmp-quirks cups-1.5.2/backend/snmp-supplies.c
|
||||||
--- cups-1.5b1/backend/snmp-supplies.c.snmp-quirks 2011-05-20 05:49:49.000000000 +0200
|
--- cups-1.5.2/backend/snmp-supplies.c.snmp-quirks 2011-10-07 23:41:07.000000000 +0200
|
||||||
+++ cups-1.5b1/backend/snmp-supplies.c 2011-05-24 17:15:55.000000000 +0200
|
+++ cups-1.5.2/backend/snmp-supplies.c 2012-02-06 10:48:47.543906526 +0100
|
||||||
@@ -47,6 +47,13 @@
|
@@ -47,6 +47,13 @@
|
||||||
|
|
||||||
|
|
||||||
@ -59,7 +59,7 @@ diff -up cups-1.5b1/backend/snmp-supplies.c.snmp-quirks cups-1.5b1/backend/snmp-
|
|||||||
+ if (quirks & QUIRK_CAPACITY)
|
+ if (quirks & QUIRK_CAPACITY)
|
||||||
+ supplies[i].max_capacity = 100;
|
+ supplies[i].max_capacity = 100;
|
||||||
+
|
+
|
||||||
if (supplies[i].max_capacity > 0)
|
if (supplies[i].max_capacity > 0 && supplies[i].level >= 0)
|
||||||
percent = 100 * supplies[i].level / supplies[i].max_capacity;
|
percent = 100 * supplies[i].level / supplies[i].max_capacity;
|
||||||
else
|
else
|
||||||
@@ -401,6 +427,7 @@ backend_init_supplies(
|
@@ -401,6 +427,7 @@ backend_init_supplies(
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
diff -up cups-1.5.0/scheduler/cups-driverd.cxx.str3921 cups-1.5.0/scheduler/cups-driverd.cxx
|
|
||||||
--- cups-1.5.0/scheduler/cups-driverd.cxx.str3921 2011-06-08 22:19:11.000000000 +0100
|
|
||||||
+++ cups-1.5.0/scheduler/cups-driverd.cxx 2011-10-11 12:07:34.979538544 +0100
|
|
||||||
@@ -1411,9 +1411,7 @@ load_drv(const char *filename, /* I -
|
|
||||||
* Add a dummy entry for the file...
|
|
||||||
*/
|
|
||||||
|
|
||||||
- httpAssembleURIf(HTTP_URI_CODING_ALL, uri, sizeof(uri), "drv", "", "", 0,
|
|
||||||
- "/%s", name);
|
|
||||||
- add_ppd(name, uri, "", "", "", "", "", "", mtime, size, 0,
|
|
||||||
+ add_ppd(name, name, "", "", "", "", "", "", mtime, size, 0,
|
|
||||||
PPD_TYPE_DRV, "drv");
|
|
||||||
ChangedPPD = 1;
|
|
||||||
|
|
@ -1,26 +0,0 @@
|
|||||||
diff -up cups-1.5.0/notifier/dbus.c.str3947 cups-1.5.0/notifier/dbus.c
|
|
||||||
--- cups-1.5.0/notifier/dbus.c.str3947 2011-03-04 16:55:59.000000000 +0000
|
|
||||||
+++ cups-1.5.0/notifier/dbus.c 2011-09-28 10:42:56.298760622 +0100
|
|
||||||
@@ -4,7 +4,7 @@
|
|
||||||
* D-Bus notifier for CUPS.
|
|
||||||
*
|
|
||||||
* Copyright 2008-2010 by Apple Inc.
|
|
||||||
- * Copyright (C) 2007 Red Hat, Inc.
|
|
||||||
+ * Copyright (C) 2011 Red Hat, Inc.
|
|
||||||
* Copyright (C) 2007 Tim Waugh <twaugh@redhat.com>
|
|
||||||
* Copyright 1997-2005 by Easy Software Products.
|
|
||||||
*
|
|
||||||
@@ -423,10 +423,11 @@ main(int argc, /* I - Number of comm
|
|
||||||
p = printer_reasons;
|
|
||||||
for (i = 0; i < attr->num_values; i++)
|
|
||||||
{
|
|
||||||
- strcpy(p, attr->values[i].string.text);
|
|
||||||
- p += strlen(p);
|
|
||||||
if (i)
|
|
||||||
*p++ = ',';
|
|
||||||
+
|
|
||||||
+ strcpy(p, attr->values[i].string.text);
|
|
||||||
+ p += strlen(p);
|
|
||||||
}
|
|
||||||
dbus_message_iter_append_string(&iter, &printer_reasons);
|
|
||||||
}
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up cups-1.5.0/scripting/php/phpcups.c.orig cups-1.5.0/scripting/php/phpcups.c
|
|
||||||
--- cups-1.5.0/scripting/php/phpcups.c.orig 2011-12-27 16:54:21.520359399 +0100
|
|
||||||
+++ cups-1.5.0/scripting/php/phpcups.c 2011-12-27 16:54:55.461360314 +0100
|
|
||||||
@@ -40,7 +40,7 @@
|
|
||||||
* PHP function list...
|
|
||||||
*/
|
|
||||||
|
|
||||||
-function_entry phpcups_functions[] =
|
|
||||||
+zend_function_entry phpcups_functions[] =
|
|
||||||
{
|
|
||||||
PHP_FE(cups_cancel_job, NULL)
|
|
||||||
PHP_FE(cups_get_dests, NULL)
|
|
@ -1,13 +0,0 @@
|
|||||||
diff -up cups-1.5.0/backend/snmp.c.snmp-bad-uri cups-1.5.0/backend/snmp.c
|
|
||||||
--- cups-1.5.0/backend/snmp.c.snmp-bad-uri 2012-01-17 11:51:00.786457690 +0000
|
|
||||||
+++ cups-1.5.0/backend/snmp.c 2012-01-17 11:51:57.123384361 +0000
|
|
||||||
@@ -1120,7 +1120,8 @@ read_snmp_response(int fd) /* I - SNMP
|
|
||||||
|
|
||||||
case DEVICE_URI :
|
|
||||||
if (device && packet.object_type == CUPS_ASN1_OCTET_STRING &&
|
|
||||||
- !device->uri && packet.object_value.string.num_bytes > 0)
|
|
||||||
+ !device->uri && packet.object_value.string.num_bytes > 3 &&
|
|
||||||
+ strlen ((char *)packet.object_value.string.bytes) > 3)
|
|
||||||
{
|
|
||||||
/*
|
|
||||||
* Update an existing cache entry...
|
|
@ -1,25 +0,0 @@
|
|||||||
diff -up cups-1.5.0/cups/backend.c.backend-bad-id cups-1.5.0/cups/backend.c
|
|
||||||
--- cups-1.5.0/cups/backend.c.backend-bad-id 2011-04-29 23:45:35.000000000 +0100
|
|
||||||
+++ cups-1.5.0/cups/backend.c 2012-01-17 12:23:13.687442534 +0000
|
|
||||||
@@ -110,7 +110,8 @@ cupsBackendReport(
|
|
||||||
|
|
||||||
|
|
||||||
/*
|
|
||||||
- * 'quote_string()' - Write a quoted string to stdout, escaping \ and ".
|
|
||||||
+ * 'quote_string()' - Write a quoted string to stdout, escaping \ and ",
|
|
||||||
+ * and replacing newline with space.
|
|
||||||
*/
|
|
||||||
|
|
||||||
static void
|
|
||||||
@@ -125,7 +126,10 @@ quote_string(const char *s) /* I - Stri
|
|
||||||
if (*s == '\\' || *s == '\"')
|
|
||||||
putchar('\\');
|
|
||||||
|
|
||||||
- putchar(*s);
|
|
||||||
+ if (*s == '\n')
|
|
||||||
+ putchar(' ');
|
|
||||||
+ else
|
|
||||||
+ putchar(*s);
|
|
||||||
|
|
||||||
s ++;
|
|
||||||
}
|
|
55
cups.spec
55
cups.spec
@ -18,8 +18,8 @@
|
|||||||
|
|
||||||
Summary: Common Unix Printing System
|
Summary: Common Unix Printing System
|
||||||
Name: cups
|
Name: cups
|
||||||
Version: 1.5.0
|
Version: 1.5.2
|
||||||
Release: 28%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: http://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
Source: http://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
||||||
@ -62,7 +62,6 @@ Patch20: cups-filter-debug.patch
|
|||||||
Patch21: cups-uri-compat.patch
|
Patch21: cups-uri-compat.patch
|
||||||
Patch22: cups-cups-get-classes.patch
|
Patch22: cups-cups-get-classes.patch
|
||||||
Patch23: cups-str3382.patch
|
Patch23: cups-str3382.patch
|
||||||
Patch24: cups-str3947.patch
|
|
||||||
Patch25: cups-0755.patch
|
Patch25: cups-0755.patch
|
||||||
Patch26: cups-snmp-quirks.patch
|
Patch26: cups-snmp-quirks.patch
|
||||||
Patch27: cups-hp-deviceid-oid.patch
|
Patch27: cups-hp-deviceid-oid.patch
|
||||||
@ -77,12 +76,6 @@ Patch34: cups-avahi-5-services.patch
|
|||||||
|
|
||||||
Patch35: cups-icc.patch
|
Patch35: cups-icc.patch
|
||||||
Patch36: cups-systemd-socket.patch
|
Patch36: cups-systemd-socket.patch
|
||||||
Patch37: cups-CVE-2011-2896.patch
|
|
||||||
Patch38: cups-str3921.patch
|
|
||||||
Patch39: cups-ps-command-filter.patch
|
|
||||||
Patch40: cups-str4004.patch
|
|
||||||
Patch41: cups-str4005.patch
|
|
||||||
Patch42: cups-str3999.patch
|
|
||||||
|
|
||||||
Patch100: cups-lspp.patch
|
Patch100: cups-lspp.patch
|
||||||
|
|
||||||
@ -255,7 +248,7 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
|
|||||||
%patch12 -p1 -b .eggcups
|
%patch12 -p1 -b .eggcups
|
||||||
# More sophisticated implementation of cupsGetPassword than getpass.
|
# More sophisticated implementation of cupsGetPassword than getpass.
|
||||||
%patch13 -p1 -b .getpass
|
%patch13 -p1 -b .getpass
|
||||||
# Increase driverd timeout to 70s to accommodate foomatic.
|
# Increase driverd timeout to 70s to accommodate foomatic (bug #744715).
|
||||||
%patch14 -p1 -b .driverd-timeout
|
%patch14 -p1 -b .driverd-timeout
|
||||||
# Only enforce maximum PPD line length when in strict mode.
|
# Only enforce maximum PPD line length when in strict mode.
|
||||||
%patch15 -p1 -b .strict-ppd-line-length
|
%patch15 -p1 -b .strict-ppd-line-length
|
||||||
@ -275,8 +268,6 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
|
|||||||
%patch22 -p1 -b .cups-get-classes
|
%patch22 -p1 -b .cups-get-classes
|
||||||
# Fix temporary filename creation.
|
# Fix temporary filename creation.
|
||||||
%patch23 -p1 -b .str3382
|
%patch23 -p1 -b .str3382
|
||||||
# Fixed string manipulation in the dbus notifier (STR #3947, bug #741833).
|
|
||||||
%patch24 -p1 -b .str3947
|
|
||||||
# Use mode 0755 for binaries and libraries where appropriate.
|
# Use mode 0755 for binaries and libraries where appropriate.
|
||||||
%patch25 -p1 -b .0755
|
%patch25 -p1 -b .0755
|
||||||
# Handle SNMP supply level quirks (bug #581825).
|
# Handle SNMP supply level quirks (bug #581825).
|
||||||
@ -304,27 +295,6 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
|
|||||||
# Poettering).
|
# Poettering).
|
||||||
%patch36 -p1 -b .systemd-socket
|
%patch36 -p1 -b .systemd-socket
|
||||||
|
|
||||||
# Avoid GIF reader loop (CVE-2011-2896, STR #3914, bug #727800).
|
|
||||||
%patch37 -p1 -b .CVE-2011-2896
|
|
||||||
|
|
||||||
# Work around PPDs cache handling issue (bug #742989).
|
|
||||||
%patch38 -p1 -b .str3921
|
|
||||||
|
|
||||||
# Set the correct PostScript command filter for e.g. foomatic queues
|
|
||||||
# (STR #3973).
|
|
||||||
%patch39 -p1 -b .ps-command-filter
|
|
||||||
|
|
||||||
# Don't accept Device URIs of '\0' from SNMP devices
|
|
||||||
# (bug #770646, STR #4004).
|
|
||||||
%patch40 -p1 -b .str4004
|
|
||||||
|
|
||||||
# Replace newline characters with spaces in reported Device IDs
|
|
||||||
# (bug #782129, STR #4005).
|
|
||||||
%patch41 -p1 -b .str4005
|
|
||||||
|
|
||||||
# Build against PHP 5.4.0 (STR #3999)
|
|
||||||
%patch42 -p1 -b .str3999
|
|
||||||
|
|
||||||
%if %lspp
|
%if %lspp
|
||||||
# LSPP support.
|
# LSPP support.
|
||||||
%patch100 -p1 -b .lspp
|
%patch100 -p1 -b .lspp
|
||||||
@ -582,6 +552,8 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc %{_datadir}/%{name}/www/de/index.html
|
%doc %{_datadir}/%{name}/www/de/index.html
|
||||||
%doc %{_datadir}/%{name}/www/es/index.html
|
%doc %{_datadir}/%{name}/www/es/index.html
|
||||||
%doc %{_datadir}/%{name}/www/eu/index.html
|
%doc %{_datadir}/%{name}/www/eu/index.html
|
||||||
|
%doc %{_datadir}/%{name}/www/fr/index.html
|
||||||
|
%doc %{_datadir}/%{name}/www/hu/index.html
|
||||||
%doc %{_datadir}/%{name}/www/id/index.html
|
%doc %{_datadir}/%{name}/www/id/index.html
|
||||||
%doc %{_datadir}/%{name}/www/it/index.html
|
%doc %{_datadir}/%{name}/www/it/index.html
|
||||||
%doc %{_datadir}/%{name}/www/ja/index.html
|
%doc %{_datadir}/%{name}/www/ja/index.html
|
||||||
@ -625,6 +597,8 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/cups/templates/de/*.tmpl
|
%{_datadir}/cups/templates/de/*.tmpl
|
||||||
%{_datadir}/cups/templates/es/*.tmpl
|
%{_datadir}/cups/templates/es/*.tmpl
|
||||||
%{_datadir}/cups/templates/eu/*.tmpl
|
%{_datadir}/cups/templates/eu/*.tmpl
|
||||||
|
%{_datadir}/cups/templates/fr/*.tmpl
|
||||||
|
%{_datadir}/cups/templates/hu/*.tmpl
|
||||||
%{_datadir}/cups/templates/id/*.tmpl
|
%{_datadir}/cups/templates/id/*.tmpl
|
||||||
%{_datadir}/cups/templates/it/*.tmpl
|
%{_datadir}/cups/templates/it/*.tmpl
|
||||||
%{_datadir}/cups/templates/ja/*.tmpl
|
%{_datadir}/cups/templates/ja/*.tmpl
|
||||||
@ -676,19 +650,14 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/ipptool
|
%{_bindir}/ipptool
|
||||||
%dir %{_datadir}/cups/ipptool
|
%dir %{_datadir}/cups/ipptool
|
||||||
%{_datadir}/cups/ipptool/create-printer-subscription.test
|
%{_datadir}/cups/ipptool/*
|
||||||
%{_datadir}/cups/ipptool/get-completed-jobs.test
|
|
||||||
%{_datadir}/cups/ipptool/get-jobs.test
|
|
||||||
%{_datadir}/cups/ipptool/ipp-1.1.test
|
|
||||||
%{_datadir}/cups/ipptool/ipp-2.0.test
|
|
||||||
%{_datadir}/cups/ipptool/ipp-2.1.test
|
|
||||||
%{_datadir}/cups/ipptool/testfile.jpg
|
|
||||||
%{_datadir}/cups/ipptool/testfile.pdf
|
|
||||||
%{_datadir}/cups/ipptool/testfile.ps
|
|
||||||
%{_datadir}/cups/ipptool/testfile.txt
|
|
||||||
%{_mandir}/man1/ipptool.1.gz
|
%{_mandir}/man1/ipptool.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 06 2012 Jiri Popelka <jpopelka@redhat.com> 1:1.5.2-1
|
||||||
|
- 1.5.2
|
||||||
|
- Updated FSF address in pstopdf and textonly filters
|
||||||
|
|
||||||
* Wed Jan 18 2012 Remi Collet <remi@fedoraproject.org> 1:1.5.0-28
|
* Wed Jan 18 2012 Remi Collet <remi@fedoraproject.org> 1:1.5.0-28
|
||||||
- build against php 5.4.0, patch for STR #3999
|
- build against php 5.4.0, patch for STR #3999
|
||||||
- add filter to fix private-shared-object-provides
|
- add filter to fix private-shared-object-provides
|
||||||
|
11
pstopdf
11
pstopdf
@ -5,10 +5,10 @@
|
|||||||
# Copyright 2001-2002 by Easy Software Products.
|
# Copyright 2001-2002 by Easy Software Products.
|
||||||
# Copyright 2006 by Hewlett-Packard Development Company, L.P.
|
# Copyright 2006 by Hewlett-Packard Development Company, L.P.
|
||||||
#
|
#
|
||||||
# This program is free software; you can redistribute it and/or modify
|
# This program is free software; you can redistribute it and/or
|
||||||
# it under the terms of the GNU General Public License as published by
|
# modify it under the terms of the GNU General Public License
|
||||||
# the Free Software Foundation; either version 2, or (at your option)
|
# as published by the Free Software Foundation; either version 2
|
||||||
# any later version.
|
# of the License, or (at your option) any later version.
|
||||||
#
|
#
|
||||||
# This program is distributed in the hope that it will be useful,
|
# This program is distributed in the hope that it will be useful,
|
||||||
# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
@ -17,8 +17,7 @@
|
|||||||
#
|
#
|
||||||
# You should have received a copy of the GNU General Public License
|
# You should have received a copy of the GNU General Public License
|
||||||
# along with this program; if not, write to the Free Software
|
# along with this program; if not, write to the Free Software
|
||||||
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
|
||||||
#
|
|
||||||
|
|
||||||
# Installation directories...
|
# Installation directories...
|
||||||
prefix=/usr
|
prefix=/usr
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
e54ed09ede2340fc3014913333520fe4 cups-1.5.0-source.tar.bz2
|
9471d2a7c920cfbb17133c32d2e6866f cups-1.5.2-source.tar.bz2
|
||||||
|
@ -5,10 +5,10 @@
|
|||||||
## Added support for page-ranges option.
|
## Added support for page-ranges option.
|
||||||
## Added page accounting.
|
## Added page accounting.
|
||||||
|
|
||||||
## This program is free software; you can redistribute it and/or modify
|
## This program is free software; you can redistribute it and/or
|
||||||
## it under the terms of the GNU General Public License as published by
|
## modify it under the terms of the GNU General Public License
|
||||||
## the Free Software Foundation; either version 2 of the License, or
|
## as published by the Free Software Foundation; either version 2
|
||||||
## (at your option) any later version.
|
## of the License, or (at your option) any later version.
|
||||||
|
|
||||||
## This program is distributed in the hope that it will be useful,
|
## This program is distributed in the hope that it will be useful,
|
||||||
## but WITHOUT ANY WARRANTY; without even the implied warranty of
|
## but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
@ -17,7 +17,7 @@
|
|||||||
|
|
||||||
## You should have received a copy of the GNU General Public License
|
## You should have received a copy of the GNU General Public License
|
||||||
## along with this program; if not, write to the Free Software
|
## along with this program; if not, write to the Free Software
|
||||||
## Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
|
## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
|
||||||
|
|
||||||
if [ $# == 0 ]; then
|
if [ $# == 0 ]; then
|
||||||
echo >&2 "ERROR: $0 job-id user title copies options [file]"
|
echo >&2 "ERROR: $0 job-id user title copies options [file]"
|
||||||
|
Loading…
Reference in New Issue
Block a user