Merge branch 'f13' into f14
This commit is contained in:
commit
b6d77d523b
@ -1,22 +0,0 @@
|
|||||||
diff -up cups-1.4.6/backend/runloop.c.usb-buffer-size cups-1.4.6/backend/runloop.c
|
|
||||||
--- cups-1.4.6/backend/runloop.c.usb-buffer-size 2011-01-10 15:37:56.885677732 +0000
|
|
||||||
+++ cups-1.4.6/backend/runloop.c 2011-01-10 15:37:59.499623140 +0000
|
|
||||||
@@ -45,7 +45,7 @@ backendDrainOutput(int print_fd, /* I -
|
|
||||||
fd_set input; /* Input set for reading */
|
|
||||||
ssize_t print_bytes, /* Print bytes read */
|
|
||||||
bytes; /* Bytes written */
|
|
||||||
- char print_buffer[8192], /* Print data buffer */
|
|
||||||
+ char print_buffer[512], /* Print data buffer */
|
|
||||||
*print_ptr; /* Pointer into print data buffer */
|
|
||||||
struct timeval timeout; /* Timeout for read... */
|
|
||||||
|
|
||||||
@@ -160,7 +160,7 @@ backendRunLoop(
|
|
||||||
bytes; /* Bytes written */
|
|
||||||
int paperout; /* "Paper out" status */
|
|
||||||
int offline; /* "Off-line" status */
|
|
||||||
- char print_buffer[8192], /* Print data buffer */
|
|
||||||
+ char print_buffer[512], /* Print data buffer */
|
|
||||||
*print_ptr, /* Pointer into print data buffer */
|
|
||||||
bc_buffer[1024]; /* Back-channel data buffer */
|
|
||||||
struct timeval timeout; /* Timeout for select() */
|
|
||||||
diff -up cups-1.4.6/backend/usb.c.usb-buffer-size cups-1.4.6/backend/usb.c
|
|
10
cups.spec
10
cups.spec
@ -8,7 +8,7 @@
|
|||||||
Summary: Common Unix Printing System
|
Summary: Common Unix Printing System
|
||||||
Name: cups
|
Name: cups
|
||||||
Version: 1.4.6
|
Version: 1.4.6
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: http://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
Source: http://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
||||||
@ -67,7 +67,6 @@ Patch36: cups-ricoh-deviceid-oid.patch
|
|||||||
Patch37: cups-texttops-rotate-page.patch
|
Patch37: cups-texttops-rotate-page.patch
|
||||||
Patch38: cups-autotype-crash.patch
|
Patch38: cups-autotype-crash.patch
|
||||||
Patch39: cups-str3754.patch
|
Patch39: cups-str3754.patch
|
||||||
Patch40: cups-usb-buffer-size.patch
|
|
||||||
|
|
||||||
Patch100: cups-lspp.patch
|
Patch100: cups-lspp.patch
|
||||||
|
|
||||||
@ -277,8 +276,6 @@ module.
|
|||||||
%patch38 -p1 -b .autotype-crash
|
%patch38 -p1 -b .autotype-crash
|
||||||
# Don't crash when job queued for printer that times out (bug #660604).
|
# Don't crash when job queued for printer that times out (bug #660604).
|
||||||
%patch39 -p1 -b .str3754
|
%patch39 -p1 -b .str3754
|
||||||
# Use a smaller buffer when writing to USB devices (bug #617208).
|
|
||||||
%patch40 -p1 -b .usb-buffer-size
|
|
||||||
|
|
||||||
%if %lspp
|
%if %lspp
|
||||||
# LSPP support.
|
# LSPP support.
|
||||||
@ -576,12 +573,15 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{php_extdir}/phpcups.so
|
%{php_extdir}/phpcups.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 10 2011 Jiri Popelka <jpopelka@redhat.com> 1:1.4.6-4
|
||||||
|
- Remove testing cups-usb-buffer-size.patch (bug #661814).
|
||||||
|
|
||||||
* Tue Jan 18 2011 Tim Waugh <twaugh@redhat.com> 1:1.4.6-3
|
* Tue Jan 18 2011 Tim Waugh <twaugh@redhat.com> 1:1.4.6-3
|
||||||
- Don't use --enable-pie configure option as it has been removed and
|
- Don't use --enable-pie configure option as it has been removed and
|
||||||
is now assumed. See STR #3691.
|
is now assumed. See STR #3691.
|
||||||
|
|
||||||
* Mon Jan 10 2011 Tim Waugh <twaugh@redhat.com> 1:1.4.6-2
|
* Mon Jan 10 2011 Tim Waugh <twaugh@redhat.com> 1:1.4.6-2
|
||||||
- Use a smaller buffer when writing to USB devices (bug #617208).
|
- Use a smaller buffer when writing to USB devices (bug #661814).
|
||||||
- Handle EAI_NONAME when resolving hostnames (bug #617208).
|
- Handle EAI_NONAME when resolving hostnames (bug #617208).
|
||||||
|
|
||||||
* Fri Jan 07 2011 Jiri Popelka <jpopelka@redhat.com> 1:1.4.6-1
|
* Fri Jan 07 2011 Jiri Popelka <jpopelka@redhat.com> 1:1.4.6-1
|
||||||
|
Loading…
Reference in New Issue
Block a user