2239982 - cups-2.4.7 is available
This commit is contained in:
parent
6ec0fd19d8
commit
abbee104ee
1
.gitignore
vendored
1
.gitignore
vendored
@ -101,3 +101,4 @@ cups-1.4.4-source.tar.bz2
|
|||||||
/cups-2.4.4-source.tar.gz
|
/cups-2.4.4-source.tar.gz
|
||||||
/cups-2.4.5-source.tar.gz
|
/cups-2.4.5-source.tar.gz
|
||||||
/cups-2.4.6-source.tar.gz
|
/cups-2.4.6-source.tar.gz
|
||||||
|
/cups-2.4.7-source.tar.gz
|
||||||
|
@ -1,41 +0,0 @@
|
|||||||
From d82c43db87ac421ad9830c77342ad68b1d4d20c3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Bryan Mason <bmason@redhat.com>
|
|
||||||
Date: Sat, 24 Jun 2023 12:31:23 -0700
|
|
||||||
Subject: [PATCH 1/2] Fix delays printing to lpd when reserved ports are
|
|
||||||
exhausted
|
|
||||||
|
|
||||||
cups_rresvport() doesn't reserve ports less than 512; however,
|
|
||||||
lpd_queue() continues decrementing the port number to 0. This leads
|
|
||||||
to delays of ~511 seconds once all ports between 512-1023 are
|
|
||||||
exhausted. Even when ports become available, lpd_queue() still tries
|
|
||||||
calling cups_rresvport() with port numbers less than 512, waiting one
|
|
||||||
second between each call.
|
|
||||||
---
|
|
||||||
backend/lpd.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/backend/lpd.c b/backend/lpd.c
|
|
||||||
index a7a44ab20..425b8512a 100644
|
|
||||||
--- a/backend/lpd.c
|
|
||||||
+++ b/backend/lpd.c
|
|
||||||
@@ -63,7 +63,7 @@ static int abort_job = 0; /* Non-zero if we get SIGTERM */
|
|
||||||
|
|
||||||
#define RESERVE_NONE 0 /* Don't reserve a privileged port */
|
|
||||||
#define RESERVE_RFC1179 1 /* Reserve port 721-731 */
|
|
||||||
-#define RESERVE_ANY 2 /* Reserve port 1-1023 */
|
|
||||||
+#define RESERVE_ANY 2 /* Reserve port 512-1023 */
|
|
||||||
|
|
||||||
|
|
||||||
/*
|
|
||||||
@@ -775,7 +775,7 @@ lpd_queue(const char *hostname, /* I - Host to connect to */
|
|
||||||
|
|
||||||
if (lport < 721 && reserve == RESERVE_RFC1179)
|
|
||||||
lport = 731;
|
|
||||||
- else if (lport < 1)
|
|
||||||
+ else if (lport < 512)
|
|
||||||
lport = 1023;
|
|
||||||
|
|
||||||
#ifdef HAVE_GETEUID
|
|
||||||
--
|
|
||||||
2.41.0
|
|
||||||
|
|
12
cups.spec
12
cups.spec
@ -21,8 +21,8 @@
|
|||||||
Summary: CUPS printing system
|
Summary: CUPS printing system
|
||||||
Name: cups
|
Name: cups
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.4.6
|
Version: 2.4.7
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
# backend/failover.c - BSD-3-Clause
|
# backend/failover.c - BSD-3-Clause
|
||||||
# cups/md5* - Zlib
|
# cups/md5* - Zlib
|
||||||
# scheduler/colorman.c - Apache-2.0 WITH LLVM-exception AND BSD-2-Clause
|
# scheduler/colorman.c - Apache-2.0 WITH LLVM-exception AND BSD-2-Clause
|
||||||
@ -84,9 +84,6 @@ Patch100: cups-lspp.patch
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
#### UPSTREAM PATCHES (starts with 1000) ####
|
#### UPSTREAM PATCHES (starts with 1000) ####
|
||||||
# https://github.com/OpenPrinting/cups/pull/741
|
|
||||||
# 2218123 - Delays printing to lpd when reserved ports are exhausted
|
|
||||||
Patch1000: 0001-Fix-delays-printing-to-lpd-when-reserved-ports-are-e.patch
|
|
||||||
# https://github.com/OpenPrinting/cups/pull/742
|
# https://github.com/OpenPrinting/cups/pull/742
|
||||||
# 2218124 - The command "cancel -x <job>" does not remove job files
|
# 2218124 - The command "cancel -x <job>" does not remove job files
|
||||||
Patch1001: 0001-Use-purge-job-instead-of-purge-jobs-when-canceling-a.patch
|
Patch1001: 0001-Use-purge-job-instead-of-purge-jobs-when-canceling-a.patch
|
||||||
@ -312,8 +309,6 @@ to CUPS daemon. This solution will substitute printer drivers and raw queues in
|
|||||||
%patch -P 13 -p1 -b .dymo-deviceid
|
%patch -P 13 -p1 -b .dymo-deviceid
|
||||||
|
|
||||||
# UPSTREAM PATCHES
|
# UPSTREAM PATCHES
|
||||||
# 2218123 - Delays printing to lpd when reserved ports are exhausted
|
|
||||||
%patch -P 1000 -p1 -b .lpd-delay
|
|
||||||
# 2218124 - The command "cancel -x <job>" does not remove job files
|
# 2218124 - The command "cancel -x <job>" does not remove job files
|
||||||
%patch -P 1001 -p1 -b .purge-job
|
%patch -P 1001 -p1 -b .purge-job
|
||||||
|
|
||||||
@ -788,6 +783,9 @@ rm -f %{cups_serverbin}/backend/smb
|
|||||||
%{_mandir}/man7/ippeveps.7.gz
|
%{_mandir}/man7/ippeveps.7.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 20 2023 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.4.7-1
|
||||||
|
- 2239982 - cups-2.4.7 is available
|
||||||
|
|
||||||
* Mon Sep 11 2023 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.4.6-6
|
* Mon Sep 11 2023 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.4.6-6
|
||||||
- use unified __python macro
|
- use unified __python macro
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (cups-2.4.6-source.tar.gz) = eb748680a748f599e4826c17054a24259d190e6c8e8339f6a7a37ee2a3f4c3fd1829e856b25a854cfdbee1b51279c70a0e847f6142225b8b68f1cd10c4ce4ce4
|
SHA512 (cups-2.4.7-source.tar.gz) = 914b574ff6d85de9f3471528b52d4a436c484c441f47651846e1bdfa00aec26774efd416ff466216d2bccf468f8a797b1e0d666b5c82abc87e77550ce8b00d39
|
||||||
|
Loading…
Reference in New Issue
Block a user