Updated colord patch with fixes from Tim Waugh.
This commit is contained in:
parent
a0358da130
commit
ab7ce8068f
@ -1,17 +1,18 @@
|
|||||||
From f8907dde0b21af7e78ed208bd850119715af4bfc Mon Sep 17 00:00:00 2001
|
From 7a8aceb1e8585410e3fca17c2e349877915dfdac Mon Sep 17 00:00:00 2001
|
||||||
From: Richard Hughes <richard@hughsie.com>
|
From: Richard Hughes <richard@hughsie.com>
|
||||||
Date: Tue, 1 Mar 2011 16:05:48 +0000
|
Date: Tue, 1 Mar 2011 16:05:48 +0000
|
||||||
Subject: [PATCH] Add colord support to CUPS which allows Linux printers to be
|
Subject: [PATCH] Add colord support to CUPS which allows Linux printers to be
|
||||||
color managed
|
color managed
|
||||||
|
|
||||||
|
This functionality is possible because of lots of help from Tim Waugh -- thanks!
|
||||||
---
|
---
|
||||||
scheduler/Makefile | 1 +
|
scheduler/Makefile | 1 +
|
||||||
scheduler/colord.c | 678 ++++++++++++++++++++++++++++++++++++++++++++++++++
|
scheduler/colord.c | 682 ++++++++++++++++++++++++++++++++++++++++++++++++++
|
||||||
scheduler/colord.h | 22 ++
|
scheduler/colord.h | 22 ++
|
||||||
scheduler/ipp.c | 18 ++-
|
scheduler/ipp.c | 18 ++-
|
||||||
scheduler/printers.c | 69 +++++
|
scheduler/printers.c | 69 +++++
|
||||||
scheduler/printers.h | 4 +
|
scheduler/printers.h | 4 +
|
||||||
6 files changed, 789 insertions(+), 3 deletions(-)
|
6 files changed, 793 insertions(+), 3 deletions(-)
|
||||||
create mode 100644 scheduler/colord.c
|
create mode 100644 scheduler/colord.c
|
||||||
create mode 100644 scheduler/colord.h
|
create mode 100644 scheduler/colord.h
|
||||||
|
|
||||||
@ -29,10 +30,10 @@ index 3c7da8e..b9c47d3 100644
|
|||||||
log.o \
|
log.o \
|
||||||
diff --git a/scheduler/colord.c b/scheduler/colord.c
|
diff --git a/scheduler/colord.c b/scheduler/colord.c
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..6c60237
|
index 0000000..e420a6d
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/scheduler/colord.c
|
+++ b/scheduler/colord.c
|
||||||
@@ -0,0 +1,678 @@
|
@@ -0,0 +1,682 @@
|
||||||
+/*
|
+/*
|
||||||
+ * "$Id$"
|
+ * "$Id$"
|
||||||
+ *
|
+ *
|
||||||
@ -480,7 +481,7 @@ index 0000000..6c60237
|
|||||||
+ tmp += 7;
|
+ tmp += 7;
|
||||||
+ format[0] = strdup(tmp);
|
+ format[0] = strdup(tmp);
|
||||||
+
|
+
|
||||||
+ /* get 2st section */
|
+ /* get 2nd section */
|
||||||
+ tmp = "cupsICCQualifier2";
|
+ tmp = "cupsICCQualifier2";
|
||||||
+ attr = ppdFindAttr(ppd, tmp, NULL);
|
+ attr = ppdFindAttr(ppd, tmp, NULL);
|
||||||
+ if (attr != NULL)
|
+ if (attr != NULL)
|
||||||
@ -498,7 +499,7 @@ index 0000000..6c60237
|
|||||||
+ tmp += 7;
|
+ tmp += 7;
|
||||||
+ format[1] = strdup(tmp);
|
+ format[1] = strdup(tmp);
|
||||||
+
|
+
|
||||||
+ /* get 3st section */
|
+ /* get 3rd section */
|
||||||
+ tmp = "cupsICCQualifier3";
|
+ tmp = "cupsICCQualifier3";
|
||||||
+ attr = ppdFindAttr(ppd, tmp, NULL);
|
+ attr = ppdFindAttr(ppd, tmp, NULL);
|
||||||
+ if (attr != NULL)
|
+ if (attr != NULL)
|
||||||
@ -549,6 +550,8 @@ index 0000000..6c60237
|
|||||||
+ */
|
+ */
|
||||||
+
|
+
|
||||||
+ colordStart();
|
+ colordStart();
|
||||||
|
+ if (con == NULL)
|
||||||
|
+ return;
|
||||||
+
|
+
|
||||||
+ /*
|
+ /*
|
||||||
+ * Try opening the PPD file for this printer...
|
+ * Try opening the PPD file for this printer...
|
||||||
@ -697,6 +700,8 @@ index 0000000..6c60237
|
|||||||
+ */
|
+ */
|
||||||
+
|
+
|
||||||
+ colordStart();
|
+ colordStart();
|
||||||
|
+ if (con == NULL)
|
||||||
|
+ return;
|
||||||
+
|
+
|
||||||
+ /*
|
+ /*
|
||||||
+ * Just delete the device itself, and leave the profiles registered
|
+ * Just delete the device itself, and leave the profiles registered
|
||||||
|
@ -15,7 +15,7 @@
|
|||||||
Summary: Common Unix Printing System
|
Summary: Common Unix Printing System
|
||||||
Name: cups
|
Name: cups
|
||||||
Version: 1.5
|
Version: 1.5
|
||||||
Release: 0.5.%{alphatag}%{?dist}
|
Release: 0.6.%{alphatag}%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: http://ftp.easysw.com/pub/cups/%{version}%{alphatag}/cups-%{version}%{alphatag}-source.tar.bz2
|
Source: http://ftp.easysw.com/pub/cups/%{version}%{alphatag}/cups-%{version}%{alphatag}-source.tar.bz2
|
||||||
@ -612,6 +612,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/ipptool.1.gz
|
%{_mandir}/man1/ipptool.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jun 04 2011 Richard Hughes <rhughes@redhat.com> 1:1.5-0.6.b2
|
||||||
|
- Updated colord patch with fixes from Tim Waugh.
|
||||||
|
|
||||||
* Tue May 31 2011 Jiri Popelka <jpopelka@redhat.com> 1:1.5-0.5.b2
|
* Tue May 31 2011 Jiri Popelka <jpopelka@redhat.com> 1:1.5-0.5.b2
|
||||||
- enable LSPP support again
|
- enable LSPP support again
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user