Fixed avahi-no-threaded patch so it removes a call to avahi_threaded_poll_stop() (bug #1044602).
Resolves: rhbz#1044602
This commit is contained in:
parent
618d1c8838
commit
9e47311571
@ -1,6 +1,25 @@
|
|||||||
diff -up cups-1.7rc1/scheduler/avahi.c.avahi-no-threaded cups-1.7rc1/scheduler/avahi.c
|
diff -up cups-1.7.0/scheduler/Makefile.avahi-no-threaded cups-1.7.0/scheduler/Makefile
|
||||||
--- cups-1.7rc1/scheduler/avahi.c.avahi-no-threaded 2013-07-22 11:47:27.599101572 +0100
|
--- cups-1.7.0/scheduler/Makefile.avahi-no-threaded 2014-01-02 12:05:07.477750519 +0000
|
||||||
+++ cups-1.7rc1/scheduler/avahi.c 2013-07-22 11:47:27.599101572 +0100
|
+++ cups-1.7.0/scheduler/Makefile 2014-01-02 12:05:07.498750621 +0000
|
||||||
|
@@ -17,6 +17,7 @@ include ../Makedefs
|
||||||
|
|
||||||
|
CUPSDOBJS = \
|
||||||
|
auth.o \
|
||||||
|
+ avahi.o \
|
||||||
|
banners.o \
|
||||||
|
cert.o \
|
||||||
|
classes.o \
|
||||||
|
@@ -41,6 +42,7 @@ CUPSDOBJS = \
|
||||||
|
statbuf.o \
|
||||||
|
subscriptions.o \
|
||||||
|
sysman.o \
|
||||||
|
+ timeout.o \
|
||||||
|
tls.o
|
||||||
|
LIBOBJS = \
|
||||||
|
filter.o \
|
||||||
|
diff -up cups-1.7.0/scheduler/avahi.c.avahi-no-threaded cups-1.7.0/scheduler/avahi.c
|
||||||
|
--- cups-1.7.0/scheduler/avahi.c.avahi-no-threaded 2014-01-02 12:05:07.497750616 +0000
|
||||||
|
+++ cups-1.7.0/scheduler/avahi.c 2014-01-02 12:05:07.497750616 +0000
|
||||||
@@ -0,0 +1,441 @@
|
@@ -0,0 +1,441 @@
|
||||||
+/*
|
+/*
|
||||||
+ * "$Id$"
|
+ * "$Id$"
|
||||||
@ -443,9 +462,9 @@ diff -up cups-1.7rc1/scheduler/avahi.c.avahi-no-threaded cups-1.7rc1/scheduler/a
|
|||||||
+/*
|
+/*
|
||||||
+ * End of "$Id$".
|
+ * End of "$Id$".
|
||||||
+ */
|
+ */
|
||||||
diff -up cups-1.7rc1/scheduler/avahi.h.avahi-no-threaded cups-1.7rc1/scheduler/avahi.h
|
diff -up cups-1.7.0/scheduler/avahi.h.avahi-no-threaded cups-1.7.0/scheduler/avahi.h
|
||||||
--- cups-1.7rc1/scheduler/avahi.h.avahi-no-threaded 2013-07-22 11:47:27.599101572 +0100
|
--- cups-1.7.0/scheduler/avahi.h.avahi-no-threaded 2014-01-02 12:05:07.497750616 +0000
|
||||||
+++ cups-1.7rc1/scheduler/avahi.h 2013-07-22 11:47:27.599101572 +0100
|
+++ cups-1.7.0/scheduler/avahi.h 2014-01-02 12:05:07.497750616 +0000
|
||||||
@@ -0,0 +1,69 @@
|
@@ -0,0 +1,69 @@
|
||||||
+/*
|
+/*
|
||||||
+ * "$Id$"
|
+ * "$Id$"
|
||||||
@ -516,9 +535,9 @@ diff -up cups-1.7rc1/scheduler/avahi.h.avahi-no-threaded cups-1.7rc1/scheduler/a
|
|||||||
+/*
|
+/*
|
||||||
+ * End of "$Id$".
|
+ * End of "$Id$".
|
||||||
+ */
|
+ */
|
||||||
diff -up cups-1.7rc1/scheduler/cupsd.h.avahi-no-threaded cups-1.7rc1/scheduler/cupsd.h
|
diff -up cups-1.7.0/scheduler/cupsd.h.avahi-no-threaded cups-1.7.0/scheduler/cupsd.h
|
||||||
--- cups-1.7rc1/scheduler/cupsd.h.avahi-no-threaded 2013-05-29 12:51:34.000000000 +0100
|
--- cups-1.7.0/scheduler/cupsd.h.avahi-no-threaded 2013-05-29 12:51:34.000000000 +0100
|
||||||
+++ cups-1.7rc1/scheduler/cupsd.h 2013-07-22 11:47:31.319118984 +0100
|
+++ cups-1.7.0/scheduler/cupsd.h 2014-01-02 12:05:07.497750616 +0000
|
||||||
@@ -119,6 +119,7 @@ extern const char *cups_hstrerror(int);
|
@@ -119,6 +119,7 @@ extern const char *cups_hstrerror(int);
|
||||||
#include "colorman.h"
|
#include "colorman.h"
|
||||||
#include "conf.h"
|
#include "conf.h"
|
||||||
@ -573,9 +592,9 @@ diff -up cups-1.7rc1/scheduler/cupsd.h.avahi-no-threaded cups-1.7rc1/scheduler/c
|
|||||||
|
|
||||||
/*
|
/*
|
||||||
* End of "$Id: cupsd.h 10996 2013-05-29 11:51:34Z msweet $".
|
* End of "$Id: cupsd.h 10996 2013-05-29 11:51:34Z msweet $".
|
||||||
diff -up cups-1.7rc1/scheduler/dirsvc.c.avahi-no-threaded cups-1.7rc1/scheduler/dirsvc.c
|
diff -up cups-1.7.0/scheduler/dirsvc.c.avahi-no-threaded cups-1.7.0/scheduler/dirsvc.c
|
||||||
--- cups-1.7rc1/scheduler/dirsvc.c.avahi-no-threaded 2013-05-29 12:51:34.000000000 +0100
|
--- cups-1.7.0/scheduler/dirsvc.c.avahi-no-threaded 2013-07-26 04:12:37.000000000 +0100
|
||||||
+++ cups-1.7rc1/scheduler/dirsvc.c 2013-07-22 11:47:27.600101576 +0100
|
+++ cups-1.7.0/scheduler/dirsvc.c 2014-01-02 12:06:27.027137247 +0000
|
||||||
@@ -212,7 +212,7 @@ cupsdStartBrowsing(void)
|
@@ -212,7 +212,7 @@ cupsdStartBrowsing(void)
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -607,7 +626,7 @@ diff -up cups-1.7rc1/scheduler/dirsvc.c.avahi-no-threaded cups-1.7rc1/scheduler/
|
|||||||
}
|
}
|
||||||
# endif /* HAVE_DNSSD */
|
# endif /* HAVE_DNSSD */
|
||||||
|
|
||||||
@@ -746,9 +744,7 @@ dnssdDeregisterInstance(
|
@@ -748,9 +746,7 @@ dnssdDeregisterInstance(
|
||||||
DNSServiceRefDeallocate(*srv);
|
DNSServiceRefDeallocate(*srv);
|
||||||
|
|
||||||
# else /* HAVE_AVAHI */
|
# else /* HAVE_AVAHI */
|
||||||
@ -617,7 +636,7 @@ diff -up cups-1.7rc1/scheduler/dirsvc.c.avahi-no-threaded cups-1.7rc1/scheduler/
|
|||||||
# endif /* HAVE_DNSSD */
|
# endif /* HAVE_DNSSD */
|
||||||
|
|
||||||
*srv = NULL;
|
*srv = NULL;
|
||||||
@@ -1043,14 +1039,10 @@ dnssdRegisterInstance(
|
@@ -1045,14 +1041,10 @@ dnssdRegisterInstance(
|
||||||
(void)commit;
|
(void)commit;
|
||||||
|
|
||||||
# else /* HAVE_AVAHI */
|
# else /* HAVE_AVAHI */
|
||||||
@ -632,7 +651,7 @@ diff -up cups-1.7rc1/scheduler/dirsvc.c.avahi-no-threaded cups-1.7rc1/scheduler/
|
|||||||
cupsdLogMessage(CUPSD_LOG_WARN, "DNS-SD registration of \"%s\" failed: %s",
|
cupsdLogMessage(CUPSD_LOG_WARN, "DNS-SD registration of \"%s\" failed: %s",
|
||||||
name, dnssdErrorString(avahi_client_errno(DNSSDClient)));
|
name, dnssdErrorString(avahi_client_errno(DNSSDClient)));
|
||||||
return (0);
|
return (0);
|
||||||
@@ -1165,8 +1157,6 @@ dnssdRegisterInstance(
|
@@ -1167,8 +1159,6 @@ dnssdRegisterInstance(
|
||||||
cupsdLogMessage(CUPSD_LOG_DEBUG, "DNS-SD commit of \"%s\" failed.",
|
cupsdLogMessage(CUPSD_LOG_DEBUG, "DNS-SD commit of \"%s\" failed.",
|
||||||
name);
|
name);
|
||||||
}
|
}
|
||||||
@ -641,7 +660,12 @@ diff -up cups-1.7rc1/scheduler/dirsvc.c.avahi-no-threaded cups-1.7rc1/scheduler/
|
|||||||
# endif /* HAVE_DNSSD */
|
# endif /* HAVE_DNSSD */
|
||||||
|
|
||||||
if (error)
|
if (error)
|
||||||
@@ -1338,7 +1328,7 @@ dnssdStop(void)
|
@@ -1335,12 +1325,10 @@ dnssdStop(void)
|
||||||
|
DNSSDMaster = NULL;
|
||||||
|
|
||||||
|
# else /* HAVE_AVAHI */
|
||||||
|
- avahi_threaded_poll_stop(DNSSDMaster);
|
||||||
|
-
|
||||||
avahi_client_free(DNSSDClient);
|
avahi_client_free(DNSSDClient);
|
||||||
DNSSDClient = NULL;
|
DNSSDClient = NULL;
|
||||||
|
|
||||||
@ -650,9 +674,9 @@ diff -up cups-1.7rc1/scheduler/dirsvc.c.avahi-no-threaded cups-1.7rc1/scheduler/
|
|||||||
DNSSDMaster = NULL;
|
DNSSDMaster = NULL;
|
||||||
# endif /* HAVE_DNSSD */
|
# endif /* HAVE_DNSSD */
|
||||||
|
|
||||||
diff -up cups-1.7rc1/scheduler/dirsvc.h.avahi-no-threaded cups-1.7rc1/scheduler/dirsvc.h
|
diff -up cups-1.7.0/scheduler/dirsvc.h.avahi-no-threaded cups-1.7.0/scheduler/dirsvc.h
|
||||||
--- cups-1.7rc1/scheduler/dirsvc.h.avahi-no-threaded 2013-05-29 12:51:34.000000000 +0100
|
--- cups-1.7.0/scheduler/dirsvc.h.avahi-no-threaded 2013-05-29 12:51:34.000000000 +0100
|
||||||
+++ cups-1.7rc1/scheduler/dirsvc.h 2013-07-22 11:47:27.600101576 +0100
|
+++ cups-1.7.0/scheduler/dirsvc.h 2014-01-02 12:05:07.498750621 +0000
|
||||||
@@ -51,7 +51,7 @@ VAR cups_array_t *DNSSDPrinters VALUE(NU
|
@@ -51,7 +51,7 @@ VAR cups_array_t *DNSSDPrinters VALUE(NU
|
||||||
VAR DNSServiceRef DNSSDMaster VALUE(NULL);
|
VAR DNSServiceRef DNSSDMaster VALUE(NULL);
|
||||||
/* Master DNS-SD service reference */
|
/* Master DNS-SD service reference */
|
||||||
@ -662,9 +686,9 @@ diff -up cups-1.7rc1/scheduler/dirsvc.h.avahi-no-threaded cups-1.7rc1/scheduler/
|
|||||||
/* Master polling interface for Avahi */
|
/* Master polling interface for Avahi */
|
||||||
VAR AvahiClient *DNSSDClient VALUE(NULL);
|
VAR AvahiClient *DNSSDClient VALUE(NULL);
|
||||||
/* Client information */
|
/* Client information */
|
||||||
diff -up cups-1.7rc1/scheduler/main.c.avahi-no-threaded cups-1.7rc1/scheduler/main.c
|
diff -up cups-1.7.0/scheduler/main.c.avahi-no-threaded cups-1.7.0/scheduler/main.c
|
||||||
--- cups-1.7rc1/scheduler/main.c.avahi-no-threaded 2013-07-22 11:47:27.578101474 +0100
|
--- cups-1.7.0/scheduler/main.c.avahi-no-threaded 2014-01-02 12:05:07.477750519 +0000
|
||||||
+++ cups-1.7rc1/scheduler/main.c 2013-07-22 11:47:27.601101581 +0100
|
+++ cups-1.7.0/scheduler/main.c 2014-01-02 12:05:07.498750621 +0000
|
||||||
@@ -155,6 +155,10 @@ main(int argc, /* I - Number of comm
|
@@ -155,6 +155,10 @@ main(int argc, /* I - Number of comm
|
||||||
int launchd_idle_exit;
|
int launchd_idle_exit;
|
||||||
/* Idle exit on select timeout? */
|
/* Idle exit on select timeout? */
|
||||||
@ -739,28 +763,9 @@ diff -up cups-1.7rc1/scheduler/main.c.avahi-no-threaded cups-1.7rc1/scheduler/ma
|
|||||||
/*
|
/*
|
||||||
* Check whether we are accepting new connections...
|
* Check whether we are accepting new connections...
|
||||||
*/
|
*/
|
||||||
diff -up cups-1.7rc1/scheduler/Makefile.avahi-no-threaded cups-1.7rc1/scheduler/Makefile
|
diff -up cups-1.7.0/scheduler/timeout.c.avahi-no-threaded cups-1.7.0/scheduler/timeout.c
|
||||||
--- cups-1.7rc1/scheduler/Makefile.avahi-no-threaded 2013-07-22 11:47:27.578101474 +0100
|
--- cups-1.7.0/scheduler/timeout.c.avahi-no-threaded 2014-01-02 12:05:07.498750621 +0000
|
||||||
+++ cups-1.7rc1/scheduler/Makefile 2013-07-22 11:47:27.601101581 +0100
|
+++ cups-1.7.0/scheduler/timeout.c 2014-01-02 12:05:07.498750621 +0000
|
||||||
@@ -17,6 +17,7 @@ include ../Makedefs
|
|
||||||
|
|
||||||
CUPSDOBJS = \
|
|
||||||
auth.o \
|
|
||||||
+ avahi.o \
|
|
||||||
banners.o \
|
|
||||||
cert.o \
|
|
||||||
classes.o \
|
|
||||||
@@ -41,6 +42,7 @@ CUPSDOBJS = \
|
|
||||||
statbuf.o \
|
|
||||||
subscriptions.o \
|
|
||||||
sysman.o \
|
|
||||||
+ timeout.o \
|
|
||||||
tls.o
|
|
||||||
LIBOBJS = \
|
|
||||||
filter.o \
|
|
||||||
diff -up cups-1.7rc1/scheduler/timeout.c.avahi-no-threaded cups-1.7rc1/scheduler/timeout.c
|
|
||||||
--- cups-1.7rc1/scheduler/timeout.c.avahi-no-threaded 2013-07-22 11:47:27.601101581 +0100
|
|
||||||
+++ cups-1.7rc1/scheduler/timeout.c 2013-07-22 11:47:27.601101581 +0100
|
|
||||||
@@ -0,0 +1,235 @@
|
@@ -0,0 +1,235 @@
|
||||||
+/*
|
+/*
|
||||||
+ * "$Id$"
|
+ * "$Id$"
|
||||||
|
@ -11,7 +11,7 @@ Summary: CUPS printing system
|
|||||||
Name: cups
|
Name: cups
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 1.7.0
|
Version: 1.7.0
|
||||||
Release: 8%{?dist}
|
Release: 9%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Url: http://www.cups.org/
|
Url: http://www.cups.org/
|
||||||
@ -658,6 +658,10 @@ rm -f %{cups_serverbin}/backend/smb
|
|||||||
%{_mandir}/man5/ipptoolfile.5.gz
|
%{_mandir}/man5/ipptoolfile.5.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 2 2014 Tim Waugh <twaugh@redhat.com> - 1:1.7.0-9
|
||||||
|
- Fixed avahi-no-threaded patch so it removes a call to
|
||||||
|
avahi_threaded_poll_stop() (bug #1044602).
|
||||||
|
|
||||||
* Fri Dec 13 2013 Tim Waugh <twaugh@redhat.com> - 1:1.7.0-8
|
* Fri Dec 13 2013 Tim Waugh <twaugh@redhat.com> - 1:1.7.0-8
|
||||||
- Use string literal for format string in sd_journal_print call.
|
- Use string literal for format string in sd_journal_print call.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user