backport 2 upstream commits (r10638, r10642)
This commit is contained in:
parent
7238440cc4
commit
95d92a2c9b
24
cups-r10638.patch
Normal file
24
cups-r10638.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
From b1c8da8900d3c854e108ce445bef9fce8522ca22 Mon Sep 17 00:00:00 2001
|
||||||
|
From: mike <mike@7a7537e8-13f0-0310-91df-b6672ffda945>
|
||||||
|
Date: Tue, 2 Oct 2012 16:30:35 +0000
|
||||||
|
Subject: [PATCH] The IPP backend did not send a cancel request to printers
|
||||||
|
when a job was canceled and the printer did not support
|
||||||
|
Create-Job.
|
||||||
|
|
||||||
|
git-svn-id: http://svn.easysw.com/public/cups/trunk@10638 7a7537e8-13f0-0310-91df-b6672ffda945
|
||||||
|
---
|
||||||
|
diff --git a/backend/ipp.c b/backend/ipp.c
|
||||||
|
index b509996..5eecc29 100644
|
||||||
|
--- a/backend/ipp.c
|
||||||
|
+++ b/backend/ipp.c
|
||||||
|
@@ -89,6 +89,7 @@ static int child_pid = 0; /* Child process ID */
|
||||||
|
#endif /* HAVE_GSSAPI && HAVE_XPC */
|
||||||
|
static const char * const jattrs[] = /* Job attributes we want */
|
||||||
|
{
|
||||||
|
+ "job-id",
|
||||||
|
"job-impressions-completed",
|
||||||
|
"job-media-sheets-completed",
|
||||||
|
"job-name",
|
||||||
|
--
|
||||||
|
1.7.11.7
|
||||||
|
|
40
cups-r10642.patch
Normal file
40
cups-r10642.patch
Normal file
@ -0,0 +1,40 @@
|
|||||||
|
From c98bc4b769f85da3199485c85e8c98bb8c87ff04 Mon Sep 17 00:00:00 2001
|
||||||
|
From: mike <mike@7a7537e8-13f0-0310-91df-b6672ffda945>
|
||||||
|
Date: Tue, 9 Oct 2012 03:01:31 +0000
|
||||||
|
Subject: [PATCH] Work around broken 1284 device IDs that use a newline
|
||||||
|
instead of a semicolon.
|
||||||
|
|
||||||
|
git-svn-id: http://svn.easysw.com/public/cups/trunk@10642 7a7537e8-13f0-0310-91df-b6672ffda945
|
||||||
|
---
|
||||||
|
diff --git a/backend/snmp.c b/backend/snmp.c
|
||||||
|
index f672e37..fc40800 100644
|
||||||
|
--- a/backend/snmp.c
|
||||||
|
+++ b/backend/snmp.c
|
||||||
|
@@ -1025,6 +1025,11 @@ read_snmp_response(int fd) /* I - SNMP socket file descriptor */
|
||||||
|
* Description is the IEEE-1284 device ID...
|
||||||
|
*/
|
||||||
|
|
||||||
|
+ char *ptr; /* Pointer into device ID */
|
||||||
|
+
|
||||||
|
+ for (ptr = (char *)packet.object_value.string.bytes; *ptr; ptr ++)
|
||||||
|
+ if (*ptr == '\n')
|
||||||
|
+ *ptr = ';'; /* A lot of bad printers put a newline */
|
||||||
|
if (!device->id)
|
||||||
|
device->id = strdup((char *)packet.object_value.string.bytes);
|
||||||
|
|
||||||
|
@@ -1066,8 +1071,11 @@ read_snmp_response(int fd) /* I - SNMP socket file descriptor */
|
||||||
|
*/
|
||||||
|
|
||||||
|
char make_model[256]; /* Make and model */
|
||||||
|
+ char *ptr; /* Pointer into device ID */
|
||||||
|
|
||||||
|
-
|
||||||
|
+ for (ptr = (char *)packet.object_value.string.bytes; *ptr; ptr ++)
|
||||||
|
+ if (*ptr == '\n')
|
||||||
|
+ *ptr = ';'; /* A lot of bad printers put a newline */
|
||||||
|
if (device->id)
|
||||||
|
free(device->id);
|
||||||
|
|
||||||
|
--
|
||||||
|
1.7.11.7
|
||||||
|
|
12
cups.spec
12
cups.spec
@ -12,7 +12,7 @@
|
|||||||
Summary: Common Unix Printing System
|
Summary: Common Unix Printing System
|
||||||
Name: cups
|
Name: cups
|
||||||
Version: 1.5.4
|
Version: 1.5.4
|
||||||
Release: 8%{?dist}
|
Release: 9%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: http://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
Source: http://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
||||||
@ -76,6 +76,8 @@ Patch40: cups-r10572.patch
|
|||||||
Patch41: cups-str4072.patch
|
Patch41: cups-str4072.patch
|
||||||
Patch42: cups-str4124.patch
|
Patch42: cups-str4124.patch
|
||||||
Patch43: cups-str4194.patch
|
Patch43: cups-str4194.patch
|
||||||
|
Patch44: cups-r10638.patch
|
||||||
|
Patch45: cups-r10642.patch
|
||||||
|
|
||||||
Patch100: cups-lspp.patch
|
Patch100: cups-lspp.patch
|
||||||
|
|
||||||
@ -314,6 +316,11 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
|
|||||||
# The IPP backend could get stuck in an endless loop on certain network errors
|
# The IPP backend could get stuck in an endless loop on certain network errors
|
||||||
# (STR #4194)
|
# (STR #4194)
|
||||||
%patch43 -p1 -b .str4194
|
%patch43 -p1 -b .str4194
|
||||||
|
# The IPP backend did not send a cancel request to printers when a job was
|
||||||
|
# canceled and the printer did not support Create-Job.
|
||||||
|
%patch44 -p1 -b .r10638
|
||||||
|
# Work around broken 1284 device IDs that use a newline instead of a semicolon.
|
||||||
|
%patch45 -p1 -b .r10642
|
||||||
|
|
||||||
%if %lspp
|
%if %lspp
|
||||||
# LSPP support.
|
# LSPP support.
|
||||||
@ -675,6 +682,9 @@ rm -f %{cups_serverbin}/backend/smb
|
|||||||
%{_mandir}/man1/ipptool.1.gz
|
%{_mandir}/man1/ipptool.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 11 2012 Jiri Popelka <jpopelka@redhat.com> 1:1.5.4-9
|
||||||
|
- backport 2 upstream commits (r10638, r10642)
|
||||||
|
|
||||||
* Mon Oct 01 2012 Jiri Popelka <jpopelka@redhat.com> 1:1.5.4-8
|
* Mon Oct 01 2012 Jiri Popelka <jpopelka@redhat.com> 1:1.5.4-8
|
||||||
- backport fixes for STR #4191, STR #4194
|
- backport fixes for STR #4191, STR #4194
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user