2.0.2
This commit is contained in:
parent
e946d3c862
commit
9347f32db4
1
.gitignore
vendored
1
.gitignore
vendored
@ -65,3 +65,4 @@ cups-1.4.4-source.tar.bz2
|
||||
/cups-2.0rc1-source.tar.bz2
|
||||
/cups-2.0.0-source.tar.bz2
|
||||
/cups-2.0.1-source.tar.bz2
|
||||
/cups-2.0.2-source.tar.bz2
|
||||
|
Binary file not shown.
BIN
cups-2.0.2-source.tar.bz2.sig
Normal file
BIN
cups-2.0.2-source.tar.bz2.sig
Normal file
Binary file not shown.
@ -1,6 +1,6 @@
|
||||
diff -up cups-2.0rc1/scheduler/avahi.c.avahi-no-threaded cups-2.0rc1/scheduler/avahi.c
|
||||
--- cups-2.0rc1/scheduler/avahi.c.avahi-no-threaded 2014-09-12 15:45:28.772280006 +0200
|
||||
+++ cups-2.0rc1/scheduler/avahi.c 2014-09-12 15:45:28.772280006 +0200
|
||||
diff -up cups-2.0.2/scheduler/avahi.c.KUoOri cups-2.0.2/scheduler/avahi.c
|
||||
--- cups-2.0.2/scheduler/avahi.c.KUoOri 2015-02-10 13:47:38.620396709 +0100
|
||||
+++ cups-2.0.2/scheduler/avahi.c 2015-02-10 13:47:38.620396709 +0100
|
||||
@@ -0,0 +1,441 @@
|
||||
+/*
|
||||
+ * "$Id$"
|
||||
@ -443,9 +443,9 @@ diff -up cups-2.0rc1/scheduler/avahi.c.avahi-no-threaded cups-2.0rc1/scheduler/a
|
||||
+/*
|
||||
+ * End of "$Id$".
|
||||
+ */
|
||||
diff -up cups-2.0rc1/scheduler/avahi.h.avahi-no-threaded cups-2.0rc1/scheduler/avahi.h
|
||||
--- cups-2.0rc1/scheduler/avahi.h.avahi-no-threaded 2014-09-12 15:45:28.772280006 +0200
|
||||
+++ cups-2.0rc1/scheduler/avahi.h 2014-09-12 15:45:28.772280006 +0200
|
||||
diff -up cups-2.0.2/scheduler/avahi.h.KUoOri cups-2.0.2/scheduler/avahi.h
|
||||
--- cups-2.0.2/scheduler/avahi.h.KUoOri 2015-02-10 13:47:38.620396709 +0100
|
||||
+++ cups-2.0.2/scheduler/avahi.h 2015-02-10 13:47:38.620396709 +0100
|
||||
@@ -0,0 +1,69 @@
|
||||
+/*
|
||||
+ * "$Id$"
|
||||
@ -516,9 +516,9 @@ diff -up cups-2.0rc1/scheduler/avahi.h.avahi-no-threaded cups-2.0rc1/scheduler/a
|
||||
+/*
|
||||
+ * End of "$Id$".
|
||||
+ */
|
||||
diff -up cups-2.0rc1/scheduler/cupsd.h.avahi-no-threaded cups-2.0rc1/scheduler/cupsd.h
|
||||
--- cups-2.0rc1/scheduler/cupsd.h.avahi-no-threaded 2014-03-21 17:42:53.000000000 +0100
|
||||
+++ cups-2.0rc1/scheduler/cupsd.h 2014-09-12 15:47:02.886945551 +0200
|
||||
diff -up cups-2.0.2/scheduler/cupsd.h.KUoOri cups-2.0.2/scheduler/cupsd.h
|
||||
--- cups-2.0.2/scheduler/cupsd.h.KUoOri 2014-03-21 17:42:53.000000000 +0100
|
||||
+++ cups-2.0.2/scheduler/cupsd.h 2015-02-10 13:47:38.624396652 +0100
|
||||
@@ -119,6 +119,7 @@ extern const char *cups_hstrerror(int);
|
||||
#include "colorman.h"
|
||||
#include "conf.h"
|
||||
@ -572,9 +572,9 @@ diff -up cups-2.0rc1/scheduler/cupsd.h.avahi-no-threaded cups-2.0rc1/scheduler/c
|
||||
|
||||
/*
|
||||
* End of "$Id: cupsd.h 11717 2014-03-21 16:42:53Z msweet $".
|
||||
diff -up cups-2.0rc1/scheduler/dirsvc.c.avahi-no-threaded cups-2.0rc1/scheduler/dirsvc.c
|
||||
--- cups-2.0rc1/scheduler/dirsvc.c.avahi-no-threaded 2014-05-09 22:57:11.000000000 +0200
|
||||
+++ cups-2.0rc1/scheduler/dirsvc.c 2014-09-12 15:45:28.773279992 +0200
|
||||
diff -up cups-2.0.2/scheduler/dirsvc.c.KUoOri cups-2.0.2/scheduler/dirsvc.c
|
||||
--- cups-2.0.2/scheduler/dirsvc.c.KUoOri 2015-01-30 17:16:12.000000000 +0100
|
||||
+++ cups-2.0.2/scheduler/dirsvc.c 2015-02-10 13:50:47.131728120 +0100
|
||||
@@ -195,7 +195,7 @@ cupsdStartBrowsing(void)
|
||||
cupsdUpdateDNSSDName();
|
||||
|
||||
@ -656,23 +656,28 @@ diff -up cups-2.0rc1/scheduler/dirsvc.c.avahi-no-threaded cups-2.0rc1/scheduler/
|
||||
# endif /* HAVE_DNSSD */
|
||||
|
||||
if (error)
|
||||
@@ -1296,12 +1279,10 @@ dnssdStop(void)
|
||||
@@ -1296,9 +1279,6 @@ dnssdStop(void)
|
||||
DNSSDMaster = NULL;
|
||||
|
||||
# else /* HAVE_AVAHI */
|
||||
- avahi_threaded_poll_stop(DNSSDMaster);
|
||||
- if (DNSSDMaster)
|
||||
- avahi_threaded_poll_stop(DNSSDMaster);
|
||||
-
|
||||
avahi_client_free(DNSSDClient);
|
||||
DNSSDClient = NULL;
|
||||
if (DNSSDClient)
|
||||
{
|
||||
avahi_client_free(DNSSDClient);
|
||||
@@ -1307,7 +1287,7 @@ dnssdStop(void)
|
||||
|
||||
- avahi_threaded_poll_free(DNSSDMaster);
|
||||
+ avahi_cups_poll_free(DNSSDMaster);
|
||||
DNSSDMaster = NULL;
|
||||
if (DNSSDMaster)
|
||||
{
|
||||
- avahi_threaded_poll_free(DNSSDMaster);
|
||||
+ avahi_cups_poll_free(DNSSDMaster);
|
||||
DNSSDMaster = NULL;
|
||||
}
|
||||
# endif /* HAVE_DNSSD */
|
||||
|
||||
diff -up cups-2.0rc1/scheduler/dirsvc.h.avahi-no-threaded cups-2.0rc1/scheduler/dirsvc.h
|
||||
--- cups-2.0rc1/scheduler/dirsvc.h.avahi-no-threaded 2013-05-29 13:51:34.000000000 +0200
|
||||
+++ cups-2.0rc1/scheduler/dirsvc.h 2014-09-12 15:45:28.773279992 +0200
|
||||
diff -up cups-2.0.2/scheduler/dirsvc.h.KUoOri cups-2.0.2/scheduler/dirsvc.h
|
||||
--- cups-2.0.2/scheduler/dirsvc.h.KUoOri 2013-05-29 13:51:34.000000000 +0200
|
||||
+++ cups-2.0.2/scheduler/dirsvc.h 2015-02-10 13:47:38.640396426 +0100
|
||||
@@ -51,7 +51,7 @@ VAR cups_array_t *DNSSDPrinters VALUE(NU
|
||||
VAR DNSServiceRef DNSSDMaster VALUE(NULL);
|
||||
/* Master DNS-SD service reference */
|
||||
@ -682,10 +687,10 @@ diff -up cups-2.0rc1/scheduler/dirsvc.h.avahi-no-threaded cups-2.0rc1/scheduler/
|
||||
/* Master polling interface for Avahi */
|
||||
VAR AvahiClient *DNSSDClient VALUE(NULL);
|
||||
/* Client information */
|
||||
diff -up cups-2.0rc1/scheduler/main.c.avahi-no-threaded cups-2.0rc1/scheduler/main.c
|
||||
--- cups-2.0rc1/scheduler/main.c.avahi-no-threaded 2014-09-12 15:45:28.736280516 +0200
|
||||
+++ cups-2.0rc1/scheduler/main.c 2014-09-12 15:47:43.433370643 +0200
|
||||
@@ -127,6 +127,10 @@ main(int argc, /* I - Number of comm
|
||||
diff -up cups-2.0.2/scheduler/main.c.KUoOri cups-2.0.2/scheduler/main.c
|
||||
--- cups-2.0.2/scheduler/main.c.KUoOri 2015-02-10 13:40:24.295545063 +0100
|
||||
+++ cups-2.0.2/scheduler/main.c 2015-02-10 13:47:38.641396412 +0100
|
||||
@@ -129,6 +129,10 @@ main(int argc, /* I - Number of comm
|
||||
int service_idle_exit;
|
||||
/* Idle exit on select timeout? */
|
||||
#endif /* HAVE_LAUNCHD || HAVE_SYSTEMD */
|
||||
@ -696,7 +701,7 @@ diff -up cups-2.0rc1/scheduler/main.c.avahi-no-threaded cups-2.0rc1/scheduler/ma
|
||||
|
||||
|
||||
#ifdef HAVE_GETEUID
|
||||
@@ -569,6 +573,14 @@ main(int argc, /* I - Number of comm
|
||||
@@ -577,6 +581,14 @@ main(int argc, /* I - Number of comm
|
||||
|
||||
httpInitialize();
|
||||
|
||||
@ -711,7 +716,7 @@ diff -up cups-2.0rc1/scheduler/main.c.avahi-no-threaded cups-2.0rc1/scheduler/ma
|
||||
cupsdStartServer();
|
||||
|
||||
/*
|
||||
@@ -871,6 +883,16 @@ main(int argc, /* I - Number of comm
|
||||
@@ -883,6 +895,16 @@ main(int argc, /* I - Number of comm
|
||||
}
|
||||
#endif /* __APPLE__ */
|
||||
|
||||
@ -728,7 +733,7 @@ diff -up cups-2.0rc1/scheduler/main.c.avahi-no-threaded cups-2.0rc1/scheduler/ma
|
||||
#ifndef __APPLE__
|
||||
/*
|
||||
* Update the network interfaces once a minute...
|
||||
@@ -1562,6 +1584,10 @@ select_timeout(int fds) /* I - Number
|
||||
@@ -1574,6 +1596,10 @@ select_timeout(int fds) /* I - Number
|
||||
cupsd_job_t *job; /* Job information */
|
||||
cupsd_subscription_t *sub; /* Subscription information */
|
||||
const char *why; /* Debugging aid */
|
||||
@ -739,7 +744,7 @@ diff -up cups-2.0rc1/scheduler/main.c.avahi-no-threaded cups-2.0rc1/scheduler/ma
|
||||
|
||||
|
||||
cupsdLogMessage(CUPSD_LOG_DEBUG2, "select_timeout: JobHistoryUpdate=%ld",
|
||||
@@ -1607,6 +1633,19 @@ select_timeout(int fds) /* I - Number
|
||||
@@ -1619,6 +1645,19 @@ select_timeout(int fds) /* I - Number
|
||||
}
|
||||
#endif /* __APPLE__ */
|
||||
|
||||
@ -759,9 +764,9 @@ diff -up cups-2.0rc1/scheduler/main.c.avahi-no-threaded cups-2.0rc1/scheduler/ma
|
||||
/*
|
||||
* Check whether we are accepting new connections...
|
||||
*/
|
||||
diff -up cups-2.0rc1/scheduler/Makefile.avahi-no-threaded cups-2.0rc1/scheduler/Makefile
|
||||
--- cups-2.0rc1/scheduler/Makefile.avahi-no-threaded 2014-08-29 13:27:18.000000000 +0200
|
||||
+++ cups-2.0rc1/scheduler/Makefile 2014-09-12 15:48:35.367634265 +0200
|
||||
diff -up cups-2.0.2/scheduler/Makefile.KUoOri cups-2.0.2/scheduler/Makefile
|
||||
--- cups-2.0.2/scheduler/Makefile.KUoOri 2014-10-21 13:55:01.000000000 +0200
|
||||
+++ cups-2.0.2/scheduler/Makefile 2015-02-10 13:47:38.646396341 +0100
|
||||
@@ -17,6 +17,7 @@ include ../Makedefs
|
||||
|
||||
CUPSDOBJS = \
|
||||
@ -780,9 +785,9 @@ diff -up cups-2.0rc1/scheduler/Makefile.avahi-no-threaded cups-2.0rc1/scheduler/
|
||||
LIBOBJS = \
|
||||
filter.o \
|
||||
mime.o \
|
||||
diff -up cups-2.0rc1/scheduler/timeout.c.avahi-no-threaded cups-2.0rc1/scheduler/timeout.c
|
||||
--- cups-2.0rc1/scheduler/timeout.c.avahi-no-threaded 2014-09-12 15:45:28.775279963 +0200
|
||||
+++ cups-2.0rc1/scheduler/timeout.c 2014-09-12 15:45:28.775279963 +0200
|
||||
diff -up cups-2.0.2/scheduler/timeout.c.KUoOri cups-2.0.2/scheduler/timeout.c
|
||||
--- cups-2.0.2/scheduler/timeout.c.KUoOri 2015-02-10 13:47:38.646396341 +0100
|
||||
+++ cups-2.0.2/scheduler/timeout.c 2015-02-10 13:47:38.646396341 +0100
|
||||
@@ -0,0 +1,235 @@
|
||||
+/*
|
||||
+ * "$Id$"
|
||||
|
@ -1,14 +1,15 @@
|
||||
diff -up cups-1.7b1/scheduler/listen.c.freebind cups-1.7b1/scheduler/listen.c
|
||||
--- cups-1.7b1/scheduler/listen.c.freebind 2013-06-20 11:48:17.427352639 +0100
|
||||
+++ cups-1.7b1/scheduler/listen.c 2013-06-20 11:51:15.023288361 +0100
|
||||
@@ -198,6 +198,10 @@ cupsdStartListening(void)
|
||||
setsockopt(lis->fd, SOL_SOCKET, SO_REUSEADDR, &val, sizeof(val));
|
||||
#endif /* __sun */
|
||||
diff -up cups-2.0.2/cups/http-addr.c.freebind cups-2.0.2/cups/http-addr.c
|
||||
--- cups-2.0.2/cups/http-addr.c.freebind 2015-02-10 14:46:33.000000000 +0100
|
||||
+++ cups-2.0.2/cups/http-addr.c 2015-02-10 14:50:35.074759141 +0100
|
||||
@@ -186,6 +186,10 @@ httpAddrListen(http_addr_t *addr, /* I -
|
||||
val = 1;
|
||||
setsockopt(fd, SOL_SOCKET, SO_REUSEADDR, CUPS_SOCAST &val, sizeof(val));
|
||||
|
||||
+#ifdef __linux
|
||||
+ setsockopt(lis->fd, IPPROTO_IP, IP_FREEBIND, &val, sizeof(val));
|
||||
+ setsockopt(fd, IPPROTO_IP, IP_FREEBIND, CUPS_SOCAST &val, sizeof(val));
|
||||
+#endif /* __linux */
|
||||
+
|
||||
/*
|
||||
* Bind to the port we found...
|
||||
*/
|
||||
#ifdef IPV6_V6ONLY
|
||||
if (addr->addr.sa_family == AF_INET6)
|
||||
setsockopt(fd, IPPROTO_IPV6, IPV6_V6ONLY, CUPS_SOCAST &val, sizeof(val));
|
||||
diff -up cups-2.0.2/scheduler/listen.c.freebind cups-2.0.2/scheduler/listen.c
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up cups-2.0.0/conf/cups-files.conf.in.journal cups-2.0.0/conf/cups-files.conf.in
|
||||
--- cups-2.0.0/conf/cups-files.conf.in.journal 2014-03-03 16:46:23.000000000 +0000
|
||||
+++ cups-2.0.0/conf/cups-files.conf.in 2014-11-06 14:10:21.874448772 +0000
|
||||
@@ -28,9 +28,10 @@ SystemGroup @CUPS_SYSTEM_GROUPS@
|
||||
diff -up cups-2.0.2/conf/cups-files.conf.in.rMbEsH cups-2.0.2/conf/cups-files.conf.in
|
||||
--- cups-2.0.2/conf/cups-files.conf.in.rMbEsH 2014-12-05 18:25:55.000000000 +0100
|
||||
+++ cups-2.0.2/conf/cups-files.conf.in 2015-02-10 13:51:24.912193296 +0100
|
||||
@@ -29,9 +29,10 @@ SystemGroup @CUPS_SYSTEM_GROUPS@
|
||||
#ConfigFilePerm 0@CUPS_CONFIG_FILE_PERM@
|
||||
#LogFilePerm 0@CUPS_LOG_FILE_PERM@
|
||||
|
||||
@ -15,7 +15,7 @@ diff -up cups-2.0.0/conf/cups-files.conf.in.journal cups-2.0.0/conf/cups-files.c
|
||||
AccessLog @CUPS_LOGDIR@/access_log
|
||||
|
||||
# Location of cache files used by the scheduler...
|
||||
@@ -42,11 +43,11 @@ AccessLog @CUPS_LOGDIR@/access_log
|
||||
@@ -43,11 +44,11 @@ AccessLog @CUPS_LOGDIR@/access_log
|
||||
# Location of the static web content served by the scheduler...
|
||||
#DocumentRoot @CUPS_DOCROOT@
|
||||
|
||||
@ -32,7 +32,7 @@ diff -up cups-2.0.0/conf/cups-files.conf.in.journal cups-2.0.0/conf/cups-files.c
|
||||
|
||||
# Location of fonts used by older print filters...
|
||||
#FontPath @CUPS_FONTPATH@
|
||||
@@ -54,10 +55,10 @@ ErrorLog @CUPS_LOGDIR@/error_log
|
||||
@@ -55,10 +56,10 @@ ErrorLog @CUPS_LOGDIR@/error_log
|
||||
# Location of LPD configuration
|
||||
#LPDConfigFile @CUPS_DEFAULT_LPD_CONFIG_FILE@
|
||||
|
||||
@ -47,9 +47,9 @@ diff -up cups-2.0.0/conf/cups-files.conf.in.journal cups-2.0.0/conf/cups-files.c
|
||||
PageLog @CUPS_LOGDIR@/page_log
|
||||
|
||||
# Location of the file listing all of the local printers...
|
||||
diff -up cups-2.0.0/config-scripts/cups-startup.m4.journal cups-2.0.0/config-scripts/cups-startup.m4
|
||||
--- cups-2.0.0/config-scripts/cups-startup.m4.journal 2014-03-27 01:15:48.000000000 +0000
|
||||
+++ cups-2.0.0/config-scripts/cups-startup.m4 2014-11-06 14:10:00.186328322 +0000
|
||||
diff -up cups-2.0.2/config-scripts/cups-startup.m4.rMbEsH cups-2.0.2/config-scripts/cups-startup.m4
|
||||
--- cups-2.0.2/config-scripts/cups-startup.m4.rMbEsH 2014-12-09 23:18:45.000000000 +0100
|
||||
+++ cups-2.0.2/config-scripts/cups-startup.m4 2015-02-10 13:51:24.912193296 +0100
|
||||
@@ -56,11 +56,11 @@ if test x$enable_systemd != xno; then
|
||||
AC_MSG_ERROR(Need pkg-config to enable systemd support.)
|
||||
fi
|
||||
@ -66,11 +66,11 @@ diff -up cups-2.0.0/config-scripts/cups-startup.m4.journal cups-2.0.0/config-scr
|
||||
AC_DEFINE(HAVE_SYSTEMD)
|
||||
if test "x$SYSTEMD_DIR" = x; then
|
||||
SYSTEMD_DIR="`$PKGCONFIG --variable=systemdsystemunitdir systemd`"
|
||||
diff -up cups-2.0.0/doc/help/man-cups-files.conf.html.journal cups-2.0.0/doc/help/man-cups-files.conf.html
|
||||
--- cups-2.0.0/doc/help/man-cups-files.conf.html.journal 2014-06-13 01:01:23.000000000 +0100
|
||||
+++ cups-2.0.0/doc/help/man-cups-files.conf.html 2014-11-06 14:10:00.187328328 +0000
|
||||
diff -up cups-2.0.2/doc/help/man-cups-files.conf.html.rMbEsH cups-2.0.2/doc/help/man-cups-files.conf.html
|
||||
--- cups-2.0.2/doc/help/man-cups-files.conf.html.rMbEsH 2015-02-10 13:51:24.977192375 +0100
|
||||
+++ cups-2.0.2/doc/help/man-cups-files.conf.html 2015-02-10 13:52:36.839175089 +0100
|
||||
@@ -24,6 +24,7 @@ The following directives are understood
|
||||
<dt><b>AccessLog</b>
|
||||
<dt><a name="AccessLog"></a><b>AccessLog</b>
|
||||
<dd style="margin-left: 5.0em"><dt><b>AccessLog </b><i>filename</i>
|
||||
<dd style="margin-left: 5.0em"><dt><b>AccessLog syslog</b>
|
||||
+<dd style="margin-left: 5.0em"><dt><b>AccessLog journal</b>
|
||||
@ -78,7 +78,7 @@ diff -up cups-2.0.0/doc/help/man-cups-files.conf.html.journal cups-2.0.0/doc/hel
|
||||
Specifying a blank filename disables access log generation.
|
||||
The value "syslog" causes log entries to be sent to the system log daemon.
|
||||
@@ -51,6 +52,7 @@ The default is usually "/usr/share/doc/c
|
||||
<dt><b>ErrorLog</b>
|
||||
<dt><a name="ErrorLog"></a><b>ErrorLog</b>
|
||||
<dd style="margin-left: 5.0em"><dt><b>ErrorLog </b><i>filename</i>
|
||||
<dd style="margin-left: 5.0em"><dt><b>ErrorLog syslog</b>
|
||||
+<dd style="margin-left: 5.0em"><dt><b>ErrorLog journal</b>
|
||||
@ -87,16 +87,16 @@ diff -up cups-2.0.0/doc/help/man-cups-files.conf.html.journal cups-2.0.0/doc/hel
|
||||
The value "syslog" causes log entries to be sent to the system log daemon.
|
||||
@@ -96,6 +98,7 @@ The default group is operating system sp
|
||||
The default is "0644".
|
||||
<dt><b>PageLog </b>[ <i>filename</i> ]
|
||||
<dt><a name="PageLog"></a><b>PageLog </b>[ <i>filename</i> ]
|
||||
<dd style="margin-left: 5.0em"><dt><b>PageLog syslog</b>
|
||||
+<dd style="margin-left: 5.0em"><dt><b>PageLog journal</b>
|
||||
<dd style="margin-left: 5.0em">Defines the page log filename.
|
||||
The value "syslog" causes log entries to be sent to the system log daemon.
|
||||
Specifying a blank filename disables page log generation.
|
||||
diff -up cups-2.0.0/man/cups-files.conf.man.in.journal cups-2.0.0/man/cups-files.conf.man.in
|
||||
--- cups-2.0.0/man/cups-files.conf.man.in.journal 2014-06-13 01:01:23.000000000 +0100
|
||||
+++ cups-2.0.0/man/cups-files.conf.man.in 2014-11-06 14:10:00.187328328 +0000
|
||||
@@ -33,9 +33,13 @@ The following directives are understood
|
||||
diff -up cups-2.0.2/man/cups-files.conf.man.in.rMbEsH cups-2.0.2/man/cups-files.conf.man.in
|
||||
--- cups-2.0.2/man/cups-files.conf.man.in.rMbEsH 2015-02-02 19:38:25.000000000 +0100
|
||||
+++ cups-2.0.2/man/cups-files.conf.man.in 2015-02-10 13:51:24.980192333 +0100
|
||||
@@ -34,9 +34,13 @@ The following directives are understood
|
||||
\fBAccessLog \fIfilename\fR
|
||||
.TP 5
|
||||
\fBAccessLog syslog\fR
|
||||
@ -111,7 +111,7 @@ diff -up cups-2.0.0/man/cups-files.conf.man.in.journal cups-2.0.0/man/cups-files
|
||||
The server name may be included in filenames using the string "%s", for example:
|
||||
.nf
|
||||
|
||||
@@ -65,9 +69,13 @@ The default is usually "/usr/share/doc/c
|
||||
@@ -70,9 +74,13 @@ The default is usually "/usr/share/doc/c
|
||||
\fBErrorLog \fIfilename\fR
|
||||
.TP 5
|
||||
\fBErrorLog syslog\fR
|
||||
@ -126,7 +126,7 @@ diff -up cups-2.0.0/man/cups-files.conf.man.in.journal cups-2.0.0/man/cups-files
|
||||
The server name may be included in filenames using the string "%s", for example:
|
||||
.nf
|
||||
|
||||
@@ -125,8 +133,12 @@ The default is "0644".
|
||||
@@ -135,8 +143,12 @@ The default is "0644".
|
||||
\fBPageLog \fR[ \fIfilename\fR ]
|
||||
.TP 5
|
||||
\fBPageLog syslog\fR
|
||||
@ -140,10 +140,10 @@ diff -up cups-2.0.0/man/cups-files.conf.man.in.journal cups-2.0.0/man/cups-files
|
||||
Specifying a blank filename disables page log generation.
|
||||
The server name may be included in filenames using the string "%s", for example:
|
||||
.nf
|
||||
diff -up cups-2.0.0/scheduler/conf.c.journal cups-2.0.0/scheduler/conf.c
|
||||
--- cups-2.0.0/scheduler/conf.c.journal 2014-11-06 14:10:00.132328022 +0000
|
||||
+++ cups-2.0.0/scheduler/conf.c 2014-11-06 14:10:00.187328328 +0000
|
||||
@@ -950,9 +950,9 @@ cupsdReadConfiguration(void)
|
||||
diff -up cups-2.0.2/scheduler/conf.c.rMbEsH cups-2.0.2/scheduler/conf.c
|
||||
--- cups-2.0.2/scheduler/conf.c.rMbEsH 2015-02-10 13:40:24.057548432 +0100
|
||||
+++ cups-2.0.2/scheduler/conf.c 2015-02-10 13:51:24.991192177 +0100
|
||||
@@ -952,9 +952,9 @@ cupsdReadConfiguration(void)
|
||||
*/
|
||||
|
||||
#ifdef HAVE_VSYSLOG
|
||||
@ -156,7 +156,7 @@ diff -up cups-2.0.0/scheduler/conf.c.journal cups-2.0.0/scheduler/conf.c
|
||||
openlog("cupsd", LOG_PID | LOG_NOWAIT | LOG_NDELAY, LOG_LPR);
|
||||
#endif /* HAVE_VSYSLOG */
|
||||
|
||||
@@ -960,13 +960,13 @@ cupsdReadConfiguration(void)
|
||||
@@ -962,13 +962,13 @@ cupsdReadConfiguration(void)
|
||||
* Make sure each of the log files exists and gets rotated as necessary...
|
||||
*/
|
||||
|
||||
@ -173,9 +173,9 @@ diff -up cups-2.0.0/scheduler/conf.c.journal cups-2.0.0/scheduler/conf.c
|
||||
cupsdCheckLogFile(&PageFile, PageLog);
|
||||
|
||||
/*
|
||||
diff -up cups-2.0.0/scheduler/conf.h.journal cups-2.0.0/scheduler/conf.h
|
||||
--- cups-2.0.0/scheduler/conf.h.journal 2014-11-06 14:10:00.132328022 +0000
|
||||
+++ cups-2.0.0/scheduler/conf.h 2014-11-06 14:10:00.188328333 +0000
|
||||
diff -up cups-2.0.2/scheduler/conf.h.rMbEsH cups-2.0.2/scheduler/conf.h
|
||||
--- cups-2.0.2/scheduler/conf.h.rMbEsH 2015-02-10 13:40:24.057548432 +0100
|
||||
+++ cups-2.0.2/scheduler/conf.h 2015-02-10 13:51:24.999192064 +0100
|
||||
@@ -291,16 +291,69 @@ extern int cupsdLogGSSMessage(int level,
|
||||
OM_uint32 minor_status,
|
||||
const char *message, ...);
|
||||
@ -251,9 +251,9 @@ diff -up cups-2.0.0/scheduler/conf.h.journal cups-2.0.0/scheduler/conf.h
|
||||
/*
|
||||
* End of "$Id: conf.h 11789 2014-04-02 16:52:53Z msweet $".
|
||||
*/
|
||||
diff -up cups-2.0.0/scheduler/log.c.journal cups-2.0.0/scheduler/log.c
|
||||
--- cups-2.0.0/scheduler/log.c.journal 2014-11-06 14:10:00.154328144 +0000
|
||||
+++ cups-2.0.0/scheduler/log.c 2014-11-06 14:10:00.188328333 +0000
|
||||
diff -up cups-2.0.2/scheduler/log.c.rMbEsH cups-2.0.2/scheduler/log.c
|
||||
--- cups-2.0.2/scheduler/log.c.rMbEsH 2015-02-10 13:40:24.173546790 +0100
|
||||
+++ cups-2.0.2/scheduler/log.c 2015-02-10 13:51:25.008191937 +0100
|
||||
@@ -23,6 +23,12 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up cups-2.0rc1/conf/cups-files.conf.in.synconclose cups-2.0rc1/conf/cups-files.conf.in
|
||||
--- cups-2.0rc1/conf/cups-files.conf.in.synconclose 2014-09-12 16:48:36.510689633 +0200
|
||||
+++ cups-2.0rc1/conf/cups-files.conf.in 2014-09-12 16:48:36.517689534 +0200
|
||||
diff -up cups-2.0.2/conf/cups-files.conf.in.LGOyhq cups-2.0.2/conf/cups-files.conf.in
|
||||
--- cups-2.0.2/conf/cups-files.conf.in.LGOyhq 2015-02-10 13:51:24.912193296 +0100
|
||||
+++ cups-2.0.2/conf/cups-files.conf.in 2015-02-10 13:52:49.400997262 +0100
|
||||
@@ -7,7 +7,7 @@
|
||||
#FatalErrors @CUPS_FATAL_ERRORS@
|
||||
|
||||
@ -10,34 +10,34 @@ diff -up cups-2.0rc1/conf/cups-files.conf.in.synconclose cups-2.0rc1/conf/cups-f
|
||||
|
||||
# Default user and group for filters/backends/helper programs; this cannot be
|
||||
# any user or group that resolves to ID 0 for security reasons...
|
||||
diff -up cups-2.0rc1/doc/help/man-cups-files.conf.html.synconclose cups-2.0rc1/doc/help/man-cups-files.conf.html
|
||||
--- cups-2.0rc1/doc/help/man-cups-files.conf.html.synconclose 2014-09-12 16:48:36.517689534 +0200
|
||||
+++ cups-2.0rc1/doc/help/man-cups-files.conf.html 2014-09-12 16:49:20.643066238 +0200
|
||||
@@ -140,7 +140,7 @@ The default is "/etc/cups".
|
||||
diff -up cups-2.0.2/doc/help/man-cups-files.conf.html.LGOyhq cups-2.0.2/doc/help/man-cups-files.conf.html
|
||||
--- cups-2.0.2/doc/help/man-cups-files.conf.html.LGOyhq 2015-02-10 13:52:49.400997262 +0100
|
||||
+++ cups-2.0.2/doc/help/man-cups-files.conf.html 2015-02-10 13:53:07.057747311 +0100
|
||||
@@ -136,7 +136,7 @@ The default is "/etc/cups".
|
||||
<dd style="margin-left: 5.0em">Specifies whether the scheduler calls
|
||||
<b>fsync</b>(2)
|
||||
after writing configuration or state files.
|
||||
-The default is "No".
|
||||
+The default is "Yes".
|
||||
<dt><b>SystemGroup </b><i>group-name </i>[ ... <i>group-name</i> ]
|
||||
<dt><a name="SystemGroup"></a><b>SystemGroup </b><i>group-name </i>[ ... <i>group-name</i> ]
|
||||
<dd style="margin-left: 5.0em">Specifies the group(s) to use for <i>@SYSTEM</i> group authentication.
|
||||
The default contains "admin", "lpadmin", "root", "sys", and/or "system".
|
||||
diff -up cups-2.0rc1/man/cups-files.conf.man.in.synconclose cups-2.0rc1/man/cups-files.conf.man.in
|
||||
--- cups-2.0rc1/man/cups-files.conf.man.in.synconclose 2014-09-12 16:48:36.518689520 +0200
|
||||
+++ cups-2.0rc1/man/cups-files.conf.man.in 2014-09-12 16:49:52.793612092 +0200
|
||||
@@ -182,7 +182,7 @@ The default is "/etc/cups".
|
||||
diff -up cups-2.0.2/man/cups-files.conf.man.in.LGOyhq cups-2.0.2/man/cups-files.conf.man.in
|
||||
--- cups-2.0.2/man/cups-files.conf.man.in.LGOyhq 2015-02-10 13:52:49.400997262 +0100
|
||||
+++ cups-2.0.2/man/cups-files.conf.man.in 2015-02-10 13:53:23.753510964 +0100
|
||||
@@ -201,7 +201,7 @@ The default is "/etc/cups".
|
||||
Specifies whether the scheduler calls
|
||||
.BR fsync (2)
|
||||
after writing configuration or state files.
|
||||
-The default is "No".
|
||||
+The default is "Yes".
|
||||
.\"#SystemGroup
|
||||
.TP 5
|
||||
\fBSystemGroup \fIgroup-name \fR[ ... \fIgroup-name\fR ]
|
||||
Specifies the group(s) to use for \fI@SYSTEM\fR group authentication.
|
||||
diff -up cups-2.0rc1/scheduler/conf.c.synconclose cups-2.0rc1/scheduler/conf.c
|
||||
--- cups-2.0rc1/scheduler/conf.c.synconclose 2014-09-12 16:48:36.519689506 +0200
|
||||
+++ cups-2.0rc1/scheduler/conf.c 2014-09-12 16:50:24.289167199 +0200
|
||||
@@ -715,7 +715,7 @@ cupsdReadConfiguration(void)
|
||||
diff -up cups-2.0.2/scheduler/conf.c.LGOyhq cups-2.0.2/scheduler/conf.c
|
||||
--- cups-2.0.2/scheduler/conf.c.LGOyhq 2015-02-10 13:51:24.991192177 +0100
|
||||
+++ cups-2.0.2/scheduler/conf.c 2015-02-10 13:52:49.401997248 +0100
|
||||
@@ -717,7 +717,7 @@ cupsdReadConfiguration(void)
|
||||
RootCertDuration = 300;
|
||||
Sandboxing = CUPSD_SANDBOXING_STRICT;
|
||||
StrictConformance = FALSE;
|
||||
|
@ -1,18 +1,18 @@
|
||||
diff -up cups-2.0.1/cups/usersys.c.systemd-socket cups-2.0.1/cups/usersys.c
|
||||
--- cups-2.0.1/cups/usersys.c.systemd-socket 2014-10-20 19:24:56.000000000 +0100
|
||||
+++ cups-2.0.1/cups/usersys.c 2015-01-27 11:20:16.674428706 +0000
|
||||
@@ -1078,7 +1078,7 @@ cups_read_client_conf(
|
||||
diff -up cups-2.0.2/cups/usersys.c.ustTJg cups-2.0.2/cups/usersys.c
|
||||
--- cups-2.0.2/cups/usersys.c.ustTJg 2015-02-10 13:40:24.294545077 +0100
|
||||
+++ cups-2.0.2/cups/usersys.c 2015-02-10 13:46:56.763989233 +0100
|
||||
@@ -1017,7 +1017,7 @@ cups_finalize_client_conf(
|
||||
struct stat sockinfo; /* Domain socket information */
|
||||
|
||||
if (!stat(CUPS_DEFAULT_DOMAINSOCKET, &sockinfo) &&
|
||||
- (sockinfo.st_mode & S_IRWXO) == S_IRWXO)
|
||||
+ (sockinfo.st_mode & (S_IROTH | S_IWOTH)) == (S_IROTH | S_IWOTH))
|
||||
cups_server = CUPS_DEFAULT_DOMAINSOCKET;
|
||||
cups_set_server_name(cc, CUPS_DEFAULT_DOMAINSOCKET);
|
||||
else
|
||||
#endif /* CUPS_DEFAULT_DOMAINSOCKET */
|
||||
diff -up cups-2.0.1/scheduler/main.c.systemd-socket cups-2.0.1/scheduler/main.c
|
||||
--- cups-2.0.1/scheduler/main.c.systemd-socket 2015-01-27 11:20:16.647428582 +0000
|
||||
+++ cups-2.0.1/scheduler/main.c 2015-01-27 11:20:16.675428711 +0000
|
||||
diff -up cups-2.0.2/scheduler/main.c.ustTJg cups-2.0.2/scheduler/main.c
|
||||
--- cups-2.0.2/scheduler/main.c.ustTJg 2015-02-10 13:40:24.121547526 +0100
|
||||
+++ cups-2.0.2/scheduler/main.c 2015-02-10 13:40:24.295545063 +0100
|
||||
@@ -658,8 +658,15 @@ main(int argc, /* I - Number of comm
|
||||
|
||||
#if defined(HAVE_LAUNCHD) || defined(HAVE_SYSTEMD)
|
||||
@ -30,9 +30,9 @@ diff -up cups-2.0.1/scheduler/main.c.systemd-socket cups-2.0.1/scheduler/main.c
|
||||
#endif /* HAVE_LAUNCHD || HAVE_SYSTEMD */
|
||||
if (fg)
|
||||
cupsdAddEvent(CUPSD_EVENT_SERVER_STARTED, NULL, NULL, "Scheduler started in foreground.");
|
||||
diff -up cups-2.0.1/scheduler/org.cups.cupsd.path.in.systemd-socket cups-2.0.1/scheduler/org.cups.cupsd.path.in
|
||||
--- cups-2.0.1/scheduler/org.cups.cupsd.path.in.systemd-socket 2014-03-21 14:50:24.000000000 +0000
|
||||
+++ cups-2.0.1/scheduler/org.cups.cupsd.path.in 2015-01-27 11:20:16.675428711 +0000
|
||||
diff -up cups-2.0.2/scheduler/org.cups.cupsd.path.in.ustTJg cups-2.0.2/scheduler/org.cups.cupsd.path.in
|
||||
--- cups-2.0.2/scheduler/org.cups.cupsd.path.in.ustTJg 2014-03-21 15:50:24.000000000 +0100
|
||||
+++ cups-2.0.2/scheduler/org.cups.cupsd.path.in 2015-02-10 13:40:24.295545063 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
Description=CUPS Scheduler
|
||||
|
||||
@ -42,9 +42,9 @@ diff -up cups-2.0.1/scheduler/org.cups.cupsd.path.in.systemd-socket cups-2.0.1/s
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
||||
diff -up cups-2.0.1/scheduler/org.cups.cupsd.service.in.systemd-socket cups-2.0.1/scheduler/org.cups.cupsd.service.in
|
||||
--- cups-2.0.1/scheduler/org.cups.cupsd.service.in.systemd-socket 2014-10-21 12:55:01.000000000 +0100
|
||||
+++ cups-2.0.1/scheduler/org.cups.cupsd.service.in 2015-01-27 11:20:39.631534108 +0000
|
||||
diff -up cups-2.0.2/scheduler/org.cups.cupsd.service.in.ustTJg cups-2.0.2/scheduler/org.cups.cupsd.service.in
|
||||
--- cups-2.0.2/scheduler/org.cups.cupsd.service.in.ustTJg 2014-10-21 13:55:01.000000000 +0200
|
||||
+++ cups-2.0.2/scheduler/org.cups.cupsd.service.in 2015-02-10 13:40:24.296545049 +0100
|
||||
@@ -1,10 +1,11 @@
|
||||
[Unit]
|
||||
Description=CUPS Scheduler
|
||||
|
13
cups.spec
13
cups.spec
@ -10,8 +10,8 @@
|
||||
Summary: CUPS printing system
|
||||
Name: cups
|
||||
Epoch: 1
|
||||
Version: 2.0.1
|
||||
Release: 2%{?dist}
|
||||
Version: 2.0.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Url: http://www.cups.org/
|
||||
Source0: http://www.cups.org/software/%{version}/cups-%{version}-source.tar.bz2
|
||||
@ -238,7 +238,7 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
|
||||
# Added IEEE 1284 Device ID for a Dymo device (bug #747866).
|
||||
%patch29 -p1 -b .dymo-deviceid
|
||||
# Use IP_FREEBIND socket option when binding listening sockets (bug #970809).
|
||||
#%%patch30 -p1 -b .freebind
|
||||
%patch30 -p1 -b .freebind
|
||||
# Don't link against libgcrypt needlessly.
|
||||
%patch31 -p1 -b .no-gcry
|
||||
# Added libusb quirk for Canon PIXMA MP540 (bug #967873).
|
||||
@ -497,12 +497,14 @@ rm -f %{cups_serverbin}/backend/smb
|
||||
%config(noreplace) %{_sysconfdir}/logrotate.d/cups
|
||||
%dir %{_datadir}/%{name}/www
|
||||
%dir %{_datadir}/%{name}/www/es
|
||||
%dir %{_datadir}/%{name}/www/ja
|
||||
%{_datadir}/%{name}/www/images
|
||||
%{_datadir}/%{name}/www/*.css
|
||||
%doc %{_datadir}/%{name}/www/index.html
|
||||
%doc %{_datadir}/%{name}/www/help
|
||||
%doc %{_datadir}/%{name}/www/robots.txt
|
||||
%doc %{_datadir}/%{name}/www/es/index.html
|
||||
%doc %{_datadir}/%{name}/www/ja/index.html
|
||||
%doc %{_datadir}/%{name}/www/apple-touch-icon.png
|
||||
%dir %{_datadir}/%{name}/usb
|
||||
%{_datadir}/%{name}/usb/org.cups.usb-quirks
|
||||
@ -538,8 +540,10 @@ rm -f %{cups_serverbin}/backend/smb
|
||||
%exclude %{_sbindir}/lpc.cups
|
||||
%dir %{_datadir}/cups/templates
|
||||
%dir %{_datadir}/cups/templates/es
|
||||
%dir %{_datadir}/cups/templates/ja
|
||||
%{_datadir}/cups/templates/*.tmpl
|
||||
%{_datadir}/cups/templates/es/*.tmpl
|
||||
%{_datadir}/cups/templates/ja/*.tmpl
|
||||
%dir %attr(1770,root,lp) %{_localstatedir}/spool/cups/tmp
|
||||
%dir %attr(0710,root,lp) %{_localstatedir}/spool/cups
|
||||
%dir %attr(0755,lp,sys) %{_localstatedir}/log/cups
|
||||
@ -601,6 +605,9 @@ rm -f %{cups_serverbin}/backend/smb
|
||||
%{_mandir}/man5/ipptoolfile.5.gz
|
||||
|
||||
%changelog
|
||||
* Tue Feb 10 2015 Jiri Popelka <jpopelka@redhat.com> - 1:2.0.2-1
|
||||
- 2.0.2
|
||||
|
||||
* Tue Jan 27 2015 Tim Waugh <twaugh@redhat.com> - 1:2.0.1-2
|
||||
- Fixed systemd notify support (bug #1184453).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user