1.5.0
This commit is contained in:
commit
90cf1a0fdd
1
.gitignore
vendored
1
.gitignore
vendored
@ -48,3 +48,4 @@ cups-1.4.4-source.tar.bz2
|
|||||||
/cups-1.5b1-source.tar.bz2
|
/cups-1.5b1-source.tar.bz2
|
||||||
/cups-1.5b2-source.tar.bz2
|
/cups-1.5b2-source.tar.bz2
|
||||||
/cups-1.5rc1-source.tar.bz2
|
/cups-1.5rc1-source.tar.bz2
|
||||||
|
/cups-1.5.0-source.tar.bz2
|
||||||
|
@ -1,15 +0,0 @@
|
|||||||
diff -up cups-1.4.7/backend/snmp-supplies.c.str3875 cups-1.4.7/backend/snmp-supplies.c
|
|
||||||
--- cups-1.4.7/backend/snmp-supplies.c.str3875 2011-07-07 16:44:41.000000000 +0200
|
|
||||||
+++ cups-1.4.7/backend/snmp-supplies.c 2011-07-07 16:48:19.201008765 +0200
|
|
||||||
@@ -259,7 +259,10 @@ backendSNMPSupplies(
|
|
||||||
if (quirks & QUIRK_CAPACITY)
|
|
||||||
supplies[i].max_capacity = 100;
|
|
||||||
|
|
||||||
- percent = 100 * supplies[i].level / supplies[i].max_capacity;
|
|
||||||
+ if (supplies[i].max_capacity > 0)
|
|
||||||
+ percent = 100 * supplies[i].level / supplies[i].max_capacity;
|
|
||||||
+ else
|
|
||||||
+ percent = 50;
|
|
||||||
|
|
||||||
if (percent <= 10)
|
|
||||||
{
|
|
@ -1,34 +0,0 @@
|
|||||||
diff -up cups-1.5rc1/scheduler/job.c.str3880 cups-1.5rc1/scheduler/job.c
|
|
||||||
--- cups-1.5rc1/scheduler/job.c.str3880 2011-07-20 13:25:04.830715537 +0100
|
|
||||||
+++ cups-1.5rc1/scheduler/job.c 2011-07-20 13:25:33.637200511 +0100
|
|
||||||
@@ -1407,17 +1407,22 @@ cupsdDeleteJob(cupsd_job_t *job, /
|
|
||||||
free(job->compressions);
|
|
||||||
free(job->filetypes);
|
|
||||||
|
|
||||||
- while (job->num_files > 0)
|
|
||||||
+ if (action == CUPSD_JOB_PURGE)
|
|
||||||
{
|
|
||||||
- snprintf(filename, sizeof(filename), "%s/d%05d-%03d", RequestRoot,
|
|
||||||
- job->id, job->num_files);
|
|
||||||
- if (Classification)
|
|
||||||
- cupsdRemoveFile(filename);
|
|
||||||
- else
|
|
||||||
- unlink(filename);
|
|
||||||
+ while (job->num_files > 0)
|
|
||||||
+ {
|
|
||||||
+ snprintf(filename, sizeof(filename), "%s/d%05d-%03d", RequestRoot,
|
|
||||||
+ job->id, job->num_files);
|
|
||||||
+ if (Classification)
|
|
||||||
+ cupsdRemoveFile(filename);
|
|
||||||
+ else
|
|
||||||
+ unlink(filename);
|
|
||||||
|
|
||||||
- job->num_files --;
|
|
||||||
+ job->num_files --;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
+ else
|
|
||||||
+ job->num_files = 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
if (job->history)
|
|
17
cups.spec
17
cups.spec
@ -10,15 +10,13 @@
|
|||||||
# but we use lib for compatibility with 3rd party drivers (at upstream request).
|
# but we use lib for compatibility with 3rd party drivers (at upstream request).
|
||||||
%global cups_serverbin %{_exec_prefix}/lib/cups
|
%global cups_serverbin %{_exec_prefix}/lib/cups
|
||||||
|
|
||||||
%global alphatag rc1
|
|
||||||
|
|
||||||
Summary: Common Unix Printing System
|
Summary: Common Unix Printing System
|
||||||
Name: cups
|
Name: cups
|
||||||
Version: 1.5
|
Version: 1.5.0
|
||||||
Release: 0.16.%{alphatag}%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: http://ftp.easysw.com/pub/cups/%{version}%{alphatag}/cups-%{version}%{alphatag}-source.tar.bz2
|
Source: http://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
||||||
# Pixmap for desktop file
|
# Pixmap for desktop file
|
||||||
Source2: cupsprinter.png
|
Source2: cupsprinter.png
|
||||||
# LSPP-required ps->pdf filter
|
# LSPP-required ps->pdf filter
|
||||||
@ -67,7 +65,6 @@ Patch29: cups-ricoh-deviceid-oid.patch
|
|||||||
Patch31: cups-avahi.patch
|
Patch31: cups-avahi.patch
|
||||||
Patch32: cups-icc.patch
|
Patch32: cups-icc.patch
|
||||||
Patch33: cups-systemd-socket.patch
|
Patch33: cups-systemd-socket.patch
|
||||||
Patch34: cups-str3880.patch
|
|
||||||
|
|
||||||
Patch100: cups-lspp.patch
|
Patch100: cups-lspp.patch
|
||||||
|
|
||||||
@ -213,7 +210,7 @@ module.
|
|||||||
Sends IPP requests to the specified URI and tests and/or displays the results.
|
Sends IPP requests to the specified URI and tests and/or displays the results.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}%{alphatag}
|
%setup -q
|
||||||
# Don't gzip man pages in the Makefile, let rpmbuild do it.
|
# Don't gzip man pages in the Makefile, let rpmbuild do it.
|
||||||
%patch1 -p1 -b .no-gzip-man
|
%patch1 -p1 -b .no-gzip-man
|
||||||
# Use the system pam configuration.
|
# Use the system pam configuration.
|
||||||
@ -280,9 +277,6 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
|
|||||||
# Poettering).
|
# Poettering).
|
||||||
%patch33 -p1 -b .systemd-socket
|
%patch33 -p1 -b .systemd-socket
|
||||||
|
|
||||||
# Don't delete job data files when restarted (STR #3880).
|
|
||||||
%patch34 -p1 -b .str3880
|
|
||||||
|
|
||||||
%if %lspp
|
%if %lspp
|
||||||
# LSPP support.
|
# LSPP support.
|
||||||
%patch100 -p1 -b .lspp
|
%patch100 -p1 -b .lspp
|
||||||
@ -629,6 +623,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/ipptool.1.gz
|
%{_mandir}/man1/ipptool.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 26 2011 Jiri Popelka <jpopelka@redhat.com> 1:1.5.0-1
|
||||||
|
- 1.5.0
|
||||||
|
|
||||||
* Wed Jul 20 2011 Tim Waugh <twaugh@redhat.com> 1:1.5-0.16.rc1
|
* Wed Jul 20 2011 Tim Waugh <twaugh@redhat.com> 1:1.5-0.16.rc1
|
||||||
- Don't delete job data files when restarted (STR #3880).
|
- Don't delete job data files when restarted (STR #3880).
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user