- 1.2.8.
This commit is contained in:
parent
6e8cd74b38
commit
88fa535d14
@ -17,3 +17,4 @@ cups-1.2.4-source.tar.bz2
|
||||
cups-1.2.5-source.tar.bz2
|
||||
cups-1.2.6-source.tar.bz2
|
||||
cups-1.2.7-source.tar.bz2
|
||||
cups-1.2.8-source.tar.bz2
|
||||
|
@ -1,15 +1,15 @@
|
||||
--- cups-1.2.7/backend/usb-unix.c.direct-usb 2006-11-15 20:28:39.000000000 +0000
|
||||
+++ cups-1.2.7/backend/usb-unix.c 2006-11-16 16:23:51.000000000 +0000
|
||||
@@ -85,6 +85,8 @@
|
||||
*/
|
||||
|
||||
use_bc = strcasecmp(hostname, "Canon") && !strstr(hostname, "Minolta");
|
||||
--- cups-1.2.8/backend/usb-unix.c.direct-usb 2007-02-05 20:25:50.000000000 +0000
|
||||
+++ cups-1.2.8/backend/usb-unix.c 2007-02-14 17:44:40.000000000 +0000
|
||||
@@ -87,6 +87,8 @@
|
||||
use_bc = strcasecmp(hostname, "Canon") &&
|
||||
strcasecmp(hostname, "Konica Minolta") &&
|
||||
strcasecmp(hostname, "Minolta");
|
||||
+ if (use_bc && !strncmp(uri, "usb:/dev/", 9))
|
||||
+ use_bc = 0;
|
||||
|
||||
if ((device_fd = open_device(uri, &use_bc)) == -1)
|
||||
{
|
||||
@@ -302,12 +304,7 @@
|
||||
@@ -304,12 +306,7 @@
|
||||
if (!strncmp(uri, "usb:/dev/", 9))
|
||||
#ifdef __linux
|
||||
{
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- cups-1.2.4/conf/cupsd.conf.in.directed-broadcast 2006-10-05 12:33:08.000000000 +0100
|
||||
+++ cups-1.2.4/conf/cupsd.conf.in 2006-10-05 12:33:04.000000000 +0100
|
||||
@@ -21,6 +21,7 @@
|
||||
--- cups-1.2.8/conf/cupsd.conf.in.directed-broadcast 2006-04-23 22:46:38.000000000 +0100
|
||||
+++ cups-1.2.8/conf/cupsd.conf.in 2007-02-14 17:44:51.000000000 +0000
|
||||
@@ -20,6 +20,7 @@
|
||||
# Show shared printers on the local network.
|
||||
Browsing On
|
||||
BrowseOrder allow,deny
|
||||
@ -8,17 +8,17 @@
|
||||
BrowseAllow @LOCAL
|
||||
|
||||
# Default authentication type, when authentication is required...
|
||||
--- cups-1.2.4/cups/adminutil.c.directed-broadcast 2006-10-05 12:16:48.000000000 +0100
|
||||
+++ cups-1.2.4/cups/adminutil.c 2006-10-05 12:19:29.000000000 +0100
|
||||
@@ -1155,7 +1155,11 @@
|
||||
--- cups-1.2.8/cups/adminutil.c.directed-broadcast 2007-02-11 16:59:33.000000000 +0000
|
||||
+++ cups-1.2.8/cups/adminutil.c 2007-02-14 17:47:04.000000000 +0000
|
||||
@@ -1278,7 +1278,11 @@
|
||||
cupsFilePuts(temp, "BrowseOrder allow,deny\n");
|
||||
|
||||
if (remote_printers)
|
||||
if (remote_printers > 0)
|
||||
+ {
|
||||
+ cupsFilePuts(temp, "# (Change '@LOCAL' to 'ALL' if using "
|
||||
+ "directed broadcasts from another subnet.)\n");
|
||||
cupsFilePuts(temp, "BrowseAllow @LOCAL\n");
|
||||
+ }
|
||||
|
||||
if (share_printers)
|
||||
if (share_printers > 0)
|
||||
cupsFilePuts(temp, "BrowseAddress @LOCAL\n");
|
||||
|
14
cups.spec
14
cups.spec
@ -5,8 +5,8 @@
|
||||
|
||||
Summary: Common Unix Printing System
|
||||
Name: cups
|
||||
Version: 1.2.7
|
||||
Release: 8%{?dist}
|
||||
Version: 1.2.8
|
||||
Release: 1%{?dist}
|
||||
License: GPL
|
||||
Group: System Environment/Daemons
|
||||
Source: ftp://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
||||
@ -43,9 +43,6 @@ Patch18: cups-directed-broadcast.patch
|
||||
Patch19: cups-eggcups.patch
|
||||
Patch20: cups-getpass.patch
|
||||
Patch21: cups-driverd-timeout.patch
|
||||
Patch22: cups-str2121.patch
|
||||
Patch23: cups-str2111.patch
|
||||
Patch24: cups-str2133.patch
|
||||
Patch100: cups-lspp.patch
|
||||
Epoch: 1
|
||||
Url: http://www.cups.org/
|
||||
@ -151,9 +148,6 @@ lpd emulation.
|
||||
%patch19 -p1 -b .eggcups
|
||||
%patch20 -p1 -b .getpass
|
||||
%patch21 -p1 -b .driverd-timeout
|
||||
%patch22 -p1 -b .str2121
|
||||
%patch23 -p1 -b .str2111
|
||||
%patch24 -p1 -b .str2133
|
||||
|
||||
%if %lspp
|
||||
%patch100 -p1 -b .lspp
|
||||
@ -371,6 +365,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_docdir}/cups-%{version}/de
|
||||
%{_docdir}/cups-%{version}/es
|
||||
%{_docdir}/cups-%{version}/et
|
||||
%{_docdir}/cups-%{version}/fr
|
||||
%{_docdir}/cups-%{version}/it
|
||||
%{_docdir}/cups-%{version}/ja
|
||||
%{_docdir}/cups-%{version}/pl
|
||||
@ -438,6 +433,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{cups_serverbin}/daemon/cups-lpd
|
||||
|
||||
%changelog
|
||||
* Wed Feb 14 2007 Tim Waugh <twaugh@redhat.com> 1:1.2.8-1
|
||||
- 1.2.8.
|
||||
|
||||
* Tue Feb 13 2007 Tim Waugh <twaugh@redhat.com> 1:1.2.7-8
|
||||
- Removed logrotate config file and maxlogsize patch (bug #227369). Now
|
||||
CUPS is in charge of rotating its own logs, and defaults to doing so once
|
||||
|
Loading…
Reference in New Issue
Block a user