rename unit files and update their patches
This commit is contained in:
parent
bee9347973
commit
66f882d58a
@ -0,0 +1,25 @@
|
|||||||
|
From 1157832777d18f614cee9f396d8f34a938adb796 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Didier Raboud <odyx@debian.org>
|
||||||
|
Date: Mon, 24 Feb 2020 11:46:49 +0100
|
||||||
|
Subject: [PATCH] Add Requires=cups.socket to cups.service, to make sure they
|
||||||
|
start in the right order
|
||||||
|
|
||||||
|
---
|
||||||
|
scheduler/cups.service.in | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/scheduler/cups.service.in b/scheduler/cups.service.in
|
||||||
|
index 5273762fb..e9052d7a3 100644
|
||||||
|
--- a/scheduler/cups.service.in
|
||||||
|
+++ b/scheduler/cups.service.in
|
||||||
|
@@ -2,6 +2,7 @@
|
||||||
|
Description=CUPS Scheduler
|
||||||
|
Documentation=man:cupsd(8)
|
||||||
|
After=network.target sssd.service ypbind.service
|
||||||
|
+Requires=cups.socket
|
||||||
|
|
||||||
|
[Service]
|
||||||
|
ExecStart=@sbindir@/cupsd -l
|
||||||
|
--
|
||||||
|
2.26.2
|
||||||
|
|
@ -1,10 +1,10 @@
|
|||||||
diff --git a/scheduler/org.cups.cupsd.service.in b/scheduler/org.cups.cupsd.service.in
|
diff --git a/scheduler/cups.service.in b/scheduler/cups.service.in
|
||||||
index bf308a5..add238b 100644
|
index bf308a5..add238b 100644
|
||||||
--- a/scheduler/org.cups.cupsd.service.in
|
--- a/scheduler/cups.service.in
|
||||||
+++ b/scheduler/org.cups.cupsd.service.in
|
+++ b/scheduler/cups.service.in
|
||||||
@@ -10,4 +10,4 @@ Restart=on-failure
|
@@ -10,4 +10,4 @@ Restart=on-failure
|
||||||
|
|
||||||
[Install]
|
[Install]
|
||||||
Also=cups.socket cups.path
|
Also=cups.socket cups.path
|
||||||
-WantedBy=printer.target
|
-WantedBy=printer.target
|
||||||
+WantedBy=printer.target multi-user.target
|
+WantedBy=multi-user.target printer.target
|
||||||
|
@ -1,7 +1,26 @@
|
|||||||
diff -up cups-2.2.12/scheduler/main.c.systemd-socket cups-2.2.12/scheduler/main.c
|
diff --git a/scheduler/cups.service.in b/scheduler/cups.service.in
|
||||||
--- cups-2.2.12/scheduler/main.c.systemd-socket 2019-08-16 00:35:30.000000000 +0200
|
index cd23343..928d77f 100644
|
||||||
+++ cups-2.2.12/scheduler/main.c 2019-08-19 09:31:09.703370325 +0200
|
--- a/scheduler/cups.service.in
|
||||||
@@ -674,8 +674,16 @@ main(int argc, /* I - Number of comm
|
+++ b/scheduler/cups.service.in
|
||||||
|
@@ -1,11 +1,11 @@
|
||||||
|
[Unit]
|
||||||
|
Description=CUPS Scheduler
|
||||||
|
Documentation=man:cupsd(8)
|
||||||
|
-After=sssd.service
|
||||||
|
+After=network.target sssd.service
|
||||||
|
|
||||||
|
[Service]
|
||||||
|
ExecStart=@sbindir@/cupsd -l
|
||||||
|
-Type=simple
|
||||||
|
+Type=notify
|
||||||
|
Restart=on-failure
|
||||||
|
|
||||||
|
[Install]
|
||||||
|
diff --git a/scheduler/main.c b/scheduler/main.c
|
||||||
|
index 4fee24f..206db30 100644
|
||||||
|
--- a/scheduler/main.c
|
||||||
|
+++ b/scheduler/main.c
|
||||||
|
@@ -706,8 +706,16 @@ main(int argc, /* I - Number of command-line args */
|
||||||
|
|
||||||
#ifdef HAVE_ONDEMAND
|
#ifdef HAVE_ONDEMAND
|
||||||
if (OnDemand)
|
if (OnDemand)
|
||||||
@ -19,56 +38,3 @@ diff -up cups-2.2.12/scheduler/main.c.systemd-socket cups-2.2.12/scheduler/main.
|
|||||||
#endif /* HAVE_ONDEMAND */
|
#endif /* HAVE_ONDEMAND */
|
||||||
if (fg)
|
if (fg)
|
||||||
cupsdAddEvent(CUPSD_EVENT_SERVER_STARTED, NULL, NULL, "Scheduler started in foreground.");
|
cupsdAddEvent(CUPSD_EVENT_SERVER_STARTED, NULL, NULL, "Scheduler started in foreground.");
|
||||||
diff -up cups-2.2.12/scheduler/org.cups.cupsd.path.in.systemd-socket cups-2.2.12/scheduler/org.cups.cupsd.path.in
|
|
||||||
--- cups-2.2.12/scheduler/org.cups.cupsd.path.in.systemd-socket 2019-08-16 00:35:30.000000000 +0200
|
|
||||||
+++ cups-2.2.12/scheduler/org.cups.cupsd.path.in 2019-08-19 09:31:09.703370325 +0200
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
[Unit]
|
|
||||||
Description=CUPS Scheduler
|
|
||||||
-PartOf=org.cups.cupsd.service
|
|
||||||
+PartOf=cups.service
|
|
||||||
|
|
||||||
[Path]
|
|
||||||
PathExists=@CUPS_CACHEDIR@/org.cups.cupsd
|
|
||||||
diff -up cups-2.2.12/scheduler/org.cups.cupsd.service.in.systemd-socket cups-2.2.12/scheduler/org.cups.cupsd.service.in
|
|
||||||
--- cups-2.2.12/scheduler/org.cups.cupsd.service.in.systemd-socket 2019-08-19 09:31:09.703370325 +0200
|
|
||||||
+++ cups-2.2.12/scheduler/org.cups.cupsd.service.in 2019-08-19 09:54:58.890036404 +0200
|
|
||||||
@@ -1,13 +1,13 @@
|
|
||||||
[Unit]
|
|
||||||
Description=CUPS Scheduler
|
|
||||||
Documentation=man:cupsd(8)
|
|
||||||
-After=sssd.service
|
|
||||||
+After=sssd.service network.target
|
|
||||||
|
|
||||||
[Service]
|
|
||||||
ExecStart=@sbindir@/cupsd -l
|
|
||||||
-Type=simple
|
|
||||||
+Type=notify
|
|
||||||
Restart=on-failure
|
|
||||||
|
|
||||||
[Install]
|
|
||||||
-Also=org.cups.cupsd.socket org.cups.cupsd.path
|
|
||||||
+Also=cups.socket cups.path
|
|
||||||
WantedBy=printer.target
|
|
||||||
diff -up cups-2.2.12/scheduler/org.cups.cupsd.socket.in.systemd-socket cups-2.2.12/scheduler/org.cups.cupsd.socket.in
|
|
||||||
--- cups-2.2.12/scheduler/org.cups.cupsd.socket.in.systemd-socket 2019-08-16 00:35:30.000000000 +0200
|
|
||||||
+++ cups-2.2.12/scheduler/org.cups.cupsd.socket.in 2019-08-19 09:31:09.703370325 +0200
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
[Unit]
|
|
||||||
Description=CUPS Scheduler
|
|
||||||
-PartOf=org.cups.cupsd.service
|
|
||||||
+PartOf=cups.service
|
|
||||||
|
|
||||||
[Socket]
|
|
||||||
ListenStream=@CUPS_DEFAULT_DOMAINSOCKET@
|
|
||||||
diff -up cups-2.2.12/scheduler/org.cups.cups-lpd.socket.systemd-socket cups-2.2.12/scheduler/org.cups.cups-lpd.socket
|
|
||||||
--- cups-2.2.12/scheduler/org.cups.cups-lpd.socket.systemd-socket 2019-08-16 00:35:30.000000000 +0200
|
|
||||||
+++ cups-2.2.12/scheduler/org.cups.cups-lpd.socket 2019-08-19 09:31:09.703370325 +0200
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
[Unit]
|
|
||||||
Description=CUPS LPD Server Socket
|
|
||||||
-PartOf=org.cups.cups-lpd.service
|
|
||||||
+PartOf=cups-lpd.service
|
|
||||||
|
|
||||||
[Socket]
|
|
||||||
ListenStream=515
|
|
||||||
|
265
cups-unit-files.patch
Normal file
265
cups-unit-files.patch
Normal file
@ -0,0 +1,265 @@
|
|||||||
|
diff --git a/configure b/configure
|
||||||
|
index 6f34f65..e57e603 100755
|
||||||
|
--- a/configure
|
||||||
|
+++ b/configure
|
||||||
|
@@ -9993,7 +9993,7 @@ fi
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
-ac_config_files="$ac_config_files Makedefs conf/cups-files.conf conf/cupsd.conf conf/mime.convs conf/pam.std conf/snmp.conf cups-config desktop/cups.desktop doc/index.html scheduler/cups-lpd.xinetd scheduler/cups.sh scheduler/cups.xml scheduler/org.cups.cups-lpd.plist scheduler/org.cups.cups-lpdAT.service scheduler/org.cups.cupsd.path scheduler/org.cups.cupsd.service scheduler/org.cups.cupsd.socket templates/header.tmpl packaging/cups.list $LANGFILES"
|
||||||
|
+ac_config_files="$ac_config_files Makedefs conf/cups-files.conf conf/cupsd.conf conf/mime.convs conf/pam.std conf/snmp.conf cups-config desktop/cups.desktop doc/index.html scheduler/cups-lpd.xinetd scheduler/cups.sh scheduler/cups.xml scheduler/org.cups.cups-lpd.plist scheduler/cups-lpdAT.service scheduler/cups.path scheduler/cups.service scheduler/cups.socket templates/header.tmpl packaging/cups.list $LANGFILES"
|
||||||
|
|
||||||
|
cat >confcache <<\_ACEOF
|
||||||
|
# This file is a shell script that caches the results of configure
|
||||||
|
@@ -10700,10 +10700,10 @@ do
|
||||||
|
"scheduler/cups.sh") CONFIG_FILES="$CONFIG_FILES scheduler/cups.sh" ;;
|
||||||
|
"scheduler/cups.xml") CONFIG_FILES="$CONFIG_FILES scheduler/cups.xml" ;;
|
||||||
|
"scheduler/org.cups.cups-lpd.plist") CONFIG_FILES="$CONFIG_FILES scheduler/org.cups.cups-lpd.plist" ;;
|
||||||
|
- "scheduler/org.cups.cups-lpdAT.service") CONFIG_FILES="$CONFIG_FILES scheduler/org.cups.cups-lpdAT.service" ;;
|
||||||
|
- "scheduler/org.cups.cupsd.path") CONFIG_FILES="$CONFIG_FILES scheduler/org.cups.cupsd.path" ;;
|
||||||
|
- "scheduler/org.cups.cupsd.service") CONFIG_FILES="$CONFIG_FILES scheduler/org.cups.cupsd.service" ;;
|
||||||
|
- "scheduler/org.cups.cupsd.socket") CONFIG_FILES="$CONFIG_FILES scheduler/org.cups.cupsd.socket" ;;
|
||||||
|
+ "scheduler/cups-lpdAT.service") CONFIG_FILES="$CONFIG_FILES scheduler/cups-lpdAT.service" ;;
|
||||||
|
+ "scheduler/cups.path") CONFIG_FILES="$CONFIG_FILES scheduler/cups.path" ;;
|
||||||
|
+ "scheduler/cups.service") CONFIG_FILES="$CONFIG_FILES scheduler/cups.service" ;;
|
||||||
|
+ "scheduler/cups.socket") CONFIG_FILES="$CONFIG_FILES scheduler/cups.socket" ;;
|
||||||
|
"templates/header.tmpl") CONFIG_FILES="$CONFIG_FILES templates/header.tmpl" ;;
|
||||||
|
"packaging/cups.list") CONFIG_FILES="$CONFIG_FILES packaging/cups.list" ;;
|
||||||
|
"$LANGFILES") CONFIG_FILES="$CONFIG_FILES $LANGFILES" ;;
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 44bf6eb..78b318e 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -72,10 +72,10 @@ AC_OUTPUT(Makedefs
|
||||||
|
scheduler/cups.sh
|
||||||
|
scheduler/cups.xml
|
||||||
|
scheduler/org.cups.cups-lpd.plist
|
||||||
|
- scheduler/org.cups.cups-lpdAT.service
|
||||||
|
- scheduler/org.cups.cupsd.path
|
||||||
|
- scheduler/org.cups.cupsd.service
|
||||||
|
- scheduler/org.cups.cupsd.socket
|
||||||
|
+ scheduler/cups-lpdAT.service
|
||||||
|
+ scheduler/cups.path
|
||||||
|
+ scheduler/cups.service
|
||||||
|
+ scheduler/cups.socket
|
||||||
|
templates/header.tmpl
|
||||||
|
packaging/cups.list
|
||||||
|
$LANGFILES)
|
||||||
|
diff --git a/packaging/cups.list.in b/packaging/cups.list.in
|
||||||
|
index 537c194..a167a99 100644
|
||||||
|
--- a/packaging/cups.list.in
|
||||||
|
+++ b/packaging/cups.list.in
|
||||||
|
@@ -1,6 +1,7 @@
|
||||||
|
#
|
||||||
|
# ESP Package Manager (EPM) file list for CUPS.
|
||||||
|
#
|
||||||
|
+# Copyright © 2020 by Michael R Sweet
|
||||||
|
# Copyright © 2007-2019 by Apple Inc.
|
||||||
|
# Copyright © 1997-2007 by Easy Software Products, all rights reserved.
|
||||||
|
#
|
||||||
|
@@ -10,8 +11,8 @@
|
||||||
|
|
||||||
|
# Product information
|
||||||
|
%product CUPS
|
||||||
|
-%copyright 2007-2019 by Apple Inc.
|
||||||
|
-%vendor Apple Inc.
|
||||||
|
+%copyright 2020 by Michael R Sweet, 2007-2019 by Apple Inc.
|
||||||
|
+%vendor OpenPrinting
|
||||||
|
#%license LICENSE
|
||||||
|
%readme LICENSE
|
||||||
|
%format rpm
|
||||||
|
@@ -20,8 +21,9 @@
|
||||||
|
%format !rpm
|
||||||
|
%version @CUPS_VERSION@
|
||||||
|
%format all
|
||||||
|
-%description CUPS is the standards-based, open source printing system developed by
|
||||||
|
-%description Apple Inc. for macOS® and other UNIX®-like operating systems.
|
||||||
|
+%description CUPS is the standards-based, open source printing system developed
|
||||||
|
+%description by Apple Inc. and maintained by OpenPrinting for macOS® and other
|
||||||
|
+%description UNIX®-like operating systems.
|
||||||
|
|
||||||
|
%format rpm
|
||||||
|
%provides lpd
|
||||||
|
diff --git a/packaging/cups.spec.in b/packaging/cups.spec.in
|
||||||
|
index d37103c..59caee0 100644
|
||||||
|
--- a/packaging/cups.spec.in
|
||||||
|
+++ b/packaging/cups.spec.in
|
||||||
|
@@ -3,6 +3,7 @@
|
||||||
|
#
|
||||||
|
# Original version by Jason McMullan <jmcc@ontv.com>.
|
||||||
|
#
|
||||||
|
+# Copyright © 2020 by Michael R Sweet
|
||||||
|
# Copyright © 2007-2019 by Apple Inc.
|
||||||
|
# Copyright © 1999-2007 by Easy Software Products, all rights reserved.
|
||||||
|
#
|
||||||
|
@@ -48,7 +49,7 @@ Group: System Environment/Daemons
|
||||||
|
Source: https://github.com/apple/cups/releases/download/v%{version}/cups-%{version}-source.tar.gz
|
||||||
|
Url: http://www.cups.org
|
||||||
|
Packager: Anonymous <anonymous@example.com>
|
||||||
|
-Vendor: Example Corp
|
||||||
|
+Vendor: OpenPrinting
|
||||||
|
|
||||||
|
# Package names are as defined for Red Hat (and clone) distributions
|
||||||
|
BuildRequires: gnutls-devel, pam-devel
|
||||||
|
@@ -97,7 +98,8 @@ Requires: %{name} = %{epoch}:%{version} xinetd
|
||||||
|
|
||||||
|
%description
|
||||||
|
CUPS is the standards-based, open source printing system developed by
|
||||||
|
-Apple Inc. for macOS® and other UNIX®-like operating systems.
|
||||||
|
+Apple Inc. and maintained by OpenPrinting for macOS® and other UNIX®-like
|
||||||
|
+operating systems.
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package provides the CUPS headers and development environment.
|
||||||
|
@@ -126,11 +128,11 @@ rm -rf $RPM_BUILD_ROOT/usr/share/cups/banners $RPM_BUILD_ROOT/usr/share/cups/dat
|
||||||
|
|
||||||
|
%post
|
||||||
|
%if %{?_with_systemd:1}%{!?_with_systemd:0}
|
||||||
|
-/bin/systemctl enable org.cups.cupsd.service
|
||||||
|
+/bin/systemctl enable cups.service
|
||||||
|
|
||||||
|
if test $1 -ge 1; then
|
||||||
|
- /bin/systemctl stop org.cups.cupsd.service
|
||||||
|
- /bin/systemctl start org.cups.cupsd.service
|
||||||
|
+ /bin/systemctl stop cups.service
|
||||||
|
+ /bin/systemctl start cups.service
|
||||||
|
fi
|
||||||
|
|
||||||
|
%else
|
||||||
|
@@ -150,8 +152,8 @@ fi
|
||||||
|
%preun
|
||||||
|
%if %{?_with_systemd:1}%{!?_with_systemd:0}
|
||||||
|
if test $1 -ge 1; then
|
||||||
|
- /bin/systemctl stop org.cups.cupsd.service
|
||||||
|
- /bin/systemctl disable org.cups.cupsd.service
|
||||||
|
+ /bin/systemctl stop cups.service
|
||||||
|
+ /bin/systemctl disable cups.service
|
||||||
|
fi
|
||||||
|
|
||||||
|
%else
|
||||||
|
@@ -164,8 +166,8 @@ fi
|
||||||
|
%postun
|
||||||
|
%if %{?_with_systemd:1}%{!?_with_systemd:0}
|
||||||
|
if test $1 -ge 1; then
|
||||||
|
- /bin/systemctl stop org.cups.cupsd.service
|
||||||
|
- /bin/systemctl start org.cups.cupsd.service
|
||||||
|
+ /bin/systemctl stop cups.service
|
||||||
|
+ /bin/systemctl start cups.service
|
||||||
|
fi
|
||||||
|
|
||||||
|
%else
|
||||||
|
@@ -203,7 +205,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
%if %{?_with_systemd:1}%{!?_with_systemd:0}
|
||||||
|
# SystemD
|
||||||
|
-/usr/lib/systemd/system/org.cups.cupsd.*
|
||||||
|
+/usr/lib/systemd/system/cups.*
|
||||||
|
|
||||||
|
%else
|
||||||
|
# Legacy init support on Linux
|
||||||
|
@@ -425,7 +427,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%if %{?_with_systemd:1}%{!?_with_systemd:0}
|
||||||
|
# SystemD
|
||||||
|
-/usr/lib/systemd/system/org.cups.cups-lpd*
|
||||||
|
+/usr/lib/systemd/system/cups-lpd*
|
||||||
|
%else
|
||||||
|
# Legacy xinetd
|
||||||
|
/etc/xinetd.d/cups-lpd
|
||||||
|
diff --git a/scheduler/Makefile b/scheduler/Makefile
|
||||||
|
index b50bd0a..a9b6ad6 100644
|
||||||
|
--- a/scheduler/Makefile
|
||||||
|
+++ b/scheduler/Makefile
|
||||||
|
@@ -194,11 +194,11 @@ install-data:
|
||||||
|
if test "x$(SYSTEMD_DIR)" != x; then \
|
||||||
|
echo Installing systemd configuration files...; \
|
||||||
|
$(INSTALL_DIR) $(BUILDROOT)$(SYSTEMD_DIR); \
|
||||||
|
- $(INSTALL_DATA) org.cups.cupsd.path $(BUILDROOT)$(SYSTEMD_DIR); \
|
||||||
|
- $(INSTALL_DATA) org.cups.cupsd.service $(BUILDROOT)$(SYSTEMD_DIR); \
|
||||||
|
- $(INSTALL_DATA) org.cups.cupsd.socket $(BUILDROOT)$(SYSTEMD_DIR); \
|
||||||
|
- $(INSTALL_DATA) org.cups.cups-lpdAT.service $(BUILDROOT)$(SYSTEMD_DIR)/org.cups.cups-lpd@.service; \
|
||||||
|
- $(INSTALL_DATA) org.cups.cups-lpd.socket $(BUILDROOT)$(SYSTEMD_DIR); \
|
||||||
|
+ $(INSTALL_DATA) cups.path $(BUILDROOT)$(SYSTEMD_DIR); \
|
||||||
|
+ $(INSTALL_DATA) cups.service $(BUILDROOT)$(SYSTEMD_DIR); \
|
||||||
|
+ $(INSTALL_DATA) cups.socket $(BUILDROOT)$(SYSTEMD_DIR); \
|
||||||
|
+ $(INSTALL_DATA) cups-lpdAT.service $(BUILDROOT)$(SYSTEMD_DIR)/cups-lpd@.service; \
|
||||||
|
+ $(INSTALL_DATA) cups-lpd.socket $(BUILDROOT)$(SYSTEMD_DIR); \
|
||||||
|
elif test "x$(XINETD)" != x; then \
|
||||||
|
echo Installing xinetd configuration file for cups-lpd...; \
|
||||||
|
$(INSTALL_DIR) -m 755 $(BUILDROOT)$(XINETD); \
|
||||||
|
@@ -294,9 +294,9 @@ uninstall:
|
||||||
|
fi
|
||||||
|
if test "x$SYSTEMD_DIR" != x; then \
|
||||||
|
echo Uninstalling systemd files...; \
|
||||||
|
- $(RM) $(BUILDROOT)$(SYSTEMD_DIR)/org.cups.cupsd.path; \
|
||||||
|
- $(RM) $(BUILDROOT)$(SYSTEMD_DIR)/org.cups.cupsd.service; \
|
||||||
|
- $(RM) $(BUILDROOT)$(SYSTEMD_DIR)/org.cups.cupsd.socket; \
|
||||||
|
+ $(RM) $(BUILDROOT)$(SYSTEMD_DIR)/cups.path; \
|
||||||
|
+ $(RM) $(BUILDROOT)$(SYSTEMD_DIR)/cups.service; \
|
||||||
|
+ $(RM) $(BUILDROOT)$(SYSTEMD_DIR)/cups.socket; \
|
||||||
|
fi
|
||||||
|
if test "x$(SMFMANIFESTDIR)" != x; then \
|
||||||
|
echo Uninstalling SMF manifest file...;\
|
||||||
|
diff --git a/scheduler/org.cups.cups-lpd.socket b/scheduler/cups-lpd.socket
|
||||||
|
similarity index 77%
|
||||||
|
rename from scheduler/org.cups.cups-lpd.socket
|
||||||
|
rename to scheduler/cups-lpd.socket
|
||||||
|
index ed23f9d..eb84459 100644
|
||||||
|
--- a/scheduler/org.cups.cups-lpd.socket
|
||||||
|
+++ b/scheduler/cups-lpd.socket
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
[Unit]
|
||||||
|
Description=CUPS LPD Server Socket
|
||||||
|
-PartOf=org.cups.cups-lpd.service
|
||||||
|
+PartOf=cups-lpd.service
|
||||||
|
|
||||||
|
[Socket]
|
||||||
|
ListenStream=515
|
||||||
|
diff --git a/scheduler/org.cups.cups-lpdAT.service.in b/scheduler/cups-lpdAT.service.in
|
||||||
|
similarity index 100%
|
||||||
|
rename from scheduler/org.cups.cups-lpdAT.service.in
|
||||||
|
rename to scheduler/cups-lpdAT.service.in
|
||||||
|
diff --git a/scheduler/org.cups.cupsd.path.in b/scheduler/cups.path.in
|
||||||
|
similarity index 80%
|
||||||
|
rename from scheduler/org.cups.cupsd.path.in
|
||||||
|
rename to scheduler/cups.path.in
|
||||||
|
index 0f1cc46..7c8509f 100644
|
||||||
|
--- a/scheduler/org.cups.cupsd.path.in
|
||||||
|
+++ b/scheduler/cups.path.in
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
[Unit]
|
||||||
|
Description=CUPS Scheduler
|
||||||
|
-PartOf=org.cups.cupsd.service
|
||||||
|
+PartOf=cups.service
|
||||||
|
|
||||||
|
[Path]
|
||||||
|
PathExists=@CUPS_CACHEDIR@/org.cups.cupsd
|
||||||
|
diff --git a/scheduler/org.cups.cupsd.service.in b/scheduler/cups.service.in
|
||||||
|
similarity index 79%
|
||||||
|
rename from scheduler/org.cups.cupsd.service.in
|
||||||
|
rename to scheduler/cups.service.in
|
||||||
|
index 5273762..cd23343 100644
|
||||||
|
--- a/scheduler/org.cups.cupsd.service.in
|
||||||
|
+++ b/scheduler/cups.service.in
|
||||||
|
@@ -9,5 +9,5 @@ Type=simple
|
||||||
|
Restart=on-failure
|
||||||
|
|
||||||
|
[Install]
|
||||||
|
-Also=org.cups.cupsd.socket org.cups.cupsd.path
|
||||||
|
+Also=cups.socket cups.path
|
||||||
|
WantedBy=printer.target
|
||||||
|
diff --git a/scheduler/org.cups.cupsd.socket.in b/scheduler/cups.socket.in
|
||||||
|
similarity index 80%
|
||||||
|
rename from scheduler/org.cups.cupsd.socket.in
|
||||||
|
rename to scheduler/cups.socket.in
|
||||||
|
index 613b977..3c37d72 100644
|
||||||
|
--- a/scheduler/org.cups.cupsd.socket.in
|
||||||
|
+++ b/scheduler/cups.socket.in
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
[Unit]
|
||||||
|
Description=CUPS Scheduler
|
||||||
|
-PartOf=org.cups.cupsd.service
|
||||||
|
+PartOf=cups.service
|
||||||
|
|
||||||
|
[Socket]
|
||||||
|
ListenStream=@CUPS_DEFAULT_DOMAINSOCKET@
|
@ -1,12 +1,12 @@
|
|||||||
diff -up cups-2.2.12/scheduler/org.cups.cupsd.service.in.ypbind cups-2.2.12/scheduler/org.cups.cupsd.service.in
|
diff -up cups-2.2.12/scheduler/cups.service.in.ypbind cups-2.2.12/scheduler/cups.service.in
|
||||||
--- cups-2.2.12/scheduler/org.cups.cupsd.service.in.ypbind 2019-08-19 10:00:47.586326493 +0200
|
--- cups-2.2.12/scheduler/cups.service.in.ypbind 2019-08-19 10:00:47.586326493 +0200
|
||||||
+++ cups-2.2.12/scheduler/org.cups.cupsd.service.in 2019-08-19 10:01:39.295890076 +0200
|
+++ cups-2.2.12/scheduler/cups.service.in 2019-08-19 10:01:39.295890076 +0200
|
||||||
@@ -1,7 +1,7 @@
|
@@ -1,7 +1,7 @@
|
||||||
[Unit]
|
[Unit]
|
||||||
Description=CUPS Scheduler
|
Description=CUPS Scheduler
|
||||||
Documentation=man:cupsd(8)
|
Documentation=man:cupsd(8)
|
||||||
-After=sssd.service network.target
|
-After=network.target sssd.service
|
||||||
+After=sssd.service network.target ypbind.service
|
+After=network.target sssd.service ypbind.service
|
||||||
|
|
||||||
[Service]
|
[Service]
|
||||||
ExecStart=@sbindir@/cupsd -l
|
ExecStart=@sbindir@/cupsd -l
|
||||||
|
34
cups.spec
34
cups.spec
@ -49,6 +49,7 @@ Patch10: cups-uri-compat.patch
|
|||||||
# change to notify type, because when it fails to start, it gives a error
|
# change to notify type, because when it fails to start, it gives a error
|
||||||
# message + renaming org.cups.cupsd names, because we have cups units in
|
# message + renaming org.cups.cupsd names, because we have cups units in
|
||||||
# in older Fedoras
|
# in older Fedoras
|
||||||
|
# https://github.com/OpenPrinting/cups/pull/51
|
||||||
Patch13: cups-systemd-socket.patch
|
Patch13: cups-systemd-socket.patch
|
||||||
# use IP_FREEBIND, because cupsd cannot bind to not yet existing IP address
|
# use IP_FREEBIND, because cupsd cannot bind to not yet existing IP address
|
||||||
# by default
|
# by default
|
||||||
@ -60,6 +61,7 @@ Patch16: cups-web-devices-timeout.patch
|
|||||||
# needs to be set to Yes to avoid race conditions
|
# needs to be set to Yes to avoid race conditions
|
||||||
Patch17: cups-synconclose.patch
|
Patch17: cups-synconclose.patch
|
||||||
# ypbind must be started before cups if NIS configured
|
# ypbind must be started before cups if NIS configured
|
||||||
|
# https://github.com/OpenPrinting/cups/pull/51
|
||||||
Patch18: cups-ypbind.patch
|
Patch18: cups-ypbind.patch
|
||||||
# failover backend for implementing failover functionality
|
# failover backend for implementing failover functionality
|
||||||
# TODO: move it to the cups-filters upstream
|
# TODO: move it to the cups-filters upstream
|
||||||
@ -109,7 +111,14 @@ Patch29: cups-manual-copies.patch
|
|||||||
# freed as a different attribute type than it was allocated
|
# freed as a different attribute type than it was allocated
|
||||||
# backported from upstream https://github.com/OpenPrinting/cups/pull/43
|
# backported from upstream https://github.com/OpenPrinting/cups/pull/43
|
||||||
Patch30: 0001-backend-scheduler-ipp.c-Fix-printer-alert-invalid-fr.patch
|
Patch30: 0001-backend-scheduler-ipp.c-Fix-printer-alert-invalid-fr.patch
|
||||||
|
# https://github.com/OpenPrinting/cups/pull/49
|
||||||
|
# https://github.com/OpenPrinting/cups/pull/52
|
||||||
Patch31: 0001-Fix-memory-leak-Issue-49.patch
|
Patch31: 0001-Fix-memory-leak-Issue-49.patch
|
||||||
|
# https://github.com/OpenPrinting/cups/commit/a72b0140ee9ad72f7ffc1f46fbe962bde159cbb8
|
||||||
|
# https://github.com/OpenPrinting/cups/commit/4999193d4778288e6bbddbbb86dbbb70835ea982
|
||||||
|
Patch32: cups-unit-files.patch
|
||||||
|
# https://github.com/OpenPrinting/cups/pull/31
|
||||||
|
Patch33: 0001-Add-Requires-cups.socket-to-cups.service-to-make-sur.patch
|
||||||
|
|
||||||
##### Patches removed because IMHO they aren't no longer needed
|
##### Patches removed because IMHO they aren't no longer needed
|
||||||
##### but still I'll leave them in git in case their removal
|
##### but still I'll leave them in git in case their removal
|
||||||
@ -285,8 +294,6 @@ to CUPS daemon. This solution will substitute printer drivers and raw queues in
|
|||||||
%patch10 -p1 -b .uri-compat
|
%patch10 -p1 -b .uri-compat
|
||||||
# Add an SNMP query for HP's device ID OID (STR #3552).
|
# Add an SNMP query for HP's device ID OID (STR #3552).
|
||||||
%patch11 -p1 -b .deviceid-oid
|
%patch11 -p1 -b .deviceid-oid
|
||||||
# Make cups.service Type=notify (bug #1088918).
|
|
||||||
%patch13 -p1 -b .systemd-socket
|
|
||||||
# Use IP_FREEBIND socket option when binding listening sockets (bug #970809).
|
# Use IP_FREEBIND socket option when binding listening sockets (bug #970809).
|
||||||
%patch14 -p1 -b .freebind
|
%patch14 -p1 -b .freebind
|
||||||
# Fixes for jobs with multiple files and multiple formats.
|
# Fixes for jobs with multiple files and multiple formats.
|
||||||
@ -295,8 +302,6 @@ to CUPS daemon. This solution will substitute printer drivers and raw queues in
|
|||||||
%patch16 -p1 -b .web-devices-timeout
|
%patch16 -p1 -b .web-devices-timeout
|
||||||
# Set the default for SyncOnClose to Yes.
|
# Set the default for SyncOnClose to Yes.
|
||||||
%patch17 -p1 -b .synconclose
|
%patch17 -p1 -b .synconclose
|
||||||
# CUPS may fail to start if NIS groups are used (bug #1494558)
|
|
||||||
%patch18 -p1 -b .ypbind
|
|
||||||
# Add failover backend (bug #1689209)
|
# Add failover backend (bug #1689209)
|
||||||
%patch19 -p1 -b .failover
|
%patch19 -p1 -b .failover
|
||||||
|
|
||||||
@ -309,8 +314,6 @@ to CUPS daemon. This solution will substitute printer drivers and raw queues in
|
|||||||
%patch20 -p1 -b .filter-debug
|
%patch20 -p1 -b .filter-debug
|
||||||
# Added IEEE 1284 Device ID for a Dymo device (bug #747866).
|
# Added IEEE 1284 Device ID for a Dymo device (bug #747866).
|
||||||
%patch21 -p1 -b .dymo-deviceid
|
%patch21 -p1 -b .dymo-deviceid
|
||||||
# 1822154 - cups.service doesn't execute automatically on request
|
|
||||||
%patch22 -p1 -b .autostart-when-enabled
|
|
||||||
%patch23 -p1 -b .print-color-mode
|
%patch23 -p1 -b .print-color-mode
|
||||||
%patch24 -p1 -b .ppdleak
|
%patch24 -p1 -b .ppdleak
|
||||||
%patch25 -p1 -b .rastertopwg-crash
|
%patch25 -p1 -b .rastertopwg-crash
|
||||||
@ -322,6 +325,15 @@ to CUPS daemon. This solution will substitute printer drivers and raw queues in
|
|||||||
%patch29 -p1 -b .manual-copies
|
%patch29 -p1 -b .manual-copies
|
||||||
%patch30 -p1 -b .printer-alert
|
%patch30 -p1 -b .printer-alert
|
||||||
%patch31 -p1 -b .avahi-leak
|
%patch31 -p1 -b .avahi-leak
|
||||||
|
%patch32 -p1 -b .unit-files
|
||||||
|
# Make cups.service Type=notify (bug #1088918).
|
||||||
|
%patch13 -p1 -b .systemd-socket
|
||||||
|
# CUPS may fail to start if NIS groups are used (bug #1494558)
|
||||||
|
%patch18 -p1 -b .ypbind
|
||||||
|
# https://github.com/OpenPrinting/cups/pull/31
|
||||||
|
%patch33 -p1 -b .require-socket
|
||||||
|
# 1822154 - cups.service doesn't execute automatically on request
|
||||||
|
%patch22 -p1 -b .autostart-when-enabled
|
||||||
|
|
||||||
|
|
||||||
# Log to the system journal by default (bug #1078781, bug #1519331).
|
# Log to the system journal by default (bug #1078781, bug #1519331).
|
||||||
@ -397,13 +409,6 @@ mv lpc.8 lpc-cups.8
|
|||||||
popd
|
popd
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
mv %{buildroot}%{_unitdir}/org.cups.cupsd.path %{buildroot}%{_unitdir}/cups.path
|
|
||||||
mv %{buildroot}%{_unitdir}/org.cups.cupsd.service %{buildroot}%{_unitdir}/cups.service
|
|
||||||
mv %{buildroot}%{_unitdir}/org.cups.cupsd.socket %{buildroot}%{_unitdir}/cups.socket
|
|
||||||
mv %{buildroot}%{_unitdir}/org.cups.cups-lpd.socket %{buildroot}%{_unitdir}/cups-lpd.socket
|
|
||||||
mv %{buildroot}%{_unitdir}/org.cups.cups-lpd@.service %{buildroot}%{_unitdir}/cups-lpd@.service
|
|
||||||
/bin/sed -i -e "s,org.cups.cupsd,cups,g" %{buildroot}%{_unitdir}/cups.service
|
|
||||||
|
|
||||||
mkdir -p %{buildroot}%{_datadir}/pixmaps %{buildroot}%{_sysconfdir}/X11/sysconfig %{buildroot}%{_sysconfdir}/X11/applnk/System
|
mkdir -p %{buildroot}%{_datadir}/pixmaps %{buildroot}%{_sysconfdir}/X11/sysconfig %{buildroot}%{_sysconfdir}/X11/applnk/System
|
||||||
install -p -m 644 %{SOURCE1} %{buildroot}%{_datadir}/pixmaps
|
install -p -m 644 %{SOURCE1} %{buildroot}%{_datadir}/pixmaps
|
||||||
|
|
||||||
@ -548,7 +553,7 @@ exit 0
|
|||||||
exit 0
|
exit 0
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
# ignore the messages due #1614751 (systemd bug) and #1897023 (CUPS unit file design)
|
# ignore the messages due #1614751 (systemd bug)
|
||||||
%systemd_postun_with_restart %{name}.path %{name}.socket %{name}.service > /dev/null 2>&1
|
%systemd_postun_with_restart %{name}.path %{name}.socket %{name}.service > /dev/null 2>&1
|
||||||
exit 0
|
exit 0
|
||||||
|
|
||||||
@ -735,6 +740,7 @@ rm -f %{cups_serverbin}/backend/smb
|
|||||||
- CREDITS is now in markdown format, so we don't need to convert
|
- CREDITS is now in markdown format, so we don't need to convert
|
||||||
- fix requires on nss-mdns for cups-printerapp
|
- fix requires on nss-mdns for cups-printerapp
|
||||||
- take SNMP OID from upstream
|
- take SNMP OID from upstream
|
||||||
|
- rename unit files and update their patches
|
||||||
|
|
||||||
* Thu Nov 12 2020 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.3.3-19
|
* Thu Nov 12 2020 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.3.3-19
|
||||||
- 1897023 - Cups service restart sequence during upgrade incorrect
|
- 1897023 - Cups service restart sequence during upgrade incorrect
|
||||||
|
Loading…
Reference in New Issue
Block a user