Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/cups.git#e1122ab84c5804fec4fd513cd88b4b27973a25bf
This commit is contained in:
parent
f083cb8e2f
commit
60a0ec96d3
16
cups-logs.patch
Normal file
16
cups-logs.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff --git a/scheduler/log.c b/scheduler/log.c
|
||||
index 17331ff02..41ddb4cb9 100644
|
||||
--- a/scheduler/log.c
|
||||
+++ b/scheduler/log.c
|
||||
@@ -569,11 +569,7 @@ cupsdLogJob(cupsd_job_t *job, /* I - Job */
|
||||
* Format and write the log message...
|
||||
*/
|
||||
|
||||
-#ifdef HAVE_SYSTEMD_SD_JOURNAL_H
|
||||
- if (job && strcmp(ErrorLog, "syslog"))
|
||||
-#else
|
||||
if (job)
|
||||
-#endif /* HAVE_SYSTEMD_SD_JOURNAL_H */
|
||||
snprintf(jobmsg, sizeof(jobmsg), "[Job %d] %s", job->id, message);
|
||||
else
|
||||
strlcpy(jobmsg, message, sizeof(jobmsg));
|
28
cups.spec
28
cups.spec
@ -17,7 +17,7 @@ Summary: CUPS printing system
|
||||
Name: cups
|
||||
Epoch: 1
|
||||
Version: 2.3.3%{OP_VER}
|
||||
Release: 1%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: ASL 2.0
|
||||
Url: http://www.cups.org/
|
||||
# Apple stopped uploading the new versions into github, use OpenPrinting fork
|
||||
@ -61,6 +61,8 @@ Patch11: cups-web-devices-timeout.patch
|
||||
Patch12: cups-failover-backend.patch
|
||||
# add device id for dymo printer
|
||||
Patch13: cups-dymo-deviceid.patch
|
||||
# add [Job N] in logs
|
||||
Patch14: cups-logs.patch
|
||||
|
||||
%if %{lspp}
|
||||
# selinux and audit enablement for CUPS - needs work and CUPS upstream wants
|
||||
@ -267,6 +269,8 @@ to CUPS daemon. This solution will substitute printer drivers and raw queues in
|
||||
%patch12 -p1 -b .failover
|
||||
# Added IEEE 1284 Device ID for a Dymo device (bug #747866).
|
||||
%patch13 -p1 -b .dymo-deviceid
|
||||
# add [Job N] to logs
|
||||
%patch14 -p1 -b .logs
|
||||
|
||||
# UPSTREAM PATCHES
|
||||
|
||||
@ -470,44 +474,35 @@ exit 0
|
||||
--slave %{_mandir}/man1/lpq.1.gz print-lpqman %{_mandir}/man1/lpq-cups.1.gz \
|
||||
--slave %{_mandir}/man1/lpr.1.gz print-lprman %{_mandir}/man1/lpr-cups.1.gz \
|
||||
--slave %{_mandir}/man1/lprm.1.gz print-lprmman %{_mandir}/man1/lprm-cups.1.gz \
|
||||
--slave %{_mandir}/man1/lpstat.1.gz print-lpstatman %{_mandir}/man1/lpstat-cups.1.gz
|
||||
--slave %{_mandir}/man1/lpstat.1.gz print-lpstatman %{_mandir}/man1/lpstat-cups.1.gz || :
|
||||
%endif
|
||||
exit 0
|
||||
|
||||
%post lpd
|
||||
%systemd_post cups-lpd.socket
|
||||
exit 0
|
||||
|
||||
%ldconfig_scriptlets libs
|
||||
|
||||
%preun
|
||||
%systemd_preun %{name}.path %{name}.socket %{name}.service
|
||||
exit 0
|
||||
|
||||
%preun client
|
||||
%if %{use_alternatives}
|
||||
if [ $1 -eq 0 ] ; then
|
||||
/usr/sbin/alternatives --remove print %{_bindir}/lpr.cups
|
||||
/usr/sbin/alternatives --remove print %{_bindir}/lpr.cups || :
|
||||
fi
|
||||
%endif
|
||||
exit 0
|
||||
|
||||
%preun lpd
|
||||
%systemd_preun cups-lpd.socket
|
||||
exit 0
|
||||
|
||||
%postun
|
||||
# ignore the messages due #1614751 (systemd bug)
|
||||
%systemd_postun_with_restart %{name}.path %{name}.socket %{name}.service > /dev/null 2>&1
|
||||
exit 0
|
||||
%systemd_postun_with_restart %{name}.path %{name}.socket %{name}.service
|
||||
|
||||
%postun lpd
|
||||
%systemd_postun_with_restart cups-lpd.socket
|
||||
exit 0
|
||||
|
||||
%triggerin -- samba-client
|
||||
ln -sf %{_libexecdir}/samba/cups_backend_smb %{cups_serverbin}/backend/smb || :
|
||||
exit 0
|
||||
|
||||
%triggerun -- samba-client
|
||||
[ $2 = 0 ] || exit 0
|
||||
@ -675,6 +670,13 @@ rm -f %{cups_serverbin}/backend/smb
|
||||
%{_mandir}/man7/ippeveps.7.gz
|
||||
|
||||
%changelog
|
||||
* Mon Mar 22 2021 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.3.3op2-3
|
||||
- add [Job N] in logs for better debugging
|
||||
|
||||
* Tue Mar 02 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1:2.3.3op2-2
|
||||
- Rebuilt for updated systemd-rpm-macros
|
||||
See https://pagure.io/fesco/issue/2583.
|
||||
|
||||
* Tue Feb 02 2021 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.3.3op2-1
|
||||
- 1923828 - cups-2.3.3op2 is available
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user