2.1.4, 1346668 - Change symlink for smb backend to /usr/libexec/samba/cups_backend_smb
This commit is contained in:
parent
a9b9d752e3
commit
297482d2e7
1
.gitignore
vendored
1
.gitignore
vendored
@ -74,3 +74,4 @@ cups-1.4.4-source.tar.bz2
|
|||||||
/cups-2.1.1-source.tar.bz2
|
/cups-2.1.1-source.tar.bz2
|
||||||
/cups-2.1.2-source.tar.bz2
|
/cups-2.1.2-source.tar.bz2
|
||||||
/cups-2.1.3-source.tar.bz2
|
/cups-2.1.3-source.tar.bz2
|
||||||
|
/cups-2.1.4-source.tar.gz
|
||||||
|
@ -1,16 +1,16 @@
|
|||||||
diff -up cups-2.0rc1/backend/dnssd.c.dnssd-deviceid cups-2.0rc1/backend/dnssd.c
|
diff -up cups-2.1.4/backend/dnssd.c.dnssd-deviceid cups-2.1.4/backend/dnssd.c
|
||||||
--- cups-2.0rc1/backend/dnssd.c.dnssd-deviceid 2014-06-30 16:27:01.000000000 +0200
|
--- cups-2.1.4/backend/dnssd.c.dnssd-deviceid 2016-06-15 14:36:19.922353606 +0200
|
||||||
+++ cups-2.0rc1/backend/dnssd.c 2014-09-12 14:08:38.624252208 +0200
|
+++ cups-2.1.4/backend/dnssd.c 2016-06-15 14:45:45.794966648 +0200
|
||||||
@@ -1196,15 +1196,22 @@ query_callback(
|
@@ -1188,15 +1188,22 @@ query_callback(
|
||||||
if (device->device_id)
|
if (device->device_id)
|
||||||
free(device->device_id);
|
free(device->device_id);
|
||||||
|
|
||||||
+ if (device_id[0])
|
+if (device_id[0])
|
||||||
+ {
|
+{
|
||||||
+ /* Mark this as the real device ID. */
|
+ /* Mark this as the real device ID. */
|
||||||
+ ptr = device_id + strlen(device_id);
|
+ ptr = device_id + strlen(device_id);
|
||||||
+ snprintf(ptr, sizeof(device_id) - (ptr - device_id), "FZY:0;");
|
+ snprintf(ptr, sizeof(device_id) - (ptr - device_id), "FZY:0;");
|
||||||
+ }
|
+}
|
||||||
+
|
+
|
||||||
if (!device_id[0] && strcmp(model, "Unknown"))
|
if (!device_id[0] && strcmp(model, "Unknown"))
|
||||||
{
|
{
|
||||||
@ -19,19 +19,19 @@ diff -up cups-2.0rc1/backend/dnssd.c.dnssd-deviceid cups-2.0rc1/backend/dnssd.c
|
|||||||
+ snprintf(device_id, sizeof(device_id), "MFG:%s;MDL:%s;FZY:1;",
|
+ snprintf(device_id, sizeof(device_id), "MFG:%s;MDL:%s;FZY:1;",
|
||||||
make_and_model, model);
|
make_and_model, model);
|
||||||
else if (!_cups_strncasecmp(model, "designjet ", 10))
|
else if (!_cups_strncasecmp(model, "designjet ", 10))
|
||||||
- snprintf(device_id, sizeof(device_id), "MFG:HP;MDL:%s", model + 10);
|
- snprintf(device_id, sizeof(device_id), "MFG:HP;MDL:%s;", model + 10);
|
||||||
+ snprintf(device_id, sizeof(device_id), "MFG:HP;MDL:%s;FZY:1;", model + 10);
|
+ snprintf(device_id, sizeof(device_id), "MFG:HP;MDL:%s;FZY:1;", model + 10);
|
||||||
else if (!_cups_strncasecmp(model, "stylus ", 7))
|
else if (!_cups_strncasecmp(model, "stylus ", 7))
|
||||||
- snprintf(device_id, sizeof(device_id), "MFG:EPSON;MDL:%s", model + 7);
|
- snprintf(device_id, sizeof(device_id), "MFG:EPSON;MDL:%s;", model + 7);
|
||||||
+ snprintf(device_id, sizeof(device_id), "MFG:EPSON;MDL:%s;FZY:1;", model + 7);
|
+ snprintf(device_id, sizeof(device_id), "MFG:EPSON;MDL:%s;FZY:1;", model + 7);
|
||||||
else if ((ptr = strchr(model, ' ')) != NULL)
|
else if ((ptr = strchr(model, ' ')) != NULL)
|
||||||
{
|
{
|
||||||
/*
|
/*
|
||||||
@@ -1214,7 +1221,7 @@ query_callback(
|
@@ -1206,7 +1213,7 @@ query_callback(
|
||||||
memcpy(make_and_model, model, (size_t)(ptr - model));
|
memcpy(make_and_model, model, (size_t)(ptr - model));
|
||||||
make_and_model[ptr - model] = '\0';
|
make_and_model[ptr - model] = '\0';
|
||||||
|
|
||||||
- snprintf(device_id, sizeof(device_id), "MFG:%s;MDL:%s",
|
- snprintf(device_id, sizeof(device_id), "MFG:%s;MDL:%s;",
|
||||||
+ snprintf(device_id, sizeof(device_id), "MFG:%s;MDL:%s;FZY:1;",
|
+ snprintf(device_id, sizeof(device_id), "MFG:%s;MDL:%s;FZY:1;",
|
||||||
make_and_model, ptr + 1);
|
make_and_model, ptr + 1);
|
||||||
}
|
}
|
||||||
|
@ -1,14 +1,13 @@
|
|||||||
diff -up cups-1.7.0/backend/org.cups.usb-quirks.libusb-quirks cups-1.7.0/backend/org.cups.usb-quirks
|
diff -up cups-2.1.4/backend/org.cups.usb-quirks.libusb-quirks cups-2.1.4/backend/org.cups.usb-quirks
|
||||||
--- cups-1.7.0/backend/org.cups.usb-quirks.libusb-quirks 2013-10-24 15:49:41.960232193 +0100
|
--- cups-2.1.4/backend/org.cups.usb-quirks.libusb-quirks 2016-06-15 14:46:46.122497874 +0200
|
||||||
+++ cups-1.7.0/backend/org.cups.usb-quirks 2013-10-24 15:50:58.307550615 +0100
|
+++ cups-2.1.4/backend/org.cups.usb-quirks 2016-06-15 14:48:47.752552749 +0200
|
||||||
@@ -75,6 +75,9 @@
|
@@ -76,6 +76,9 @@
|
||||||
# Canon, Inc. MP510 Printer, https://bugs.launchpad.net/bugs/1050009
|
# Canon, Inc. MP510 Printer (https://bugs.launchpad.net/bugs/1050009)
|
||||||
0x04a9 0x1717 unidir
|
0x04a9 0x1717 unidir
|
||||||
|
|
||||||
+# Canon, Inc. MP540 Printer, https://bugzilla.redhat.com/967873
|
+# Canon, Inc. MP540 Printer, https://bugzilla.redhat.com/967873
|
||||||
+0x04a9 0x1730 unidir
|
+0x04a9 0x1730 unidir
|
||||||
+
|
+
|
||||||
# Canon, Inc. MP550 Printer, http://www.cups.org/str.php?L4155
|
# Canon, Inc. MP550 Printer (Issue #4155)
|
||||||
0x04a9 0x173d unidir
|
0x04a9 0x173d unidir
|
||||||
|
|
||||||
diff -up cups-1.7.0/backend/usb-libusb.c.libusb-quirks cups-1.7.0/backend/usb-libusb.c
|
|
||||||
|
20
cups.spec
20
cups.spec
@ -14,11 +14,11 @@
|
|||||||
Summary: CUPS printing system
|
Summary: CUPS printing system
|
||||||
Name: cups
|
Name: cups
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.1.3
|
Version: 2.1.4
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Url: http://www.cups.org/
|
Url: http://www.cups.org/
|
||||||
Source0: http://www.cups.org/software/%{VERSION}/cups-%{VERSION}-source.tar.bz2
|
Source0: http://www.cups.org/software/%{VERSION}/cups-%{VERSION}-source.tar.gz
|
||||||
# Pixmap for desktop file
|
# Pixmap for desktop file
|
||||||
Source2: cupsprinter.png
|
Source2: cupsprinter.png
|
||||||
# Logrotate configuration
|
# Logrotate configuration
|
||||||
@ -463,21 +463,13 @@ exit 0
|
|||||||
exit 0
|
exit 0
|
||||||
|
|
||||||
%triggerin -- samba-client
|
%triggerin -- samba-client
|
||||||
ln -sf ../../../bin/smbspool %{cups_serverbin}/backend/smb || :
|
ln -sf %{_libexecdir}/samba/cups_backend_smb %{cups_serverbin}/backend/smb || :
|
||||||
exit 0
|
exit 0
|
||||||
|
|
||||||
%triggerun -- samba-client
|
%triggerun -- samba-client
|
||||||
[ $2 = 0 ] || exit 0
|
[ $2 = 0 ] || exit 0
|
||||||
rm -f %{cups_serverbin}/backend/smb
|
rm -f %{cups_serverbin}/backend/smb
|
||||||
|
|
||||||
%triggerin -- samba4-client
|
|
||||||
ln -sf %{_bindir}/smbspool %{cups_serverbin}/backend/smb || :
|
|
||||||
exit 0
|
|
||||||
|
|
||||||
%triggerun -- samba4-client
|
|
||||||
[ $2 = 0 ] || exit 0
|
|
||||||
rm -f %{cups_serverbin}/backend/smb
|
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%doc README.txt CREDITS.txt CHANGES.txt
|
%doc README.txt CREDITS.txt CHANGES.txt
|
||||||
%dir %attr(0755,root,lp) %{_sysconfdir}/cups
|
%dir %attr(0755,root,lp) %{_sysconfdir}/cups
|
||||||
@ -515,6 +507,7 @@ rm -f %{cups_serverbin}/backend/smb
|
|||||||
%doc %{_datadir}/%{name}/www/es/index.html
|
%doc %{_datadir}/%{name}/www/es/index.html
|
||||||
%doc %{_datadir}/%{name}/www/ja/index.html
|
%doc %{_datadir}/%{name}/www/ja/index.html
|
||||||
%doc %{_datadir}/%{name}/www/ru/index.html
|
%doc %{_datadir}/%{name}/www/ru/index.html
|
||||||
|
%doc %{_datadir}/%{name}/www/pt_BR/index.html
|
||||||
%doc %{_datadir}/%{name}/www/apple-touch-icon.png
|
%doc %{_datadir}/%{name}/www/apple-touch-icon.png
|
||||||
%dir %{_datadir}/%{name}/usb
|
%dir %{_datadir}/%{name}/usb
|
||||||
%{_datadir}/%{name}/usb/org.cups.usb-quirks
|
%{_datadir}/%{name}/usb/org.cups.usb-quirks
|
||||||
@ -553,11 +546,13 @@ rm -f %{cups_serverbin}/backend/smb
|
|||||||
%dir %{_datadir}/cups/templates/es
|
%dir %{_datadir}/cups/templates/es
|
||||||
%dir %{_datadir}/cups/templates/ja
|
%dir %{_datadir}/cups/templates/ja
|
||||||
%dir %{_datadir}/cups/templates/ru
|
%dir %{_datadir}/cups/templates/ru
|
||||||
|
%dir %{_datadir}/cups/templates/pt_BR
|
||||||
%{_datadir}/cups/templates/*.tmpl
|
%{_datadir}/cups/templates/*.tmpl
|
||||||
%{_datadir}/cups/templates/de/*.tmpl
|
%{_datadir}/cups/templates/de/*.tmpl
|
||||||
%{_datadir}/cups/templates/es/*.tmpl
|
%{_datadir}/cups/templates/es/*.tmpl
|
||||||
%{_datadir}/cups/templates/ja/*.tmpl
|
%{_datadir}/cups/templates/ja/*.tmpl
|
||||||
%{_datadir}/cups/templates/ru/*.tmpl
|
%{_datadir}/cups/templates/ru/*.tmpl
|
||||||
|
%{_datadir}/cups/templates/pt_BR/*.tmpl
|
||||||
%dir %attr(1770,root,lp) %{_localstatedir}/spool/cups/tmp
|
%dir %attr(1770,root,lp) %{_localstatedir}/spool/cups/tmp
|
||||||
%dir %attr(0710,root,lp) %{_localstatedir}/spool/cups
|
%dir %attr(0710,root,lp) %{_localstatedir}/spool/cups
|
||||||
%dir %attr(0755,lp,sys) %{_localstatedir}/log/cups
|
%dir %attr(0755,lp,sys) %{_localstatedir}/log/cups
|
||||||
@ -619,6 +614,9 @@ rm -f %{cups_serverbin}/backend/smb
|
|||||||
%{_mandir}/man5/ipptoolfile.5.gz
|
%{_mandir}/man5/ipptoolfile.5.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 15 2016 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.1.4-1
|
||||||
|
- 2.1.4, 1346668 - Change symlink for smb backend to /usr/libexec/samba/cups_backend_smb
|
||||||
|
|
||||||
* Mon Feb 08 2016 Jiri Popelka <jpopelka@redhat.com> - 1:2.1.3-1
|
* Mon Feb 08 2016 Jiri Popelka <jpopelka@redhat.com> - 1:2.1.3-1
|
||||||
- 2.1.3
|
- 2.1.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user