RHEL-32727 lpoptions with root writes to ~/.cups/lpoptions
Resolves: RHEL-32727
This commit is contained in:
parent
e7f50abf2a
commit
2031f024f2
@ -0,0 +1,32 @@
|
|||||||
|
From 8ae6eb11184dcbd9eaf3c6badd4fad59fcc3863a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Zdenek Dohnal <zdohnal@redhat.com>
|
||||||
|
Date: Mon, 15 Aug 2022 17:38:12 +0200
|
||||||
|
Subject: [PATCH] cups/dest.c: Write data into /etc/cups/lpoptions if we're
|
||||||
|
root
|
||||||
|
|
||||||
|
Fixes #454 , the patch is created by Yair Yarom
|
||||||
|
(https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1008053).
|
||||||
|
---
|
||||||
|
cups/dest.c | 6 +++++-
|
||||||
|
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/cups/dest.c b/cups/dest.c
|
||||||
|
index f563ce226..a9273ff93 100644
|
||||||
|
--- a/cups/dest.c
|
||||||
|
+++ b/cups/dest.c
|
||||||
|
@@ -2080,7 +2080,11 @@ cupsSetDests2(http_t *http, /* I - Connection to server or @code CUPS_HTTP_
|
||||||
|
|
||||||
|
snprintf(filename, sizeof(filename), "%s/lpoptions", cg->cups_serverroot);
|
||||||
|
|
||||||
|
- if (cg->home)
|
||||||
|
+ if (cg->home
|
||||||
|
+#ifndef _WIN32
|
||||||
|
+ && getuid() != 0
|
||||||
|
+#endif /* !_WIN32 */
|
||||||
|
+ )
|
||||||
|
{
|
||||||
|
/*
|
||||||
|
* Create ~/.cups subdirectory...
|
||||||
|
--
|
||||||
|
2.44.0
|
||||||
|
|
10
cups.spec
10
cups.spec
@ -24,7 +24,7 @@ Summary: CUPS printing system
|
|||||||
Name: cups
|
Name: cups
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.3.3%{OP_VER}
|
Version: 2.3.3%{OP_VER}
|
||||||
Release: 25%{?dist}
|
Release: 26%{?dist}
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
Url: http://www.cups.org/
|
Url: http://www.cups.org/
|
||||||
# Apple stopped uploading the new versions into github, use OpenPrinting fork
|
# Apple stopped uploading the new versions into github, use OpenPrinting fork
|
||||||
@ -134,6 +134,9 @@ Patch38: 0001-scheduler-conf.c-Print-to-stderr-if-we-don-t-open-cu.patch
|
|||||||
Patch39: 0001-httpAddrConnect2-Check-for-error-if-POLLHUP-is-in-va.patch
|
Patch39: 0001-httpAddrConnect2-Check-for-error-if-POLLHUP-is-in-va.patch
|
||||||
# https://github.com/OpenPrinting/cups/pull/927
|
# https://github.com/OpenPrinting/cups/pull/927
|
||||||
Patch40: 0001-scheduler-Fix-sending-response-headers-to-client.patch
|
Patch40: 0001-scheduler-Fix-sending-response-headers-to-client.patch
|
||||||
|
# RHEL-32727 lpoptions with root writes to ~/.cups/lpoptions
|
||||||
|
# https://github.com/OpenPrinting/cups/pull/456
|
||||||
|
Patch41: 0001-cups-dest.c-Write-data-into-etc-cups-lpoptions-if-we.patch
|
||||||
|
|
||||||
|
|
||||||
##### Patches removed because IMHO they aren't no longer needed
|
##### Patches removed because IMHO they aren't no longer needed
|
||||||
@ -397,6 +400,8 @@ to CUPS daemon. This solution will substitute printer drivers and raw queues in
|
|||||||
%patch39 -p1 -b .cupsgetjobs-pollhup
|
%patch39 -p1 -b .cupsgetjobs-pollhup
|
||||||
# https://github.com/OpenPrinting/cups/pull/927
|
# https://github.com/OpenPrinting/cups/pull/927
|
||||||
%patch40 -p1 -b .sent-headers
|
%patch40 -p1 -b .sent-headers
|
||||||
|
# RHEL-32727 lpoptions with root writes to ~/.cups/lpoptions
|
||||||
|
%patch41 -p1 -b .root-lpoptions
|
||||||
|
|
||||||
%if %{lspp}
|
%if %{lspp}
|
||||||
# LSPP support.
|
# LSPP support.
|
||||||
@ -831,6 +836,9 @@ rm -f %{cups_serverbin}/backend/smb
|
|||||||
%{_mandir}/man7/ippeveps.7.gz
|
%{_mandir}/man7/ippeveps.7.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 15 2024 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.3.3op2-26
|
||||||
|
- RHEL-32727 lpoptions with root writes to ~/.cups/lpoptions
|
||||||
|
|
||||||
* Fri Apr 05 2024 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.3.3op2-25
|
* Fri Apr 05 2024 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.3.3op2-25
|
||||||
- RHEL-29764 cups doesn't send Content-Type header back to client when Set-Cookie is seen first
|
- RHEL-29764 cups doesn't send Content-Type header back to client when Set-Cookie is seen first
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user