Don't use the IPP Create-Job operation, widely implemented unreliably (bug #854989).
Resolves: rhbz#854989
This commit is contained in:
parent
46c9f563bf
commit
13ead681f3
25
cups-ipp-no-create-job.patch
Normal file
25
cups-ipp-no-create-job.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff -up cups-1.5.4/backend/ipp.c.no-create-job cups-1.5.4/backend/ipp.c
|
||||
--- cups-1.5.4/backend/ipp.c.no-create-job 2012-09-18 10:27:00.674951341 +0100
|
||||
+++ cups-1.5.4/backend/ipp.c 2012-09-18 10:28:37.360322089 +0100
|
||||
@@ -1127,21 +1127,10 @@ main(int argc, /* I - Number of comm
|
||||
{
|
||||
if (operations_sup->values[i].integer == IPP_VALIDATE_JOB)
|
||||
validate_job = 1;
|
||||
- else if (operations_sup->values[i].integer == IPP_CREATE_JOB)
|
||||
- create_job = 1;
|
||||
- else if (operations_sup->values[i].integer == IPP_SEND_DOCUMENT)
|
||||
- send_document = 1;
|
||||
else if (operations_sup->values[i].integer == IPP_GET_JOB_ATTRIBUTES)
|
||||
get_job_attrs = 1;
|
||||
}
|
||||
|
||||
- if (!send_document)
|
||||
- {
|
||||
- fputs("DEBUG: Printer supports Create-Job but not Send-Document.\n",
|
||||
- stderr);
|
||||
- create_job = 0;
|
||||
- }
|
||||
-
|
||||
if (!validate_job)
|
||||
update_reasons(NULL, "+cups-ipp-conformance-failure-report,"
|
||||
"cups-ipp-missing-validate-job");
|
11
cups.spec
11
cups.spec
@ -12,7 +12,7 @@
|
||||
Summary: Common Unix Printing System
|
||||
Name: cups
|
||||
Version: 1.5.4
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Daemons
|
||||
Source: http://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
||||
@ -72,6 +72,7 @@ Patch35: cups-icc.patch
|
||||
Patch36: cups-systemd-socket.patch
|
||||
|
||||
Patch40: cups-r10572.patch
|
||||
Patch41: cups-ipp-no-create-job.patch
|
||||
|
||||
Patch100: cups-lspp.patch
|
||||
|
||||
@ -298,6 +299,10 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
|
||||
# CUPS now includes the port number in the Host: header for HTTP requests. (r10572)
|
||||
%patch40 -p1 -b .r10572
|
||||
|
||||
# Don't use the IPP Create-Job operation, widely implemented
|
||||
# unreliably (bug #854989).
|
||||
%patch41 -p1 -b .ipp-no-create-job
|
||||
|
||||
%if %lspp
|
||||
# LSPP support.
|
||||
%patch100 -p1 -b .lspp
|
||||
@ -658,6 +663,10 @@ rm -f %{cups_serverbin}/backend/smb
|
||||
%{_mandir}/man1/ipptool.1.gz
|
||||
|
||||
%changelog
|
||||
* Tue Sep 18 2012 Tim Waugh <twaugh@redhat.com> 1:1.5.4-5
|
||||
- Don't use the IPP Create-Job operation, widely implemented
|
||||
unreliably (bug #854989).
|
||||
|
||||
* Wed Aug 29 2012 Jiri Popelka <jpopelka@redhat.com> 1:1.5.4-4
|
||||
- backport 2 upstream commits (r10572, r10573)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user