- 1.4.2. No longer need str3380, str3332, str3356, str3396 patches.
- Removed postscript.ppd.gz (bug #533371).
This commit is contained in:
parent
4e5971975b
commit
12b1aefb46
@ -1,10 +1,27 @@
|
||||
--- cups-1.2svn-r5238/conf/Makefile.system-auth 2006-03-07 09:34:20.000000000 +0000
|
||||
+++ cups-1.2svn-r5238/conf/Makefile 2006-03-07 09:45:41.000000000 +0000
|
||||
@@ -79,10 +79,16 @@
|
||||
diff -up /dev/null cups-1.4.2/conf/cups.password-auth
|
||||
--- /dev/null 2009-11-10 09:17:06.284031490 +0000
|
||||
+++ cups-1.4.2/conf/cups.password-auth 2009-11-10 11:15:42.750666738 +0000
|
||||
@@ -0,0 +1,4 @@
|
||||
+#%PAM-1.0
|
||||
+# Use password-auth common PAM configuration for the daemon
|
||||
+auth include password-auth
|
||||
+account include password-auth
|
||||
diff -up cups-1.4.2/conf/cups.system-auth cups-1.4.2/conf/cups
|
||||
diff -up /dev/null cups-1.4.2/conf/cups.system-auth
|
||||
--- /dev/null 2009-11-10 09:17:06.284031490 +0000
|
||||
+++ cups-1.4.2/conf/cups.system-auth 2009-11-10 11:15:42.750666738 +0000
|
||||
@@ -0,0 +1,3 @@
|
||||
+#%PAM-1.0
|
||||
+auth include system-auth
|
||||
+account include system-auth
|
||||
diff -up cups-1.4.2/conf/Makefile.system-auth cups-1.4.2/conf/Makefile
|
||||
--- cups-1.4.2/conf/Makefile.system-auth 2009-09-22 22:53:31.000000000 +0100
|
||||
+++ cups-1.4.2/conf/Makefile 2009-11-10 11:18:44.188791989 +0000
|
||||
@@ -90,10 +90,16 @@ install-data:
|
||||
done
|
||||
-if test x$(PAMDIR) != x; then \
|
||||
$(INSTALL_DIR) -m 755 $(BUILDROOT)$(PAMDIR); \
|
||||
- if test -r $(BUILDROOT)$(PAMDIR)/cups/$(PAMFILE) ; then \
|
||||
- if test -r $(BUILDROOT)$(PAMDIR)/cups ; then \
|
||||
- $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups.N ; \
|
||||
+ if test -f /etc/pam.d/password-auth; then \
|
||||
+ $(INSTALL_DATA) cups.password-auth $(BUILDROOT)$(PAMDIR)/cups; \
|
||||
@ -12,7 +29,7 @@
|
||||
+ $(INSTALL_DATA) cups.system-auth $(BUILDROOT)$(PAMDIR)/cups; \
|
||||
else \
|
||||
- $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups ; \
|
||||
+ if test -r $(BUILDROOT)$(PAMDIR)/cups/$(PAMFILE) ; then \
|
||||
+ if test -r $(BUILDROOT)$(PAMDIR)/cups ; then \
|
||||
+ $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups.N ; \
|
||||
+ else \
|
||||
+ $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups ; \
|
||||
@ -20,16 +37,3 @@
|
||||
fi ; \
|
||||
fi
|
||||
|
||||
--- /dev/null 2006-03-07 09:12:30.964372750 +0000
|
||||
+++ cups-1.2svn-r5238/conf/cups.system-auth 2006-03-07 09:43:12.000000000 +0000
|
||||
@@ -0,0 +1,3 @@
|
||||
+#%PAM-1.0
|
||||
+auth include system-auth
|
||||
+account include system-auth
|
||||
--- /dev/null 2006-03-07 09:12:30.964372750 +0000
|
||||
+++ cups-1.2svn-r5238/conf/cups.password-auth 2006-03-07 09:43:12.000000000 +0000
|
||||
@@ -0,0 +1,4 @@
|
||||
+#%PAM-1.0
|
||||
+# Use password-auth common PAM configuration for the daemon
|
||||
+auth include password-auth
|
||||
+account include password-auth
|
||||
|
@ -1,20 +0,0 @@
|
||||
diff -up ./postscript.ppd.generic-ps ./postscript.ppd
|
||||
--- ./postscript.ppd.generic-ps 2009-10-08 11:08:07.389336611 +0100
|
||||
+++ ./postscript.ppd 2009-10-08 11:06:40.836338000 +0100
|
||||
@@ -12,11 +12,11 @@
|
||||
*LanguageVersion: English
|
||||
*LanguageEncoding: ISOLatin1
|
||||
*PCFileName: "POSTSCRIPT.PPD"
|
||||
-*Manufacturer: "Postscript"
|
||||
-*Product: "(CUPS v1.1)"
|
||||
-*ModelName: "Generic postscript printer"
|
||||
-*ShortNickName: "Generic postscript printer"
|
||||
-*NickName: "Generic postscript printer"
|
||||
+*Manufacturer: "Generic"
|
||||
+*Product: "(PostScript Printer)"
|
||||
+*ModelName: "Generic PostScript Printer"
|
||||
+*ShortNickName: "Generic PostScript Printer"
|
||||
+*NickName: "Generic PostScript Printer"
|
||||
*PSVersion: "(2017.000) 0"
|
||||
*LanguageLevel: "2"
|
||||
*ColorDevice: False
|
@ -1,12 +0,0 @@
|
||||
diff -up cups-1.4.1/backend/usb-unix.c.function-decl cups-1.4.1/backend/usb-unix.c
|
||||
--- cups-1.4.1/backend/usb-unix.c.function-decl 2009-09-14 17:36:06.087996470 +0100
|
||||
+++ cups-1.4.1/backend/usb-unix.c 2009-09-14 17:36:13.656996607 +0100
|
||||
@@ -605,7 +605,7 @@ open_device(const char *uri, /* I - Dev
|
||||
* 'side_cb()' - Handle side-channel requests...
|
||||
*/
|
||||
|
||||
-static void
|
||||
+static int
|
||||
side_cb(int print_fd, /* I - Print file */
|
||||
int device_fd, /* I - Device file */
|
||||
int snmp_fd, /* I - SNMP socket (unused) */
|
@ -1,101 +0,0 @@
|
||||
diff -up cups-1.4.1/scheduler/ipp.c.str3356 cups-1.4.1/scheduler/ipp.c
|
||||
--- cups-1.4.1/scheduler/ipp.c.str3356 2009-10-07 17:26:27.504800579 +0100
|
||||
+++ cups-1.4.1/scheduler/ipp.c 2009-10-07 17:26:31.311800539 +0100
|
||||
@@ -2324,8 +2324,9 @@ add_printer(cupsd_client_t *con, /* I -
|
||||
dstfile[1024]; /* Destination Script/PPD file */
|
||||
int modify; /* Non-zero if we are modifying */
|
||||
char newname[IPP_MAX_NAME]; /* New printer name */
|
||||
- int need_restart_job; /* Need to restart job? */
|
||||
- int set_device_uri, /* Did we set the device URI? */
|
||||
+ int changed_driver, /* Changed the PPD/interface script? */
|
||||
+ need_restart_job, /* Need to restart job? */
|
||||
+ set_device_uri, /* Did we set the device URI? */
|
||||
set_port_monitor; /* Did we set the port monitor? */
|
||||
|
||||
|
||||
@@ -2469,6 +2470,7 @@ add_printer(cupsd_client_t *con, /* I -
|
||||
* Look for attributes and copy them over as needed...
|
||||
*/
|
||||
|
||||
+ changed_driver = 0;
|
||||
need_restart_job = 0;
|
||||
|
||||
if ((attr = ippFindAttribute(con->request, "printer-location",
|
||||
@@ -2731,6 +2733,7 @@ add_printer(cupsd_client_t *con, /* I -
|
||||
if (con->filename)
|
||||
{
|
||||
need_restart_job = 1;
|
||||
+ changed_driver = 1;
|
||||
|
||||
strlcpy(srcfile, con->filename, sizeof(srcfile));
|
||||
|
||||
@@ -2801,18 +2804,6 @@ add_printer(cupsd_client_t *con, /* I -
|
||||
cupsdLogMessage(CUPSD_LOG_DEBUG,
|
||||
"Copied PPD file successfully!");
|
||||
chmod(dstfile, 0644);
|
||||
-
|
||||
-#ifdef __APPLE__
|
||||
- /*
|
||||
- * (Re)register color profiles...
|
||||
- */
|
||||
-
|
||||
- if (!RunUser)
|
||||
- {
|
||||
- apple_unregister_profiles(printer);
|
||||
- apple_register_profiles(printer);
|
||||
- }
|
||||
-#endif /* __APPLE__ */
|
||||
}
|
||||
else
|
||||
{
|
||||
@@ -2829,6 +2820,7 @@ add_printer(cupsd_client_t *con, /* I -
|
||||
IPP_TAG_NAME)) != NULL)
|
||||
{
|
||||
need_restart_job = 1;
|
||||
+ changed_driver = 1;
|
||||
|
||||
if (!strcmp(attr->values[0].string.text, "raw"))
|
||||
{
|
||||
@@ -2866,19 +2858,33 @@ add_printer(cupsd_client_t *con, /* I -
|
||||
cupsdLogMessage(CUPSD_LOG_DEBUG,
|
||||
"Copied PPD file successfully!");
|
||||
chmod(dstfile, 0644);
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ if (changed_driver)
|
||||
+ {
|
||||
+ /*
|
||||
+ * If we changed the PPD/interface script, then remove the printer's cache
|
||||
+ * file...
|
||||
+ */
|
||||
+
|
||||
+ char cache_name[1024]; /* Cache filename for printer attrs */
|
||||
+
|
||||
+ snprintf(cache_name, sizeof(cache_name), "%s/%s.ipp", CacheDir,
|
||||
+ printer->name);
|
||||
+ unlink(cache_name);
|
||||
|
||||
#ifdef __APPLE__
|
||||
- /*
|
||||
- * (Re)register color profiles...
|
||||
- */
|
||||
+ /*
|
||||
+ * (Re)register color profiles...
|
||||
+ */
|
||||
|
||||
- if (!RunUser)
|
||||
- {
|
||||
- apple_unregister_profiles(printer);
|
||||
- apple_register_profiles(printer);
|
||||
- }
|
||||
-#endif /* __APPLE__ */
|
||||
+ if (!RunUser)
|
||||
+ {
|
||||
+ apple_unregister_profiles(printer);
|
||||
+ apple_register_profiles(printer);
|
||||
}
|
||||
+#endif /* __APPLE__ */
|
||||
}
|
||||
|
||||
/*
|
@ -1,12 +0,0 @@
|
||||
diff -up cups-1.4.1/doc/de/index.html.in.str3380 cups-1.4.1/doc/de/index.html.in
|
||||
--- cups-1.4.1/doc/de/index.html.in.str3380 2009-04-09 22:22:42.000000000 +0100
|
||||
+++ cups-1.4.1/doc/de/index.html.in 2009-10-19 12:04:30.352768816 +0100
|
||||
@@ -17,7 +17,7 @@ SRC="/images/left.gif" WIDTH="64" HEIGHT
|
||||
<TD CLASS="unsel"><A HREF="/admin"> Verwaltung </A></TD>
|
||||
<TD CLASS="unsel"><A HREF="/classes/"> Klassen </A></TD>
|
||||
<TD CLASS="unsel"><A HREF="/help/"> On-Line Hilfe </A></TD>
|
||||
-<TD CLASS="unsel"><A HREF="/jobs/"> Auftrüge </A></TD>
|
||||
+<TD CLASS="unsel"><A HREF="/jobs/"> Aufträge </A></TD>
|
||||
<TD CLASS="unsel"><A HREF="/printers/"> Drucker </A></TD>
|
||||
<TD CLASS="unsel" WIDTH="100%"><FORM ACTION="/help/" METHOD="GET"><INPUT
|
||||
TYPE="SEARCH" NAME="QUERY" SIZE="20" PLACEHOLDER="Search Help"
|
@ -1,11 +0,0 @@
|
||||
diff -up cups-1.4.1/templates/de/set-printer-options-header.tmpl.str3396 cups-1.4.1/templates/de/set-printer-options-header.tmpl
|
||||
--- cups-1.4.1/templates/de/set-printer-options-header.tmpl.str3396 2009-04-03 17:55:28.000000000 +0200
|
||||
+++ cups-1.4.1/templates/de/set-printer-options-header.tmpl 2009-10-27 15:17:53.000000000 +0100
|
||||
@@ -1,6 +1,6 @@
|
||||
<DIV CLASS="indent">
|
||||
|
||||
-<H2 CLASS="title">Standardeinstellungen f%uuml;r {printer_name} festlegen</H2>
|
||||
+<H2 CLASS="title">Standardeinstellungen für {printer_name} festlegen</H2>
|
||||
|
||||
<FORM METHOD="POST" ACTION="/admin">
|
||||
<INPUT TYPE="HIDDEN" NAME="PRINTER_NAME" VALUE="{printer_name}">
|
27
cups.spec
27
cups.spec
@ -8,23 +8,21 @@
|
||||
|
||||
Summary: Common Unix Printing System
|
||||
Name: cups
|
||||
Version: 1.4.1
|
||||
Release: 14%{?dist}
|
||||
Version: 1.4.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Daemons
|
||||
Source: http://ftp.easysw.com/pub/cups/1.4.0/cups-%{version}-source.tar.bz2
|
||||
Source: http://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
||||
Source1: cups.init
|
||||
Source2: cupsprinter.png
|
||||
Source3: cups-libusb.rules
|
||||
Source4: pstopdf
|
||||
Source5: cups-lpd
|
||||
Source8: postscript.ppd.gz
|
||||
Source9: cups.logrotate
|
||||
Source10: ncp.backend
|
||||
Source12: cups.cron
|
||||
Source14: textonly.filter
|
||||
Source15: textonly.ppd
|
||||
Patch0: cups-generic-ps.patch
|
||||
Patch1: cups-no-gzip-man.patch
|
||||
Patch2: cups-1.1.16-system-auth.patch
|
||||
Patch3: cups-multilib.patch
|
||||
@ -33,7 +31,6 @@ Patch6: cups-banners.patch
|
||||
Patch7: cups-serverbin-compat.patch
|
||||
Patch8: cups-no-export-ssllibs.patch
|
||||
Patch9: cups-paps.patch
|
||||
Patch10: cups-str3380.patch
|
||||
Patch11: cups-direct-usb.patch
|
||||
Patch12: cups-lpr-help.patch
|
||||
Patch13: cups-peercred.patch
|
||||
@ -51,13 +48,10 @@ Patch25: cups-filter-debug.patch
|
||||
Patch30: cups-uri-compat.patch
|
||||
Patch35: cups-cups-get-classes.patch
|
||||
Patch37: cups-avahi.patch
|
||||
Patch38: cups-str3332.patch
|
||||
Patch39: cups-str3356.patch
|
||||
Patch40: cups-str3382.patch
|
||||
Patch41: cups-str3285_v2.patch
|
||||
Patch42: cups-str3390.patch
|
||||
Patch43: cups-str3391.patch
|
||||
Patch44: cups-str3396.patch
|
||||
|
||||
Patch100: cups-lspp.patch
|
||||
Epoch: 1
|
||||
@ -186,10 +180,6 @@ module.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
gunzip -c %{SOURCE8} > postscript.ppd
|
||||
%patch0 -p0 -b .generic-ps
|
||||
gzip -n postscript.ppd
|
||||
|
||||
%patch1 -p1 -b .no-gzip-man
|
||||
%patch2 -p1 -b .system-auth
|
||||
%patch3 -p1 -b .multilib
|
||||
@ -198,7 +188,6 @@ gzip -n postscript.ppd
|
||||
%patch7 -p1 -b .serverbin-compat
|
||||
%patch8 -p1 -b .no-export-ssllibs
|
||||
%patch9 -p1 -b .paps
|
||||
%patch10 -p1 -b .str3380
|
||||
%patch11 -p1 -b .direct-usb
|
||||
%patch12 -p1 -b .lpr-help
|
||||
%patch13 -p1 -b .peercred
|
||||
@ -216,13 +205,10 @@ gzip -n postscript.ppd
|
||||
%patch30 -p1 -b .uri-compat
|
||||
%patch35 -p1 -b .cups-get-classes
|
||||
%patch37 -p1 -b .avahi
|
||||
%patch38 -p1 -b .str3332
|
||||
%patch39 -p1 -b .str3356
|
||||
%patch40 -p1 -b .str3382
|
||||
%patch41 -p1 -b .str3285_v2
|
||||
%patch42 -p1 -b .str3390
|
||||
%patch43 -p1 -b .str3391
|
||||
%patch44 -p1 -b .str3396
|
||||
|
||||
%if %lspp
|
||||
%patch100 -p1 -b .lspp
|
||||
@ -305,9 +291,6 @@ install -c -m 644 %{SOURCE15} $RPM_BUILD_ROOT%{_datadir}/cups/model/textonly.ppd
|
||||
install -c -m 755 %{SOURCE4} $RPM_BUILD_ROOT%{cups_serverbin}/filter
|
||||
%endif
|
||||
|
||||
# Ship a generic postscript PPD file (#73061)
|
||||
install -c -m 644 postscript.ppd.gz $RPM_BUILD_ROOT%{_datadir}/cups/model
|
||||
|
||||
# Ship a printers.conf file, and a client.conf file. That way, they get
|
||||
# their SELinux file contexts set correctly.
|
||||
touch $RPM_BUILD_ROOT%{_sysconfdir}/cups/printers.conf
|
||||
@ -518,6 +501,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{php_extdir}/phpcups.so
|
||||
|
||||
%changelog
|
||||
* Tue Nov 10 2009 Tim Waugh <twaugh@redhat.com> 1:1.4.2-1
|
||||
- 1.4.2. No longer need str3380, str3332, str3356, str3396 patches.
|
||||
- Removed postscript.ppd.gz (bug #533371).
|
||||
|
||||
* Tue Nov 3 2009 Tim Waugh <twaugh@redhat.com> 1:1.4.1-14
|
||||
- Removed stale patch from STR #2831 which was causing problems with
|
||||
number-up (bug #532516).
|
||||
|
Loading…
Reference in New Issue
Block a user