- Include fixes from svn up to revision 7287. No longer need str2650 or
str2664 patches.
This commit is contained in:
parent
4c05344dab
commit
11fbd76145
7990
cups-1.3.x.patch
Normal file
7990
cups-1.3.x.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -1297,7 +1297,7 @@
|
|||||||
+ {
|
+ {
|
||||||
+ if (getfilecon(con->filename, &spoolcon) == -1)
|
+ if (getfilecon(con->filename, &spoolcon) == -1)
|
||||||
+ {
|
+ {
|
||||||
+ cupsdSendError(con, HTTP_SERVER_ERROR, AUTH_NONE);
|
+ cupsdSendError(con, HTTP_SERVER_ERROR, CUPSD_AUTH_NONE);
|
||||||
+ return (cupsdCloseClient(con));
|
+ return (cupsdCloseClient(con));
|
||||||
+ }
|
+ }
|
||||||
+ clicon = context_new(con->scon);
|
+ clicon = context_new(con->scon);
|
||||||
@ -1305,7 +1305,7 @@
|
|||||||
+ freecon(spoolcon);
|
+ freecon(spoolcon);
|
||||||
+ if (!clicon || !tmpcon)
|
+ if (!clicon || !tmpcon)
|
||||||
+ {
|
+ {
|
||||||
+ cupsdSendError(con, HTTP_SERVER_ERROR, AUTH_NONE);
|
+ cupsdSendError(con, HTTP_SERVER_ERROR, CUPSD_AUTH_NONE);
|
||||||
+ if (clicon)
|
+ if (clicon)
|
||||||
+ context_free(clicon);
|
+ context_free(clicon);
|
||||||
+ if (tmpcon)
|
+ if (tmpcon)
|
||||||
@ -1320,7 +1320,7 @@
|
|||||||
+ {
|
+ {
|
||||||
+ if (context_range_set(tmpcon, cliclearance) == -1)
|
+ if (context_range_set(tmpcon, cliclearance) == -1)
|
||||||
+ {
|
+ {
|
||||||
+ cupsdSendError(con, HTTP_SERVER_ERROR, AUTH_NONE);
|
+ cupsdSendError(con, HTTP_SERVER_ERROR, CUPSD_AUTH_NONE);
|
||||||
+ free(clirange);
|
+ free(clirange);
|
||||||
+ context_free(tmpcon);
|
+ context_free(tmpcon);
|
||||||
+ context_free(clicon);
|
+ context_free(clicon);
|
||||||
@ -1331,7 +1331,7 @@
|
|||||||
+ {
|
+ {
|
||||||
+ if (context_range_set(tmpcon, (context_range_get(clicon))) == -1)
|
+ if (context_range_set(tmpcon, (context_range_get(clicon))) == -1)
|
||||||
+ {
|
+ {
|
||||||
+ cupsdSendError(con, HTTP_SERVER_ERROR, AUTH_NONE);
|
+ cupsdSendError(con, HTTP_SERVER_ERROR, CUPSD_AUTH_NONE);
|
||||||
+ free(clirange);
|
+ free(clirange);
|
||||||
+ context_free(tmpcon);
|
+ context_free(tmpcon);
|
||||||
+ context_free(clicon);
|
+ context_free(clicon);
|
||||||
@ -1342,7 +1342,7 @@
|
|||||||
+ }
|
+ }
|
||||||
+ if (setfilecon(con->filename, context_str(tmpcon)) == -1)
|
+ if (setfilecon(con->filename, context_str(tmpcon)) == -1)
|
||||||
+ {
|
+ {
|
||||||
+ cupsdSendError(con, HTTP_SERVER_ERROR, AUTH_NONE);
|
+ cupsdSendError(con, HTTP_SERVER_ERROR, CUPSD_AUTH_NONE);
|
||||||
+ context_free(tmpcon);
|
+ context_free(tmpcon);
|
||||||
+ context_free(clicon);
|
+ context_free(clicon);
|
||||||
+ return (cupsdCloseClient(con));
|
+ return (cupsdCloseClient(con));
|
||||||
|
@ -1,25 +0,0 @@
|
|||||||
diff -up cups-1.3.5/cups/adminutil.c.str2650 cups-1.3.5/cups/adminutil.c
|
|
||||||
--- cups-1.3.5/cups/adminutil.c.str2650 2007-11-30 07:00:59.000000000 +0000
|
|
||||||
+++ cups-1.3.5/cups/adminutil.c 2008-01-09 12:14:45.000000000 +0000
|
|
||||||
@@ -1057,7 +1057,7 @@ _cupsAdminGetServerSettings(
|
|
||||||
in_admin_location = 0;
|
|
||||||
in_location = 0;
|
|
||||||
}
|
|
||||||
- else if (!strcasecmp(line, "Allow") && in_admin_location &&
|
|
||||||
+ else if (!strcasecmp(line, "Allow") &&
|
|
||||||
strcasecmp(value, "localhost") && strcasecmp(value, "127.0.0.1")
|
|
||||||
#ifdef AF_LOCAL
|
|
||||||
&& *value != '/'
|
|
||||||
@@ -1067,9 +1067,9 @@ _cupsAdminGetServerSettings(
|
|
||||||
#endif /* AF_INET6 */
|
|
||||||
)
|
|
||||||
{
|
|
||||||
- remote_admin = 1;
|
|
||||||
-
|
|
||||||
- if (!strcasecmp(value, "all"))
|
|
||||||
+ if (in_admin_location)
|
|
||||||
+ remote_admin = 1;
|
|
||||||
+ else if (!strcasecmp(value, "all"))
|
|
||||||
remote_any = 1;
|
|
||||||
}
|
|
||||||
else if (line[0] != '<' && !in_location && !in_policy)
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up cups-1.3.5/backend/runloop.c~ cups-1.3.5/backend/runloop.c
|
|
||||||
--- cups-1.3.5/backend/runloop.c~ 2007-08-22 19:34:34.000000000 +0100
|
|
||||||
+++ cups-1.3.5/backend/runloop.c 2008-01-09 15:37:44.000000000 +0000
|
|
||||||
@@ -216,7 +216,7 @@ backendRunLoop(
|
|
||||||
FD_SET(CUPS_SC_FD, &input);
|
|
||||||
|
|
||||||
FD_ZERO(&output);
|
|
||||||
- if (print_bytes || !use_bc)
|
|
||||||
+ if (print_bytes || (!use_bc && !side_cb))
|
|
||||||
FD_SET(device_fd, &output);
|
|
||||||
|
|
||||||
if (use_bc || side_cb)
|
|
12
cups.spec
12
cups.spec
@ -6,7 +6,7 @@
|
|||||||
Summary: Common Unix Printing System
|
Summary: Common Unix Printing System
|
||||||
Name: cups
|
Name: cups
|
||||||
Version: 1.3.5
|
Version: 1.3.5
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: ftp://ftp.easysw.com/pub/cups/test//cups-%{version}-source.tar.bz2
|
Source: ftp://ftp.easysw.com/pub/cups/test//cups-%{version}-source.tar.bz2
|
||||||
@ -24,6 +24,7 @@ Source12: cups.cron
|
|||||||
Source13: pdftops.conf
|
Source13: pdftops.conf
|
||||||
Source14: textonly.filter
|
Source14: textonly.filter
|
||||||
Source15: textonly.ppd
|
Source15: textonly.ppd
|
||||||
|
Patch0: cups-1.3.x.patch
|
||||||
Patch1: cups-1.1.15-initscript.patch
|
Patch1: cups-1.1.15-initscript.patch
|
||||||
Patch2: cups-no-gzip-man.patch
|
Patch2: cups-no-gzip-man.patch
|
||||||
Patch3: cups-1.1.16-system-auth.patch
|
Patch3: cups-1.1.16-system-auth.patch
|
||||||
@ -40,12 +41,10 @@ Patch13: cups-direct-usb.patch
|
|||||||
Patch14: cups-lpr-help.patch
|
Patch14: cups-lpr-help.patch
|
||||||
Patch16: cups-pid.patch
|
Patch16: cups-pid.patch
|
||||||
Patch17: cups-foomatic-recommended.patch
|
Patch17: cups-foomatic-recommended.patch
|
||||||
Patch18: cups-str2650.patch
|
|
||||||
Patch19: cups-eggcups.patch
|
Patch19: cups-eggcups.patch
|
||||||
Patch20: cups-getpass.patch
|
Patch20: cups-getpass.patch
|
||||||
Patch21: cups-driverd-timeout.patch
|
Patch21: cups-driverd-timeout.patch
|
||||||
Patch22: cups-strict-ppd-line-length.patch
|
Patch22: cups-strict-ppd-line-length.patch
|
||||||
Patch23: cups-str2664.patch
|
|
||||||
Patch25: cups-usb-paperout.patch
|
Patch25: cups-usb-paperout.patch
|
||||||
Patch100: cups-lspp.patch
|
Patch100: cups-lspp.patch
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
@ -138,6 +137,7 @@ lpd emulation.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name}-%{version}
|
||||||
|
%patch0 -p1 -b .1.3.x
|
||||||
%patch1 -p1 -b .noinit
|
%patch1 -p1 -b .noinit
|
||||||
%patch2 -p1 -b .no-gzip-man
|
%patch2 -p1 -b .no-gzip-man
|
||||||
%patch3 -p1 -b .system-auth
|
%patch3 -p1 -b .system-auth
|
||||||
@ -154,12 +154,10 @@ lpd emulation.
|
|||||||
%patch14 -p1 -b .lpr-help
|
%patch14 -p1 -b .lpr-help
|
||||||
%patch16 -p1 -b .pid
|
%patch16 -p1 -b .pid
|
||||||
%patch17 -p1 -b .foomatic-recommended
|
%patch17 -p1 -b .foomatic-recommended
|
||||||
%patch18 -p1 -b .str2650
|
|
||||||
%patch19 -p1 -b .eggcups
|
%patch19 -p1 -b .eggcups
|
||||||
%patch20 -p1 -b .getpass
|
%patch20 -p1 -b .getpass
|
||||||
%patch21 -p1 -b .driverd-timeout
|
%patch21 -p1 -b .driverd-timeout
|
||||||
%patch22 -p1 -b .strict-ppd-line-length
|
%patch22 -p1 -b .strict-ppd-line-length
|
||||||
%patch23 -p1 -b .str2664
|
|
||||||
%patch25 -p1 -b .usb-paperout
|
%patch25 -p1 -b .usb-paperout
|
||||||
|
|
||||||
%if %lspp
|
%if %lspp
|
||||||
@ -452,6 +450,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{cups_serverbin}/daemon/cups-lpd
|
%{cups_serverbin}/daemon/cups-lpd
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 5 2008 Tim Waugh <twaugh@redhat.com> 1:1.3.5-4
|
||||||
|
- Include fixes from svn up to revision 7287. No longer need str2650 or
|
||||||
|
str2664 patches.
|
||||||
|
|
||||||
* Fri Feb 1 2008 Tim Waugh <twaugh@redhat.com>
|
* Fri Feb 1 2008 Tim Waugh <twaugh@redhat.com>
|
||||||
- Updated initscript for LSB exit codes and actions (bug #246897).
|
- Updated initscript for LSB exit codes and actions (bug #246897).
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user