Set the correct PostScript command filter for e.g. foomatic queues (STR #3973).
This commit is contained in:
parent
d44ca3247c
commit
03ff0bfd1a
13
cups-ps-command-filter.patch
Normal file
13
cups-ps-command-filter.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff -up cups-1.5.0/cups/ppd-cache.c.ps-command-filter cups-1.5.0/cups/ppd-cache.c
|
||||||
|
--- cups-1.5.0/cups/ppd-cache.c.ps-command-filter 2011-11-04 13:10:34.405729542 +0000
|
||||||
|
+++ cups-1.5.0/cups/ppd-cache.c 2011-11-04 13:11:58.502184096 +0000
|
||||||
|
@@ -1272,7 +1272,8 @@ _ppdCacheCreateWithPPD(ppd_file_t *ppd)
|
||||||
|
|
||||||
|
if (filter)
|
||||||
|
cupsArrayAdd(pc->filters,
|
||||||
|
- "application/vnd.cups-command application/postscript 0 -");
|
||||||
|
+ "application/vnd.cups-command application/postscript 100 "
|
||||||
|
+ "commandtops");
|
||||||
|
}
|
||||||
|
|
||||||
|
if ((ppd_attr = ppdFindAttr(ppd, "cupsPreFilter", NULL)) != NULL)
|
11
cups.spec
11
cups.spec
@ -13,7 +13,7 @@
|
|||||||
Summary: Common Unix Printing System
|
Summary: Common Unix Printing System
|
||||||
Name: cups
|
Name: cups
|
||||||
Version: 1.5.0
|
Version: 1.5.0
|
||||||
Release: 19%{?dist}
|
Release: 20%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: http://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
Source: http://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
||||||
@ -73,6 +73,7 @@ Patch35: cups-icc.patch
|
|||||||
Patch36: cups-systemd-socket.patch
|
Patch36: cups-systemd-socket.patch
|
||||||
Patch37: cups-CVE-2011-2896.patch
|
Patch37: cups-CVE-2011-2896.patch
|
||||||
Patch38: cups-str3921.patch
|
Patch38: cups-str3921.patch
|
||||||
|
Patch39: cups-ps-command-filter.patch
|
||||||
|
|
||||||
Patch100: cups-lspp.patch
|
Patch100: cups-lspp.patch
|
||||||
|
|
||||||
@ -300,6 +301,10 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
|
|||||||
# Work around PPDs cache handling issue (bug #742989).
|
# Work around PPDs cache handling issue (bug #742989).
|
||||||
%patch38 -p1 -b .str3921
|
%patch38 -p1 -b .str3921
|
||||||
|
|
||||||
|
# Set the correct PostScript command filter for e.g. foomatic queues
|
||||||
|
# (STR #3973).
|
||||||
|
%patch39 -p1 -b .ps-command-filter
|
||||||
|
|
||||||
%if %lspp
|
%if %lspp
|
||||||
# LSPP support.
|
# LSPP support.
|
||||||
%patch100 -p1 -b .lspp
|
%patch100 -p1 -b .lspp
|
||||||
@ -649,6 +654,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/ipptool.1.gz
|
%{_mandir}/man1/ipptool.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 4 2011 Tim Waugh <twaugh@redhat.com> 1:1.5.0-20
|
||||||
|
- Set the correct PostScript command filter for e.g. foomatic queues
|
||||||
|
(STR #3973).
|
||||||
|
|
||||||
* Mon Oct 31 2011 Tim Waugh <twaugh@redhat.com> 1:1.5.0-19
|
* Mon Oct 31 2011 Tim Waugh <twaugh@redhat.com> 1:1.5.0-19
|
||||||
- Set correct systemd service default on upgrade (bug #748841).
|
- Set correct systemd service default on upgrade (bug #748841).
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user