From 019a41cd01fb6ebfacf735675049f07770e4a2e0 Mon Sep 17 00:00:00 2001
From: Jiri Popelka
Date: Fri, 3 Jun 2011 14:43:17 +0200
Subject: [PATCH] Set the default RIPCache to 128m (STR #3535, bug #549901).
---
cups-str3535.patch | 48 ++++++++++++++++++++++++++++++++++++++++++++++
cups.spec | 8 +++++++-
2 files changed, 55 insertions(+), 1 deletion(-)
create mode 100644 cups-str3535.patch
diff --git a/cups-str3535.patch b/cups-str3535.patch
new file mode 100644
index 0000000..6c77215
--- /dev/null
+++ b/cups-str3535.patch
@@ -0,0 +1,48 @@
+diff -up cups-1.4.6/doc/help/ref-cupsd-conf.html.in.str3535 cups-1.4.6/doc/help/ref-cupsd-conf.html.in
+--- cups-1.4.6/doc/help/ref-cupsd-conf.html.in.str3535 2010-07-14 04:43:27.000000000 +0200
++++ cups-1.4.6/doc/help/ref-cupsd-conf.html.in 2011-06-03 13:53:04.711110536 +0200
+@@ -2646,7 +2646,7 @@ appear inside a Examples
+
+
+-RIPCache 8m
++RIPCache 128m
+ RIPCache 1g
+ RIPCache 2048k
+
+@@ -2657,8 +2657,9 @@ RIPCache 2048k
+ memory cache used by Raster Image Processor ("RIP") filters such
+ as imagetoraster
and pstoraster
. The
+ size can be suffixed with a "k" for kilobytes, "m" for megabytes,
+-or "g" for gigabytes. The default cache size is "8m", or 8
+-megabytes.
++or "g" for gigabytes. The default cache size is "128m", or 128
++megabytes (compare
++CUPS STR 3535
).
+
+
+
+diff -up cups-1.4.6/scheduler/conf.c.str3535 cups-1.4.6/scheduler/conf.c
+--- cups-1.4.6/scheduler/conf.c.str3535 2011-06-03 13:53:04.552112524 +0200
++++ cups-1.4.6/scheduler/conf.c 2011-06-03 13:53:04.712110524 +0200
+@@ -543,7 +543,7 @@ cupsdReadConfiguration(void)
+
+ cupsdClearString(&DefaultPaperSize);
+
+- cupsdSetString(&RIPCache, "8m");
++ cupsdSetString(&RIPCache, "128m");
+
+ cupsdSetString(&TempDir, NULL);
+
+diff -up cups-1.4.6/scheduler/cupsfilter.c.str3535 cups-1.4.6/scheduler/cupsfilter.c
+--- cups-1.4.6/scheduler/cupsfilter.c.str3535 2010-03-31 00:07:33.000000000 +0200
++++ cups-1.4.6/scheduler/cupsfilter.c 2011-06-03 13:53:04.713110512 +0200
+@@ -1218,7 +1218,7 @@ read_cupsd_conf(const char *filename) /*
+ else
+ set_string(&FontPath, CUPS_FONTPATH);
+
+- set_string(&RIPCache, "8m");
++ set_string(&RIPCache, "128m");
+
+ if ((temp = getenv("CUPS_SERVERBIN")) != NULL)
+ set_string(&ServerBin, temp);
diff --git a/cups.spec b/cups.spec
index c9c6f93..e46af38 100644
--- a/cups.spec
+++ b/cups.spec
@@ -13,7 +13,7 @@
Summary: Common Unix Printing System
Name: cups
Version: 1.4.6
-Release: 17%{?dist}
+Release: 18%{?dist}
License: GPLv2
Group: System Environment/Daemons
Source: http://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
@@ -75,6 +75,7 @@ Patch40: cups-avahi.patch
Patch41: cups-icc.patch
Patch42: cups-usb-parallel.patch
Patch43: cups-job-state-changed.patch
+Patch44: cups-str3535.patch
Patch100: cups-lspp.patch
@@ -295,6 +296,8 @@ module.
%patch42 -p1 -b .usb-parallel
# Fixed dbus notifier support for job-state-changed.
%patch43 -p1 -b .job-state-changed
+# Set the default RIPCache to 128m (STR #3535, bug #549901).
+%patch44 -p1 -b .str3535
%if %lspp
# LSPP support.
@@ -614,6 +617,9 @@ rm -rf $RPM_BUILD_ROOT
%{php_extdir}/phpcups.so
%changelog
+* Fri Jun 03 2011 Jiri Popelka 1:1.4.6-18
+- Set the default RIPCache to 128m (STR #3535, bug #549901).
+
* Wed May 18 2011 Tim Waugh 1:1.4.6-17
- Package parallel port printer device nodes (bug #678804).