diff --git a/.gitignore b/.gitignore
index 092c705..c7f9338 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ cups-pk-helper-0.0.4.tar.bz2
/cups-pk-helper-0.1.1.tar.bz2
/cups-pk-helper-0.1.2.tar.bz2
/cups-pk-helper-0.1.3.tar.bz2
+/cups-pk-helper-0.2.1.tar.bz2
diff --git a/allow_authentication.patch b/allow_authentication.patch
deleted file mode 100644
index 47e4473..0000000
--- a/allow_authentication.patch
+++ /dev/null
@@ -1,112 +0,0 @@
---- cups-pk-helper-0.1.3/src/org.opensuse.cupspkhelper.mechanism.policy.in 2011-07-05 14:07:05.000000000 +0200
-+++ cups-pk-helper-0.1.3/src/org.opensuse.cupspkhelper.mechanism.policy.in 2011-09-02 11:34:12.000000000 +0200
-@@ -12,7 +12,8 @@
- <_description>Get/Set server settings
- <_message>Privileges are required to get/set server settings.
-
-- no
-+ auth_admin
-+ auth_admin
- auth_admin_keep
-
-
-@@ -21,7 +22,8 @@
- <_description>Get list of available devices
- <_message>Privileges are required to get list of available devices.
-
-- no
-+ auth_admin
-+ auth_admin
- auth_admin_keep
-
-
-@@ -33,7 +35,8 @@
- <_description>Set a printer as default printer
- <_message>Privileges are required to set a printer, or a class, as default printer.
-
-- no
-+ auth_admin
-+ auth_admin
- auth_admin_keep
-
-
-@@ -45,7 +48,8 @@
- <_description>Enable/Disable a printer
- <_message>Privileges are required to enable/disable a printer, or a class.
-
-- no
-+ auth_admin
-+ auth_admin
- auth_admin_keep
-
-
-@@ -54,7 +58,8 @@
- <_description>Add/Remove/Edit a local printer
- <_message>Privileges are required to add/remove/edit a local printer.
-
-- no
-+ auth_admin
-+ auth_admin
- auth_admin_keep
-
-
-@@ -63,7 +68,8 @@
- <_description>Add/Remove/Edit a remote printer
- <_message>Privileges are required to add/remove/edit a remote printer.
-
-- no
-+ auth_admin
-+ auth_admin
- auth_admin_keep
-
-
-@@ -72,7 +78,8 @@
- <_description>Add/Remove/Edit a class
- <_message>Privileges are required to add/remove/edit a class.
-
-- no
-+ auth_admin
-+ auth_admin
- auth_admin_keep
-
-
-@@ -81,7 +88,8 @@
- <_description>Restart/Cancel/Edit a job
- <_message>Privileges are required to restart/cancel/edit a job.
-
-- no
-+ auth_admin
-+ auth_admin
- yes
-
-
-@@ -90,7 +98,8 @@
- <_description>Restart/Cancel/Edit a job owned by another user
- <_message>Privileges are required to restart/cancel/edit a job owned by another user.
-
-- no
-+ auth_admin
-+ auth_admin
- auth_admin_keep
-
-
-@@ -99,7 +108,8 @@
- <_description>Change printer settings
- <_message>Privileges are required to change printer settings. This should only be needed from the Printers system settings panel.
-
-- no
-+ auth_admin
-+ auth_admin
- auth_admin_keep
-
-
-@@ -109,7 +119,8 @@
- <_description>Add/Remove/Edit a printer
- <_message>Privileges are required to add/remove/edit a printer.
-
-- no
-+ auth_admin
-+ auth_admin
- auth_admin_keep
-
-
diff --git a/cups-pk-helper-add-printer-ppd-optional.patch b/cups-pk-helper-add-printer-ppd-optional.patch
deleted file mode 100644
index 90dafd9..0000000
--- a/cups-pk-helper-add-printer-ppd-optional.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- cups-pk-helper-0.0.4/src/cups.c 2009-12-10 15:08:12.000000000 +0100
-+++ cups-pk-helper-0.0.4/src/cups.c 2009-12-10 15:09:00.000000000 +0100
-@@ -998,9 +998,11 @@ cph_cups_printer_add (CphCups *cups,
-
- ippAddString (request, IPP_TAG_PRINTER, IPP_TAG_NAME,
- "printer-name", NULL, printer_name);
-- ippAddString (request, IPP_TAG_PRINTER, IPP_TAG_NAME,
-- "ppd-name", NULL, ppd_file);
-
-+ if (ppd_file && ppd_file[0] != '\0') {
-+ ippAddString (request, IPP_TAG_PRINTER, IPP_TAG_NAME,
-+ "ppd-name", NULL, ppd_file);
-+ }
- if (printer_uri && printer_uri[0] != '\0') {
- ippAddString (request, IPP_TAG_PRINTER, IPP_TAG_URI,
- "device-uri", NULL, printer_uri);
diff --git a/cups-pk-helper-check-mechanism.patch b/cups-pk-helper-check-mechanism.patch
deleted file mode 100644
index 9851de3..0000000
--- a/cups-pk-helper-check-mechanism.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/src/cups-pk-helper-mechanism.c b/src/cups-pk-helper-mechanism.c
-index 273c262..8b3d781 100644
---- a/src/cups-pk-helper-mechanism.c
-+++ b/src/cups-pk-helper-mechanism.c
-@@ -205,6 +205,8 @@ register_mechanism (CphMechanism *mechanism)
- {
- GError *error;
-
-+ g_return_val_if_fail (CPH_IS_MECHANISM (mechanism), FALSE);
-+
- mechanism->priv->pol_auth = polkit_authority_get ();
-
- error = NULL;
-@@ -238,7 +240,8 @@ cph_mechanism_new (void)
- object = g_object_new (CPH_TYPE_MECHANISM, NULL);
-
- if (!register_mechanism (CPH_MECHANISM (object))) {
-- g_object_unref (object);
-+ if (object)
-+ g_object_unref (object);
- return NULL;
- }
-
diff --git a/cups-pk-helper.spec b/cups-pk-helper.spec
index 45e5c02..eb902a7 100644
--- a/cups-pk-helper.spec
+++ b/cups-pk-helper.spec
@@ -1,6 +1,6 @@
Name: cups-pk-helper
-Version: 0.1.3
-Release: 3%{?dist}
+Version: 0.2.1
+Release: 1%{?dist}
Summary: A helper that makes system-config-printer use PolicyKit
Group: System Environment/Base
@@ -8,21 +8,19 @@ License: GPLv2+
URL: http://www.vuntz.net/download/cups-pk-helper/
Source0: http://cgit.freedesktop.org/cups-pk-helper/snapshot/cups-pk-helper-%{version}.tar.bz2
-Patch0: cups-pk-helper-check-mechanism.patch
-Patch1: cups-pk-helper-add-printer-ppd-optional.patch
-Patch2: polkit_result.patch
-Patch3: allow_authentication.patch
-Patch4: cups-pk-helper-requesting-user-name.patch
+Patch0: polkit_result.patch
+Patch1: cups-pk-helper-requesting-user-name.patch
+Patch2: cups-pk-helper-configure.patch
BuildRequires: libtool >= 1.4.3
BuildRequires: cups-devel >= 1.2
BuildRequires: python-devel >= 2.4
-BuildRequires: glib2-devel >= 2.14.0
+BuildRequires: glib2-devel >= 2.29.8
BuildRequires: gtk2-devel >= 2.12.0
BuildRequires: dbus-glib-devel >= 0.74
-BuildRequires: polkit-devel >= 0.92
-BuildRequires: polkit-gnome >= 0.92
-BuildRequires: intltool >= 0.40.0
+BuildRequires: polkit-devel >= 0.97
+BuildRequires: polkit-gnome >= 0.97
+BuildRequires: intltool >= 0.40.6
BuildRequires: gettext-devel >= 0.17
BuildRequires: gnome-common >= 2.26
BuildRequires: autoconf automake libtool
@@ -31,7 +29,7 @@ Requires: python >= 2.4
Requires: cups-libs >= 1.2
Requires: dbus >= 1.2
Requires: dbus-glib >= 0.74
-Requires: glib2 >= 2.14.0
+Requires: glib2 >= 2.29.8
%description
@@ -41,11 +39,9 @@ interfaces available under control of PolicyKit.
%prep
%setup -q
-%patch0 -p1 -b .check-mechanism
-%patch1 -p1 -b .ppd
-%patch2 -p1 -b .polkit-result
-%patch3 -p1 -b .allow_auth
-%patch4 -p1 -b .requesting-user-name
+%patch0 -p1 -b .polkit-result
+%patch1 -p1 -b .requesting-user-name
+%patch2 -p1 -b .configure
%build
@@ -73,6 +69,11 @@ make install DESTDIR=$RPM_BUILD_ROOT
%changelog
+* Tue Nov 22 2011 Marek Kasik - 0.2.1-1
+- Update to 0.2.1
+- Remove upstreamed patches
+- Actualize Requires
+
* Thu Oct 27 2011 Marek Kasik - 0.1.3-3
- Set requesting-user-name for IPP_GET_JOB_ATTRIBUTES
- Resolves: #743886
diff --git a/sources b/sources
index 341b7f6..2d17a35 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-885eabdf404cc80797478cc52414b21b cups-pk-helper-0.1.3.tar.bz2
+c9858f7d722ff4c29e0201cb464cde91 cups-pk-helper-0.2.1.tar.bz2