46 lines
1.9 KiB
Diff
46 lines
1.9 KiB
Diff
diff --git a/configure.ac b/configure.ac
|
|
index 3c3d68ad..4e2ee330 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -850,6 +850,16 @@ PKG_CHECK_EXISTS([liblouis], [
|
|
AM_CONDITIONAL(ENABLE_BRAILLE, test "x$enable_braille" = xyes)
|
|
AC_SUBST(TABLESDIR)
|
|
|
|
+# ===============================================
|
|
+# Should we keep generated queues after shutdown?
|
|
+# ===============================================
|
|
+AC_ARG_ENABLE(saving-created-queues, AS_HELP_STRING([--enable-saving-created-queues], [enable saving created queues during shutdown]),
|
|
+ [SAVING_CREATED_QUEUES=$enableval],[SAVING_CREATED_QUEUES="no"])
|
|
+
|
|
+AS_IF([test "x$SAVING_CREATED_QUEUES" != "xno"],
|
|
+ [AC_DEFINE([SAVING_CREATED_QUEUES], [1], [Define whether we save queues during shutdown])]
|
|
+)
|
|
+
|
|
# =========================================
|
|
# Local queue naming for remote CUPS queues
|
|
# =========================================
|
|
@@ -979,6 +989,7 @@ Build configuration:
|
|
apple-raster: ${APPLE_RASTER_FILTER}
|
|
pclm: ${enable_pclm}
|
|
local queue naming for remote CUPS queues: ${REMOTE_CUPS_LOCAL_QUEUE_NAMING}
|
|
+ keep generated queues during shutdown: ${SAVING_CREATED_QUEUES}
|
|
all ipp printer auto-setup: ${enable_auto_setup_all}
|
|
only driverless auto-setup: ${enable_auto_setup_driverless_only}
|
|
only local auto-setup: ${enable_auto_setup_local_only}
|
|
diff --git a/utils/cups-browsed.c b/utils/cups-browsed.c
|
|
index 59e3c269..00039c49 100644
|
|
--- a/utils/cups-browsed.c
|
|
+++ b/utils/cups-browsed.c
|
|
@@ -466,7 +466,11 @@ static create_ipp_printer_queues_t CreateIPPPrinterQueues = IPP_PRINTERS_DRIVERL
|
|
static create_ipp_printer_queues_t CreateIPPPrinterQueues = IPP_PRINTERS_ALL;
|
|
#endif
|
|
#endif
|
|
+#ifdef SAVING_CREATED_QUEUES
|
|
static unsigned int KeepGeneratedQueuesOnShutdown = 1;
|
|
+#else
|
|
+static unsigned int KeepGeneratedQueuesOnShutdown = 0;
|
|
+#endif
|
|
static ipp_queue_type_t IPPPrinterQueueType = PPD_YES;
|
|
static int NewIPPPrinterQueuesShared = 0;
|
|
static int AutoClustering = 1;
|