Include dbus so that colord support works (bug #1026928).
Resolves: rhbz#1026928
This commit is contained in:
parent
de59c126c4
commit
f7177f4071
58
cups-filters-dbus.patch
Normal file
58
cups-filters-dbus.patch
Normal file
@ -0,0 +1,58 @@
|
||||
diff -up cups-filters-1.0.41/Makefile.am.dbus cups-filters-1.0.41/Makefile.am
|
||||
--- cups-filters-1.0.41/Makefile.am.dbus 2013-10-25 14:12:56.000000000 +0100
|
||||
+++ cups-filters-1.0.41/Makefile.am 2013-11-06 17:16:58.504234619 +0000
|
||||
@@ -474,9 +474,11 @@ gstoraster_SOURCES = \
|
||||
cupsfilters/raster.h
|
||||
gstoraster_CFLAGS = \
|
||||
$(CUPS_CFLAGS) \
|
||||
+ $(DBUS_CFLAGS) \
|
||||
-I$(srcdir)/cupsfilters/
|
||||
gstoraster_LDADD = \
|
||||
$(CUPS_LIBS) \
|
||||
+ $(DBUS_LIBS) \
|
||||
libcupsfilters.la
|
||||
|
||||
imagetopdf_SOURCES = \
|
||||
diff -up cups-filters-1.0.41/config.h.in.dbus cups-filters-1.0.41/config.h.in
|
||||
diff -up cups-filters-1.0.41/configure.ac.dbus cups-filters-1.0.41/configure.ac
|
||||
--- cups-filters-1.0.41/configure.ac.dbus 2013-10-30 07:21:44.000000000 +0000
|
||||
+++ cups-filters-1.0.41/configure.ac 2013-11-06 17:23:07.619921079 +0000
|
||||
@@ -114,6 +114,18 @@ AX_COMPARE_VERSION([$CUPS_VERSION],[gt],
|
||||
AC_DEFINE(PDFTOPDF, [], [Needed for pdftopdf filter compilation])
|
||||
AC_DEFINE_DIR(BANNERTOPDF_DATADIR, "{CUPS_DATADIR}/data", [Directory where bannertopdf finds its data files (PDF templates)])
|
||||
|
||||
+dnl DBus support
|
||||
+DBUS_CFLAGS=""
|
||||
+DBUS_LIBS=""
|
||||
+AC_ARG_ENABLE([dbus], AC_HELP_STRING([--disable-dbus],
|
||||
+ [Do not use dbus to communicate with external services]))
|
||||
+if test "$enable_dbus" != "no"; then
|
||||
+ PKG_CHECK_MODULES(DBUS, [dbus-1], [HAVE_DBUS=-DHAVE_DBUS])
|
||||
+ AC_DEFINE([HAVE_DBUS], [], [Defines if dbus is available.])
|
||||
+fi
|
||||
+AC_SUBST(DBUS_CFLAGS)
|
||||
+AC_SUBST(DBUS_LIBS)
|
||||
+
|
||||
AC_SEARCH_LIBS([dlopen],
|
||||
[dl],
|
||||
[AS_IF([test "$ac_cv_search_dlopen" != "none required"], [
|
||||
@@ -640,6 +652,7 @@ Build configuration:
|
||||
php-config: ${with_php_config}
|
||||
test-font: ${with_test_font_path}
|
||||
tiff: ${with_tiff}
|
||||
+ dbus: ${HAVE_DBUS}
|
||||
avahi: ${enable_avahi}
|
||||
browsing: ${with_browseremoteprotocols}
|
||||
werror: ${enable_werror}
|
||||
diff -up cups-filters-1.0.41/filter/colord.c.dbus cups-filters-1.0.41/filter/colord.c
|
||||
--- cups-filters-1.0.41/filter/colord.c.dbus 2013-07-29 20:12:42.000000000 +0100
|
||||
+++ cups-filters-1.0.41/filter/colord.c 2013-11-06 17:16:58.505234623 +0000
|
||||
@@ -32,6 +32,8 @@ MIT Open Source License - http://www.o
|
||||
#include <stdio.h>
|
||||
#include <sys/types.h>
|
||||
|
||||
+#include "config.h"
|
||||
+
|
||||
#ifdef HAVE_DBUS
|
||||
#include <dbus/dbus.h>
|
||||
#endif
|
@ -4,7 +4,7 @@
|
||||
Summary: OpenPrinting CUPS filters and backends
|
||||
Name: cups-filters
|
||||
Version: 1.0.41
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
|
||||
# For a breakdown of the licensing, see COPYING file
|
||||
# GPLv2: filters: commandto*, imagetoraster, pdftops, rasterto*,
|
||||
@ -22,6 +22,7 @@ Url: http://www.linuxfoundation.org/collaborate/workgroups/openprinting/cups
|
||||
Source0: http://www.openprinting.org/download/cups-filters/cups-filters-%{version}.tar.xz
|
||||
|
||||
Patch1: cups-filters-pdf-landscape.patch
|
||||
Patch2: cups-filters-dbus.patch
|
||||
|
||||
Requires: cups-filters-libs%{?_isa} = %{version}-%{release}
|
||||
|
||||
@ -35,12 +36,13 @@ BuildRequires: cups-devel
|
||||
BuildRequires: qpdf-devel
|
||||
# pdftops
|
||||
BuildRequires: poppler-utils
|
||||
# pdftoijs, pdftoopvp, pdftoraster
|
||||
# pdftoijs, pdftoopvp, pdftoraster, gstoraster
|
||||
BuildRequires: poppler-devel poppler-cpp-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: pkgconfig dbus-devel
|
||||
# libijs
|
||||
BuildRequires: ghostscript-devel
|
||||
BuildRequires: freetype-devel
|
||||
@ -107,6 +109,9 @@ This is the development package for OpenPrinting CUPS filters and backends.
|
||||
# Fix PDF landscape printing (bug #768811).
|
||||
%patch1 -p1 -b .pdf-landscape
|
||||
|
||||
# Include dbus so that colord support works (bug #1026928).
|
||||
%patch2 -p1 -b .dbus
|
||||
|
||||
%build
|
||||
# work-around Rpath
|
||||
./autogen.sh
|
||||
@ -118,6 +123,7 @@ This is the development package for OpenPrinting CUPS filters and backends.
|
||||
%configure --disable-static \
|
||||
--disable-silent-rules \
|
||||
--with-pdftops=hybrid \
|
||||
--enable-dbus \
|
||||
--with-rcdir=no
|
||||
|
||||
make %{?_smp_mflags}
|
||||
@ -220,6 +226,9 @@ fi
|
||||
%{_libdir}/libfontembed.so
|
||||
|
||||
%changelog
|
||||
* Wed Nov 6 2013 Tim Waugh <twaugh@redhat.com> - 1.0.41-2
|
||||
- Include dbus so that colord support works (bug #1026928).
|
||||
|
||||
* Wed Oct 30 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.41-1
|
||||
- 1.0.41 - PPD-less printing support
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user