Merge branch 'f20'

This commit is contained in:
Tim Waugh 2014-06-11 14:21:17 +01:00
commit 8aa4ed9abd
4 changed files with 75 additions and 1 deletions

View File

@ -0,0 +1,12 @@
diff -up cups-filters-1.0.53/filter/pstopdf.execmem cups-filters-1.0.53/filter/pstopdf
--- cups-filters-1.0.53/filter/pstopdf.execmem 2014-06-06 13:48:30.005230247 +0100
+++ cups-filters-1.0.53/filter/pstopdf 2014-06-06 13:49:05.762403657 +0100
@@ -105,7 +105,7 @@ eval "$(printf "%s" "$5" | sed -nre 's/.
eval "$(printf "%s" "$5" | sed -nre 's/.*(^|\s)orientation-requested=4.*/orientation="${orientation:-90}"/p')"
eval "$(printf "%s" "$5" | sed -nre 's/.*(^|\s)orientation-requested=5.*/orientation="${orientation:-270}"/p')"
eval "$(printf "%s" "$5" | sed -nre 's/.*(^|\s)orientation-requested=6.*/orientation="${orientation:-180}"/p')"
-if printf "%s" "$5" | grep -iPq '(\s|^)landscape(=(1|on|yes|true))?(\s|$)'; then
+if printf "%s" "$5" | grep -qiE '(\s|^)landscape(=(1|on|yes|true))?(\s|$)'; then
if test -e "$PPD"; then
eval "$(sed -nre 's/^\*LandscapeOrientation:\s*Plus90.*/orientation="${orientation:-90}"/p' "$PPD")"
eval "$(sed -nre 's/^\*LandscapeOrientation:\s*Minus90.*/orientation="${orientation:-270}"/p' "$PPD")"

View File

@ -0,0 +1,14 @@
diff -up cups-filters-1.0.54/Makefile.am.makefile cups-filters-1.0.54/Makefile.am
--- cups-filters-1.0.54/Makefile.am.makefile 2014-06-11 13:36:11.962393900 +0100
+++ cups-filters-1.0.54/Makefile.am 2014-06-11 13:40:34.343533005 +0100
@@ -467,7 +467,9 @@ bannertopdf_LDADD = \
$(FONTCONFIG_LIBS) \
libfontembed.la
-bannertopdf_DEPENDENCIES = $(GETLINE)
+bannertopdf_DEPENDENCIES = \
+ $(GETLINE) \
+ libfontembed.la
commandtoescpx_SOURCES = \
cupsfilters/driver.h \

View File

@ -0,0 +1,34 @@
diff -up cups-filters-1.0.53/filter/pdftops.c.pdf-landscape cups-filters-1.0.53/filter/pdftops.c
--- cups-filters-1.0.53/filter/pdftops.c.pdf-landscape 2014-05-09 12:18:35.679501730 +0200
+++ cups-filters-1.0.53/filter/pdftops.c 2014-05-09 12:19:34.114704598 +0200
@@ -646,23 +646,23 @@ main(int argc, /* I - Number of comm
if ((renderer == PDFTOPS) || (renderer == PDFTOCAIRO))
{
/*
- * Use the page sizes of the original PDF document, this way documents
- * which contain pages of different sizes can be printed correctly
+ * No options to add. Note: pdftopdf has already rotated pages
+ * for us.
*/
- pdf_argv[pdf_argc++] = (char *)"-origpagesizes";
- pdf_argv[pdf_argc++] = (char *)"-nocenter";
+ //pdf_argv[pdf_argc++] = (char *)"-origpagesizes";
+ //pdf_argv[pdf_argc++] = (char *)"-nocenter";
}
else
#endif /* HAVE_POPPLER_PDFTOPS_WITH_ORIGPAGESIZES */
if (renderer == ACROREAD)
{
/*
- * Use the page sizes of the original PDF document, this way documents
- * which contain pages of different sizes can be printed correctly
+ * No options to add. Note: pdftopdf has already rotated pages
+ * for us.
*/
- pdf_argv[pdf_argc++] = (char *)"-choosePaperByPDFPageSize";
+ //pdf_argv[pdf_argc++] = (char *)"-choosePaperByPDFPageSize";
}
/*

View File

@ -4,7 +4,7 @@
Summary: OpenPrinting CUPS filters and backends
Name: cups-filters
Version: 1.0.54
Release: 1%{?dist}
Release: 2%{?dist}
# For a breakdown of the licensing, see COPYING file
# GPLv2: filters: commandto*, imagetoraster, pdftops, rasterto*,
@ -20,6 +20,9 @@ License: GPLv2 and GPLv2+ and GPLv3 and GPLv3+ and LGPLv2+ and MIT
Url: http://www.linuxfoundation.org/collaborate/workgroups/openprinting/cups-filters
Source0: http://www.openprinting.org/download/cups-filters/cups-filters-%{version}.tar.xz
Patch1: cups-filters-pdf-landscape.patch
Patch2: cups-filters-makefile.patch
Requires: cups-filters-libs%{?_isa} = %{version}-%{release}
# Obsolete cups-php (bug #971741)
@ -114,6 +117,12 @@ This is the development package for OpenPrinting CUPS filters and backends.
%prep
%setup -q
# Fix PDF landscape printing (bug #768811).
%patch1 -p1 -b .pdf-landscape
# Fixed build issue (bug #1106101).
%patch2 -p1 -b .cups-filters
%build
# work-around Rpath
./autogen.sh
@ -242,6 +251,11 @@ fi
%{_libdir}/libfontembed.so
%changelog
* Wed Jun 11 2014 Tim Waugh <twaugh@redhat.com> - 1.0.54-2
- Fix build issue (bug #1106101).
- Don't use grep's -P switch in pstopdf as it needs execmem (bug #1079534).
- Return work-around patch for bug #768811.
* Mon Jun 09 2014 Jiri Popelka <jpopelka@redhat.com> - 1.0.54-1
- 1.0.54