Don't ship pdftoopvp (#1027557) and urftopdf (#1002947).

This commit is contained in:
Jiri Popelka 2014-03-11 13:10:24 +01:00
parent 9da3b66ab2
commit 4426ef164d
3 changed files with 210 additions and 2 deletions

View File

@ -0,0 +1,160 @@
diff -up cups-filters-1.0.47/Makefile.am.pdftoopvp cups-filters-1.0.47/Makefile.am
--- cups-filters-1.0.47/Makefile.am.pdftoopvp 2014-03-11 12:50:50.107190697 +0100
+++ cups-filters-1.0.47/Makefile.am 2014-03-11 12:50:50.111190645 +0100
@@ -317,10 +317,7 @@ EXTRA_DIST += \
# PDF to OPVP
# ===========
pkgfilterdir = $(CUPS_SERVERBIN)/filter
-pkgfilter_PROGRAMS = pdftoopvp
-
-pkgfontconfigdir = $(sysconfdir)/$(FONTDIR)
-pkgfontconfig_DATA = filter/pdftoopvp/99pdftoopvp.conf
+pkgfilter_PROGRAMS =
pdftoopvp_SOURCES = \
filter/pdftoopvp/oprs/OPRS.cxx \
@@ -363,8 +360,6 @@ pdftoopvp_LDADD = \
$(POPPLER_LIBS) \
$(DLOPEN_LIBS)
-EXTRA_DIST += $(pkgfontconfig_DATA)
-
# ==========
# PDF to PDF
# ==========
diff -up cups-filters-1.0.47/Makefile.in.pdftoopvp cups-filters-1.0.47/Makefile.in
--- cups-filters-1.0.47/Makefile.in.pdftoopvp 2014-03-11 12:50:50.108190684 +0100
+++ cups-filters-1.0.47/Makefile.in 2014-03-11 12:54:10.592549788 +0100
@@ -91,7 +91,7 @@ TESTS = testdither$(EXEEXT) test_analyze
@BUILD_DBUS_TRUE@am__append_1 = $(DBUS_CFLAGS) -DHAVE_DBUS
@BUILD_DBUS_TRUE@am__append_2 = $(DBUS_LIBS)
bin_PROGRAMS = ttfread$(EXEEXT)
-pkgfilter_PROGRAMS = pdftoopvp$(EXEEXT) pdftopdf$(EXEEXT) \
+pkgfilter_PROGRAMS = pdftopdf$(EXEEXT) \
bannertopdf$(EXEEXT) commandtoescpx$(EXEEXT) \
commandtopclx$(EXEEXT) foomatic-rip$(EXEEXT) \
gstoraster$(EXEEXT) pdftoijs$(EXEEXT) pdftoippprinter$(EXEEXT) \
@@ -169,7 +169,6 @@ am__installdirs = "$(DESTDIR)$(libdir)"
"$(DESTDIR)$(pkgcupsserverrootdir)" \
"$(DESTDIR)$(pkgdriverdir)" \
"$(DESTDIR)$(pkgfiltersincludedir)" \
- "$(DESTDIR)$(pkgfontconfigdir)" \
"$(DESTDIR)$(pkgfontembedincludedir)" \
"$(DESTDIR)$(pkgmimedir)" "$(DESTDIR)$(pkgppdcdir)" \
"$(DESTDIR)$(ppddir)"
@@ -531,7 +530,7 @@ MANS = $(man_MANS)
DATA = $(doc_DATA) $(pkgbanner_DATA) $(pkgcharset_DATA) \
$(pkgconf_DATA) $(pkgcupsdata_DATA) $(pkgcupsserverroot_DATA) \
$(pkgdriver_DATA) $(pkgfiltersinclude_DATA) \
- $(pkgfontconfig_DATA) $(pkgfontembedinclude_DATA) \
+ $(pkgfontembedinclude_DATA) \
$(pkgmime_DATA) $(pkgppdc_DATA) $(ppd_DATA)
am__tagged_files = $(HEADERS) $(SOURCES) $(TAGS_FILES) \
$(LISP)config.h.in
@@ -948,7 +947,7 @@ EXTRA_DIST = $(doc_DATA) autogen.sh libc
cupsfilters/image.pgm cupsfilters/image.ppm \
$(pkgcupsdata_DATA) $(pkgdriver_DATA) $(pkgppdc_DATA) \
$(pkgmime_DATA) $(pkgfontembedinclude_DATA) fontembed/README \
- $(pkgfontconfig_DATA) $(pkgfilter_SCRIPTS) filter/test.sh \
+ $(pkgfilter_SCRIPTS) filter/test.sh \
utils/cups-browsed.in $(man_MANS) $(ppd_DATA) scripting/perl \
scripting/php/README scripting/php/phpcups.php
@@ -1203,8 +1202,6 @@ test_ps_LDADD = libfontembed.la
# PDF to OPVP
# ===========
pkgfilterdir = $(CUPS_SERVERBIN)/filter
-pkgfontconfigdir = $(sysconfdir)/$(FONTDIR)
-pkgfontconfig_DATA = filter/pdftoopvp/99pdftoopvp.conf
pdftoopvp_SOURCES = \
filter/pdftoopvp/oprs/OPRS.cxx \
filter/pdftoopvp/oprs/OPRS.h \
@@ -3928,43 +3925,6 @@ uninstall-pkgfiltersincludeDATA:
@list='$(pkgfiltersinclude_DATA)'; test -n "$(pkgfiltersincludedir)" || list=; \
files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
dir='$(DESTDIR)$(pkgfiltersincludedir)'; $(am__uninstall_files_from_dir)
-install-pkgfontconfigDATA: $(pkgfontconfig_DATA)
- @$(NORMAL_INSTALL)
- @list='$(pkgfontconfig_DATA)'; test -n "$(pkgfontconfigdir)" || list=; \
- if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(pkgfontconfigdir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(pkgfontconfigdir)" || exit 1; \
- fi; \
- for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
- echo "$$d$$p"; \
- done | $(am__base_list) | \
- while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(pkgfontconfigdir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(pkgfontconfigdir)" || exit $$?; \
- done
-
-uninstall-pkgfontconfigDATA:
- @$(NORMAL_UNINSTALL)
- @list='$(pkgfontconfig_DATA)'; test -n "$(pkgfontconfigdir)" || list=; \
- files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
- dir='$(DESTDIR)$(pkgfontconfigdir)'; $(am__uninstall_files_from_dir)
-install-pkgfontembedincludeDATA: $(pkgfontembedinclude_DATA)
- @$(NORMAL_INSTALL)
- @list='$(pkgfontembedinclude_DATA)'; test -n "$(pkgfontembedincludedir)" || list=; \
- if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(pkgfontembedincludedir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(pkgfontembedincludedir)" || exit 1; \
- fi; \
- for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
- echo "$$d$$p"; \
- done | $(am__base_list) | \
- while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(pkgfontembedincludedir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(pkgfontembedincludedir)" || exit $$?; \
- done
-
uninstall-pkgfontembedincludeDATA:
@$(NORMAL_UNINSTALL)
@list='$(pkgfontembedinclude_DATA)'; test -n "$(pkgfontembedincludedir)" || list=; \
@@ -4454,7 +4414,7 @@ all-am: Makefile $(LTLIBRARIES) $(PROGRA
install-binPROGRAMS: install-libLTLIBRARIES
installdirs:
- for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(phpextensiondir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pkgbackenddir)" "$(DESTDIR)$(pkgfilterdir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(initrcdir)" "$(DESTDIR)$(pkgfilterdir)" "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man5dir)" "$(DESTDIR)$(man8dir)" "$(DESTDIR)$(docdir)" "$(DESTDIR)$(pkgbannerdir)" "$(DESTDIR)$(pkgcharsetdir)" "$(DESTDIR)$(pkgconfdir)" "$(DESTDIR)$(pkgcupsdatadir)" "$(DESTDIR)$(pkgcupsserverrootdir)" "$(DESTDIR)$(pkgdriverdir)" "$(DESTDIR)$(pkgfiltersincludedir)" "$(DESTDIR)$(pkgfontconfigdir)" "$(DESTDIR)$(pkgfontembedincludedir)" "$(DESTDIR)$(pkgmimedir)" "$(DESTDIR)$(pkgppdcdir)" "$(DESTDIR)$(ppddir)"; do \
+ for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(phpextensiondir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pkgbackenddir)" "$(DESTDIR)$(pkgfilterdir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(initrcdir)" "$(DESTDIR)$(pkgfilterdir)" "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man5dir)" "$(DESTDIR)$(man8dir)" "$(DESTDIR)$(docdir)" "$(DESTDIR)$(pkgbannerdir)" "$(DESTDIR)$(pkgcharsetdir)" "$(DESTDIR)$(pkgconfdir)" "$(DESTDIR)$(pkgcupsdatadir)" "$(DESTDIR)$(pkgcupsserverrootdir)" "$(DESTDIR)$(pkgdriverdir)" "$(DESTDIR)$(pkgfiltersincludedir)" "$(DESTDIR)$(pkgfontembedincludedir)" "$(DESTDIR)$(pkgmimedir)" "$(DESTDIR)$(pkgppdcdir)" "$(DESTDIR)$(ppddir)"; do \
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
done
install: install-am
@@ -4522,7 +4482,7 @@ install-data-am: install-docDATA install
install-pkgconfDATA install-pkgcupsdataDATA \
install-pkgcupsserverrootDATA install-pkgdriverDATA \
install-pkgfilterPROGRAMS install-pkgfilterSCRIPTS \
- install-pkgfiltersincludeDATA install-pkgfontconfigDATA \
+ install-pkgfiltersincludeDATA \
install-pkgfontembedincludeDATA install-pkgmimeDATA \
install-pkgppdcDATA install-ppdDATA
@$(NORMAL_INSTALL)
@@ -4581,7 +4541,7 @@ uninstall-am: uninstall-binPROGRAMS unin
uninstall-pkgconfDATA uninstall-pkgcupsdataDATA \
uninstall-pkgcupsserverrootDATA uninstall-pkgdriverDATA \
uninstall-pkgfilterPROGRAMS uninstall-pkgfilterSCRIPTS \
- uninstall-pkgfiltersincludeDATA uninstall-pkgfontconfigDATA \
+ uninstall-pkgfiltersincludeDATA \
uninstall-pkgfontembedincludeDATA uninstall-pkgmimeDATA \
uninstall-pkgppdcDATA uninstall-ppdDATA uninstall-sbinPROGRAMS
@$(NORMAL_INSTALL)
@@ -4613,7 +4573,7 @@ uninstall-man: uninstall-man1 uninstall-
install-pkgcupsdataDATA install-pkgcupsserverrootDATA \
install-pkgdriverDATA install-pkgfilterPROGRAMS \
install-pkgfilterSCRIPTS install-pkgfiltersincludeDATA \
- install-pkgfontconfigDATA install-pkgfontembedincludeDATA \
+ install-pkgfontembedincludeDATA \
install-pkgmimeDATA install-pkgppdcDATA install-ppdDATA \
install-ps install-ps-am install-sbinPROGRAMS install-strip \
installcheck installcheck-am installdirs maintainer-clean \
@@ -4628,7 +4588,7 @@ uninstall-man: uninstall-man1 uninstall-
uninstall-pkgconfDATA uninstall-pkgcupsdataDATA \
uninstall-pkgcupsserverrootDATA uninstall-pkgdriverDATA \
uninstall-pkgfilterPROGRAMS uninstall-pkgfilterSCRIPTS \
- uninstall-pkgfiltersincludeDATA uninstall-pkgfontconfigDATA \
+ uninstall-pkgfiltersincludeDATA \
uninstall-pkgfontembedincludeDATA uninstall-pkgmimeDATA \
uninstall-pkgppdcDATA uninstall-ppdDATA uninstall-sbinPROGRAMS

View File

@ -0,0 +1,37 @@
diff -up cups-filters-1.0.47/Makefile.am.urftopdf cups-filters-1.0.47/Makefile.am
--- cups-filters-1.0.47/Makefile.am.urftopdf 2014-02-27 16:33:39.000000000 +0100
+++ cups-filters-1.0.47/Makefile.am 2014-03-11 12:46:24.566688998 +0100
@@ -421,8 +421,8 @@ pkgfilter_PROGRAMS += \
pdftoraster \
rastertoescpx \
rastertopclx \
- texttopdf \
- urftopdf
+ texttopdf
+
if ENABLE_IMAGEFILTERS
pkgfilter_PROGRAMS += \
imagetopdf \
diff -up cups-filters-1.0.47/Makefile.in.urftopdf cups-filters-1.0.47/Makefile.in
--- cups-filters-1.0.47/Makefile.in.urftopdf 2014-03-11 12:46:24.568688972 +0100
+++ cups-filters-1.0.47/Makefile.in 2014-03-11 12:48:31.572015731 +0100
@@ -96,7 +96,7 @@ pkgfilter_PROGRAMS = pdftoopvp$(EXEEXT)
commandtopclx$(EXEEXT) foomatic-rip$(EXEEXT) \
gstoraster$(EXEEXT) pdftoijs$(EXEEXT) pdftoippprinter$(EXEEXT) \
pdftops$(EXEEXT) pdftoraster$(EXEEXT) rastertoescpx$(EXEEXT) \
- rastertopclx$(EXEEXT) texttopdf$(EXEEXT) urftopdf$(EXEEXT) \
+ rastertopclx$(EXEEXT) texttopdf$(EXEEXT) \
$(am__EXEEXT_1)
@ENABLE_IMAGEFILTERS_TRUE@am__append_3 = \
@ENABLE_IMAGEFILTERS_TRUE@ imagetopdf \
diff -up cups-filters-1.0.47/mime/cupsfilters.convs.urftopdf cups-filters-1.0.47/mime/cupsfilters.convs
--- cups-filters-1.0.47/mime/cupsfilters.convs.urftopdf 2013-12-10 22:20:15.000000000 +0100
+++ cups-filters-1.0.47/mime/cupsfilters.convs 2014-03-11 12:46:24.569688958 +0100
@@ -68,7 +68,6 @@ image/x-xpixmap application/vnd.cups-pd
image/x-xwindowdump application/vnd.cups-pdf 65 imagetopdf
image/x-sun-raster application/vnd.cups-pdf 65 imagetopdf
application/vnd.cups-pdf-banner application/pdf 32 bannertopdf
-image/urf application/pdf 0 urftopdf
########################################################################
#

View File

@ -4,7 +4,7 @@
Summary: OpenPrinting CUPS filters and backends
Name: cups-filters
Version: 1.0.47
Release: 1%{?dist}
Release: 2%{?dist}
# For a breakdown of the licensing, see COPYING file
# GPLv2: filters: commandto*, imagetoraster, pdftops, rasterto*,
@ -20,6 +20,9 @@ License: GPLv2 and GPLv2+ and GPLv3 and GPLv3+ and LGPLv2+ and MIT
Url: http://www.linuxfoundation.org/collaborate/workgroups/openprinting/cups-filters
Source0: http://www.openprinting.org/download/cups-filters/cups-filters-%{version}.tar.xz
Patch1: cups-filters-urftopdf.patch
Patch2: cups-filters-pdftoopvp.patch
Requires: cups-filters-libs%{?_isa} = %{version}-%{release}
# Obsolete cups-php (bug #971741)
@ -114,6 +117,12 @@ This is the development package for OpenPrinting CUPS filters and backends.
%prep
%setup -q
# Don't ship urftopdf for now (bug #1002947).
%patch1 -p1 -b .urftopdf
# Don't ship pdftoopvp for now (bug #1027557).
%patch2 -p1 -b .pdftoopvp
%build
# work-around Rpath
./autogen.sh
@ -198,7 +207,6 @@ fi
%files
%doc __doc/README __doc/AUTHORS __doc/NEWS
%config(noreplace) %{_sysconfdir}/cups/cups-browsed.conf
%config(noreplace) %{_sysconfdir}/fonts/conf.d/99pdftoopvp.conf
%attr(0755,root,root) %{_cups_serverbin}/filter/*
%attr(0755,root,root) %{_cups_serverbin}/backend/parallel
# Serial backend needs to run as root (bug #212577#c4).
@ -234,6 +242,9 @@ fi
%{_libdir}/libfontembed.so
%changelog
* Tue Mar 11 2014 Jiri Popelka <jpopelka@redhat.com> - 1.0.47-2
- Don't ship pdftoopvp (#1027557) and urftopdf (#1002947).
* Tue Mar 11 2014 Jiri Popelka <jpopelka@redhat.com> - 1.0.47-1
- 1.0.47: CVE-2013-6473 CVE-2013-6476 CVE-2013-6474 CVE-2013-6475 (#1074840)