Don't ship pdftoopvp (#1027557) and urftopdf (#1002947).

This commit is contained in:
Jiri Popelka 2014-03-11 13:10:24 +01:00
parent 8b7e0c531c
commit 285b84a7cd
3 changed files with 209 additions and 2 deletions

View File

@ -0,0 +1,160 @@
diff -up cups-filters-1.0.41/Makefile.am.pdftoopvp cups-filters-1.0.41/Makefile.am
--- cups-filters-1.0.41/Makefile.am.pdftoopvp 2014-03-11 13:15:07.367197743 +0100
+++ cups-filters-1.0.41/Makefile.am 2014-03-11 13:15:07.372197679 +0100
@@ -307,10 +307,7 @@ EXTRA_DIST += \
# PDF to OPVP
# ===========
pkgfilterdir = $(CUPS_SERVERBIN)/filter
-pkgfilter_PROGRAMS = pdftoopvp
-
-pkgfontconfigdir = $(sysconfdir)/$(FONTDIR)
-pkgfontconfig_DATA = filter/pdftoopvp/99pdftoopvp.conf
+pkgfilter_PROGRAMS =
pdftoopvp_SOURCES = \
filter/pdftoopvp/oprs/OPRS.cxx \
@@ -353,8 +350,6 @@ pdftoopvp_LDADD = \
$(POPPLER_LIBS) \
$(DLOPEN_LIBS)
-EXTRA_DIST += $(pkgfontconfig_DATA)
-
# ==========
# PDF to PDF
# ==========
diff -up cups-filters-1.0.41/Makefile.in.pdftoopvp cups-filters-1.0.41/Makefile.in
--- cups-filters-1.0.41/Makefile.in.pdftoopvp 2014-03-11 13:15:07.369197717 +0100
+++ cups-filters-1.0.41/Makefile.in 2014-03-11 13:16:50.989858630 +0100
@@ -89,7 +89,7 @@ check_PROGRAMS = test1284$(EXEEXT) testc
TESTS = testdither$(EXEEXT) test_analyze$(EXEEXT) test_pdf$(EXEEXT) \
test_ps$(EXEEXT) test_pdf1$(EXEEXT) test_pdf2$(EXEEXT)
bin_PROGRAMS = ttfread$(EXEEXT)
-pkgfilter_PROGRAMS = pdftoopvp$(EXEEXT) pdftopdf$(EXEEXT) \
+pkgfilter_PROGRAMS = pdftopdf$(EXEEXT) \
bannertopdf$(EXEEXT) commandtoescpx$(EXEEXT) \
commandtopclx$(EXEEXT) gstoraster$(EXEEXT) pdftoijs$(EXEEXT) \
pdftoippprinter$(EXEEXT) pdftops$(EXEEXT) pdftoraster$(EXEEXT) \
@@ -164,7 +164,6 @@ am__installdirs = "$(DESTDIR)$(libdir)"
"$(DESTDIR)$(pkgcupsserverrootdir)" \
"$(DESTDIR)$(pkgdriverdir)" \
"$(DESTDIR)$(pkgfiltersincludedir)" \
- "$(DESTDIR)$(pkgfontconfigdir)" \
"$(DESTDIR)$(pkgfontembedincludedir)" \
"$(DESTDIR)$(pkgmimedir)" "$(DESTDIR)$(pkgppdcdir)" \
"$(DESTDIR)$(ppddir)"
@@ -514,7 +513,7 @@ MANS = $(man_MANS)
DATA = $(doc_DATA) $(pkgbanner_DATA) $(pkgcharset_DATA) \
$(pkgconf_DATA) $(pkgcupsdata_DATA) $(pkgcupsserverroot_DATA) \
$(pkgdriver_DATA) $(pkgfiltersinclude_DATA) \
- $(pkgfontconfig_DATA) $(pkgfontembedinclude_DATA) \
+ $(pkgfontembedinclude_DATA) \
$(pkgmime_DATA) $(pkgppdc_DATA) $(ppd_DATA)
am__tagged_files = $(HEADERS) $(SOURCES) $(TAGS_FILES) \
$(LISP)config.h.in
@@ -929,7 +928,7 @@ EXTRA_DIST = $(doc_DATA) autogen.sh libc
cupsfilters/image.pgm cupsfilters/image.ppm \
$(pkgcupsdata_DATA) $(pkgdriver_DATA) $(pkgppdc_DATA) \
$(pkgmime_DATA) $(pkgfontembedinclude_DATA) fontembed/README \
- $(pkgfontconfig_DATA) $(pkgfilter_SCRIPTS) filter/test.sh \
+ $(pkgfilter_SCRIPTS) filter/test.sh \
utils/cups-browsed.in $(man_MANS) $(ppd_DATA) scripting/perl \
scripting/php/README scripting/php/phpcups.php
@@ -1186,8 +1185,6 @@ test_ps_LDADD = libfontembed.la
# PDF to OPVP
# ===========
pkgfilterdir = $(CUPS_SERVERBIN)/filter
-pkgfontconfigdir = $(sysconfdir)/$(FONTDIR)
-pkgfontconfig_DATA = filter/pdftoopvp/99pdftoopvp.conf
pdftoopvp_SOURCES = \
filter/pdftoopvp/oprs/OPRS.cxx \
filter/pdftoopvp/oprs/OPRS.h \
@@ -3715,43 +3712,6 @@ uninstall-pkgfiltersincludeDATA:
@list='$(pkgfiltersinclude_DATA)'; test -n "$(pkgfiltersincludedir)" || list=; \
files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
dir='$(DESTDIR)$(pkgfiltersincludedir)'; $(am__uninstall_files_from_dir)
-install-pkgfontconfigDATA: $(pkgfontconfig_DATA)
- @$(NORMAL_INSTALL)
- @list='$(pkgfontconfig_DATA)'; test -n "$(pkgfontconfigdir)" || list=; \
- if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(pkgfontconfigdir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(pkgfontconfigdir)" || exit 1; \
- fi; \
- for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
- echo "$$d$$p"; \
- done | $(am__base_list) | \
- while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(pkgfontconfigdir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(pkgfontconfigdir)" || exit $$?; \
- done
-
-uninstall-pkgfontconfigDATA:
- @$(NORMAL_UNINSTALL)
- @list='$(pkgfontconfig_DATA)'; test -n "$(pkgfontconfigdir)" || list=; \
- files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
- dir='$(DESTDIR)$(pkgfontconfigdir)'; $(am__uninstall_files_from_dir)
-install-pkgfontembedincludeDATA: $(pkgfontembedinclude_DATA)
- @$(NORMAL_INSTALL)
- @list='$(pkgfontembedinclude_DATA)'; test -n "$(pkgfontembedincludedir)" || list=; \
- if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(pkgfontembedincludedir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(pkgfontembedincludedir)" || exit 1; \
- fi; \
- for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
- echo "$$d$$p"; \
- done | $(am__base_list) | \
- while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(pkgfontembedincludedir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(pkgfontembedincludedir)" || exit $$?; \
- done
-
uninstall-pkgfontembedincludeDATA:
@$(NORMAL_UNINSTALL)
@list='$(pkgfontembedinclude_DATA)'; test -n "$(pkgfontembedincludedir)" || list=; \
@@ -4241,7 +4201,7 @@ all-am: Makefile $(LTLIBRARIES) $(PROGRA
install-binPROGRAMS: install-libLTLIBRARIES
installdirs:
- for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(phpextensiondir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pkgbackenddir)" "$(DESTDIR)$(pkgfilterdir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(initrcdir)" "$(DESTDIR)$(pkgfilterdir)" "$(DESTDIR)$(man5dir)" "$(DESTDIR)$(man8dir)" "$(DESTDIR)$(docdir)" "$(DESTDIR)$(pkgbannerdir)" "$(DESTDIR)$(pkgcharsetdir)" "$(DESTDIR)$(pkgconfdir)" "$(DESTDIR)$(pkgcupsdatadir)" "$(DESTDIR)$(pkgcupsserverrootdir)" "$(DESTDIR)$(pkgdriverdir)" "$(DESTDIR)$(pkgfiltersincludedir)" "$(DESTDIR)$(pkgfontconfigdir)" "$(DESTDIR)$(pkgfontembedincludedir)" "$(DESTDIR)$(pkgmimedir)" "$(DESTDIR)$(pkgppdcdir)" "$(DESTDIR)$(ppddir)"; do \
+ for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(phpextensiondir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pkgbackenddir)" "$(DESTDIR)$(pkgfilterdir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(initrcdir)" "$(DESTDIR)$(pkgfilterdir)" "$(DESTDIR)$(man5dir)" "$(DESTDIR)$(man8dir)" "$(DESTDIR)$(docdir)" "$(DESTDIR)$(pkgbannerdir)" "$(DESTDIR)$(pkgcharsetdir)" "$(DESTDIR)$(pkgconfdir)" "$(DESTDIR)$(pkgcupsdatadir)" "$(DESTDIR)$(pkgcupsserverrootdir)" "$(DESTDIR)$(pkgdriverdir)" "$(DESTDIR)$(pkgfiltersincludedir)" "$(DESTDIR)$(pkgfontembedincludedir)" "$(DESTDIR)$(pkgmimedir)" "$(DESTDIR)$(pkgppdcdir)" "$(DESTDIR)$(ppddir)"; do \
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
done
install: install-am
@@ -4309,7 +4269,7 @@ install-data-am: install-docDATA install
install-pkgconfDATA install-pkgcupsdataDATA \
install-pkgcupsserverrootDATA install-pkgdriverDATA \
install-pkgfilterPROGRAMS install-pkgfilterSCRIPTS \
- install-pkgfiltersincludeDATA install-pkgfontconfigDATA \
+ install-pkgfiltersincludeDATA \
install-pkgfontembedincludeDATA install-pkgmimeDATA \
install-pkgppdcDATA install-ppdDATA
@$(NORMAL_INSTALL)
@@ -4368,7 +4328,7 @@ uninstall-am: uninstall-binPROGRAMS unin
uninstall-pkgconfDATA uninstall-pkgcupsdataDATA \
uninstall-pkgcupsserverrootDATA uninstall-pkgdriverDATA \
uninstall-pkgfilterPROGRAMS uninstall-pkgfilterSCRIPTS \
- uninstall-pkgfiltersincludeDATA uninstall-pkgfontconfigDATA \
+ uninstall-pkgfiltersincludeDATA \
uninstall-pkgfontembedincludeDATA uninstall-pkgmimeDATA \
uninstall-pkgppdcDATA uninstall-ppdDATA uninstall-sbinPROGRAMS
@$(NORMAL_INSTALL)
@@ -4399,7 +4359,7 @@ uninstall-man: uninstall-man5 uninstall-
install-pkgconfDATA install-pkgcupsdataDATA \
install-pkgcupsserverrootDATA install-pkgdriverDATA \
install-pkgfilterPROGRAMS install-pkgfilterSCRIPTS \
- install-pkgfiltersincludeDATA install-pkgfontconfigDATA \
+ install-pkgfiltersincludeDATA \
install-pkgfontembedincludeDATA install-pkgmimeDATA \
install-pkgppdcDATA install-ppdDATA install-ps install-ps-am \
install-sbinPROGRAMS install-strip installcheck \
@@ -4415,7 +4375,7 @@ uninstall-man: uninstall-man5 uninstall-
uninstall-pkgconfDATA uninstall-pkgcupsdataDATA \
uninstall-pkgcupsserverrootDATA uninstall-pkgdriverDATA \
uninstall-pkgfilterPROGRAMS uninstall-pkgfilterSCRIPTS \
- uninstall-pkgfiltersincludeDATA uninstall-pkgfontconfigDATA \
+ uninstall-pkgfiltersincludeDATA \
uninstall-pkgfontembedincludeDATA uninstall-pkgmimeDATA \
uninstall-pkgppdcDATA uninstall-ppdDATA uninstall-sbinPROGRAMS

View File

@ -0,0 +1,37 @@
diff -up cups-filters-1.0.41/Makefile.am.urftopdf cups-filters-1.0.41/Makefile.am
--- cups-filters-1.0.41/Makefile.am.urftopdf 2014-03-11 13:13:48.012222641 +0100
+++ cups-filters-1.0.41/Makefile.am 2014-03-11 13:13:48.020222538 +0100
@@ -410,8 +410,8 @@ pkgfilter_PROGRAMS += \
pdftoraster \
rastertoescpx \
rastertopclx \
- texttopdf \
- urftopdf
+ texttopdf
+
if ENABLE_IMAGEFILTERS
pkgfilter_PROGRAMS += \
imagetopdf \
diff -up cups-filters-1.0.41/Makefile.in.urftopdf cups-filters-1.0.41/Makefile.in
--- cups-filters-1.0.41/Makefile.in.urftopdf 2014-03-11 13:13:48.022222512 +0100
+++ cups-filters-1.0.41/Makefile.in 2014-03-11 13:14:45.729477255 +0100
@@ -94,7 +94,7 @@ pkgfilter_PROGRAMS = pdftoopvp$(EXEEXT)
commandtopclx$(EXEEXT) gstoraster$(EXEEXT) pdftoijs$(EXEEXT) \
pdftoippprinter$(EXEEXT) pdftops$(EXEEXT) pdftoraster$(EXEEXT) \
rastertoescpx$(EXEEXT) rastertopclx$(EXEEXT) \
- texttopdf$(EXEEXT) urftopdf$(EXEEXT) $(am__EXEEXT_1)
+ texttopdf$(EXEEXT) $(am__EXEEXT_1)
@ENABLE_IMAGEFILTERS_TRUE@am__append_1 = \
@ENABLE_IMAGEFILTERS_TRUE@ imagetopdf \
@ENABLE_IMAGEFILTERS_TRUE@ imagetoraster
diff -up cups-filters-1.0.41/mime/cupsfilters.convs.urftopdf cups-filters-1.0.41/mime/cupsfilters.convs
--- cups-filters-1.0.41/mime/cupsfilters.convs.urftopdf 2014-03-11 13:13:48.017222576 +0100
+++ cups-filters-1.0.41/mime/cupsfilters.convs 2014-03-11 13:13:48.023222499 +0100
@@ -68,7 +68,6 @@ image/x-xpixmap application/vnd.cups-pd
image/x-xwindowdump application/vnd.cups-pdf 65 imagetopdf
image/x-sun-raster application/vnd.cups-pdf 65 imagetopdf
application/vnd.cups-pdf-banner application/pdf 32 bannertopdf
-image/urf application/pdf 0 urftopdf
########################################################################
#

View File

@ -4,7 +4,7 @@
Summary: OpenPrinting CUPS filters and backends
Name: cups-filters
Version: 1.0.41
Release: 4%{?dist}
Release: 5%{?dist}
# For a breakdown of the licensing, see COPYING file
# GPLv2: filters: commandto*, imagetoraster, pdftops, rasterto*,
@ -25,6 +25,8 @@ Patch1: cups-filters-pdf-landscape.patch
Patch2: cups-filters-dbus.patch
Patch3: cups-filters-memory-leaks.patch
Patch4: cups-filters-filter-costs.patch
Patch5: cups-filters-urftopdf.patch
Patch6: cups-filters-pdftoopvp.patch
Requires: cups-filters-libs%{?_isa} = %{version}-%{release}
@ -121,6 +123,12 @@ This is the development package for OpenPrinting CUPS filters and backends.
# doesn't go via pstotiff (bug #1008166).
%patch4 -p1 -b .filter-costs
# Don't ship urftopdf for now (bug #1002947).
%patch5 -p1 -b .urftopdf
# Don't ship pdftoopvp for now (bug #1027557).
%patch6 -p1 -b .pdftoopvp
%build
# work-around Rpath
./autogen.sh
@ -201,7 +209,6 @@ fi
%files
%doc __doc/README __doc/AUTHORS __doc/NEWS
%config(noreplace) %{_sysconfdir}/cups/cups-browsed.conf
%config(noreplace) %{_sysconfdir}/fonts/conf.d/99pdftoopvp.conf
%attr(0755,root,root) %{_cups_serverbin}/filter/*
%attr(0755,root,root) %{_cups_serverbin}/backend/parallel
# Serial backend needs to run as root (bug #212577#c4).
@ -235,6 +242,9 @@ fi
%{_libdir}/libfontembed.so
%changelog
* Tue Mar 11 2014 Jiri Popelka <jpopelka@redhat.com> - 1.0.41-5
- Don't ship pdftoopvp (#1027557) and urftopdf (#1002947).
* Tue Nov 19 2013 Tim Waugh <twaugh@redhat.com> - 1.0.41-4
- Adjust filter costs so application/vnd.adobe-read-postscript input
doesn't go via pstotiff (bug #1008166).