1.0.42: includes foomatic-rip (obsoletes foomatic-filters package)

This commit is contained in:
Jiri Popelka 2013-11-30 19:46:42 +01:00
parent 8b7e0c531c
commit 167d5a24a2
6 changed files with 13 additions and 123 deletions

1
.gitignore vendored
View File

@ -17,3 +17,4 @@
/cups-filters-1.0.39.tar.xz
/cups-filters-1.0.40.tar.xz
/cups-filters-1.0.41.tar.xz
/cups-filters-1.0.42.tar.xz

View File

@ -1,58 +0,0 @@
diff -up cups-filters-1.0.41/Makefile.am.dbus cups-filters-1.0.41/Makefile.am
--- cups-filters-1.0.41/Makefile.am.dbus 2013-10-25 14:12:56.000000000 +0100
+++ cups-filters-1.0.41/Makefile.am 2013-11-06 17:16:58.504234619 +0000
@@ -474,9 +474,11 @@ gstoraster_SOURCES = \
cupsfilters/raster.h
gstoraster_CFLAGS = \
$(CUPS_CFLAGS) \
+ $(DBUS_CFLAGS) \
-I$(srcdir)/cupsfilters/
gstoraster_LDADD = \
$(CUPS_LIBS) \
+ $(DBUS_LIBS) \
libcupsfilters.la
imagetopdf_SOURCES = \
diff -up cups-filters-1.0.41/config.h.in.dbus cups-filters-1.0.41/config.h.in
diff -up cups-filters-1.0.41/configure.ac.dbus cups-filters-1.0.41/configure.ac
--- cups-filters-1.0.41/configure.ac.dbus 2013-10-30 07:21:44.000000000 +0000
+++ cups-filters-1.0.41/configure.ac 2013-11-06 17:23:07.619921079 +0000
@@ -114,6 +114,18 @@ AX_COMPARE_VERSION([$CUPS_VERSION],[gt],
AC_DEFINE(PDFTOPDF, [], [Needed for pdftopdf filter compilation])
AC_DEFINE_DIR(BANNERTOPDF_DATADIR, "{CUPS_DATADIR}/data", [Directory where bannertopdf finds its data files (PDF templates)])
+dnl DBus support
+DBUS_CFLAGS=""
+DBUS_LIBS=""
+AC_ARG_ENABLE([dbus], AC_HELP_STRING([--disable-dbus],
+ [Do not use dbus to communicate with external services]))
+if test "$enable_dbus" != "no"; then
+ PKG_CHECK_MODULES(DBUS, [dbus-1], [HAVE_DBUS=-DHAVE_DBUS])
+ AC_DEFINE([HAVE_DBUS], [], [Defines if dbus is available.])
+fi
+AC_SUBST(DBUS_CFLAGS)
+AC_SUBST(DBUS_LIBS)
+
AC_SEARCH_LIBS([dlopen],
[dl],
[AS_IF([test "$ac_cv_search_dlopen" != "none required"], [
@@ -640,6 +652,7 @@ Build configuration:
php-config: ${with_php_config}
test-font: ${with_test_font_path}
tiff: ${with_tiff}
+ dbus: ${HAVE_DBUS}
avahi: ${enable_avahi}
browsing: ${with_browseremoteprotocols}
werror: ${enable_werror}
diff -up cups-filters-1.0.41/filter/colord.c.dbus cups-filters-1.0.41/filter/colord.c
--- cups-filters-1.0.41/filter/colord.c.dbus 2013-07-29 20:12:42.000000000 +0100
+++ cups-filters-1.0.41/filter/colord.c 2013-11-06 17:16:58.505234623 +0000
@@ -32,6 +32,8 @@ MIT Open Source License - http://www.o
#include <stdio.h>
#include <sys/types.h>
+#include "config.h"
+
#ifdef HAVE_DBUS
#include <dbus/dbus.h>
#endif

View File

@ -1,12 +0,0 @@
diff -up cups-filters-1.0.41/mime/cupsfilters.convs.filter-costs cups-filters-1.0.41/mime/cupsfilters.convs
--- cups-filters-1.0.41/mime/cupsfilters.convs.filter-costs 2013-11-19 11:51:06.279294346 +0000
+++ cups-filters-1.0.41/mime/cupsfilters.convs 2013-11-19 11:51:07.960301722 +0000
@@ -85,7 +85,7 @@ application/vnd.cups-pdf application/vnd
#
application/vnd.cups-pdf application/vnd.cups-raster 99 gstoraster
-application/vnd.cups-postscript application/vnd.cups-raster 200 gstoraster
+application/vnd.cups-postscript application/vnd.cups-raster 175 gstoraster
application/vnd.cups-pdf application/vnd.cups-raster 100 pdftoraster
image/gif application/vnd.cups-raster 100 imagetoraster
image/png application/vnd.cups-raster 100 imagetoraster

View File

@ -1,36 +0,0 @@
diff --git a/utils/cups-browsed.c b/utils/cups-browsed.c
index c312804..155b581 100644
--- a/utils/cups-browsed.c
+++ b/utils/cups-browsed.c
@@ -993,6 +993,10 @@ void generate_local_queue(const char *host,
would get, so ignore this remote printer */
debug_printf("cups-browsed: Printer with URI %s already exists, printer ignored.\n",
uri);
+ free (uri);
+ free (remote_host);
+ free (backup_queue_name);
+ cupsFreeDests(num_dests, dests);
return;
}
/* Is there a local queue with the name of the remote queue? */
@@ -1027,6 +1031,7 @@ void generate_local_queue(const char *host,
ignore this remote printer */
debug_printf("cups-browsed: %s also taken, printer ignored.\n",
local_queue_name);
+ free (uri);
free (backup_queue_name);
free (remote_host);
cupsFreeDests(num_dests, dests);
@@ -2426,9 +2431,9 @@ int main(int argc, char*argv[]) {
strcasecmp(val, "false") != 0) {
/* Queue found, add to our list */
p = create_local_queue (dest->name,
- strdup(cupsGetOption("device-uri",
- dest->num_options,
- dest->options)),
+ cupsGetOption("device-uri",
+ dest->num_options,
+ dest->options),
"", "", "", "", NULL, 1);
if (p) {
/* Mark as unconfirmed, if no Avahi report of this queue appears

View File

@ -3,14 +3,14 @@
Summary: OpenPrinting CUPS filters and backends
Name: cups-filters
Version: 1.0.41
Release: 4%{?dist}
Version: 1.0.42
Release: 1%{?dist}
# For a breakdown of the licensing, see COPYING file
# GPLv2: filters: commandto*, imagetoraster, pdftops, rasterto*,
# imagetopdf, pstopdf, texttopdf
# backends: parallel, serial
# GPLv2+: filters: gstopxl, textonly, texttops, imagetops
# GPLv2+: filters: gstopxl, textonly, texttops, imagetops, foomatic-rip
# GPLv3: filters: bannertopdf
# GPLv3+: filters: urftopdf
# LGPLv2+: utils: cups-browsed
@ -22,9 +22,6 @@ Url: http://www.linuxfoundation.org/collaborate/workgroups/openprinting/cups
Source0: http://www.openprinting.org/download/cups-filters/cups-filters-%{version}.tar.xz
Patch1: cups-filters-pdf-landscape.patch
Patch2: cups-filters-dbus.patch
Patch3: cups-filters-memory-leaks.patch
Patch4: cups-filters-filter-costs.patch
Requires: cups-filters-libs%{?_isa} = %{version}-%{release}
@ -79,6 +76,10 @@ Requires(postun): systemd
Provides: ghostscript-cups = 9.08
Obsoletes: ghostscript-cups < 9.08
# foomatic-rip's upstream moved from foomatic-filters to cups-filters-1.0.42
Provides: foomatic-filters = 4.0.9-8
Obsoletes: foomatic-filters < 4.0.9-8
%package libs
Summary: OpenPrinting CUPS filters and backends - cupsfilters and fontembed libraries
Group: System Environment/Libraries
@ -111,16 +112,6 @@ This is the development package for OpenPrinting CUPS filters and backends.
# Fix PDF landscape printing (bug #768811).
%patch1 -p1 -b .pdf-landscape
# Include dbus so that colord support works (bug #1026928).
%patch2 -p1 -b .dbus
# Fix memory leaks in cups-browsed (bug #1027317).
%patch3 -p1 -b .memory-leaks
# Adjust filter costs so application/vnd.adobe-read-postscript input
# doesn't go via pstotiff (bug #1008166).
%patch4 -p1 -b .filter-costs
%build
# work-around Rpath
./autogen.sh
@ -219,6 +210,7 @@ fi
%{_unitdir}/cups-browsed.service
%{_mandir}/man8/cups-browsed.8.gz
%{_mandir}/man5/cups-browsed.conf.5.gz
%{_mandir}/man1/foomatic-rip.1.gz
%files libs
%doc __doc/COPYING fontembed/README
@ -235,6 +227,9 @@ fi
%{_libdir}/libfontembed.so
%changelog
* Sat Nov 30 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.42-1
- 1.0.42: includes foomatic-rip (obsoletes foomatic-filters package)
* Tue Nov 19 2013 Tim Waugh <twaugh@redhat.com> - 1.0.41-4
- Adjust filter costs so application/vnd.adobe-read-postscript input
doesn't go via pstotiff (bug #1008166).

View File

@ -1 +1 @@
fe5a9a07b9a64b35975154068cbedef9 cups-filters-1.0.41.tar.xz
3047524b51f2ac064663f1997c7d2c81 cups-filters-1.0.42.tar.xz