update to p5.9-20210725
This commit is contained in:
parent
72717da0c1
commit
4e196fd004
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@ ctags-5.7.tar.gz
|
||||
ctags-5.8.tar.gz
|
||||
/ctags-p5.9.20210307.0.tar.gz
|
||||
/ctags-p5.9.20210509.0.tar.gz
|
||||
/ctags-p5.9.20210725.0.tar.gz
|
||||
|
@ -1,108 +0,0 @@
|
||||
diff -up ctags-p5.9.20210307.0/configure.ac.orig ctags-p5.9.20210307.0/configure.ac
|
||||
--- ctags-p5.9.20210307.0/configure.ac.orig 2021-03-11 15:28:04.114839683 +0100
|
||||
+++ ctags-p5.9.20210307.0/configure.ac 2021-03-11 15:28:22.233584068 +0100
|
||||
@@ -243,25 +243,6 @@ AC_PROG_CC_C99
|
||||
AC_PROG_RANLIB
|
||||
AC_C_BIGENDIAN
|
||||
|
||||
-# https://www.gnu.org/software/autoconf-archive/ax_prog_cc_for_build.html
|
||||
-AX_PROG_CC_FOR_BUILD
|
||||
-
|
||||
-# We need to compile and run a program on the build machine.
|
||||
-AC_MSG_CHECKING(for cc for build)
|
||||
-if test "$cross_compiling" = "yes"; then
|
||||
- CC_FOR_BUILD="${CC_FOR_BUILD-cc}"
|
||||
-else
|
||||
- CC_FOR_BUILD="${CC_FOR_BUILD-$CC}"
|
||||
- CFLAGS_FOR_BUILD="${CFLAGS_FOR_BUILD-$CFLAGS}"
|
||||
- CPPFLAGS_FOR_BUILD="${CPPFLAGS_FOR_BUILD-$CPPFLAGS}"
|
||||
- LDFLAGS_FOR_BUILD="${LDFLAGS_FOR_BUILD-$LDFLAGS}"
|
||||
-fi
|
||||
-AC_MSG_RESULT($CC_FOR_BUILD)
|
||||
-AC_ARG_VAR(CC_FOR_BUILD,[build system C compiler])
|
||||
-AC_ARG_VAR(CFLAGS_FOR_BUILD,[CFLAGS for build system C compiler])
|
||||
-AC_ARG_VAR(CPPFLAGS_FOR_BUILD,[CPPFLAGS for build system C compiler])
|
||||
-AC_ARG_VAR(LDFLAGS_FOR_BUILD,[LDFLAGS for build system C compiler])
|
||||
-
|
||||
AC_ARG_VAR(AR,[ar command or path])
|
||||
AC_ARG_VAR(RANLIB,[ranlib command or path])
|
||||
AC_ARG_VAR(WINDRES,[windres command or path, used with mingw-w64])
|
||||
diff -up ctags-p5.9.20210307.0/Makefile.am.orig ctags-p5.9.20210307.0/Makefile.am
|
||||
--- ctags-p5.9.20210307.0/Makefile.am.orig 2021-03-11 15:30:20.393270480 +0100
|
||||
+++ ctags-p5.9.20210307.0/Makefile.am 2021-03-11 15:30:41.824895156 +0100
|
||||
@@ -11,7 +11,7 @@ EXTRA_DIST = README.md autogen.sh \
|
||||
misc/ctags-optlib-mode.el \
|
||||
misc/mk-interactive-request.sh misc/roundtrip misc/tinst \
|
||||
misc/packcc/.gitignore misc/packcc/LICENSE.txt \
|
||||
- misc/packcc/README.md misc/packcc/packcc.c \
|
||||
+ misc/packcc/README.md \
|
||||
misc/validators/validator-jq \
|
||||
misc/validators/validator-KNOWN-INVALIDATION \
|
||||
misc/validators/validator-NONE \
|
||||
@@ -29,29 +29,21 @@ EXTRA_DIST = README.md autogen.sh \
|
||||
CLEANFILES =
|
||||
MOSTLYCLEANFILES =
|
||||
|
||||
-clean-local:
|
||||
- rm -f packcc$(BUILD_EXEEXT)
|
||||
- @if test "$(top_srcdir)" != "$(top_builddir)"; then \
|
||||
- rm -rf $(OPTLIB2C_SRCS); \
|
||||
- fi
|
||||
-
|
||||
bin_PROGRAMS = ctags
|
||||
noinst_LIBRARIES = libctags.a
|
||||
|
||||
-noinst_PROGRAMS =
|
||||
+noinst_PROGRAMS = packcc
|
||||
noinst_PROGRAMS += mini-geany
|
||||
|
||||
if HAVE_STRNLEN_FOR_BUILD
|
||||
EXTRA_CPPFLAGS_FOR_BUILD = -DUSE_SYSTEM_STRNLEN
|
||||
endif
|
||||
|
||||
-PACKCC = $(top_builddir)/packcc$(BUILD_EXEEXT)
|
||||
-
|
||||
cc4b_verbose = $(cc4b_verbose_@AM_V@)
|
||||
cc4b_verbose_ = $(cc4b_verbose_@AM_DEFAULT_V@)
|
||||
cc4b_verbose_0 = @echo CC4BUILD " $@";
|
||||
-$(PACKCC): $(top_srcdir)/misc/packcc/packcc.c
|
||||
- $(cc4b_verbose)$(CC_FOR_BUILD) $(CFLAGS_FOR_BUILD) $(CPPFLAGS_FOR_BUILD) $(EXTRA_CPPFLAGS_FOR_BUILD) $(LDFLAGS_FOR_BUILD) -o $@ $(top_srcdir)/misc/packcc/packcc.c
|
||||
+
|
||||
+packcc_SOURCES = misc/packcc/packcc.c
|
||||
|
||||
if USE_READCMD
|
||||
bin_PROGRAMS+= readtags
|
||||
@@ -144,16 +136,13 @@ SUFFIXES += .ctags
|
||||
$(OPTLIB2C_SRCS): $(OPTLIB2C) Makefile
|
||||
endif
|
||||
|
||||
-packcc_verbose = $(packcc_verbose_@AM_V@)
|
||||
-packcc_verbose_ = $(packcc_verbose_@AM_DEFAULT_V@)
|
||||
-packcc_verbose_0 = @echo PACKCC " $@";
|
||||
SUFFIXES += .peg
|
||||
-.peg.c:
|
||||
- $(packcc_verbose)$(PACKCC) -i \"general.h\" -o $(top_builddir)/peg/$(*F) "$<"
|
||||
-.peg.h:
|
||||
- $(packcc_verbose)$(PACKCC) -i \"general.h\" -o $(top_builddir)/peg/$(*F) "$<"
|
||||
-# You cannot use $(PACKCC) as a target name here.
|
||||
-$(PEG_SRCS) $(PEG_HEADS): $(PACKCC) Makefile
|
||||
+.peg.c: packcc$(EXEEXT)
|
||||
+ $(top_builddir)/packcc$(EXEEXT) -i \"general.h\" -o $(top_builddir)/peg/$(*F) "$<"
|
||||
+.peg.h: packcc$(EXEEXT)
|
||||
+ $(top_builddir)/packcc$(EXEEXT) -i \"general.h\" -o $(top_builddir)/peg/$(*F) "$<"
|
||||
+
|
||||
+$(PEG_SRCS) $(PEG_HEADS): packcc$(EXEEXT)
|
||||
dist_libctags_a_SOURCES = $(ALL_LIB_HEADS) $(ALL_LIB_SRCS)
|
||||
|
||||
ctags_CPPFLAGS = $(libctags_a_CPPFLAGS)
|
||||
diff -up ctags-p5.9.20210307.0/configure.ac.orig ctags-p5.9.20210307.0/configure.ac
|
||||
--- ctags-p5.9.20210307.0/configure.ac.orig 2021-03-11 15:32:28.016218560 +0100
|
||||
+++ ctags-p5.9.20210307.0/configure.ac 2021-03-11 15:32:35.686908229 +0100
|
||||
@@ -239,7 +239,6 @@ AM_CONDITIONAL(ENABLE_DEBUGGING, [test "
|
||||
# -------------------
|
||||
|
||||
AC_PROG_CC
|
||||
-AC_PROG_CC_C99
|
||||
AC_PROG_RANLIB
|
||||
AC_C_BIGENDIAN
|
||||
|
10
ctags.spec
10
ctags.spec
@ -1,15 +1,13 @@
|
||||
%define upstreamversion 20210509.0
|
||||
%define upstreamversion 20210725.0
|
||||
|
||||
Summary: A C programming language indexing and/or cross-reference tool
|
||||
Name: ctags
|
||||
Version: 5.9
|
||||
Release: 0.2.%{upstreamversion}%{?dist}
|
||||
Release: 1.%{upstreamversion}%{?dist}
|
||||
License: GPLv2+
|
||||
URL: https://ctags.io/
|
||||
Source0: https://github.com/universal-ctags/ctags/archive/%{name}-p%{version}.%{upstreamversion}.tar.gz
|
||||
|
||||
Patch0: ctags-p5.9.20210307.0-build.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: gcc
|
||||
@ -59,12 +57,16 @@ Install ctags if you are going to use your system for C programming.
|
||||
%license COPYING
|
||||
%doc README.md
|
||||
%{_bindir}/%{name}
|
||||
%{_bindir}/optscript
|
||||
%{_bindir}/readtags
|
||||
%{_mandir}/man1/*
|
||||
%{_mandir}/man5/*
|
||||
%{_mandir}/man7/*
|
||||
|
||||
%changelog
|
||||
* Tue Jul 27 2021 Than Ngo <than@redhat.com> - 5.9-1.20210725.0
|
||||
- update to p5.9-20210725
|
||||
|
||||
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 5.9-0.2.20210509.0
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ctags-p5.9.20210509.0.tar.gz) = e2a6b29025bc6bc3c689328a2eccf2268f84ffc41c1963977e448d72879ffa29f392d9d745aae13f4091689957985f78c51fc891fadd6d7947186b29305fa487
|
||||
SHA512 (ctags-p5.9.20210725.0.tar.gz) = dabdd7fee7484ae042fa409f78423750f170280fc3c60e61f8d784a97d7b5d5b22b1f2173cd252d69868309a3c91aad82857163117c463378a4bd7e7f7c2015c
|
||||
|
Loading…
Reference in New Issue
Block a user