Update cscope to 15.9-26 from Fedora
Fix signal handling at exit. Add emacs-nw and emacs-gtk+x11 to supported emacs flavors. Minor edits in the rpm scripts. Make xemacs a bcond. Resolves: RHEL-65464 Signed-off-by: Vladis Dronov <vdronov@redhat.com>
This commit is contained in:
parent
0f7014a8ca
commit
b8463d40c8
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
/cscope-15.9.tar.gz
|
/cscope-*.tar.gz
|
||||||
|
31
cscope.spec
31
cscope.spec
@ -1,14 +1,20 @@
|
|||||||
|
%if !0%{?rhel} && 0%{?fedora} < 36
|
||||||
|
%bcond_without xemacs
|
||||||
|
%else
|
||||||
|
%bcond_with xemacs
|
||||||
|
%endif
|
||||||
|
|
||||||
Summary: C source code tree search and browse tool
|
Summary: C source code tree search and browse tool
|
||||||
Name: cscope
|
Name: cscope
|
||||||
Version: 15.9
|
Version: 15.9
|
||||||
Release: 25%{?dist}
|
Release: 26%{?dist}
|
||||||
Source0: https://downloads.sourceforge.net/project/%{name}/%{name}/v%{version}/%{name}-%{version}.tar.gz
|
Source0: https://downloads.sourceforge.net/project/%{name}/%{name}/v%{version}/%{name}-%{version}.tar.gz
|
||||||
URL: http://cscope.sourceforge.net
|
URL: http://cscope.sourceforge.net
|
||||||
License: BSD-3-Clause AND GPL-2.0-or-later
|
License: BSD-3-Clause AND GPL-2.0-or-later
|
||||||
BuildRequires: pkgconf-pkg-config ncurses-devel gcc flex bison m4
|
BuildRequires: pkgconf-pkg-config ncurses-devel gcc flex bison m4
|
||||||
BuildRequires: autoconf automake make
|
BuildRequires: autoconf automake make
|
||||||
Requires: emacs-filesystem coreutils ed
|
Requires: emacs-filesystem coreutils ed
|
||||||
%if !0%{?rhel} && 0%{?fedora} < 36
|
%if %{with xemacs}
|
||||||
Requires: xemacs-filesystem
|
Requires: xemacs-filesystem
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -29,9 +35,10 @@ Patch11: dist-1-coverity-fixes.patch
|
|||||||
Patch12: dist-2-cscope-indexer-help.patch
|
Patch12: dist-2-cscope-indexer-help.patch
|
||||||
Patch13: dist-3-add-selftests.patch
|
Patch13: dist-3-add-selftests.patch
|
||||||
Patch14: dist-4-fix-printf.patch
|
Patch14: dist-4-fix-printf.patch
|
||||||
|
Patch15: dist-5-fix-signal-handler.patch
|
||||||
|
|
||||||
%define cscope_share_path %{_datadir}/cscope
|
%define cscope_share_path %{_datadir}/cscope
|
||||||
%if !0%{?rhel} && 0%{?fedora} < 36
|
%if %{with xemacs}
|
||||||
%define xemacs_lisp_path %{_datadir}/xemacs/site-packages/lisp
|
%define xemacs_lisp_path %{_datadir}/xemacs/site-packages/lisp
|
||||||
%else
|
%else
|
||||||
%define xemacs_lisp_path %nil
|
%define xemacs_lisp_path %nil
|
||||||
@ -83,24 +90,24 @@ make check
|
|||||||
%dir /var/lib/cs
|
%dir /var/lib/cs
|
||||||
%doc AUTHORS COPYING ChangeLog README TODO contrib/cctree.txt
|
%doc AUTHORS COPYING ChangeLog README TODO contrib/cctree.txt
|
||||||
|
|
||||||
%if !0%{?rhel} && 0%{?fedora} < 36
|
%if %{with xemacs}
|
||||||
%triggerin -- xemacs
|
%triggerin -- xemacs
|
||||||
ln -sf %{cscope_share_path}/xcscope.el %{xemacs_lisp_path}/xcscope.el
|
ln -sf %{cscope_share_path}/xcscope.el %{xemacs_lisp_path}/xcscope.el
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%triggerin -- emacs, emacs-nox, emacs-lucid
|
%triggerin -- emacs, emacs-nw, emacs-lucid, emacs-gtk+x11
|
||||||
ln -sf %{cscope_share_path}/xcscope.el %{emacs_lisp_path}/xcscope.el
|
ln -sf %{cscope_share_path}/xcscope.el %{emacs_lisp_path}/xcscope.el
|
||||||
|
|
||||||
%triggerin -- vim-filesystem
|
%triggerin -- vim-filesystem
|
||||||
ln -sf %{cscope_share_path}/cctree.vim %{vim_plugin_path}/cctree.vim
|
ln -sf %{cscope_share_path}/cctree.vim %{vim_plugin_path}/cctree.vim
|
||||||
|
|
||||||
%if !0%{?rhel} && 0%{?fedora} < 36
|
%if %{with xemacs}
|
||||||
%triggerun -- xemacs
|
%triggerun -- xemacs
|
||||||
[ $2 -gt 0 ] && exit 0
|
[ $2 -gt 0 ] && exit 0
|
||||||
rm -f %{xemacs_lisp_path}/xcscope.el
|
rm -f %{xemacs_lisp_path}/xcscope.el
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%triggerun -- emacs, emacs-nox, emacs-lucid
|
%triggerun -- emacs, emacs-nw, emacs-lucid, emacs-gtk+x11
|
||||||
[ $2 -gt 0 ] && exit 0
|
[ $2 -gt 0 ] && exit 0
|
||||||
rm -f %{emacs_lisp_path}/xcscope.el
|
rm -f %{emacs_lisp_path}/xcscope.el
|
||||||
|
|
||||||
@ -109,9 +116,15 @@ rm -f %{emacs_lisp_path}/xcscope.el
|
|||||||
rm -f %{vim_plugin_path}/cctree.vim
|
rm -f %{vim_plugin_path}/cctree.vim
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 31 2024 Vladis Dronov <vdronov@redhat.com> - 15.9-26
|
||||||
|
- Update cscope to 15.9-26 from Fedora (RHEL-65464)
|
||||||
|
- Fix signal handling at exit
|
||||||
|
- Add emacs-nw and emacs-gtk+x11 to supported emacs flavors
|
||||||
|
- Minor edits in the rpm scripts
|
||||||
|
- Make xemacs a bcond
|
||||||
|
|
||||||
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 15.9-25
|
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 15.9-25
|
||||||
- Bump release for October 2024 mass rebuild:
|
- Bump release for October 2024 mass rebuild (RHEL-64018)
|
||||||
Resolves: RHEL-64018
|
|
||||||
|
|
||||||
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 15.9-24
|
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 15.9-24
|
||||||
- Bump release for June 2024 mass rebuild
|
- Bump release for June 2024 mass rebuild
|
||||||
|
23
dist-5-fix-signal-handler.patch
Normal file
23
dist-5-fix-signal-handler.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff -up ./src/main.c.orig ./src/main.c
|
||||||
|
--- ./src/main.c.orig 2024-08-04 16:49:08.723525637 +0200
|
||||||
|
+++ ./src/main.c 2024-08-04 16:53:19.967862016 +0200
|
||||||
|
@@ -1056,11 +1056,18 @@ Please see the manpage for more informat
|
||||||
|
void
|
||||||
|
myexit(int sig)
|
||||||
|
{
|
||||||
|
+ /* reset signal handlers to default ones, so myexit() is not called
|
||||||
|
+ * recursively as a signal handler during a normal exit */
|
||||||
|
+ signal(SIGINT, SIG_DFL);
|
||||||
|
+ signal(SIGQUIT, SIG_DFL);
|
||||||
|
+ signal(SIGHUP, SIG_DFL);
|
||||||
|
+ signal(SIGTERM, SIG_DFL);
|
||||||
|
+
|
||||||
|
/* HBB 20010313; close file before unlinking it. Unix may not care
|
||||||
|
* about that, but DOS absolutely needs it */
|
||||||
|
if (refsfound != NULL)
|
||||||
|
fclose(refsfound);
|
||||||
|
-
|
||||||
|
+
|
||||||
|
/* remove any temporary files */
|
||||||
|
if (temp1[0] != '\0') {
|
||||||
|
unlink(temp1);
|
Loading…
Reference in New Issue
Block a user