crun/134.patch
Jindrich Novy 1d9c886738 link crun with embedded yajl statically in RHEL10
Resolves: RHEL-35583

Signed-off-by: Jindrich Novy <jnovy@redhat.com>
2024-05-09 13:57:57 +02:00

29 lines
1.2 KiB
Diff

diff -up crun-1.15/libocispec/configure.ac.orig crun-1.15/libocispec/configure.ac
--- crun-1.15/libocispec/configure.ac.orig 2022-11-07 11:11:00.000000000 +0100
+++ crun-1.15/libocispec/configure.ac 2024-05-09 10:41:12.308679633 +0200
@@ -25,7 +25,10 @@ case "${enableval}" in
esac],[embedded_yajl=false])
AM_CONDITIONAL([HAVE_EMBEDDED_YAJL], [test x"$embedded_yajl" = xtrue])
-AM_COND_IF([HAVE_EMBEDDED_YAJL], [], [PKG_CHECK_MODULES([YAJL], [yajl >= 2.1.0])])
+AM_COND_IF([HAVE_EMBEDDED_YAJL], [], [
+AC_SEARCH_LIBS(yajl_tree_get, [yajl], [AC_DEFINE([HAVE_YAJL], 1, [Define if libyajl is available])], [AC_MSG_ERROR([*** libyajl headers not found])])
+PKG_CHECK_MODULES([YAJL], [yajl >= 2.0.0])
+])
# Optionally install the library.
AC_ARG_ENABLE(libocispec-install,
diff -up crun-1.15/libocispec/Makefile.am.orig crun-1.15/libocispec/Makefile.am
--- crun-1.15/libocispec/Makefile.am.orig 2023-04-13 21:08:30.000000000 +0200
+++ crun-1.15/libocispec/Makefile.am 2024-05-09 10:41:12.308679633 +0200
@@ -256,7 +256,8 @@ EXTRA_DIST = autogen.sh \
runtime-spec \
image-spec \
src/ocispec/json_common.h \
- src/ocispec/json_common.c
+ src/ocispec/json_common.c \
+ yajl/src
sync:
(cd image-spec; git pull https://github.com/opencontainers/image-spec)