44 lines
1.5 KiB
Diff
44 lines
1.5 KiB
Diff
From 320a7ec41342c95fd6bdc500cd207eb0ea5cda6a Mon Sep 17 00:00:00 2001
|
|
From: Giuseppe Scrivano <gscrivan@redhat.com>
|
|
Date: Fri, 19 Feb 2021 13:25:37 +0100
|
|
Subject: [PATCH] Revert "tests: build init always statically"
|
|
|
|
This reverts commit a0f322a49a10a014a447b505eda5923a8e6aff7c as it
|
|
causes issues on RHEL 8.
|
|
|
|
Signed-off-by: Giuseppe Scrivano <gscrivan@redhat.com>
|
|
---
|
|
Makefile.am | 8 ++++----
|
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index e39dc3b..2b8e18b 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -14,7 +14,7 @@ srpm: dist-gzip rpm/crun.spec
|
|
$(MAKE) -C $(WD) dist-gzip
|
|
rpmbuild -bs --define "_sourcedir $(WD)" --define "_specdir $(WD)" --define "_builddir $(WD)" --define "_srcrpmdir $(WD)" --define "_rpmdir $(WD)" --define "_buildrootdir $(WD)/.build" rpm/crun.spec
|
|
|
|
-CLEANFILES = crun.spec tests/init
|
|
+CLEANFILES = crun.spec
|
|
|
|
lib_LTLIBRARIES = libcrun.la
|
|
|
|
@@ -79,9 +79,9 @@ noinst_PROGRAMS = tests/init $(UNIT_TESTS)
|
|
|
|
TESTS_LDADD = libcrun_testing.a $(FOUND_LIBS)
|
|
|
|
-tests/init: tests/init.c
|
|
- $(CC) -static-libgcc --static -o $@ $<
|
|
-EXTRA_DIST += tests/init.c
|
|
+tests_init_LDADD =
|
|
+tests_init_LDFLAGS = -static-libgcc -all-static
|
|
+tests_init_SOURCES = tests/init.c $(UNIT_TESTS)
|
|
|
|
tests_tests_libcrun_utils_CFLAGS = -I $(abs_top_builddir)/libocispec/src -I $(abs_top_srcdir)/libocispec/src -I $(abs_top_builddir)/src -I $(abs_top_srcdir)/src
|
|
tests_tests_libcrun_utils_SOURCES = tests/tests_libcrun_utils.c
|
|
--
|
|
2.29.2
|
|
|
|
|