import crun-0.18-2.module+el8.4.0+10614+dd38312c
This commit is contained in:
commit
38bb6a7516
1
.crun.metadata
Normal file
1
.crun.metadata
Normal file
@ -0,0 +1 @@
|
||||
c79a414d0b980611ba929a7526b7b4c30c2b3b1d SOURCES/crun-0.18.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/crun-0.18.tar.gz
|
43
SOURCES/0001-revert-tests-build-init-always-statically.patch
Normal file
43
SOURCES/0001-revert-tests-build-init-always-statically.patch
Normal file
@ -0,0 +1,43 @@
|
||||
From 320a7ec41342c95fd6bdc500cd207eb0ea5cda6a Mon Sep 17 00:00:00 2001
|
||||
From: Giuseppe Scrivano <gscrivan@redhat.com>
|
||||
Date: Fri, 19 Feb 2021 13:25:37 +0100
|
||||
Subject: [PATCH] Revert "tests: build init always statically"
|
||||
|
||||
This reverts commit a0f322a49a10a014a447b505eda5923a8e6aff7c as it
|
||||
causes issues on RHEL 8.
|
||||
|
||||
Signed-off-by: Giuseppe Scrivano <gscrivan@redhat.com>
|
||||
---
|
||||
Makefile.am | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index e39dc3b..2b8e18b 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -14,7 +14,7 @@ srpm: dist-gzip rpm/crun.spec
|
||||
$(MAKE) -C $(WD) dist-gzip
|
||||
rpmbuild -bs --define "_sourcedir $(WD)" --define "_specdir $(WD)" --define "_builddir $(WD)" --define "_srcrpmdir $(WD)" --define "_rpmdir $(WD)" --define "_buildrootdir $(WD)/.build" rpm/crun.spec
|
||||
|
||||
-CLEANFILES = crun.spec tests/init
|
||||
+CLEANFILES = crun.spec
|
||||
|
||||
lib_LTLIBRARIES = libcrun.la
|
||||
|
||||
@@ -79,9 +79,9 @@ noinst_PROGRAMS = tests/init $(UNIT_TESTS)
|
||||
|
||||
TESTS_LDADD = libcrun_testing.a $(FOUND_LIBS)
|
||||
|
||||
-tests/init: tests/init.c
|
||||
- $(CC) -static-libgcc --static -o $@ $<
|
||||
-EXTRA_DIST += tests/init.c
|
||||
+tests_init_LDADD =
|
||||
+tests_init_LDFLAGS = -static-libgcc -all-static
|
||||
+tests_init_SOURCES = tests/init.c $(UNIT_TESTS)
|
||||
|
||||
tests_tests_libcrun_utils_CFLAGS = -I $(abs_top_builddir)/libocispec/src -I $(abs_top_srcdir)/libocispec/src -I $(abs_top_builddir)/src -I $(abs_top_srcdir)/src
|
||||
tests_tests_libcrun_utils_SOURCES = tests/tests_libcrun_utils.c
|
||||
--
|
||||
2.29.2
|
||||
|
||||
|
95
SPECS/crun.spec
Normal file
95
SPECS/crun.spec
Normal file
@ -0,0 +1,95 @@
|
||||
Summary: OCI runtime written in C
|
||||
Name: crun
|
||||
Version: 0.18
|
||||
Release: 2%{?dist}
|
||||
Source0: https://github.com/containers/%{name}/releases/download/%{version}/%{name}-%{version}.tar.gz
|
||||
Patch0: 0001-revert-tests-build-init-always-statically.patch
|
||||
License: GPLv2+
|
||||
URL: https://github.com/containers/crun
|
||||
# https://fedoraproject.org/wiki/PackagingDrafts/Go#Go_Language_Architectures
|
||||
ExclusiveArch: %{go_arches}
|
||||
# We always run autogen.sh
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: gcc
|
||||
BuildRequires: python3
|
||||
BuildRequires: git
|
||||
BuildRequires: libcap-devel
|
||||
BuildRequires: systemd-devel
|
||||
BuildRequires: yajl-devel
|
||||
BuildRequires: libseccomp-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: python3-libmount
|
||||
BuildRequires: libtool
|
||||
BuildRequires: go-md2man
|
||||
Provides: oci-runtime = 2
|
||||
|
||||
%description
|
||||
crun is a runtime for running OCI containers
|
||||
|
||||
%prep
|
||||
%autosetup -Sgit -n %{name}-%{version}
|
||||
|
||||
%build
|
||||
export CFLAGS="%{optflags} -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
|
||||
./autogen.sh
|
||||
%configure --disable-silent-rules
|
||||
|
||||
%make_build
|
||||
|
||||
%install
|
||||
%make_install
|
||||
rm -rf $RPM_BUILD_ROOT/usr/lib*
|
||||
|
||||
%files
|
||||
%license COPYING
|
||||
%{_bindir}/%{name}
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Fri Feb 19 2021 Jindrich Novy <jnovy@redhat.com> - 0.18-2
|
||||
- allow to build without glibc-static (thanks to Giuseppe Scrivano)
|
||||
- Related: #1883490
|
||||
|
||||
* Fri Feb 19 2021 Jindrich Novy <jnovy@redhat.com> - 0.18-1
|
||||
- update to https://github.com/containers/crun/releases/tag/0.18
|
||||
- Related: #1883490
|
||||
|
||||
* Fri Jan 22 2021 Jindrich Novy <jnovy@redhat.com> - 0.17-1
|
||||
- update to https://github.com/containers/crun/releases/tag/0.17
|
||||
- Related: #1883490
|
||||
|
||||
* Thu Dec 03 2020 Jindrich Novy <jnovy@redhat.com> - 0.16-2
|
||||
- exclude i686 because of build failures
|
||||
- Related: #1883490
|
||||
|
||||
* Wed Nov 25 2020 Jindrich Novy <jnovy@redhat.com> - 0.16-1
|
||||
- update to https://github.com/containers/crun/releases/tag/0.16
|
||||
- Related: #1883490
|
||||
|
||||
* Wed Nov 04 2020 Jindrich Novy <jnovy@redhat.com> - 0.15.1-1
|
||||
- update to https://github.com/containers/crun/releases/tag/0.15.1
|
||||
- Related: #1883490
|
||||
|
||||
* Thu Oct 29 2020 Jindrich Novy <jnovy@redhat.com> - 0.15-2
|
||||
- synchronize with stream-container-tools-rhel8
|
||||
- Related: #1883490
|
||||
|
||||
* Wed Oct 21 2020 Jindrich Novy <jnovy@redhat.com> - 0.15-1
|
||||
- synchronize with stream-container-tools-rhel8
|
||||
- Related: #1883490
|
||||
|
||||
* Tue Aug 11 2020 Jindrich Novy <jnovy@redhat.com> - 0.14.1-2
|
||||
- use proper CFLAGS
|
||||
- Related: #1821193
|
||||
|
||||
* Wed Jul 08 2020 Jindrich Novy <jnovy@redhat.com> - 0.14.1-1
|
||||
- update to https://github.com/containers/crun/releases/tag/v0.14.1
|
||||
- Related: #1821193
|
||||
|
||||
* Thu Jul 02 2020 Jindrich Novy <jnovy@redhat.com> - 0.14-1
|
||||
- update to https://github.com/containers/crun/releases/tag/v0.14
|
||||
- Related: #1821193
|
||||
|
||||
* Tue Jun 16 2020 Giuseppe Scrivano <gscrivan@redhat.com> - 0.13-1
|
||||
- initial import
|
Loading…
Reference in New Issue
Block a user