import crun-0.18-1.module+el8.4.0+10607+f4da7515
This commit is contained in:
parent
67c08f8673
commit
142a9745c8
@ -1 +1 @@
|
|||||||
1df743f7da59aa3d8b9e057d4dae1618a7f1e7a8 SOURCES/crun-0.16.tar.gz
|
c79a414d0b980611ba929a7526b7b4c30c2b3b1d SOURCES/crun-0.18.tar.gz
|
||||||
|
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/crun-0.16.tar.gz
|
SOURCES/crun-0.18.tar.gz
|
||||||
|
43
SOURCES/0001-revert-tests-build-init-always-statically.patch
Normal file
43
SOURCES/0001-revert-tests-build-init-always-statically.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
From 320a7ec41342c95fd6bdc500cd207eb0ea5cda6a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Giuseppe Scrivano <gscrivan@redhat.com>
|
||||||
|
Date: Fri, 19 Feb 2021 13:25:37 +0100
|
||||||
|
Subject: [PATCH] Revert "tests: build init always statically"
|
||||||
|
|
||||||
|
This reverts commit a0f322a49a10a014a447b505eda5923a8e6aff7c as it
|
||||||
|
causes issues on RHEL 8.
|
||||||
|
|
||||||
|
Signed-off-by: Giuseppe Scrivano <gscrivan@redhat.com>
|
||||||
|
---
|
||||||
|
Makefile.am | 8 ++++----
|
||||||
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
|
index e39dc3b..2b8e18b 100644
|
||||||
|
--- a/Makefile.am
|
||||||
|
+++ b/Makefile.am
|
||||||
|
@@ -14,7 +14,7 @@ srpm: dist-gzip rpm/crun.spec
|
||||||
|
$(MAKE) -C $(WD) dist-gzip
|
||||||
|
rpmbuild -bs --define "_sourcedir $(WD)" --define "_specdir $(WD)" --define "_builddir $(WD)" --define "_srcrpmdir $(WD)" --define "_rpmdir $(WD)" --define "_buildrootdir $(WD)/.build" rpm/crun.spec
|
||||||
|
|
||||||
|
-CLEANFILES = crun.spec tests/init
|
||||||
|
+CLEANFILES = crun.spec
|
||||||
|
|
||||||
|
lib_LTLIBRARIES = libcrun.la
|
||||||
|
|
||||||
|
@@ -79,9 +79,9 @@ noinst_PROGRAMS = tests/init $(UNIT_TESTS)
|
||||||
|
|
||||||
|
TESTS_LDADD = libcrun_testing.a $(FOUND_LIBS)
|
||||||
|
|
||||||
|
-tests/init: tests/init.c
|
||||||
|
- $(CC) -static-libgcc --static -o $@ $<
|
||||||
|
-EXTRA_DIST += tests/init.c
|
||||||
|
+tests_init_LDADD =
|
||||||
|
+tests_init_LDFLAGS = -static-libgcc -all-static
|
||||||
|
+tests_init_SOURCES = tests/init.c $(UNIT_TESTS)
|
||||||
|
|
||||||
|
tests_tests_libcrun_utils_CFLAGS = -I $(abs_top_builddir)/libocispec/src -I $(abs_top_srcdir)/libocispec/src -I $(abs_top_builddir)/src -I $(abs_top_srcdir)/src
|
||||||
|
tests_tests_libcrun_utils_SOURCES = tests/tests_libcrun_utils.c
|
||||||
|
--
|
||||||
|
2.29.2
|
||||||
|
|
||||||
|
|
@ -1,12 +1,13 @@
|
|||||||
Summary: OCI runtime written in C
|
Summary: OCI runtime written in C
|
||||||
Name: crun
|
Name: crun
|
||||||
Version: 0.16
|
Version: 0.18
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Source0: https://github.com/containers/crun/releases/download/%{version}/%{name}-%{version}.tar.gz
|
Source0: https://github.com/containers/%{name}/releases/download/%{version}/%{name}-%{version}.tar.gz
|
||||||
|
Patch0: 0001-revert-tests-build-init-always-statically.patch
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: https://github.com/containers/crun
|
URL: https://github.com/containers/crun
|
||||||
# build fails on i686 with: No matching package to install: 'go-md2man'
|
# https://fedoraproject.org/wiki/PackagingDrafts/Go#Go_Language_Architectures
|
||||||
ExcludeArch: i686
|
ExclusiveArch: %{go_arches}
|
||||||
# We always run autogen.sh
|
# We always run autogen.sh
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
@ -27,7 +28,7 @@ Provides: oci-runtime = 2
|
|||||||
crun is a runtime for running OCI containers
|
crun is a runtime for running OCI containers
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -p1 -n %{name}-%{version}
|
%autosetup -Sgit -n %{name}-%{version}
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS="%{optflags} -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
|
export CFLAGS="%{optflags} -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
|
||||||
@ -46,26 +47,41 @@ rm -rf $RPM_BUILD_ROOT/usr/lib*
|
|||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 19 2021 Jindrich Novy <jnovy@redhat.com> - 0.18-1
|
||||||
|
- allow to build without glibc-static (thanks to Giuseppe Scrivano)
|
||||||
|
- Related: #1883490
|
||||||
|
|
||||||
|
* Fri Feb 19 2021 Jindrich Novy <jnovy@redhat.com> - 0.17-2
|
||||||
|
- reverting back to 0.17 as there's no glibc-static in RHEL
|
||||||
|
- Related: #1883490
|
||||||
|
|
||||||
|
* Fri Feb 19 2021 Jindrich Novy <jnovy@redhat.com> - 0.18-1
|
||||||
|
- update to https://github.com/containers/crun/releases/tag/0.18
|
||||||
|
- Related: #1883490
|
||||||
|
|
||||||
|
* Fri Jan 22 2021 Jindrich Novy <jnovy@redhat.com> - 0.17-1
|
||||||
|
- update to https://github.com/containers/crun/releases/tag/0.17
|
||||||
|
- Related: #1883490
|
||||||
|
|
||||||
* Thu Dec 03 2020 Jindrich Novy <jnovy@redhat.com> - 0.16-2
|
* Thu Dec 03 2020 Jindrich Novy <jnovy@redhat.com> - 0.16-2
|
||||||
- exclude i686 because of build failures
|
- exclude i686 because of build failures
|
||||||
- Related: #1888571
|
- Related: #1883490
|
||||||
|
|
||||||
* Wed Nov 25 2020 Jindrich Novy <jnovy@redhat.com> - 0.16-1
|
* Wed Nov 25 2020 Jindrich Novy <jnovy@redhat.com> - 0.16-1
|
||||||
- update to https://github.com/containers/crun/releases/tag/0.16
|
- update to https://github.com/containers/crun/releases/tag/0.16
|
||||||
- Related: #1888571
|
- Related: #1883490
|
||||||
|
|
||||||
* Wed Nov 04 2020 Jindrich Novy <jnovy@redhat.com> - 0.15.1-1
|
* Wed Nov 04 2020 Jindrich Novy <jnovy@redhat.com> - 0.15.1-1
|
||||||
- update to https://github.com/containers/crun/releases/tag/0.15.1
|
- update to https://github.com/containers/crun/releases/tag/0.15.1
|
||||||
- Related: #1888571
|
- Related: #1883490
|
||||||
|
|
||||||
* Thu Oct 29 2020 Jindrich Novy <jnovy@redhat.com> - 0.15-2
|
* Thu Oct 29 2020 Jindrich Novy <jnovy@redhat.com> - 0.15-2
|
||||||
- backport "exec: check read bytes from sync" (gscrivan@redhat.com)
|
- synchronize with stream-container-tools-rhel8
|
||||||
(https://github.com/containers/crun/issues/511)
|
- Related: #1883490
|
||||||
- Related: #1888571
|
|
||||||
|
|
||||||
* Thu Oct 22 2020 Jindrich Novy <jnovy@redhat.com> - 0.15-1
|
* Wed Oct 21 2020 Jindrich Novy <jnovy@redhat.com> - 0.15-1
|
||||||
- synchronize with stream-container-tools-rhel8-rhel-8.4.0
|
- synchronize with stream-container-tools-rhel8
|
||||||
- Related: #1888571
|
- Related: #1883490
|
||||||
|
|
||||||
* Tue Aug 11 2020 Jindrich Novy <jnovy@redhat.com> - 0.14.1-2
|
* Tue Aug 11 2020 Jindrich Novy <jnovy@redhat.com> - 0.14.1-2
|
||||||
- use proper CFLAGS
|
- use proper CFLAGS
|
||||||
|
Loading…
Reference in New Issue
Block a user