- update to new release
This commit is contained in:
parent
a48fd477f3
commit
424974e332
@ -1 +1 @@
|
|||||||
cronie-1.4.3.tar.gz
|
cronie-1.4.4.tar.gz
|
||||||
|
14
DSO.patch
14
DSO.patch
@ -1,14 +0,0 @@
|
|||||||
diff -up cronie-1.4.3/configure.ac.old cronie-1.4.3/configure.ac
|
|
||||||
--- cronie-1.4.3/configure.ac.old 2009-11-03 14:26:51.000000000 +0100
|
|
||||||
+++ cronie-1.4.3/configure.ac 2010-02-15 10:50:38.000000000 +0100
|
|
||||||
@@ -208,8 +208,9 @@ AC_ARG_WITH(audit,
|
|
||||||
[ if test "x$withval" != "xno" ; then
|
|
||||||
saved_LIBS="$LIBS"
|
|
||||||
AC_DEFINE(WITH_AUDIT,1,[Define if you want Audit trails.])
|
|
||||||
- SELINUX_MSG="yes"
|
|
||||||
AC_CHECK_HEADER([libaudit.h], ,AC_MSG_ERROR(Audit trails requires libaudit.h header))
|
|
||||||
+ AC_CHECK_LIB(audit, audit_open, [ LIBAUDIT="-laudit" ],
|
|
||||||
+ AC_MSG_ERROR(Audit support needs audit libraries.))
|
|
||||||
LIBS="$saved_LIBS $LIBAUDIT"
|
|
||||||
AC_SUBST(LIBAUDIT)
|
|
||||||
fi ]
|
|
@ -1,8 +0,0 @@
|
|||||||
diff -up cronie-1.4.3/pam/crond.ppp cronie-1.4.3/pam/crond
|
|
||||||
--- cronie-1.4.3/pam/crond.ppp 2009-09-25 08:23:18.000000000 +0200
|
|
||||||
+++ cronie-1.4.3/pam/crond 2009-11-05 16:34:06.000000000 +0100
|
|
||||||
@@ -7,3 +7,4 @@ account required pam_access.so
|
|
||||||
account include password-auth
|
|
||||||
session required pam_loginuid.so
|
|
||||||
session include password-auth
|
|
||||||
+auth include password-auth
|
|
@ -1,44 +0,0 @@
|
|||||||
diff -up cronie-1.4.3/src/security.c.old cronie-1.4.3/src/security.c
|
|
||||||
--- cronie-1.4.3/src/security.c.old 2009-09-25 08:23:18.000000000 +0200
|
|
||||||
+++ cronie-1.4.3/src/security.c 2009-11-05 16:43:13.000000000 +0100
|
|
||||||
@@ -486,9 +486,37 @@ void free_security_context(security_cont
|
|
||||||
|
|
||||||
int crontab_security_access(void) {
|
|
||||||
#ifdef WITH_SELINUX
|
|
||||||
- if (is_selinux_enabled() > 0)
|
|
||||||
- if (selinux_check_passwd_access(PASSWD__CRONTAB) != 0)
|
|
||||||
- return -1;
|
|
||||||
+ int selinux_check_passwd_access = -1;
|
|
||||||
+ if (is_selinux_enabled() > 0) {
|
|
||||||
+ security_context_t user_context;
|
|
||||||
+ if (getprevcon_raw(&user_context) == 0) {
|
|
||||||
+ security_class_t passwd_class;
|
|
||||||
+ struct av_decision avd;
|
|
||||||
+ int retval;
|
|
||||||
+
|
|
||||||
+ passwd_class = string_to_security_class("passwd");
|
|
||||||
+ if (passwd_class == 0) {
|
|
||||||
+ selinux_check_passwd_access = -1;
|
|
||||||
+ fprintf(stderr, "Security class \"passwd\" is not defined in the SELinux policy.\n");
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ retval = security_compute_av_raw(user_context,
|
|
||||||
+ user_context,
|
|
||||||
+ passwd_class,
|
|
||||||
+ PASSWD__CRONTAB,
|
|
||||||
+ &avd);
|
|
||||||
+
|
|
||||||
+ if ((retval == 0) && ((PASSWD__CRONTAB & avd.allowed) == PASSWD__CRONTAB)) {
|
|
||||||
+ selinux_check_passwd_access = 0;
|
|
||||||
+ }
|
|
||||||
+ freecon(user_context);
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ if (selinux_check_passwd_access != 0 && security_getenforce() == 0)
|
|
||||||
+ selinux_check_passwd_access = 0;
|
|
||||||
+
|
|
||||||
+ return selinux_check_passwd_access;
|
|
||||||
+ }
|
|
||||||
#endif
|
|
||||||
return 0;
|
|
||||||
}
|
|
13
cronie.spec
13
cronie.spec
@ -5,15 +5,12 @@
|
|||||||
|
|
||||||
Summary: Cron daemon for executing programs at set times
|
Summary: Cron daemon for executing programs at set times
|
||||||
Name: cronie
|
Name: cronie
|
||||||
Version: 1.4.3
|
Version: 1.4.4
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT and BSD and ISC and GPLv2
|
License: MIT and BSD and ISC and GPLv2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: https://fedorahosted.org/cronie
|
URL: https://fedorahosted.org/cronie
|
||||||
Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
|
Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
|
||||||
Patch0: cronie-selinux_passwd.patch
|
|
||||||
Patch1: cronie-pam.patch
|
|
||||||
Patch2: DSO.patch
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Requires: syslog, bash >= 2.0
|
Requires: syslog, bash >= 2.0
|
||||||
@ -75,9 +72,6 @@ Old style of {hourly,daily,weekly,monthly}.jobs without anacron. No features.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1 -b .old
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -200,6 +194,9 @@ cp -a /var/lock/subsys/crond /var/lock/subsys/cronie > /dev/null 2>&1 ||:
|
|||||||
%attr(0644,root,root) %{_sysconfdir}/cron.d/dailyjobs
|
%attr(0644,root,root) %{_sysconfdir}/cron.d/dailyjobs
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 19 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.4-1
|
||||||
|
- update to new release
|
||||||
|
|
||||||
* Mon Feb 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-3
|
* Mon Feb 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-3
|
||||||
- 564894 FTBFS DSOLinking
|
- 564894 FTBFS DSOLinking
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user