- explicitly include required headers from <packer.h> (#228698)
This commit is contained in:
parent
51f83e3c3c
commit
ba4b99c4b0
64
cracklib-2.8.9-inttypes.patch
Normal file
64
cracklib-2.8.9-inttypes.patch
Normal file
@ -0,0 +1,64 @@
|
||||
--- cracklib-2.8.9/configure.in 2006-02-17 14:49:12.000000000 -0500
|
||||
+++ cracklib-2.8.9/configure.in 2007-03-12 18:47:32.000000000 -0400
|
||||
@@ -23,6 +23,19 @@
|
||||
AC_CHECK_HEADERS(stdint.h)
|
||||
AC_CHECK_HEADERS(pthread.h)
|
||||
|
||||
+if test x$ac_cv_header_inttypes_h = xyes ; then
|
||||
+ CRACKLIB_INTEGER_TYPES1="#include <inttypes.h>"
|
||||
+ CRACKLIB_INTEGER_TYPES2=
|
||||
+elif test x$ac_cv_header_stdint_h = xyes ; then
|
||||
+ CRACKLIB_INTEGER_TYPES1="#include <stdint.h>"
|
||||
+ CRACKLIB_INTEGER_TYPES2=
|
||||
+else
|
||||
+ CRACKLIB_INTEGER_TYPES1="typedef unsigned int uint32_t;"
|
||||
+ CRACKLIB_INTEGER_TYPES2="typedef unsigned short uint16_t;"
|
||||
+fi
|
||||
+AC_SUBST(CRACKLIB_INTEGER_TYPES1)
|
||||
+AC_SUBST(CRACKLIB_INTEGER_TYPES2)
|
||||
+
|
||||
dnl Cygwin workaround
|
||||
AC_MSG_CHECKING(if LINE_MAX is defined)
|
||||
AC_EGREP_CPP(yes,
|
||||
@@ -87,6 +100,7 @@
|
||||
dnl Handle local dict compiling properly
|
||||
AC_SUBST(CROSS_COMPILING, $cross_compiling)
|
||||
|
||||
-AC_OUTPUT(util/Makefile lib/Makefile doc/Makefile python/Makefile Makefile \
|
||||
- po/Makefile.in m4/Makefile cracklib.spec)
|
||||
+AC_CONFIG_FILES(util/Makefile lib/Makefile doc/Makefile python/Makefile \
|
||||
+ Makefile po/Makefile.in m4/Makefile cracklib.spec lib/packer.h)
|
||||
+AC_OUTPUT
|
||||
|
||||
--- cracklib-2.8.9/lib/packer.h.in 2007-03-12 18:47:32.000000000 -0400
|
||||
+++ cracklib-2.8.9/lib/packer.h.in 2007-03-12 18:49:50.000000000 -0400
|
||||
@@ -32,17 +32,8 @@
|
||||
#define _(String) (String)
|
||||
#endif
|
||||
|
||||
-#if defined(HAVE_INTTYPES_H)
|
||||
-#include <inttypes.h>
|
||||
-#else
|
||||
-#if defined(HAVE_STDINT_H)
|
||||
-#include <stdint.h>
|
||||
-#else
|
||||
-typedef unsigned int uint32_t;
|
||||
-typedef unsigned short uint16_t;
|
||||
-#endif
|
||||
-#endif
|
||||
-
|
||||
+@CRACKLIB_INTEGER_TYPES1@
|
||||
+@CRACKLIB_INTEGER_TYPES2@
|
||||
|
||||
struct pi_header
|
||||
{
|
||||
@@ -84,6 +75,9 @@
|
||||
int dummy;
|
||||
} PWDICT;
|
||||
|
||||
+@CRACKLIB_INTEGER_TYPES1@
|
||||
+@CRACKLIB_INTEGER_TYPES2@
|
||||
+
|
||||
#endif
|
||||
|
||||
extern PWDICT *PWOpen(const char *prefix, char *mode);
|
Loading…
Reference in New Issue
Block a user