Don't depend on a consumer of <packer.h> to be using autoconf, and to be

checking for for the presence of <inttypes.h> and <stdint.h>, and
    including its own "config.h" before including <packer.h>, in order for
    this to be correct on 64-bit machines.
This commit is contained in:
Nalin Dahyabhai 2009-12-01 20:54:54 +00:00
parent 58eccb4e44
commit 61e8450d7a

View File

@ -2,9 +2,10 @@ Don't depend on a consumer of <packer.h> to be using autoconf, and to be
checking for for the presence of <inttypes.h> and <stdint.h>, and including
its own "config.h" before including <packer.h>, in order for this to be
correct on 64-bit machines.
diff -up cracklib-2.8.13/configure.in cracklib-2.8.13/configure.in
--- cracklib-2.8.13/configure.in 2008-09-23 07:53:24.000000000 -0400
+++ cracklib-2.8.13/configure.in 2008-10-28 13:39:08.000000000 -0400
diff -up cracklib-2.8.15/configure.in cracklib-2.8.15/configure.in
--- cracklib-2.8.15/configure.in 2009-11-18 18:58:21.000000000 -0500
+++ cracklib-2.8.15/configure.in 2009-12-01 15:16:35.000000000 -0500
@@ -26,6 +26,19 @@ AC_CHECK_HEADERS(zlib.h, AC_DEFINE(HAVE_
AC_SEARCH_LIBS(gzopen, z)
@ -25,20 +26,16 @@ diff -up cracklib-2.8.13/configure.in cracklib-2.8.13/configure.in
dnl Cygwin workaround
AC_MSG_CHECKING(if LINE_MAX is defined)
AC_EGREP_CPP(yes,
@@ -90,6 +103,8 @@ AM_CONDITIONAL(BUILD_PYTHON,[test "$buil
dnl Handle local dict compiling properly
AC_SUBST(CROSS_COMPILING, $cross_compiling)
@@ -92,5 +105,6 @@ AC_SUBST(CROSS_COMPILING, $cross_compili
-AC_OUTPUT(util/Makefile lib/Makefile doc/Makefile python/Makefile Makefile \
- po/Makefile.in m4/Makefile dicts/Makefile cracklib.spec)
+AC_CONFIG_FILES(util/Makefile lib/Makefile doc/Makefile python/Makefile \
+ Makefile po/Makefile.in m4/Makefile dicts/Makefile \
+ cracklib.spec lib/packer.h)
+AC_OUTPUT
AC_OUTPUT(util/Makefile lib/Makefile doc/Makefile python/Makefile Makefile \
python/setup.py \
+ lib/packer.h \
po/Makefile.in m4/Makefile dicts/Makefile cracklib.spec)
diff -up cracklib-2.8.13/lib/packer.h.in cracklib-2.8.13/lib/packer.h.in
--- cracklib-2.8.13/lib/packer.h.in 2008-10-28 13:38:25.000000000 -0400
+++ cracklib-2.8.13/lib/packer.h.in 2008-10-28 13:38:25.000000000 -0400
diff -up cracklib-2.8.15/lib/packer.h.in cracklib-2.8.15/lib/packer.h.in
--- cracklib-2.8.15/lib/packer.h.in 2009-12-01 15:15:38.000000000 -0500
+++ cracklib-2.8.15/lib/packer.h.in 2009-12-01 15:15:38.000000000 -0500
@@ -30,17 +30,8 @@
#define _(String) (String)
#endif