switch to new upstream
This commit is contained in:
parent
b28290392f
commit
b8f63c4263
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
cppunit-1.12.1.tar.gz
|
cppunit-1.12.1.tar.gz
|
||||||
cppunit-1.12.1.tar.gz
|
cppunit-1.12.1.tar.gz
|
||||||
|
cppunit-1.13.2.tar.gz
|
||||||
|
28
0001-Update-FSF-address-in-LGPL-license.patch
Normal file
28
0001-Update-FSF-address-in-LGPL-license.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
From 1cebdfc97b39961c2df68e84996f667d529eafc7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Thorsten Behrens <tbehrens@suse.com>
|
||||||
|
Date: Tue, 12 Nov 2013 08:59:19 +0100
|
||||||
|
Subject: [PATCH] Update FSF address in LGPL license.
|
||||||
|
|
||||||
|
Since rpmlint was bitching, and indeed
|
||||||
|
http://www.gnu.org/licenses/old-licenses/lgpl-2.1.txt features a
|
||||||
|
new address.
|
||||||
|
---
|
||||||
|
COPYING | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/COPYING b/COPYING
|
||||||
|
index b1e3f5a..0a41847 100644
|
||||||
|
--- a/COPYING
|
||||||
|
+++ b/COPYING
|
||||||
|
@@ -2,7 +2,7 @@
|
||||||
|
Version 2.1, February 1999
|
||||||
|
|
||||||
|
Copyright (C) 1991, 1999 Free Software Foundation, Inc.
|
||||||
|
- 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||||
|
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
|
||||||
|
Everyone is permitted to copy and distribute verbatim copies
|
||||||
|
of this license document, but changing it is not allowed.
|
||||||
|
|
||||||
|
--
|
||||||
|
2.5.0
|
||||||
|
|
@ -1,24 +0,0 @@
|
|||||||
--- cppunit-1.12.1/include/cppunit/Message.h 2010-10-08 14:02:26.514477964 +0200
|
|
||||||
+++ cppunit-1.12.1/include/cppunit/Message.h 2010-10-08 14:02:15.411948098 +0200
|
|
||||||
@@ -57,6 +57,8 @@ public:
|
|
||||||
const std::string &detail2,
|
|
||||||
const std::string &detail3 );
|
|
||||||
|
|
||||||
+ ~Message();
|
|
||||||
+
|
|
||||||
Message &operator =( const Message &other );
|
|
||||||
|
|
||||||
/*! \brief Returns the short description.
|
|
||||||
--- cppunit-1.12.1/src/cppunit/Message.cpp 2010-10-08 14:02:39.421768852 +0200
|
|
||||||
+++ cppunit-1.12.1/src/cppunit/Message.cpp 2010-10-08 14:02:54.066829633 +0200
|
|
||||||
@@ -47,6 +47,10 @@ Message::Message( const std::string &sho
|
|
||||||
addDetail( detail1, detail2, detail3 );
|
|
||||||
}
|
|
||||||
|
|
||||||
+Message::~Message()
|
|
||||||
+{
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
Message &
|
|
||||||
Message::operator =( const Message &other )
|
|
||||||
{
|
|
@ -1,22 +0,0 @@
|
|||||||
--- cppunit-1.12.1/include/cppunit/plugin/TestPlugIn.h 2007-01-12 05:54:34.000000000 +0100
|
|
||||||
+++ cppunit-1.12.1/include/cppunit/plugin/TestPlugIn.h 2009-12-02 15:33:29.639857272 +0100
|
|
||||||
@@ -151,9 +151,7 @@
|
|
||||||
#include <windows.h>
|
|
||||||
#endif
|
|
||||||
#define CPPUNIT_PLUGIN_IMPLEMENT_MAIN() \
|
|
||||||
- BOOL APIENTRY DllMain( HANDLE hModule, \
|
|
||||||
- DWORD ul_reason_for_call, \
|
|
||||||
- LPVOID lpReserved ) \
|
|
||||||
+ BOOL APIENTRY DllMain( HANDLE, DWORD, LPVOID ) \
|
|
||||||
{ \
|
|
||||||
return TRUE; \
|
|
||||||
} \
|
|
||||||
@@ -162,7 +160,7 @@
|
|
||||||
// Unix
|
|
||||||
#elif defined(CPPUNIT_HAVE_UNIX_DLL_LOADER) || defined(CPPUNIT_HAVE_UNIX_SHL_LOADER)
|
|
||||||
#define CPPUNIT_PLUGIN_IMPLEMENT_MAIN() \
|
|
||||||
- int main( int argc, char *argv[] ) \
|
|
||||||
+ int main( int, char *[] ) \
|
|
||||||
{ \
|
|
||||||
return 0; \
|
|
||||||
} \
|
|
25
cppunit.spec
25
cppunit.spec
@ -1,17 +1,14 @@
|
|||||||
Name: cppunit
|
Name: cppunit
|
||||||
Version: 1.12.1
|
Version: 1.13.2
|
||||||
Release: 17%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
Summary: C++ unit testing framework
|
Summary: C++ unit testing framework
|
||||||
# no license in files
|
# no license in files
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Url: http://cppunit.sourceforge.net/
|
Url: https://www.freedesktop.org/wiki/Software/cppunit/
|
||||||
Source: http://downloads.sourceforge.net/cppunit/cppunit-%{version}.tar.gz
|
Source: http://dev-www.libreoffice.org/src/%{name}-%{version}.tar.gz
|
||||||
Patch0: cppunit-1.12.0-nolibdir.patch
|
Patch0: cppunit-1.12.0-nolibdir.patch
|
||||||
Patch1: cppunit-msg.patch
|
Patch1: 0001-Update-FSF-address-in-LGPL-license.patch
|
||||||
#https://sourceforge.net/tracker/?func=detail&aid=2912630&group_id=11795&atid=311795
|
|
||||||
Patch2: cppunit-warnings-sf2912630.patch
|
|
||||||
Patch3: cppunit-aarch64.patch
|
|
||||||
|
|
||||||
BuildRequires: doxygen, graphviz
|
BuildRequires: doxygen, graphviz
|
||||||
|
|
||||||
@ -39,25 +36,22 @@ the popular doxygen documentation generation tool.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .nolibdir
|
%patch0 -p1 -b .nolibdir
|
||||||
|
%patch1 -p1 -b .fsf-address
|
||||||
for file in THANKS ChangeLog NEWS; do
|
for file in THANKS ChangeLog NEWS; do
|
||||||
iconv -f latin1 -t utf8 < $file > ${file}.utf8
|
iconv -f latin1 -t utf8 < $file > ${file}.utf8
|
||||||
touch -c -r $file ${file}.utf8
|
touch -c -r $file ${file}.utf8
|
||||||
mv ${file}.utf8 $file
|
mv ${file}.utf8 $file
|
||||||
done
|
done
|
||||||
%patch1 -p1 -b .nomsg
|
|
||||||
%patch2 -p1 -b .warnings-sf2912630
|
|
||||||
%patch3 -p1 -b .aarch64
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export LDFLAGS=-ldl
|
%configure --enable-doxygen --disable-static --disable-silent-rules
|
||||||
%configure --enable-doxygen --disable-static
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
|
make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
|
||||||
rm $RPM_BUILD_ROOT%{_libdir}/*.la
|
rm $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||||
# remove double of doc
|
# remove double of doc
|
||||||
rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/cppunit
|
rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/cppunit $RPM_BUILD_ROOT%{_datadir}/%{name}/html
|
||||||
|
|
||||||
# ensure that timestamp of cppunit-config is the same for all arches
|
# ensure that timestamp of cppunit-config is the same for all arches
|
||||||
touch -c -r cppunit-config.in.nolibdir $RPM_BUILD_ROOT%{_bindir}/cppunit-config
|
touch -c -r cppunit-config.in.nolibdir $RPM_BUILD_ROOT%{_bindir}/cppunit-config
|
||||||
@ -96,6 +90,9 @@ mv __dist-examples __dist-examples-dir/examples
|
|||||||
%doc doc/html
|
%doc doc/html
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Feb 13 2016 David Tardon <dtardon@redhat.com> - 1.13.2-1
|
||||||
|
- switch to new upstream
|
||||||
|
|
||||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.1-17
|
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.1-17
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user