- remove libdir reference to cppunit-config, should fix multiarch conflict

(#340951)
- fix encoding and remove windows related files in examples
This commit is contained in:
pertusus 2007-10-21 10:13:31 +00:00
parent dcf0684335
commit 8c7ba060db
2 changed files with 37 additions and 8 deletions

View File

@ -0,0 +1,13 @@
diff -up cppunit-1.12.0/cppunit-config.in.nolibdir cppunit-1.12.0/cppunit-config.in
--- cppunit-1.12.0/cppunit-config.in.nolibdir 2007-10-21 11:19:40.000000000 +0200
+++ cppunit-1.12.0/cppunit-config.in 2007-10-21 11:20:01.000000000 +0200
@@ -87,9 +87,6 @@ if test "$echo_cflags" = "yes"; then
fi
if test "$echo_libs" = "yes"; then
- if test @libdir@ != /usr/lib ; then
- my_linker_flags="-L@libdir@"
- fi
echo ${my_linker_flags} -lcppunit @LIBADD_DL@
fi

View File

@ -3,10 +3,12 @@ Version: 1.12.0
Release: 3%{?dist} Release: 3%{?dist}
Summary: C++ unit testing framework Summary: C++ unit testing framework
License: LGPL # no license in files
License: LGPLv2+
Group: Development/Libraries Group: Development/Libraries
Url: http://cppunit.sourceforge.net/ Url: http://cppunit.sourceforge.net/
Source: http://download.sf.net/cppunit/cppunit-%{version}.tar.gz Source: http://download.sf.net/cppunit/cppunit-%{version}.tar.gz
Patch0: cppunit-1.12.0-nolibdir.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: doxygen, graphviz BuildRequires: doxygen, graphviz
@ -36,6 +38,14 @@ the popular doxygen documentation generation tool.
%prep %prep
%setup -q %setup -q
%patch0 -p1 -b .nolibdir
for file in THANKS ChangeLog NEWS; do
touch -r $file __timestamp_$file
iconv -f latin1 -t utf8 < $file > ${file}.utf8
mv ${file}.utf8 $file
touch -r __timestamp_$file $file
rm __timestamp_$file
done
%build %build
%configure --enable-doxygen --disable-static %configure --enable-doxygen --disable-static
@ -49,13 +59,14 @@ rm $RPM_BUILD_ROOT%{_libdir}/*.la
rm -rf $RPM_BUILD_ROOT%{_datadir}/cppunit rm -rf $RPM_BUILD_ROOT%{_datadir}/cppunit
# clean up examples # clean up examples
rm -rf dist-examples dist-examples-dir rm -rf __dist-examples __dist-examples-dir
cp -a examples dist-examples cp -a examples __dist-examples
make -C dist-examples distclean make -C __dist-examples distclean
# Makefile.am files are left as documentation # Makefile.am files are left as documentation
find dist-examples \( -name Makefile.in -o -name .cvsignore \) -exec rm {} \; find __dist-examples \( -name Makefile.in -o -name .cvsignore -o -name '*.dsw' -o -name '*.dsp' \) -exec rm {} \;
mkdir dist-examples-dir chmod a-x __dist-examples/qt/run.bat
mv dist-examples dist-examples-dir/examples mkdir __dist-examples-dir
mv __dist-examples __dist-examples-dir/examples
%clean %clean
rm -rf $RPM_BUILD_ROOT rm -rf $RPM_BUILD_ROOT
@ -81,10 +92,15 @@ rm -rf $RPM_BUILD_ROOT
%files doc %files doc
%defattr(-,root,root,-) %defattr(-,root,root,-)
%doc dist-examples-dir/examples/ %doc __dist-examples-dir/examples/
%doc doc/html/ %doc doc/html/
%changelog %changelog
* Mon Jan 29 2007 Patrice Dumas <pertusus@free.fr> 1.12.0-3
- remove libdir reference to cppunit-config, should fix multiarch conflict
(#340951)
- fix encoding and remove windows related files in examples
* Mon Jan 29 2007 Patrice Dumas <pertusus@free.fr> 1.12.0-3 * Mon Jan 29 2007 Patrice Dumas <pertusus@free.fr> 1.12.0-3
- add rightly files to -devel (#224106) - add rightly files to -devel (#224106)
- add necessary requires for -devel (#224106) - add necessary requires for -devel (#224106)