Update to 1.79.
This commit is contained in:
parent
7d543feafe
commit
dd7b18f9a5
1
.gitignore
vendored
1
.gitignore
vendored
@ -30,3 +30,4 @@ cppcheck-1.44.tar.bz2
|
|||||||
/cppcheck-1.75.tar.bz2
|
/cppcheck-1.75.tar.bz2
|
||||||
/cppcheck-1.77.tar.bz2
|
/cppcheck-1.77.tar.bz2
|
||||||
/cppcheck-1.78.tar.bz2
|
/cppcheck-1.78.tar.bz2
|
||||||
|
/cppcheck-1.79.tar.bz2
|
||||||
|
@ -1,6 +1,18 @@
|
|||||||
diff -up cppcheck-1.75/gui/translationhandler.cpp.translations cppcheck-1.75/gui/translationhandler.cpp
|
diff -up cppcheck-1.79/gui/CMakeLists.txt.translations cppcheck-1.79/gui/CMakeLists.txt
|
||||||
--- cppcheck-1.75/gui/translationhandler.cpp.translations 2016-08-06 18:49:40.000000000 +0200
|
--- cppcheck-1.79/gui/CMakeLists.txt.translations 2017-05-18 05:09:44.643624491 +0200
|
||||||
+++ cppcheck-1.75/gui/translationhandler.cpp 2016-08-09 06:46:30.207146245 +0200
|
+++ cppcheck-1.79/gui/CMakeLists.txt 2017-05-18 05:09:44.651624352 +0200
|
||||||
|
@@ -29,7 +29,7 @@ if (BUILD_GUI)
|
||||||
|
target_link_libraries(cppcheck-gui tinyxml2)
|
||||||
|
|
||||||
|
install(TARGETS cppcheck-gui RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
|
||||||
|
- install(FILES ${qms} DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
|
||||||
|
+ install(FILES ${qms} DESTINATION share/${PROJECT_NAME}/lang/ COMPONENT applications)
|
||||||
|
|
||||||
|
install(FILES cppcheck-gui.desktop DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/applications)
|
||||||
|
|
||||||
|
diff -up cppcheck-1.79/gui/translationhandler.cpp.translations cppcheck-1.79/gui/translationhandler.cpp
|
||||||
|
--- cppcheck-1.79/gui/translationhandler.cpp.translations 2017-05-18 05:09:44.649624387 +0200
|
||||||
|
+++ cppcheck-1.79/gui/translationhandler.cpp 2017-05-18 05:14:16.716915424 +0200
|
||||||
@@ -116,15 +116,7 @@ bool TranslationHandler::SetLanguage(con
|
@@ -116,15 +116,7 @@ bool TranslationHandler::SetLanguage(con
|
||||||
if (datadir.isEmpty())
|
if (datadir.isEmpty())
|
||||||
datadir = appPath;
|
datadir = appPath;
|
||||||
@ -17,15 +29,4 @@ diff -up cppcheck-1.75/gui/translationhandler.cpp.translations cppcheck-1.75/gui
|
|||||||
+ QString translationFile("/usr/share/CppCheck/lang/" + mTranslations[index].mFilename + ".qm");
|
+ QString translationFile("/usr/share/CppCheck/lang/" + mTranslations[index].mFilename + ".qm");
|
||||||
|
|
||||||
if (!mTranslator->load(translationFile) && !failure) {
|
if (!mTranslator->load(translationFile) && !failure) {
|
||||||
translationFile += ".qm";
|
//If it failed, lets check if the default file exists
|
||||||
--- cppcheck-1.77/gui/CMakeLists.txt.orig 2017-01-31 12:51:02.798598710 -0600
|
|
||||||
+++ cppcheck-1.77/gui/CMakeLists.txt 2017-01-31 12:51:50.049356022 -0600
|
|
||||||
@@ -29,7 +29,7 @@
|
|
||||||
target_link_libraries(cppcheck-gui tinyxml2)
|
|
||||||
|
|
||||||
install(TARGETS cppcheck-gui RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
|
|
||||||
- install(FILES ${qms} DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
|
|
||||||
+ install(FILES ${qms} DESTINATION share/${PROJECT_NAME}/lang/ COMPONENT applications)
|
|
||||||
|
|
||||||
install(FILES cppcheck-gui.desktop DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/applications)
|
|
||||||
|
|
@ -1,5 +1,5 @@
|
|||||||
Name: cppcheck
|
Name: cppcheck
|
||||||
Version: 1.78
|
Version: 1.79
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Tool for static C/C++ code analysis
|
Summary: Tool for static C/C++ code analysis
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -11,7 +11,7 @@ BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
|||||||
# Use system tinyxml2
|
# Use system tinyxml2
|
||||||
Patch0: cppcheck-1.77-tinyxml.patch
|
Patch0: cppcheck-1.77-tinyxml.patch
|
||||||
# Fix location of translations
|
# Fix location of translations
|
||||||
Patch1: cppcheck-1.77-translations.patch
|
Patch1: cppcheck-1.79-translations.patch
|
||||||
# Set location of config files
|
# Set location of config files
|
||||||
Patch2: cppcheck-1.78-cfgdir.patch
|
Patch2: cppcheck-1.78-cfgdir.patch
|
||||||
|
|
||||||
@ -94,6 +94,9 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 17 2017 Susi Lehtola <jussilehtola@fedoraproject.org> - 1.79-1
|
||||||
|
- Update to 1.79.
|
||||||
|
|
||||||
* Sun Apr 09 2017 Susi Lehtola <jussilehtola@fedoraproject.org> - 1.78-1
|
* Sun Apr 09 2017 Susi Lehtola <jussilehtola@fedoraproject.org> - 1.78-1
|
||||||
- Make cppcheck able to find its configs once again (bug 1427788).
|
- Make cppcheck able to find its configs once again (bug 1427788).
|
||||||
- Update to 1.78.
|
- Update to 1.78.
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (cppcheck-1.78.tar.bz2) = 598556e9d657a3a77ff889cb6647291160017f7f9322326771416ff59d44126ce47c39767657b863cdb8a1b46d7c83bb337ec2fe0574500b37e99c33377b5dd8
|
SHA512 (cppcheck-1.79.tar.bz2) = 766649b685d60b057752a49eda46f5bb42681c01c32169e83f85ea6f5d3302b572a2d484c1cee1380fd304489d5a32f83eb59a72ceefb1b787031e84bf3a2676
|
||||||
|
Loading…
Reference in New Issue
Block a user