parent
2fd9c1984d
commit
dc3a190b2f
1
.gitignore
vendored
1
.gitignore
vendored
@ -53,4 +53,3 @@ cppcheck-1.44.tar.bz2
|
||||
/cppcheck-2.8.tar.gz
|
||||
/cppcheck-2.8.2.tar.gz
|
||||
/cppcheck-2.9.tar.gz
|
||||
/cppcheck-2.10.tar.gz
|
||||
|
27
cppcheck-1.88-htmlreport-python3.patch
Normal file
27
cppcheck-1.88-htmlreport-python3.patch
Normal file
@ -0,0 +1,27 @@
|
||||
diff -up cppcheck-1.88/htmlreport/cppcheck-htmlreport.python3 cppcheck-1.88/htmlreport/cppcheck-htmlreport
|
||||
--- cppcheck-1.88/htmlreport/cppcheck-htmlreport.python3 2019-06-29 09:51:25.000000000 +0200
|
||||
+++ cppcheck-1.88/htmlreport/cppcheck-htmlreport 2019-08-14 11:02:23.791627296 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/python3
|
||||
|
||||
from __future__ import unicode_literals
|
||||
|
||||
diff -up cppcheck-1.88/htmlreport/setup.py.python3 cppcheck-1.88/htmlreport/setup.py
|
||||
--- cppcheck-1.88/htmlreport/setup.py.python3 2019-06-29 09:51:25.000000000 +0200
|
||||
+++ cppcheck-1.88/htmlreport/setup.py 2019-08-14 11:02:28.570423533 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/python3
|
||||
|
||||
from setuptools import setup
|
||||
|
||||
diff -up cppcheck-1.88/htmlreport/test_htmlreport.py.python3 cppcheck-1.88/htmlreport/test_htmlreport.py
|
||||
--- cppcheck-1.88/htmlreport/test_htmlreport.py.python3 2019-06-29 09:51:25.000000000 +0200
|
||||
+++ cppcheck-1.88/htmlreport/test_htmlreport.py 2019-08-14 11:02:20.296776345 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/python3
|
||||
"""Test cppcheck-htmlreport."""
|
||||
|
||||
import os
|
@ -1,8 +1,8 @@
|
||||
%undefine __cmake_in_source_build
|
||||
|
||||
Name: cppcheck
|
||||
Version: 2.10
|
||||
Release: 1%{?dist}
|
||||
Version: 2.9
|
||||
Release: 4%{?dist}
|
||||
Summary: Tool for static C/C++ code analysis
|
||||
License: GPL-3.0
|
||||
URL: http://cppcheck.wiki.sourceforge.net/
|
||||
@ -10,6 +10,8 @@ Source0: https://github.com/danmar/%{name}/archive/%{version}.tar.gz#/%{n
|
||||
|
||||
# Fix location of translations
|
||||
Patch0: cppcheck-2.2-translations.patch
|
||||
# Select python3 explicitly
|
||||
Patch1: cppcheck-1.88-htmlreport-python3.patch
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: pcre-devel
|
||||
@ -54,6 +56,7 @@ from xml files first generated using cppcheck.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .translations
|
||||
%patch1 -p1 -b .python3
|
||||
# Make sure bundled tinyxml2 is not used
|
||||
rm -r externals/tinyxml2
|
||||
# Generate the Qt online-help file
|
||||
@ -109,10 +112,6 @@ cd %{_vpath_builddir}/bin
|
||||
%{_bindir}/cppcheck-htmlreport
|
||||
|
||||
%changelog
|
||||
* Thu Feb 02 2023 Steve Grubb <sgrubb@redhat.com> - 2.10-1
|
||||
- Update to 2.10
|
||||
- Drop python3 patch as new version uses python3
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.9-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (cppcheck-2.10.tar.gz) = 1c737736a34f0c3412d43c95f07e47c10f64feb6d94bc4dde8a2468a3b3839468b31cfe94af30200fdd326e345ba6f4647c67e43705958885e24f8582abb9785
|
||||
SHA512 (cppcheck-2.9.tar.gz) = 69204a7ceac087470201482894e6422b99d0849f08641e80b2e341c9d164a1d2095e3a08a1fba2e9fa681783d07fe7277b30ea0cc0bf582431b5d13ab2f58c1f
|
||||
|
Loading…
Reference in New Issue
Block a user