Drop cmake patch.
This commit is contained in:
parent
e13f8f241c
commit
848b9ff9f1
@ -1,38 +0,0 @@
|
||||
diff -up cppcheck-1.83/cmake/findDependencies.cmake.qt5cmake cppcheck-1.83/cmake/findDependencies.cmake
|
||||
--- cppcheck-1.83/cmake/findDependencies.cmake.qt5cmake 2018-04-02 09:02:50.000000000 +0200
|
||||
+++ cppcheck-1.83/cmake/findDependencies.cmake 2018-06-02 16:50:28.656036644 +0200
|
||||
@@ -1,6 +1,8 @@
|
||||
if (BUILD_GUI)
|
||||
- set(GUI_QT_COMPONENTS Core Gui Widgets PrintSupport)
|
||||
- find_package(Qt5 COMPONENTS ${GUI_QT_COMPONENTS})
|
||||
+ find_package(Qt5Core)
|
||||
+ find_package(Qt5Gui)
|
||||
+ find_package(Qt5Widgets)
|
||||
+ find_package(Qt5PrintSupport)
|
||||
find_package(Qt5LinguistTools)
|
||||
endif()
|
||||
|
||||
diff -up cppcheck-1.83/CMakeLists.txt.qt5cmake cppcheck-1.83/CMakeLists.txt
|
||||
--- cppcheck-1.83/CMakeLists.txt.qt5cmake 2018-06-02 16:47:11.038242820 +0200
|
||||
+++ cppcheck-1.83/CMakeLists.txt 2018-06-02 16:47:11.070242301 +0200
|
||||
@@ -1,5 +1,5 @@
|
||||
project(CppCheck)
|
||||
-cmake_minimum_required(VERSION 2.8.4)
|
||||
+cmake_minimum_required(VERSION 2.8.11)
|
||||
|
||||
include(GNUInstallDirs)
|
||||
|
||||
diff -up cppcheck-1.83/gui/CMakeLists.txt.qt5cmake cppcheck-1.83/gui/CMakeLists.txt
|
||||
--- cppcheck-1.83/gui/CMakeLists.txt.qt5cmake 2018-06-02 16:47:11.049242641 +0200
|
||||
+++ cppcheck-1.83/gui/CMakeLists.txt 2018-06-02 16:47:24.622022436 +0200
|
||||
@@ -24,8 +24,8 @@ if (BUILD_GUI)
|
||||
target_link_libraries(cppcheck-gui pcre)
|
||||
endif()
|
||||
target_link_libraries(cppcheck-gui tinyxml2)
|
||||
- qt5_use_modules(cppcheck-gui ${GUI_QT_COMPONENTS})
|
||||
-
|
||||
+ target_link_libraries(cppcheck-gui Qt5::Core Qt5::Gui Qt5::Widgets Qt5::PrintSupport)
|
||||
+
|
||||
install(TARGETS cppcheck-gui RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
|
||||
install(FILES ${qms} DESTINATION share/${PROJECT_NAME}/lang/ COMPONENT applications)
|
||||
|
@ -15,8 +15,6 @@ Patch0: cppcheck-1.84-tinyxml.patch
|
||||
Patch1: cppcheck-1.84-translations.patch
|
||||
# Set location of config files
|
||||
Patch2: cppcheck-1.78-cfgdir.patch
|
||||
# Use modern qt5 cmake
|
||||
Patch3: cppcheck-1.83-cmake.patch
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: pcre-devel
|
||||
|
Loading…
Reference in New Issue
Block a user