Merge branch 'master' into epel7
This commit is contained in:
commit
38aa927041
2
.gitignore
vendored
2
.gitignore
vendored
@ -32,3 +32,5 @@ cppcheck-1.44.tar.bz2
|
||||
/cppcheck-1.78.tar.bz2
|
||||
/cppcheck-1.79.tar.bz2
|
||||
/cppcheck-1.80.tar.gz
|
||||
/cppcheck-1.81.tar.gz
|
||||
/cppcheck-1.83.tar.gz
|
||||
|
@ -1,8 +1,8 @@
|
||||
diff -up cppcheck-1.79/gui/CMakeLists.txt.translations cppcheck-1.79/gui/CMakeLists.txt
|
||||
--- cppcheck-1.79/gui/CMakeLists.txt.translations 2017-05-18 05:09:44.643624491 +0200
|
||||
+++ cppcheck-1.79/gui/CMakeLists.txt 2017-05-18 05:09:44.651624352 +0200
|
||||
@@ -29,7 +29,7 @@ if (BUILD_GUI)
|
||||
target_link_libraries(cppcheck-gui tinyxml2)
|
||||
diff -up cppcheck-1.81/gui/CMakeLists.txt.translations cppcheck-1.81/gui/CMakeLists.txt
|
||||
--- cppcheck-1.81/gui/CMakeLists.txt.translations 2017-10-18 16:41:50.647580110 +0200
|
||||
+++ cppcheck-1.81/gui/CMakeLists.txt 2017-10-18 16:42:38.432882931 +0200
|
||||
@@ -27,7 +27,7 @@ if (BUILD_GUI)
|
||||
qt5_use_modules(cppcheck-gui ${GUI_QT_COMPONENTS})
|
||||
|
||||
install(TARGETS cppcheck-gui RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
|
||||
- install(FILES ${qms} DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
|
||||
@ -10,10 +10,10 @@ diff -up cppcheck-1.79/gui/CMakeLists.txt.translations cppcheck-1.79/gui/CMakeLi
|
||||
|
||||
install(FILES cppcheck-gui.desktop DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/applications)
|
||||
|
||||
diff -up cppcheck-1.79/gui/translationhandler.cpp.translations cppcheck-1.79/gui/translationhandler.cpp
|
||||
--- cppcheck-1.79/gui/translationhandler.cpp.translations 2017-05-18 05:09:44.649624387 +0200
|
||||
+++ cppcheck-1.79/gui/translationhandler.cpp 2017-05-18 05:14:16.716915424 +0200
|
||||
@@ -116,15 +116,7 @@ bool TranslationHandler::SetLanguage(con
|
||||
diff -up cppcheck-1.81/gui/translationhandler.cpp.translations cppcheck-1.81/gui/translationhandler.cpp
|
||||
--- cppcheck-1.81/gui/translationhandler.cpp.translations 2017-10-07 23:11:39.000000000 +0200
|
||||
+++ cppcheck-1.81/gui/translationhandler.cpp 2017-10-18 16:41:50.649580081 +0200
|
||||
@@ -116,15 +116,7 @@ bool TranslationHandler::setLanguage(con
|
||||
if (datadir.isEmpty())
|
||||
datadir = appPath;
|
||||
|
@ -1,13 +1,12 @@
|
||||
diff -up cppcheck-1.75/cli/CMakeLists.txt.tinyxml cppcheck-1.75/cli/CMakeLists.txt
|
||||
--- cppcheck-1.75/cli/CMakeLists.txt.tinyxml 2016-08-09 06:43:08.152146498 +0200
|
||||
+++ cppcheck-1.75/cli/CMakeLists.txt 2016-08-09 06:44:12.819146690 +0200
|
||||
--- cppcheck-1.83.orig/cli/CMakeLists.txt 2018-04-02 03:02:50.000000000 -0400
|
||||
+++ cppcheck-1.83.orig/cli/CMakeLists.txt 2018-04-12 12:46:04.990212969 -0400
|
||||
@@ -1,5 +1,4 @@
|
||||
include_directories(${PROJECT_SOURCE_DIR}/lib/)
|
||||
-include_directories(SYSTEM ${PROJECT_SOURCE_DIR}/externals/tinyxml/)
|
||||
include_directories(${PROJECT_SOURCE_DIR}/externals/simplecpp/)
|
||||
|
||||
file(GLOB hdrs "*.h")
|
||||
@@ -8,10 +7,11 @@ file(GLOB mainfile "main.cpp")
|
||||
@@ -8,13 +7,14 @@
|
||||
list(REMOVE_ITEM srcs ${mainfile})
|
||||
|
||||
add_library(cli_objs OBJECT ${hdrs} ${srcs})
|
||||
@ -16,14 +15,16 @@ diff -up cppcheck-1.75/cli/CMakeLists.txt.tinyxml cppcheck-1.75/cli/CMakeLists.t
|
||||
if (HAVE_RULES)
|
||||
target_link_libraries(cppcheck pcre)
|
||||
endif()
|
||||
if (MSVC)
|
||||
target_link_libraries(cppcheck Shlwapi.lib)
|
||||
endif()
|
||||
+target_link_libraries(cppcheck tinyxml2)
|
||||
|
||||
install(TARGETS cppcheck
|
||||
RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR}
|
||||
diff -up cppcheck-1.75/CMakeLists.txt.tinyxml cppcheck-1.75/CMakeLists.txt
|
||||
--- cppcheck-1.75/CMakeLists.txt.tinyxml 2016-08-09 06:43:08.153146498 +0200
|
||||
+++ cppcheck-1.75/CMakeLists.txt 2016-08-09 06:43:31.191146016 +0200
|
||||
@@ -16,7 +16,6 @@ if (BUILD_TESTS)
|
||||
--- cppcheck-1.83.orig/CMakeLists.txt 2018-04-02 03:02:50.000000000 -0400
|
||||
+++ cppcheck-1.83.orig/CMakeLists.txt 2018-04-12 12:45:04.959219411 -0400
|
||||
@@ -16,7 +16,6 @@
|
||||
enable_testing()
|
||||
endif()
|
||||
|
||||
@ -31,9 +32,31 @@ diff -up cppcheck-1.75/CMakeLists.txt.tinyxml cppcheck-1.75/CMakeLists.txt
|
||||
add_subdirectory(externals/simplecpp)
|
||||
add_subdirectory(lib) # CppCheck Library
|
||||
add_subdirectory(cli) # Client application
|
||||
diff -up cppcheck-1.75/gui/CMakeLists.txt.tinyxml cppcheck-1.75/gui/CMakeLists.txt
|
||||
--- cppcheck-1.75/test/CMakeLists.txt.tinyxml 2016-08-09 06:43:08.155146498 +0200
|
||||
+++ cppcheck-1.75/test/CMakeLists.txt 2016-08-09 06:45:26.020153572 +0200
|
||||
--- cppcheck-1.83.orig/gui/CMakeLists.txt 2018-04-02 03:02:50.000000000 -0400
|
||||
+++ cppcheck-1.83.orig/gui/CMakeLists.txt 2018-04-12 12:45:04.959219411 -0400
|
||||
@@ -10,7 +10,6 @@
|
||||
endif()
|
||||
|
||||
include_directories(${PROJECT_SOURCE_DIR}/lib/)
|
||||
- include_directories(SYSTEM ${PROJECT_SOURCE_DIR}/externals/tinyxml/)
|
||||
|
||||
file(GLOB hdrs "*.h")
|
||||
file(GLOB srcs "*.cpp")
|
||||
@@ -20,10 +19,11 @@
|
||||
QT5_ADD_RESOURCES(resources "gui.qrc")
|
||||
QT5_ADD_TRANSLATION(qms ${tss})
|
||||
|
||||
- add_executable(cppcheck-gui ${hdrs} ${srcs} ${uis_hdrs} ${resources} ${qms} $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:tinyxml_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
||||
+ add_executable(cppcheck-gui ${hdrs} ${srcs} ${uis_hdrs} ${resources} ${qms} $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
||||
if (HAVE_RULES)
|
||||
target_link_libraries(cppcheck-gui pcre)
|
||||
endif()
|
||||
+ target_link_libraries(cppcheck-gui tinyxml2)
|
||||
qt5_use_modules(cppcheck-gui ${GUI_QT_COMPONENTS})
|
||||
|
||||
install(TARGETS cppcheck-gui RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
|
||||
--- cppcheck-1.83.orig/test/CMakeLists.txt 2018-04-02 03:02:50.000000000 -0400
|
||||
+++ cppcheck-1.83.orig/test/CMakeLists.txt 2018-04-12 12:45:04.959219411 -0400
|
||||
@@ -1,16 +1,16 @@
|
||||
if (BUILD_TESTS)
|
||||
|
||||
@ -53,28 +76,3 @@ diff -up cppcheck-1.75/gui/CMakeLists.txt.tinyxml cppcheck-1.75/gui/CMakeLists.t
|
||||
|
||||
add_custom_target(copy_cfg ALL
|
||||
COMMENT "Copying cfg files")
|
||||
--- cppcheck-1.77/gui/CMakeLists.txt.orig 2017-01-31 12:46:53.394879690 -0600
|
||||
+++ cppcheck-1.77/gui/CMakeLists.txt 2017-01-31 12:47:57.626549785 -0600
|
||||
@@ -11,7 +11,6 @@
|
||||
endif()
|
||||
|
||||
include_directories(${PROJECT_SOURCE_DIR}/lib/)
|
||||
- include_directories(SYSTEM ${PROJECT_SOURCE_DIR}/externals/tinyxml/)
|
||||
|
||||
file(GLOB hdrs "*.h")
|
||||
file(GLOB srcs "*.cpp")
|
||||
@@ -21,12 +20,13 @@
|
||||
QT4_ADD_RESOURCES(resources "gui.qrc")
|
||||
QT4_ADD_TRANSLATION(qms ${tss})
|
||||
|
||||
- add_executable(cppcheck-gui ${hdrs} ${srcs} ${uis_hdrs} ${resources} ${qms} $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:tinyxml_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
||||
+ add_executable(cppcheck-gui ${hdrs} ${srcs} ${uis_hdrs} ${resources} ${qms} $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
||||
target_link_libraries(cppcheck-gui ${QT_LIBRARIES})
|
||||
if (HAVE_RULES)
|
||||
target_link_libraries(cppcheck-gui pcre)
|
||||
endif()
|
||||
|
||||
+ target_link_libraries(cppcheck-gui tinyxml2)
|
||||
|
||||
install(TARGETS cppcheck-gui RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
|
||||
install(FILES ${qms} DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
|
@ -1,25 +1,25 @@
|
||||
Name: cppcheck
|
||||
Version: 1.80
|
||||
Version: 1.83
|
||||
Release: 1%{?dist}
|
||||
Summary: Tool for static C/C++ code analysis
|
||||
Group: Development/Languages
|
||||
License: GPLv3+
|
||||
URL: http://cppcheck.wiki.sourceforge.net/
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
# Use system tinyxml2
|
||||
Patch0: cppcheck-1.77-tinyxml.patch
|
||||
Patch0: cppcheck-1.83-tinyxml.patch
|
||||
# Fix location of translations
|
||||
Patch1: cppcheck-1.79-translations.patch
|
||||
Patch1: cppcheck-1.81-translations.patch
|
||||
# Set location of config files
|
||||
Patch2: cppcheck-1.78-cfgdir.patch
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: pcre-devel
|
||||
BuildRequires: tinyxml2-devel >= 2.1.0
|
||||
BuildRequires: docbook-style-xsl
|
||||
BuildRequires: libxslt
|
||||
BuildRequires: qt4-devel
|
||||
BuildRequires: qt5-devel
|
||||
BuildRequires: cmake
|
||||
BuildRequires: desktop-file-utils
|
||||
|
||||
@ -76,9 +76,6 @@ install -D -p -m 644 gui/cppcheck-gui.png %{buildroot}%{_datadir}/pixmaps/cppche
|
||||
cd objdir-%{_target_platform}/bin
|
||||
./testrunner -g -q
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%doc AUTHORS COPYING man/manual.html
|
||||
%{_datadir}/CppCheck/
|
||||
@ -94,6 +91,24 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Apr 14 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 1.83-1
|
||||
- Update to 1.83.
|
||||
|
||||
* Wed Feb 28 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 1.81-5
|
||||
- Added gcc-c++ buildrequires.
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.81-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Tue Jan 23 2018 Björn Esser <besser82@fedoraproject.org> - 1.81-3
|
||||
- Rebuilt for tinyxml2 soname/ABI change again
|
||||
|
||||
* Tue Jan 23 2018 François Cami <fcami@fedoraproject.org> - 1.81-2
|
||||
- Rebuilt for tinyxml2 soname/ABI change
|
||||
|
||||
* Wed Oct 18 2017 Susi Lehtola <jussilehtola@fedoraproject.org> - 1.81-1
|
||||
- Update to 1.81.
|
||||
|
||||
* Tue Aug 01 2017 Gwyn Ciesla <limburgher@gmail.com> - 1.80-1
|
||||
- 1.80
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (cppcheck-1.80.tar.gz) = 3b674f54fdb9f64a2d87223439bbfdb0fc12ca3527768b2477cf4e59aa39591386efd9890dc5acae4336e86db2ef7b1efc40bc0aefe6ac9703fe5bcb8f5c6db5
|
||||
SHA512 (cppcheck-1.83.tar.gz) = 1f610c6ff73401e68c5f8ad4f6f78d754e760ca79395681fe76b1248ef596fcfd471b76482f7cce690226ed745645b03d15e3f91a6d60f58e7747d36ffda3840
|
||||
|
Loading…
Reference in New Issue
Block a user