Update to 1.73.
This commit is contained in:
parent
a56e282e6c
commit
2825eff124
1
.gitignore
vendored
1
.gitignore
vendored
@ -25,3 +25,4 @@ cppcheck-1.44.tar.bz2
|
|||||||
/cppcheck-1.68.tar.bz2
|
/cppcheck-1.68.tar.bz2
|
||||||
/cppcheck-1.70.tar.bz2
|
/cppcheck-1.70.tar.bz2
|
||||||
/cppcheck-1.71.tar.bz2
|
/cppcheck-1.71.tar.bz2
|
||||||
|
/cppcheck-1.73.tar.bz2
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
diff -up cppcheck-1.70/lib/CMakeLists.txt.orig cppcheck-1.70/lib/CMakeLists.txt
|
|
||||||
--- cppcheck-1.70/lib/CMakeLists.txt.orig 2015-09-04 11:04:31.000000000 -0700
|
|
||||||
+++ cppcheck-1.70/lib/CMakeLists.txt 2015-11-05 11:08:44.996474289 -0800
|
|
||||||
@@ -42,8 +42,8 @@ endif()
|
|
||||||
|
|
||||||
install(TARGETS ${PROJECT_NAME}
|
|
||||||
RUNTIME DESTINATION bin COMPONENT libraries
|
|
||||||
- LIBRARY DESTINATION lib PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE COMPONENT libraries
|
|
||||||
- ARCHIVE DESTINATION lib COMPONENT libraries)
|
|
||||||
+ LIBRARY DESTINATION lib${LIB_SUFFIX} PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE COMPONENT libraries
|
|
||||||
+ ARCHIVE DESTINATION lib${LIB_SUFFIX} COMPONENT libraries)
|
|
||||||
|
|
||||||
install(FILES ${hdrs}
|
|
||||||
DESTINATION include/${PROJECT_NAME}/
|
|
@ -1,22 +0,0 @@
|
|||||||
--- cppcheck-1.70/cli/CMakeLists.txt.stlink 2015-11-13 15:07:57.987502410 +0900
|
|
||||||
+++ cppcheck-1.70/cli/CMakeLists.txt 2015-11-13 16:13:30.256811541 +0900
|
|
||||||
@@ -5,7 +5,7 @@
|
|
||||||
file(GLOB mainfile "main.cpp")
|
|
||||||
list(REMOVE_ITEM srcs ${mainfile})
|
|
||||||
|
|
||||||
-link_libraries(${PROJECT_NAME} -ltinyxml2)
|
|
||||||
+link_libraries(-Wl,--whole-archive ${PROJECT_NAME} -Wl,--no-whole-archive -ltinyxml2)
|
|
||||||
|
|
||||||
add_library(cli_lib OBJECT ${hdrs} ${srcs})
|
|
||||||
|
|
||||||
--- cppcheck-1.70/gui/CMakeLists.txt.stlink 2015-11-13 15:07:57.989502413 +0900
|
|
||||||
+++ cppcheck-1.70/gui/CMakeLists.txt 2015-11-13 16:13:47.930824027 +0900
|
|
||||||
@@ -21,7 +21,7 @@
|
|
||||||
QT4_ADD_RESOURCES(resources "gui.qrc")
|
|
||||||
QT4_ADD_TRANSLATION(qms ${tss})
|
|
||||||
|
|
||||||
- link_libraries(${PROJECT_NAME} -ltinyxml2 ${QT_LIBRARIES})
|
|
||||||
+ link_libraries(-Wl,--whole-archive ${PROJECT_NAME} -Wl,--no-whole-archive -ltinyxml2 ${QT_LIBRARIES})
|
|
||||||
|
|
||||||
add_executable(cppcheck-gui ${hdrs} ${srcs} ${uis_hdrs} ${resources} ${qms})
|
|
||||||
|
|
@ -1,66 +0,0 @@
|
|||||||
diff -up cppcheck-1.70/cli/CMakeLists.txt.tinyxml cppcheck-1.70/cli/CMakeLists.txt
|
|
||||||
--- cppcheck-1.70/cli/CMakeLists.txt.tinyxml 2015-09-04 20:04:31.000000000 +0200
|
|
||||||
+++ cppcheck-1.70/cli/CMakeLists.txt 2015-11-05 18:53:51.310937488 +0100
|
|
||||||
@@ -1,4 +1,3 @@
|
|
||||||
-include_directories(SYSTEM ${PROJECT_SOURCE_DIR}/externals/tinyxml/)
|
|
||||||
include_directories(${PROJECT_SOURCE_DIR}/lib/)
|
|
||||||
|
|
||||||
file(GLOB hdrs "*.h")
|
|
||||||
@@ -6,7 +5,7 @@ file(GLOB srcs "*.cpp")
|
|
||||||
file(GLOB mainfile "main.cpp")
|
|
||||||
list(REMOVE_ITEM srcs ${mainfile})
|
|
||||||
|
|
||||||
-link_libraries(${PROJECT_NAME} tinyxml)
|
|
||||||
+link_libraries(${PROJECT_NAME} -ltinyxml2)
|
|
||||||
|
|
||||||
add_library(cli_lib OBJECT ${hdrs} ${srcs})
|
|
||||||
|
|
||||||
diff -up cppcheck-1.70/CMakeLists.txt.tinyxml cppcheck-1.70/CMakeLists.txt
|
|
||||||
--- cppcheck-1.70/CMakeLists.txt.tinyxml 2015-09-04 20:04:31.000000000 +0200
|
|
||||||
+++ cppcheck-1.70/CMakeLists.txt 2015-11-05 18:54:41.847932573 +0100
|
|
||||||
@@ -10,7 +10,6 @@ include(cmake/buildFiles.cmake REQUIRED)
|
|
||||||
|
|
||||||
file(GLOB cfgs "cfg/*.cfg")
|
|
||||||
|
|
||||||
-add_subdirectory(externals/tinyxml)
|
|
||||||
add_subdirectory(lib) # CppCheck Library
|
|
||||||
add_subdirectory(cli) # Client application
|
|
||||||
add_subdirectory(test) # Tests
|
|
||||||
diff -up cppcheck-1.70/gui/CMakeLists.txt.tinyxml cppcheck-1.70/gui/CMakeLists.txt
|
|
||||||
--- cppcheck-1.70/gui/CMakeLists.txt.tinyxml 2015-09-04 20:04:31.000000000 +0200
|
|
||||||
+++ cppcheck-1.70/gui/CMakeLists.txt 2015-11-05 18:54:32.016937559 +0100
|
|
||||||
@@ -11,7 +11,6 @@ if (BUILD_GUI)
|
|
||||||
endif()
|
|
||||||
|
|
||||||
|
|
||||||
- include_directories(SYSTEM ${PROJECT_SOURCE_DIR}/externals/tinyxml/)
|
|
||||||
include_directories(${PROJECT_SOURCE_DIR}/lib/)
|
|
||||||
|
|
||||||
file(GLOB hdrs "*.h")
|
|
||||||
@@ -22,7 +21,7 @@ if (BUILD_GUI)
|
|
||||||
QT4_ADD_RESOURCES(resources "gui.qrc")
|
|
||||||
QT4_ADD_TRANSLATION(qms ${tss})
|
|
||||||
|
|
||||||
- link_libraries(${PROJECT_NAME} tinyxml ${QT_LIBRARIES})
|
|
||||||
+ link_libraries(${PROJECT_NAME} -ltinyxml2 ${QT_LIBRARIES})
|
|
||||||
|
|
||||||
add_executable(cppcheck-gui ${hdrs} ${srcs} ${uis_hdrs} ${resources} ${qms})
|
|
||||||
|
|
||||||
diff -up cppcheck-1.70/test/CMakeLists.txt.tinyxml cppcheck-1.70/test/CMakeLists.txt
|
|
||||||
--- cppcheck-1.70/test/CMakeLists.txt.tinyxml 2015-09-04 20:04:31.000000000 +0200
|
|
||||||
+++ cppcheck-1.70/test/CMakeLists.txt 2015-11-05 18:54:08.667937833 +0100
|
|
||||||
@@ -3,13 +3,12 @@ if (BUILD_TESTS)
|
|
||||||
include_directories(
|
|
||||||
${PROJECT_SOURCE_DIR}/lib/
|
|
||||||
${PROJECT_SOURCE_DIR}/cli/
|
|
||||||
- ${PROJECT_SOURCE_DIR}/externals/tinyxml
|
|
||||||
)
|
|
||||||
|
|
||||||
file(GLOB hdrs "*.h")
|
|
||||||
file(GLOB srcs "*.cpp")
|
|
||||||
|
|
||||||
- link_libraries(${PROJECT_NAME} tinyxml)
|
|
||||||
+ link_libraries(${PROJECT_NAME} -ltinyxml2)
|
|
||||||
|
|
||||||
add_executable(testrunner ${hdrs} ${srcs}
|
|
||||||
$<TARGET_OBJECTS:cli_lib>
|
|
@ -1,32 +0,0 @@
|
|||||||
diff -up cppcheck-1.70/gui/CMakeLists.txt.translations cppcheck-1.70/gui/CMakeLists.txt
|
|
||||||
--- cppcheck-1.70/gui/CMakeLists.txt.translations 2015-11-05 11:37:19.343945331 -0800
|
|
||||||
+++ cppcheck-1.70/gui/CMakeLists.txt 2015-11-05 11:37:19.344945349 -0800
|
|
||||||
@@ -26,7 +26,7 @@ if (BUILD_GUI)
|
|
||||||
add_executable(cppcheck-gui ${hdrs} ${srcs} ${uis_hdrs} ${resources} ${qms})
|
|
||||||
|
|
||||||
install(TARGETS cppcheck-gui RUNTIME DESTINATION bin COMPONENT applications)
|
|
||||||
- install(FILES ${qms} DESTINATION bin COMPONENT applications)
|
|
||||||
+ install(FILES ${qms} DESTINATION share/${PROJECT_NAME}/lang/ COMPONENT applications)
|
|
||||||
|
|
||||||
set(CMAKE_AUTOMOC OFF)
|
|
||||||
|
|
||||||
diff -up cppcheck-1.70/gui/translationhandler.cpp.translations cppcheck-1.70/gui/translationhandler.cpp
|
|
||||||
--- cppcheck-1.70/gui/translationhandler.cpp.translations 2015-09-04 11:04:31.000000000 -0700
|
|
||||||
+++ cppcheck-1.70/gui/translationhandler.cpp 2015-11-05 11:38:34.991299374 -0800
|
|
||||||
@@ -106,15 +106,7 @@ bool TranslationHandler::SetLanguage(con
|
|
||||||
if (datadir.isEmpty())
|
|
||||||
datadir = appPath;
|
|
||||||
|
|
||||||
- QString translationFile;
|
|
||||||
- if (QFile::exists(datadir + "/lang/" + mTranslations[index].mFilename + ".qm"))
|
|
||||||
- translationFile = datadir + "/lang/" + mTranslations[index].mFilename + ".qm";
|
|
||||||
-
|
|
||||||
- else if (QFile::exists(datadir + "/" + mTranslations[index].mFilename + ".qm"))
|
|
||||||
- translationFile = datadir + "/" + mTranslations[index].mFilename + ".qm";
|
|
||||||
-
|
|
||||||
- else
|
|
||||||
- translationFile = appPath + "/" + mTranslations[index].mFilename + ".qm";
|
|
||||||
+ QString translationFile("/usr/share/CppCheck/lang/" + mTranslations[index].mFilename + ".qm");
|
|
||||||
|
|
||||||
if (!mTranslator->load(translationFile) && !failure) {
|
|
||||||
translationFile += ".qm";
|
|
34
cppcheck-1.73-link.patch
Normal file
34
cppcheck-1.73-link.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
diff -up cppcheck-1.73/cli/CMakeLists.txt.link cppcheck-1.73/cli/CMakeLists.txt
|
||||||
|
--- cppcheck-1.73/cli/CMakeLists.txt.link 2016-04-10 03:25:25.329210822 +0200
|
||||||
|
+++ cppcheck-1.73/cli/CMakeLists.txt 2016-04-10 03:26:51.813213485 +0200
|
||||||
|
@@ -11,6 +11,7 @@ if (HAVE_RULES)
|
||||||
|
target_link_libraries(cppcheck pcre)
|
||||||
|
endif()
|
||||||
|
target_link_libraries(cppcheck -ltinyxml2)
|
||||||
|
+set_target_properties(cppcheck PROPERTIES LINKER_LANGUAGE C++)
|
||||||
|
|
||||||
|
install(TARGETS cppcheck
|
||||||
|
RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR}
|
||||||
|
diff -up cppcheck-1.73/gui/CMakeLists.txt.link cppcheck-1.73/gui/CMakeLists.txt
|
||||||
|
--- cppcheck-1.73/gui/CMakeLists.txt.link 2016-04-10 03:25:25.322210822 +0200
|
||||||
|
+++ cppcheck-1.73/gui/CMakeLists.txt 2016-04-10 03:25:25.331210822 +0200
|
||||||
|
@@ -26,7 +26,7 @@ if (BUILD_GUI)
|
||||||
|
if (HAVE_RULES)
|
||||||
|
target_link_libraries(cppcheck-gui pcre)
|
||||||
|
endif()
|
||||||
|
-
|
||||||
|
+ set_target_properties(cppcheck-gui PROPERTIES LINKER_LANGUAGE C++)
|
||||||
|
|
||||||
|
install(TARGETS cppcheck-gui RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
|
||||||
|
install(FILES ${qms} DESTINATION share/${PROJECT_NAME}/lang/ COMPONENT applications)
|
||||||
|
diff -up cppcheck-1.73/test/CMakeLists.txt.link cppcheck-1.73/test/CMakeLists.txt
|
||||||
|
--- cppcheck-1.73/test/CMakeLists.txt.link 2016-04-10 03:25:25.317210822 +0200
|
||||||
|
+++ cppcheck-1.73/test/CMakeLists.txt 2016-04-10 03:25:25.333210822 +0200
|
||||||
|
@@ -10,6 +10,7 @@ if (BUILD_TESTS)
|
||||||
|
if (HAVE_RULES)
|
||||||
|
target_link_libraries(testrunner pcre)
|
||||||
|
endif()
|
||||||
|
+ set_target_properties(testrunner PROPERTIES LINKER_LANGUAGE C++)
|
||||||
|
|
||||||
|
add_custom_target(copy_cfg ALL
|
||||||
|
COMMENT "Copying cfg files")
|
73
cppcheck-1.73-tinyxml.patch
Normal file
73
cppcheck-1.73-tinyxml.patch
Normal file
@ -0,0 +1,73 @@
|
|||||||
|
diff -up cppcheck-1.73/cli/CMakeLists.txt.tinyxml cppcheck-1.73/cli/CMakeLists.txt
|
||||||
|
--- cppcheck-1.73/cli/CMakeLists.txt.tinyxml 2016-04-08 20:47:43.000000000 +0200
|
||||||
|
+++ cppcheck-1.73/cli/CMakeLists.txt 2016-04-10 03:24:45.678212832 +0200
|
||||||
|
@@ -1,5 +1,4 @@
|
||||||
|
include_directories(${PROJECT_SOURCE_DIR}/lib/)
|
||||||
|
-include_directories(SYSTEM ${PROJECT_SOURCE_DIR}/externals/tinyxml/)
|
||||||
|
|
||||||
|
file(GLOB hdrs "*.h")
|
||||||
|
file(GLOB srcs "*.cpp")
|
||||||
|
@@ -7,10 +6,11 @@ file(GLOB mainfile "main.cpp")
|
||||||
|
list(REMOVE_ITEM srcs ${mainfile})
|
||||||
|
|
||||||
|
add_library(cli_objs OBJECT ${hdrs} ${srcs})
|
||||||
|
-add_executable(cppcheck ${hdrs} ${mainfile} $<TARGET_OBJECTS:cli_objs> $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:tinyxml_objs>)
|
||||||
|
+add_executable(cppcheck ${hdrs} ${mainfile} $<TARGET_OBJECTS:cli_objs> $<TARGET_OBJECTS:lib_objs>)
|
||||||
|
if (HAVE_RULES)
|
||||||
|
target_link_libraries(cppcheck pcre)
|
||||||
|
endif()
|
||||||
|
+target_link_libraries(cppcheck -ltinyxml2)
|
||||||
|
|
||||||
|
install(TARGETS cppcheck
|
||||||
|
RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR}
|
||||||
|
diff -up cppcheck-1.73/CMakeLists.txt.tinyxml cppcheck-1.73/CMakeLists.txt
|
||||||
|
--- cppcheck-1.73/CMakeLists.txt.tinyxml 2016-04-08 20:47:43.000000000 +0200
|
||||||
|
+++ cppcheck-1.73/CMakeLists.txt 2016-04-10 03:23:36.158210959 +0200
|
||||||
|
@@ -16,7 +16,6 @@ if (BUILD_TESTS)
|
||||||
|
enable_testing()
|
||||||
|
endif()
|
||||||
|
|
||||||
|
-add_subdirectory(externals/tinyxml)
|
||||||
|
add_subdirectory(lib) # CppCheck Library
|
||||||
|
add_subdirectory(cli) # Client application
|
||||||
|
add_subdirectory(test) # Tests
|
||||||
|
diff -up cppcheck-1.73/gui/CMakeLists.txt.tinyxml cppcheck-1.73/gui/CMakeLists.txt
|
||||||
|
--- cppcheck-1.73/gui/CMakeLists.txt.tinyxml 2016-04-08 20:47:43.000000000 +0200
|
||||||
|
+++ cppcheck-1.73/gui/CMakeLists.txt 2016-04-10 03:23:36.160210959 +0200
|
||||||
|
@@ -11,7 +11,6 @@ if (BUILD_GUI)
|
||||||
|
endif()
|
||||||
|
|
||||||
|
include_directories(${PROJECT_SOURCE_DIR}/lib/)
|
||||||
|
- include_directories(SYSTEM ${PROJECT_SOURCE_DIR}/externals/tinyxml/)
|
||||||
|
|
||||||
|
file(GLOB hdrs "*.h")
|
||||||
|
file(GLOB srcs "*.cpp")
|
||||||
|
@@ -21,8 +20,9 @@ if (BUILD_GUI)
|
||||||
|
QT4_ADD_RESOURCES(resources "gui.qrc")
|
||||||
|
QT4_ADD_TRANSLATION(qms ${tss})
|
||||||
|
|
||||||
|
- add_executable(cppcheck-gui ${hdrs} ${srcs} ${uis_hdrs} ${resources} ${qms} $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:tinyxml_objs>)
|
||||||
|
+ add_executable(cppcheck-gui ${hdrs} ${srcs} ${uis_hdrs} ${resources} ${qms} $<TARGET_OBJECTS:lib_objs>)
|
||||||
|
target_link_libraries(cppcheck-gui ${QT_LIBRARIES})
|
||||||
|
+ target_link_libraries(cppcheck-gui -ltinyxml2)
|
||||||
|
if (HAVE_RULES)
|
||||||
|
target_link_libraries(cppcheck-gui pcre)
|
||||||
|
endif()
|
||||||
|
diff -up cppcheck-1.73/test/CMakeLists.txt.tinyxml cppcheck-1.73/test/CMakeLists.txt
|
||||||
|
--- cppcheck-1.73/test/CMakeLists.txt.tinyxml 2016-04-08 20:47:43.000000000 +0200
|
||||||
|
+++ cppcheck-1.73/test/CMakeLists.txt 2016-04-10 03:23:36.161210959 +0200
|
||||||
|
@@ -1,12 +1,12 @@
|
||||||
|
if (BUILD_TESTS)
|
||||||
|
|
||||||
|
include_directories(${PROJECT_SOURCE_DIR}/lib/ ${PROJECT_SOURCE_DIR}/cli/)
|
||||||
|
- include_directories(SYSTEM ${PROJECT_SOURCE_DIR}/externals/tinyxml)
|
||||||
|
|
||||||
|
file(GLOB hdrs "*.h")
|
||||||
|
file(GLOB srcs "*.cpp")
|
||||||
|
|
||||||
|
- add_executable(testrunner ${hdrs} ${srcs} $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:cli_objs> $<TARGET_OBJECTS:tinyxml_objs>)
|
||||||
|
+ add_executable(testrunner ${hdrs} ${srcs} $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:cli_objs>)
|
||||||
|
+ target_link_libraries(testrunner -ltinyxml2)
|
||||||
|
if (HAVE_RULES)
|
||||||
|
target_link_libraries(testrunner pcre)
|
||||||
|
endif()
|
32
cppcheck-1.73-translations.patch
Normal file
32
cppcheck-1.73-translations.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
diff -up cppcheck-1.73/gui/CMakeLists.txt.translations cppcheck-1.73/gui/CMakeLists.txt
|
||||||
|
--- cppcheck-1.73/gui/CMakeLists.txt.translations 2016-04-10 03:12:17.000000000 +0200
|
||||||
|
+++ cppcheck-1.73/gui/CMakeLists.txt 2016-04-10 03:13:24.959212031 +0200
|
||||||
|
@@ -29,7 +29,7 @@ if (BUILD_GUI)
|
||||||
|
|
||||||
|
|
||||||
|
install(TARGETS cppcheck-gui RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
|
||||||
|
- install(FILES ${qms} DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
|
||||||
|
+ install(FILES ${qms} DESTINATION share/${PROJECT_NAME}/lang/ COMPONENT applications)
|
||||||
|
|
||||||
|
set(CMAKE_AUTOMOC OFF)
|
||||||
|
|
||||||
|
diff -up cppcheck-1.73/gui/translationhandler.cpp.translations cppcheck-1.73/gui/translationhandler.cpp
|
||||||
|
--- cppcheck-1.73/gui/translationhandler.cpp.translations 2016-04-08 20:47:43.000000000 +0200
|
||||||
|
+++ cppcheck-1.73/gui/translationhandler.cpp 2016-04-10 03:12:17.819211809 +0200
|
||||||
|
@@ -113,15 +113,7 @@ bool TranslationHandler::SetLanguage(con
|
||||||
|
if (datadir.isEmpty())
|
||||||
|
datadir = appPath;
|
||||||
|
|
||||||
|
- QString translationFile;
|
||||||
|
- if (QFile::exists(datadir + "/lang/" + mTranslations[index].mFilename + ".qm"))
|
||||||
|
- translationFile = datadir + "/lang/" + mTranslations[index].mFilename + ".qm";
|
||||||
|
-
|
||||||
|
- else if (QFile::exists(datadir + "/" + mTranslations[index].mFilename + ".qm"))
|
||||||
|
- translationFile = datadir + "/" + mTranslations[index].mFilename + ".qm";
|
||||||
|
-
|
||||||
|
- else
|
||||||
|
- translationFile = appPath + "/" + mTranslations[index].mFilename + ".qm";
|
||||||
|
+ QString translationFile("/usr/share/CppCheck/lang/" + mTranslations[index].mFilename + ".qm");
|
||||||
|
|
||||||
|
if (!mTranslator->load(translationFile) && !failure) {
|
||||||
|
translationFile += ".qm";
|
@ -1,6 +1,6 @@
|
|||||||
Name: cppcheck
|
Name: cppcheck
|
||||||
Version: 1.71
|
Version: 1.73
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Tool for static C/C++ code analysis
|
Summary: Tool for static C/C++ code analysis
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
@ -10,13 +10,9 @@ Source1: cppcheck.desktop
|
|||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
|
|
||||||
# Use system tinyxml2
|
# Use system tinyxml2
|
||||||
Patch0: cppcheck-1.70-tinyxml.patch
|
Patch0: cppcheck-1.73-tinyxml.patch
|
||||||
# Fix location of translations
|
# Fix location of translations
|
||||||
Patch1: cppcheck-1.70-translations.patch
|
Patch1: cppcheck-1.73-translations.patch
|
||||||
# Fix library install suffix
|
|
||||||
Patch2: cppcheck-1.70-libsuffix.patch
|
|
||||||
# Link whole library
|
|
||||||
Patch3: cppcheck-1.70-link.patch
|
|
||||||
|
|
||||||
BuildRequires: pcre-devel
|
BuildRequires: pcre-devel
|
||||||
BuildRequires: tinyxml2-devel >= 2.1.0
|
BuildRequires: tinyxml2-devel >= 2.1.0
|
||||||
@ -46,8 +42,6 @@ This package contains the graphical user interface for cppcheck.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .tinyxml
|
%patch0 -p1 -b .tinyxml
|
||||||
%patch1 -p1 -b .translations
|
%patch1 -p1 -b .translations
|
||||||
%patch2 -p1 -b .libsuffix
|
|
||||||
%patch3 -p1 -b .link
|
|
||||||
# Make sure bundled tinyxml is not used
|
# Make sure bundled tinyxml is not used
|
||||||
rm -r externals/tinyxml
|
rm -r externals/tinyxml
|
||||||
|
|
||||||
@ -100,6 +94,9 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Apr 09 2016 Susi Lehtola <jussilehtola@fedoraproject.org> - 1.73-1
|
||||||
|
- Update to 1.73.
|
||||||
|
|
||||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.71-2
|
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.71-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user