Update to 2.1.
This commit is contained in:
parent
5690ed9b1d
commit
2035cd292a
1
.gitignore
vendored
1
.gitignore
vendored
@ -42,3 +42,4 @@ cppcheck-1.44.tar.bz2
|
|||||||
/cppcheck-1.89.tar.gz
|
/cppcheck-1.89.tar.gz
|
||||||
/cppcheck-1.90.tar.gz
|
/cppcheck-1.90.tar.gz
|
||||||
/cppcheck-2.0.tar.gz
|
/cppcheck-2.0.tar.gz
|
||||||
|
/cppcheck-2.1.tar.gz
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
From 809a769c690d8ab6fef293e41a29c8490512866e Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Daniel=20Marjam=C3=A4ki?= <daniel.marjamaki@gmail.com>
|
|
||||||
Date: Sun, 10 May 2020 15:38:01 +0200
|
|
||||||
Subject: [PATCH] Try to make Travis happy
|
|
||||||
|
|
||||||
---
|
|
||||||
cmake/versions.cmake | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/cmake/versions.cmake b/cmake/versions.cmake
|
|
||||||
index 4c6c27fd9d..adf6393cc7 100644
|
|
||||||
--- a/cmake/versions.cmake
|
|
||||||
+++ b/cmake/versions.cmake
|
|
||||||
@@ -1,5 +1,5 @@
|
|
||||||
# Version for libraries CPP
|
|
||||||
-SET(VERSION "2.0")
|
|
||||||
+SET(VERSION "2.0.0")
|
|
||||||
STRING(REGEX MATCHALL "[0-9]" VERSION_PARTS "${VERSION}")
|
|
||||||
LIST(GET VERSION_PARTS 0 VERSION_MAJOR)
|
|
||||||
LIST(GET VERSION_PARTS 1 VERSION_MINOR)
|
|
@ -1,6 +1,6 @@
|
|||||||
diff -urp a/cli/CMakeLists.txt b/cli/CMakeLists.txt
|
diff -up cppcheck-2.1/cli/CMakeLists.txt.orig cppcheck-2.1/cli/CMakeLists.txt
|
||||||
--- a/cli/CMakeLists.txt 2019-12-21 11:51:10.000000000 +0100
|
--- cppcheck-2.1/cli/CMakeLists.txt.orig 2020-06-13 18:08:37.000000000 +0200
|
||||||
+++ b/cli/CMakeLists.txt 2019-12-21 23:29:02.266101262 +0100
|
+++ cppcheck-2.1/cli/CMakeLists.txt 2020-06-15 11:52:39.095165469 +0200
|
||||||
@@ -1,5 +1,4 @@
|
@@ -1,5 +1,4 @@
|
||||||
include_directories(${PROJECT_SOURCE_DIR}/lib/)
|
include_directories(${PROJECT_SOURCE_DIR}/lib/)
|
||||||
-include_directories(SYSTEM ${PROJECT_SOURCE_DIR}/externals/tinyxml/)
|
-include_directories(SYSTEM ${PROJECT_SOURCE_DIR}/externals/tinyxml/)
|
||||||
@ -14,8 +14,8 @@ diff -urp a/cli/CMakeLists.txt b/cli/CMakeLists.txt
|
|||||||
-add_executable(cppcheck ${hdrs} ${mainfile} $<TARGET_OBJECTS:cli_objs> $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:tinyxml_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
-add_executable(cppcheck ${hdrs} ${mainfile} $<TARGET_OBJECTS:cli_objs> $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:tinyxml_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
||||||
+add_executable(cppcheck ${hdrs} ${mainfile} $<TARGET_OBJECTS:cli_objs> $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
+add_executable(cppcheck ${hdrs} ${mainfile} $<TARGET_OBJECTS:cli_objs> $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
||||||
if (HAVE_RULES)
|
if (HAVE_RULES)
|
||||||
find_library(PCRE_LIBRARY pcre)
|
|
||||||
target_link_libraries(cppcheck ${PCRE_LIBRARY})
|
target_link_libraries(cppcheck ${PCRE_LIBRARY})
|
||||||
|
endif()
|
||||||
@@ -18,6 +17,7 @@ endif()
|
@@ -18,6 +17,7 @@ endif()
|
||||||
if (WIN32 AND NOT BORLAND)
|
if (WIN32 AND NOT BORLAND)
|
||||||
target_link_libraries(cppcheck Shlwapi.lib)
|
target_link_libraries(cppcheck Shlwapi.lib)
|
||||||
@ -24,10 +24,10 @@ diff -urp a/cli/CMakeLists.txt b/cli/CMakeLists.txt
|
|||||||
|
|
||||||
install(TARGETS cppcheck
|
install(TARGETS cppcheck
|
||||||
RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR}
|
RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR}
|
||||||
diff -urp a/CMakeLists.txt b/CMakeLists.txt
|
diff -up cppcheck-2.1/CMakeLists.txt.orig cppcheck-2.1/CMakeLists.txt
|
||||||
--- a/CMakeLists.txt 2019-12-21 11:51:10.000000000 +0100
|
--- cppcheck-2.1/CMakeLists.txt.orig 2020-06-13 18:08:37.000000000 +0200
|
||||||
+++ b/CMakeLists.txt 2019-12-21 23:30:07.419801154 +0100
|
+++ cppcheck-2.1/CMakeLists.txt 2020-06-15 11:52:39.099165304 +0200
|
||||||
@@ -21,7 +21,6 @@ if (BUILD_TESTS)
|
@@ -23,7 +23,6 @@ if (BUILD_TESTS)
|
||||||
enable_testing()
|
enable_testing()
|
||||||
endif()
|
endif()
|
||||||
|
|
||||||
@ -35,9 +35,9 @@ diff -urp a/CMakeLists.txt b/CMakeLists.txt
|
|||||||
add_subdirectory(externals/simplecpp)
|
add_subdirectory(externals/simplecpp)
|
||||||
add_subdirectory(lib) # CppCheck Library
|
add_subdirectory(lib) # CppCheck Library
|
||||||
add_subdirectory(cli) # Client application
|
add_subdirectory(cli) # Client application
|
||||||
diff -urp a/gui/CMakeLists.txt b/gui/CMakeLists.txt
|
diff -up cppcheck-2.1/gui/CMakeLists.txt.orig cppcheck-2.1/gui/CMakeLists.txt
|
||||||
--- a/gui/CMakeLists.txt 2019-12-21 11:51:10.000000000 +0100
|
--- cppcheck-2.1/gui/CMakeLists.txt.orig 2020-06-13 18:08:37.000000000 +0200
|
||||||
+++ b/gui/CMakeLists.txt 2019-12-21 23:33:01.688541115 +0100
|
+++ cppcheck-2.1/gui/CMakeLists.txt 2020-06-15 11:53:24.866217469 +0200
|
||||||
@@ -10,7 +10,6 @@ if (BUILD_GUI)
|
@@ -10,7 +10,6 @@ if (BUILD_GUI)
|
||||||
endif()
|
endif()
|
||||||
|
|
||||||
@ -46,24 +46,27 @@ diff -urp a/gui/CMakeLists.txt b/gui/CMakeLists.txt
|
|||||||
|
|
||||||
file(GLOB hdrs "*.h")
|
file(GLOB hdrs "*.h")
|
||||||
file(GLOB srcs "*.cpp")
|
file(GLOB srcs "*.cpp")
|
||||||
@@ -20,11 +19,11 @@ if (BUILD_GUI)
|
@@ -20,14 +19,14 @@ if (BUILD_GUI)
|
||||||
QT5_ADD_RESOURCES(resources "gui.qrc")
|
QT5_ADD_RESOURCES(resources "gui.qrc")
|
||||||
QT5_ADD_TRANSLATION(qms ${tss})
|
QT5_ADD_TRANSLATION(qms ${tss})
|
||||||
|
|
||||||
- add_executable(cppcheck-gui ${hdrs} ${srcs} ${uis_hdrs} ${resources} ${qms} $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:tinyxml_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
- add_executable(cppcheck-gui ${hdrs} ${srcs} ${uis_hdrs} ${resources} ${qms} $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:tinyxml_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
||||||
+ add_executable(cppcheck-gui ${hdrs} ${srcs} ${uis_hdrs} ${resources} ${qms} $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
+ add_executable(cppcheck-gui ${hdrs} ${srcs} ${uis_hdrs} ${resources} ${qms} $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
||||||
if (HAVE_RULES)
|
if (HAVE_RULES)
|
||||||
target_link_libraries(cppcheck-gui pcre)
|
target_link_libraries(cppcheck-gui ${PCRE_LIBRARY})
|
||||||
|
endif()
|
||||||
|
if (USE_Z3)
|
||||||
|
target_link_libraries(cppcheck-gui ${Z3_LIBRARIES})
|
||||||
endif()
|
endif()
|
||||||
- target_link_libraries(cppcheck-gui Qt5::Core Qt5::Gui Qt5::Widgets Qt5::PrintSupport)
|
- target_link_libraries(cppcheck-gui Qt5::Core Qt5::Gui Qt5::Widgets Qt5::PrintSupport)
|
||||||
+ target_link_libraries(cppcheck-gui tinyxml2 Qt5::Core Qt5::Gui Qt5::Widgets Qt5::PrintSupport)
|
+ target_link_libraries(cppcheck-gui tinyxml2 Qt5::Core Qt5::Gui Qt5::Widgets Qt5::PrintSupport)
|
||||||
if(WITH_QCHART)
|
if(WITH_QCHART)
|
||||||
target_compile_definitions (cppcheck-gui PRIVATE HAVE_QCHART )
|
target_compile_definitions (cppcheck-gui PRIVATE HAVE_QCHART )
|
||||||
target_link_libraries(cppcheck-gui Qt5::Charts)
|
target_link_libraries(cppcheck-gui Qt5::Charts)
|
||||||
diff -urp a/test/CMakeLists.txt b/test/CMakeLists.txt
|
diff -up cppcheck-2.1/test/CMakeLists.txt.orig cppcheck-2.1/test/CMakeLists.txt
|
||||||
--- a/test/CMakeLists.txt 2019-12-21 11:51:10.000000000 +0100
|
--- cppcheck-2.1/test/CMakeLists.txt.orig 2020-06-15 11:52:39.108164933 +0200
|
||||||
+++ b/test/CMakeLists.txt 2019-12-21 23:34:50.432203245 +0100
|
+++ cppcheck-2.1/test/CMakeLists.txt 2020-06-15 11:54:10.167286593 +0200
|
||||||
@@ -12,16 +12,16 @@ if (BUILD_TESTS)
|
@@ -13,19 +13,19 @@ if (BUILD_TESTS)
|
||||||
add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND} --output-on-failure -j ${CTEST_PARALLEL_LEVEL} -C ${CMAKE_CFG_INTDIR} --timeout 90)
|
add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND} --output-on-failure -j ${CTEST_PARALLEL_LEVEL} -C ${CMAKE_CFG_INTDIR} --timeout 90)
|
||||||
|
|
||||||
include_directories(${PROJECT_SOURCE_DIR}/lib/ ${PROJECT_SOURCE_DIR}/cli/)
|
include_directories(${PROJECT_SOURCE_DIR}/lib/ ${PROJECT_SOURCE_DIR}/cli/)
|
||||||
@ -76,7 +79,10 @@ diff -urp a/test/CMakeLists.txt b/test/CMakeLists.txt
|
|||||||
- add_executable(testrunner ${hdrs} ${srcs} $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:cli_objs> $<TARGET_OBJECTS:tinyxml_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
- add_executable(testrunner ${hdrs} ${srcs} $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:cli_objs> $<TARGET_OBJECTS:tinyxml_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
||||||
+ add_executable(testrunner ${hdrs} ${srcs} $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:cli_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
+ add_executable(testrunner ${hdrs} ${srcs} $<TARGET_OBJECTS:lib_objs> $<TARGET_OBJECTS:cli_objs> $<TARGET_OBJECTS:simplecpp_objs>)
|
||||||
if (HAVE_RULES)
|
if (HAVE_RULES)
|
||||||
target_link_libraries(testrunner pcre)
|
target_link_libraries(testrunner ${PCRE_LIBRARY})
|
||||||
|
endif()
|
||||||
|
if (USE_Z3)
|
||||||
|
target_link_libraries(testrunner ${Z3_LIBRARIES})
|
||||||
endif()
|
endif()
|
||||||
+ target_link_libraries(testrunner tinyxml2)
|
+ target_link_libraries(testrunner tinyxml2)
|
||||||
|
|
@ -2,7 +2,7 @@
|
|||||||
%global gui 1
|
%global gui 1
|
||||||
|
|
||||||
Name: cppcheck
|
Name: cppcheck
|
||||||
Version: 2.0
|
Version: 2.1
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Tool for static C/C++ code analysis
|
Summary: Tool for static C/C++ code analysis
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
@ -10,12 +10,11 @@ URL: http://cppcheck.wiki.sourceforge.net/
|
|||||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
# Use system tinyxml2
|
# Use system tinyxml2
|
||||||
Patch0: cppcheck-1.90-tinyxml.patch
|
Patch0: cppcheck-2.1-tinyxml.patch
|
||||||
# Fix location of translations
|
# Fix location of translations
|
||||||
Patch1: cppcheck-1.89-translations.patch
|
Patch1: cppcheck-1.89-translations.patch
|
||||||
# Select python3 explicitly
|
# Select python3 explicitly
|
||||||
Patch2: cppcheck-1.88-htmlreport-python3.patch
|
Patch2: cppcheck-1.88-htmlreport-python3.patch
|
||||||
Patch3: https://github.com/danmar/cppcheck/commit/809a769.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: pcre-devel
|
BuildRequires: pcre-devel
|
||||||
@ -76,7 +75,6 @@ from xml files first generated using cppcheck.
|
|||||||
%patch0 -p1 -b .tinyxml
|
%patch0 -p1 -b .tinyxml
|
||||||
%patch1 -p1 -b .translations
|
%patch1 -p1 -b .translations
|
||||||
%patch2 -p1 -b .python3
|
%patch2 -p1 -b .python3
|
||||||
%patch3 -p1 -b .cmake
|
|
||||||
# Make sure bundled tinyxml is not used
|
# Make sure bundled tinyxml is not used
|
||||||
rm -r externals/tinyxml
|
rm -r externals/tinyxml
|
||||||
|
|
||||||
@ -138,6 +136,9 @@ cd objdir-%{_target_platform}/bin
|
|||||||
%{_bindir}/cppcheck-htmlreport
|
%{_bindir}/cppcheck-htmlreport
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 15 2020 Susi Lehtola <jussilehtola@fedoraproject.org> - 2.1-1
|
||||||
|
- Update to 2.1.
|
||||||
|
|
||||||
* Mon May 11 2020 Susi Lehtola <jussilehtola@fedoraproject.org> - 2.0-1
|
* Mon May 11 2020 Susi Lehtola <jussilehtola@fedoraproject.org> - 2.0-1
|
||||||
- Update to 2.0.
|
- Update to 2.0.
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (cppcheck-2.0.tar.gz) = 9f559564f875c2818e8b997aa3a3cc74e685169ebe829f3a41f20cd266b08cb7685efd5c266d877ada59576b8bf49ec04aead9f77d5781d3e0eb7a5d881ef281
|
SHA512 (cppcheck-2.1.tar.gz) = 5001486c0f5dd2149c733df6167e274217dba6e248f525aba0f1523c92f44ad119b7e4c5655ccc812567ccf9ab11bcaaa35aa165d5d256212802f69594a581b8
|
||||||
|
Loading…
Reference in New Issue
Block a user