Update to 1.85.
This commit is contained in:
parent
9d1bd55da1
commit
00d0476e49
27
cppcheck-1.85-htmlreport-python2.patch
Normal file
27
cppcheck-1.85-htmlreport-python2.patch
Normal file
@ -0,0 +1,27 @@
|
||||
diff -urp cppcheck-1.85.orig/htmlreport/cppcheck-htmlreport cppcheck-1.85/htmlreport/cppcheck-htmlreport
|
||||
--- cppcheck-1.85.orig/htmlreport/cppcheck-htmlreport 2018-10-14 14:56:51.000000000 +0200
|
||||
+++ cppcheck-1.85/htmlreport/cppcheck-htmlreport 2018-11-08 16:26:00.527947956 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
|
||||
from __future__ import unicode_literals
|
||||
|
||||
diff -urp cppcheck-1.85.orig/htmlreport/setup.py cppcheck-1.85/htmlreport/setup.py
|
||||
--- cppcheck-1.85.orig/htmlreport/setup.py 2018-10-14 14:56:51.000000000 +0200
|
||||
+++ cppcheck-1.85/htmlreport/setup.py 2018-11-08 16:26:40.266947340 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
|
||||
from setuptools import setup
|
||||
|
||||
diff -urp cppcheck-1.85.orig/htmlreport/test_htmlreport.py cppcheck-1.85/htmlreport/test_htmlreport.py
|
||||
--- cppcheck-1.85.orig/htmlreport/test_htmlreport.py 2018-10-14 14:56:51.000000000 +0200
|
||||
+++ cppcheck-1.85/htmlreport/test_htmlreport.py 2018-11-08 16:26:25.963947562 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
"""Test cppcheck-htmlreport."""
|
||||
|
||||
import os
|
@ -15,6 +15,8 @@ Patch0: cppcheck-1.85-tinyxml.patch
|
||||
Patch1: cppcheck-1.84-translations.patch
|
||||
# Set location of config files
|
||||
Patch2: cppcheck-1.78-cfgdir.patch
|
||||
# Select python2 explicitly
|
||||
Patch3: cppcheck-1.85-htmlreport-python2.patch
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: pcre-devel
|
||||
@ -71,6 +73,7 @@ from xml files first generated using cppcheck.
|
||||
%patch0 -p1 -b .tinyxml
|
||||
%patch1 -p1 -b .translations
|
||||
%patch2 -p1 -b .cfgdir
|
||||
%patch3 -p1 -b .python2
|
||||
# Make sure bundled tinyxml is not used
|
||||
rm -r externals/tinyxml
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user