parent
5156a84d80
commit
c31ab0b56e
212
cpio-2.11-CVE-2014-9112.patch
Normal file
212
cpio-2.11-CVE-2014-9112.patch
Normal file
@ -0,0 +1,212 @@
|
|||||||
|
diff --git a/src/copyin.c b/src/copyin.c
|
||||||
|
index d505407..db8ee66 100644
|
||||||
|
--- a/src/copyin.c
|
||||||
|
+++ b/src/copyin.c
|
||||||
|
@@ -124,10 +124,30 @@ tape_skip_padding (int in_file_des, off_t offset)
|
||||||
|
if (pad != 0)
|
||||||
|
tape_toss_input (in_file_des, pad);
|
||||||
|
}
|
||||||
|
-
|
||||||
|
+
|
||||||
|
+static char *
|
||||||
|
+get_link_name (struct cpio_file_stat *file_hdr, int in_file_des)
|
||||||
|
+{
|
||||||
|
+ char *link_name;
|
||||||
|
+
|
||||||
|
+ if (file_hdr->c_filesize < 0 || file_hdr->c_filesize > SIZE_MAX-1)
|
||||||
|
+ {
|
||||||
|
+ error (0, 0, _("%s: stored filename length is out of range"),
|
||||||
|
+ file_hdr->c_name);
|
||||||
|
+ link_name = NULL;
|
||||||
|
+ }
|
||||||
|
+ else
|
||||||
|
+ {
|
||||||
|
+ link_name = xmalloc (file_hdr->c_filesize + 1);
|
||||||
|
+ tape_buffered_read (link_name, in_file_des, file_hdr->c_filesize);
|
||||||
|
+ link_name[file_hdr->c_filesize] = '\0';
|
||||||
|
+ tape_skip_padding (in_file_des, file_hdr->c_filesize);
|
||||||
|
+ }
|
||||||
|
+ return link_name;
|
||||||
|
+}
|
||||||
|
|
||||||
|
static void
|
||||||
|
-list_file(struct cpio_file_stat* file_hdr, int in_file_des)
|
||||||
|
+list_file (struct cpio_file_stat* file_hdr, int in_file_des)
|
||||||
|
{
|
||||||
|
if (verbose_flag)
|
||||||
|
{
|
||||||
|
@@ -136,21 +156,16 @@ list_file(struct cpio_file_stat* file_hdr, int in_file_des)
|
||||||
|
{
|
||||||
|
if (archive_format != arf_tar && archive_format != arf_ustar)
|
||||||
|
{
|
||||||
|
- char *link_name = NULL; /* Name of hard and symbolic links. */
|
||||||
|
-
|
||||||
|
- link_name = (char *) xmalloc ((unsigned int) file_hdr->c_filesize + 1);
|
||||||
|
- link_name[file_hdr->c_filesize] = '\0';
|
||||||
|
- tape_buffered_read (link_name, in_file_des, file_hdr->c_filesize);
|
||||||
|
- long_format (file_hdr, link_name);
|
||||||
|
- free (link_name);
|
||||||
|
- tape_skip_padding (in_file_des, file_hdr->c_filesize);
|
||||||
|
- return;
|
||||||
|
+ char *link_name = get_link_name (file_hdr, in_file_des);
|
||||||
|
+ if (link_name)
|
||||||
|
+ {
|
||||||
|
+ long_format (file_hdr, link_name);
|
||||||
|
+ free (link_name);
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
else
|
||||||
|
- {
|
||||||
|
- long_format (file_hdr, file_hdr->c_tar_linkname);
|
||||||
|
- return;
|
||||||
|
- }
|
||||||
|
+ long_format (file_hdr, file_hdr->c_tar_linkname);
|
||||||
|
+ return;
|
||||||
|
}
|
||||||
|
else
|
||||||
|
#endif
|
||||||
|
@@ -650,10 +665,7 @@ copyin_link(struct cpio_file_stat *file_hdr, int in_file_des)
|
||||||
|
|
||||||
|
if (archive_format != arf_tar && archive_format != arf_ustar)
|
||||||
|
{
|
||||||
|
- link_name = (char *) xmalloc ((unsigned int) file_hdr->c_filesize + 1);
|
||||||
|
- link_name[file_hdr->c_filesize] = '\0';
|
||||||
|
- tape_buffered_read (link_name, in_file_des, file_hdr->c_filesize);
|
||||||
|
- tape_skip_padding (in_file_des, file_hdr->c_filesize);
|
||||||
|
+ link_name = get_link_name (file_hdr, in_file_des);
|
||||||
|
}
|
||||||
|
else
|
||||||
|
{
|
||||||
|
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
||||||
|
index b3e8e60..cf186da 100644
|
||||||
|
--- a/tests/Makefile.am
|
||||||
|
+++ b/tests/Makefile.am
|
||||||
|
@@ -52,6 +52,8 @@ TESTSUITE_AT = \
|
||||||
|
setstat04.at\
|
||||||
|
setstat05.at\
|
||||||
|
symlink.at\
|
||||||
|
+ symlink-bad-length.at\
|
||||||
|
+ symlink-long.at\
|
||||||
|
version.at
|
||||||
|
|
||||||
|
TESTSUITE = $(srcdir)/testsuite
|
||||||
|
diff --git a/tests/symlink-bad-length.at b/tests/symlink-bad-length.at
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..cbf4aa7
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/tests/symlink-bad-length.at
|
||||||
|
@@ -0,0 +1,49 @@
|
||||||
|
+# Process this file with autom4te to create testsuite. -*- Autotest -*-
|
||||||
|
+# Copyright (C) 2014 Free Software Foundation, Inc.
|
||||||
|
+
|
||||||
|
+# This program is free software; you can redistribute it and/or modify
|
||||||
|
+# it under the terms of the GNU General Public License as published by
|
||||||
|
+# the Free Software Foundation; either version 3, or (at your option)
|
||||||
|
+# any later version.
|
||||||
|
+
|
||||||
|
+# This program is distributed in the hope that it will be useful,
|
||||||
|
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||||
|
+# GNU General Public License for more details.
|
||||||
|
+
|
||||||
|
+# You should have received a copy of the GNU General Public License
|
||||||
|
+# along with this program; if not, write to the Free Software
|
||||||
|
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
|
||||||
|
+# 02110-1301 USA.
|
||||||
|
+
|
||||||
|
+# Cpio v2.11 did segfault with badly set symlink length.
|
||||||
|
+# References:
|
||||||
|
+# http://lists.gnu.org/archive/html/bug-cpio/2014-11/msg00007.html
|
||||||
|
+
|
||||||
|
+AT_SETUP([symlink-bad-length])
|
||||||
|
+AT_KEYWORDS([symlink-long copyout])
|
||||||
|
+
|
||||||
|
+AT_DATA([ARCHIVE.base64],
|
||||||
|
+[x3EjAIBAtIEtJy8nAQAAAHRUYW0FAAAADQBGSUxFAABzb21lIGNvbnRlbnQKAMdxIwBgQ/+hLScv
|
||||||
|
+JwEAAAB0VEhuBQD/////TElOSwAARklMRcdxAAAAAAAAAAAAAAEAAAAAAAAACwAAAAAAVFJBSUxF
|
||||||
|
+UiEhIQAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
|
||||||
|
+AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
|
||||||
|
+AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
|
||||||
|
+AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
|
||||||
|
+AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
|
||||||
|
+AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
|
||||||
|
+AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA=
|
||||||
|
+])
|
||||||
|
+
|
||||||
|
+AT_CHECK([
|
||||||
|
+base64 -d ARCHIVE.base64 > ARCHIVE || AT_SKIP_TEST
|
||||||
|
+cpio -ntv < ARCHIVE
|
||||||
|
+test $? -eq 2
|
||||||
|
+],
|
||||||
|
+[0],
|
||||||
|
+[-rw-rw-r-- 1 10029 10031 13 Nov 25 13:52 FILE
|
||||||
|
+],[cpio: LINK: stored filename length is out of range
|
||||||
|
+cpio: premature end of file
|
||||||
|
+])
|
||||||
|
+
|
||||||
|
+AT_CLEANUP
|
||||||
|
diff --git a/tests/symlink-long.at b/tests/symlink-long.at
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..d3def2d
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/tests/symlink-long.at
|
||||||
|
@@ -0,0 +1,46 @@
|
||||||
|
+# Process this file with autom4te to create testsuite. -*- Autotest -*-
|
||||||
|
+# Copyright (C) 2014 Free Software Foundation, Inc.
|
||||||
|
+
|
||||||
|
+# This program is free software; you can redistribute it and/or modify
|
||||||
|
+# it under the terms of the GNU General Public License as published by
|
||||||
|
+# the Free Software Foundation; either version 3, or (at your option)
|
||||||
|
+# any later version.
|
||||||
|
+
|
||||||
|
+# This program is distributed in the hope that it will be useful,
|
||||||
|
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||||
|
+# GNU General Public License for more details.
|
||||||
|
+
|
||||||
|
+# You should have received a copy of the GNU General Public License
|
||||||
|
+# along with this program; if not, write to the Free Software
|
||||||
|
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
|
||||||
|
+# 02110-1301 USA.
|
||||||
|
+
|
||||||
|
+# Cpio v2.11.90 changed the way symlink name is read from archive.
|
||||||
|
+# References:
|
||||||
|
+# http://lists.gnu.org/archive/html/bug-cpio/2014-11/msg00007.html
|
||||||
|
+
|
||||||
|
+AT_SETUP([symlink-long])
|
||||||
|
+AT_KEYWORDS([symlink-long copyout])
|
||||||
|
+
|
||||||
|
+AT_CHECK([
|
||||||
|
+
|
||||||
|
+# len(dirname) > READBUFSIZE
|
||||||
|
+dirname=
|
||||||
|
+for i in {1..52}; do
|
||||||
|
+ dirname="xxxxxxxxx/$dirname"
|
||||||
|
+ mkdir "$dirname"
|
||||||
|
+done
|
||||||
|
+ln -s "$dirname" x || AT_SKIP_TEST
|
||||||
|
+
|
||||||
|
+echo x | cpio -o > ar
|
||||||
|
+list=`cpio -tv < ar | sed 's|.*-> ||'`
|
||||||
|
+test "$list" = "$dirname" && echo success || echo fail
|
||||||
|
+],
|
||||||
|
+[0],
|
||||||
|
+[success
|
||||||
|
+],[2 blocks
|
||||||
|
+2 blocks
|
||||||
|
+])
|
||||||
|
+
|
||||||
|
+AT_CLEANUP
|
||||||
|
diff --git a/tests/testsuite.at b/tests/testsuite.at
|
||||||
|
index 8f3330b..590bdcb 100644
|
||||||
|
--- a/tests/testsuite.at
|
||||||
|
+++ b/tests/testsuite.at
|
||||||
|
@@ -31,6 +31,8 @@ m4_include([version.at])
|
||||||
|
|
||||||
|
m4_include([inout.at])
|
||||||
|
m4_include([symlink.at])
|
||||||
|
+m4_include([symlink-bad-length.at])
|
||||||
|
+m4_include([symlink-long.at])
|
||||||
|
m4_include([interdir.at])
|
||||||
|
|
||||||
|
m4_include([setstat01.at])
|
24
cpio-2.11-testsuite-CVE-2014-9112.patch
Normal file
24
cpio-2.11-testsuite-CVE-2014-9112.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff --git a/tests/symlink-bad-length.at b/tests/symlink-bad-length.at
|
||||||
|
index cbf4aa7..080163a 100644
|
||||||
|
--- a/tests/symlink-bad-length.at
|
||||||
|
+++ b/tests/symlink-bad-length.at
|
||||||
|
@@ -37,13 +37,14 @@ AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA=
|
||||||
|
|
||||||
|
AT_CHECK([
|
||||||
|
base64 -d ARCHIVE.base64 > ARCHIVE || AT_SKIP_TEST
|
||||||
|
-cpio -ntv < ARCHIVE
|
||||||
|
-test $? -eq 2
|
||||||
|
+TZ=UTC cpio -ntv < ARCHIVE 2>stderr
|
||||||
|
+rc=$?
|
||||||
|
+cat stderr | grep -v 'stored filename length is out of range' >&2
|
||||||
|
+test "$rc" -ne 0
|
||||||
|
],
|
||||||
|
[0],
|
||||||
|
-[-rw-rw-r-- 1 10029 10031 13 Nov 25 13:52 FILE
|
||||||
|
-],[cpio: LINK: stored filename length is out of range
|
||||||
|
-cpio: premature end of file
|
||||||
|
+[-rw-rw-r-- 1 10029 10031 13 Nov 25 11:52 FILE
|
||||||
|
+],[cpio: premature end of file
|
||||||
|
])
|
||||||
|
|
||||||
|
AT_CLEANUP
|
17
cpio.spec
17
cpio.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A GNU archiving program
|
Summary: A GNU archiving program
|
||||||
Name: cpio
|
Name: cpio
|
||||||
Version: 2.11
|
Version: 2.11
|
||||||
Release: 30%{?dist}
|
Release: 31%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
URL: http://www.gnu.org/software/cpio/
|
URL: http://www.gnu.org/software/cpio/
|
||||||
@ -41,6 +41,16 @@ Patch10: cpio-2.11-treat-read-errors.patch
|
|||||||
# ~> downstream?
|
# ~> downstream?
|
||||||
Patch11: cpio-2.11-ru-translation.patch
|
Patch11: cpio-2.11-ru-translation.patch
|
||||||
|
|
||||||
|
# heap-based buffer overrun
|
||||||
|
# ~> #1167573
|
||||||
|
# ~> upstream: git diff 3945f9db..58df4f1b
|
||||||
|
Patch12: cpio-2.11-CVE-2014-9112.patch
|
||||||
|
|
||||||
|
# Related to CVE-2014-9112 patch.
|
||||||
|
# ~> reported upstream:
|
||||||
|
# http://lists.gnu.org/archive/html/bug-cpio/2014-12/msg00005.html
|
||||||
|
Patch13: cpio-2.11-testsuite-CVE-2014-9112.patch
|
||||||
|
|
||||||
Requires(post): /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
Requires(preun): /sbin/install-info
|
Requires(preun): /sbin/install-info
|
||||||
Provides: bundled(gnulib)
|
Provides: bundled(gnulib)
|
||||||
@ -75,6 +85,8 @@ Install cpio if you need a program to manage file archives.
|
|||||||
%patch9 -p1 -b .crc-big-files
|
%patch9 -p1 -b .crc-big-files
|
||||||
%patch10 -p1 -b .treat-read-errors
|
%patch10 -p1 -b .treat-read-errors
|
||||||
%patch11 -p1 -b .ru-translation
|
%patch11 -p1 -b .ru-translation
|
||||||
|
%patch12 -p1 -b .CVE-2014-9112
|
||||||
|
%patch13 -p1 -b .testsuite-cve
|
||||||
|
|
||||||
autoreconf -vfi
|
autoreconf -vfi
|
||||||
|
|
||||||
@ -127,6 +139,9 @@ fi
|
|||||||
%{_infodir}/*.info*
|
%{_infodir}/*.info*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 02 2014 Pavel Raiskup <praiskup@redhat.com> - 2.11-31
|
||||||
|
- fix for CVE-2014-9112 (#1167573)
|
||||||
|
|
||||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.11-30
|
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.11-30
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user