new upstream alpha release + removed applied patches
This commit is contained in:
parent
c94c07112c
commit
38c4c851be
@ -1,2 +1 @@
|
||||
cpio-2.9.tar.gz
|
||||
cpio.1
|
||||
cpio-2.9.90.tar.bz2
|
||||
|
@ -1,32 +0,0 @@
|
||||
diff -up tar-1.19/lib/argp-fmtstream.h.gcc43 tar-1.19/lib/argp-fmtstream.h
|
||||
--- tar-1.19/lib/argp-fmtstream.h.gcc43 2007-09-28 15:11:36.000000000 +0200
|
||||
+++ tar-1.19/lib/argp-fmtstream.h 2008-02-13 16:56:58.000000000 +0100
|
||||
@@ -198,7 +198,11 @@ extern int __argp_fmtstream_ensure (argp
|
||||
#endif
|
||||
|
||||
#ifndef ARGP_FS_EI
|
||||
-#define ARGP_FS_EI extern inline
|
||||
+# ifdef __GNUC_STDC_INLINE__
|
||||
+# define ARGP_FS_EI extern inline __attribute__((__gnu_inline__))
|
||||
+# else
|
||||
+# define ARGP_FS_EI extern inline
|
||||
+# endif
|
||||
#endif
|
||||
|
||||
ARGP_FS_EI size_t
|
||||
diff -up tar-1.19/lib/argp.h.gcc43 tar-1.19/lib/argp.h
|
||||
--- tar-1.19/lib/argp.h.gcc43 2007-09-28 15:11:36.000000000 +0200
|
||||
+++ tar-1.19/lib/argp.h 2008-02-13 16:55:36.000000000 +0100
|
||||
@@ -580,7 +580,11 @@ extern void *__argp_input (const struct
|
||||
# endif
|
||||
|
||||
# ifndef ARGP_EI
|
||||
-# define ARGP_EI extern __inline__
|
||||
+# if defined __GNUC_STDC_INLINE__
|
||||
+# define ARGP_EI extern __inline__ __attribute__((__gnu_inline__))
|
||||
+# else
|
||||
+# define ARGP_EI extern __inline__
|
||||
+# endif
|
||||
# endif
|
||||
|
||||
ARGP_EI void
|
@ -1,89 +0,0 @@
|
||||
diff -up tar-1.17/lib/paxnames.c.safer_name_suffix tar-1.17/lib/paxnames.c
|
||||
--- tar-1.17/lib/paxnames.c.safer_name_suffix 2005-05-22 00:55:55.000000000 +0200
|
||||
+++ tar-1.17/lib/paxnames.c 2007-10-22 17:32:54.000000000 +0200
|
||||
@@ -36,15 +36,27 @@ hash_string_compare (void const *name1,
|
||||
return strcmp (name1, name2) == 0;
|
||||
}
|
||||
|
||||
-/* Return zero if TABLE contains a copy of STRING; otherwise, insert a
|
||||
- copy of STRING to TABLE and return 1. */
|
||||
-bool
|
||||
-hash_string_insert (Hash_table **table, char const *string)
|
||||
+/* Return zero if TABLE contains a LEN-character long prefix of STRING,
|
||||
+ otherwise, insert a newly allocated copy of this prefix to TABLE and
|
||||
+ return 1. If RETURN_PREFIX is not NULL, point it to the allocated
|
||||
+ copy. */
|
||||
+static bool
|
||||
+hash_string_insert_prefix (Hash_table **table, char const *string, size_t len,
|
||||
+ const char **return_prefix)
|
||||
{
|
||||
Hash_table *t = *table;
|
||||
- char *s = xstrdup (string);
|
||||
+ char *s;
|
||||
char *e;
|
||||
|
||||
+ if (len)
|
||||
+ {
|
||||
+ s = xmalloc (len + 1);
|
||||
+ memcpy (s, string, len);
|
||||
+ s[len] = 0;
|
||||
+ }
|
||||
+ else
|
||||
+ s = xstrdup (string);
|
||||
+
|
||||
if (! ((t
|
||||
|| (*table = t = hash_initialize (0, 0, hash_string_hasher,
|
||||
hash_string_compare, 0)))
|
||||
@@ -52,7 +64,11 @@ hash_string_insert (Hash_table **table,
|
||||
xalloc_die ();
|
||||
|
||||
if (e == s)
|
||||
- return 1;
|
||||
+ {
|
||||
+ if (return_prefix)
|
||||
+ *return_prefix = s;
|
||||
+ return 1;
|
||||
+ }
|
||||
else
|
||||
{
|
||||
free (s);
|
||||
@@ -60,6 +76,14 @@ hash_string_insert (Hash_table **table,
|
||||
}
|
||||
}
|
||||
|
||||
+/* Return zero if TABLE contains a copy of STRING; otherwise, insert a
|
||||
+ copy of STRING to TABLE and return 1. */
|
||||
+bool
|
||||
+hash_string_insert (Hash_table **table, char const *string)
|
||||
+{
|
||||
+ return hash_string_insert_prefix (table, string, 0, NULL);
|
||||
+}
|
||||
+
|
||||
/* Return 1 if TABLE contains STRING. */
|
||||
bool
|
||||
hash_string_lookup (Hash_table const *table, char const *string)
|
||||
@@ -88,7 +112,8 @@ removed_prefixes_p (void)
|
||||
If ABSOLUTE_NAMES is 0, strip filesystem prefix from the file name. */
|
||||
|
||||
char *
|
||||
-safer_name_suffix (char const *file_name, bool link_target, bool absolute_names)
|
||||
+safer_name_suffix (char const *file_name, bool link_target,
|
||||
+ bool absolute_names)
|
||||
{
|
||||
char const *p;
|
||||
|
||||
@@ -121,11 +146,9 @@ safer_name_suffix (char const *file_name
|
||||
|
||||
if (prefix_len)
|
||||
{
|
||||
- char *prefix = alloca (prefix_len + 1);
|
||||
- memcpy (prefix, file_name, prefix_len);
|
||||
- prefix[prefix_len] = '\0';
|
||||
-
|
||||
- if (hash_string_insert (&prefix_table[link_target], prefix))
|
||||
+ const char *prefix;
|
||||
+ if (hash_string_insert_prefix (&prefix_table[link_target], file_name,
|
||||
+ prefix_len, &prefix))
|
||||
{
|
||||
static char const *const diagnostic[] =
|
||||
{
|
17
cpio.spec
17
cpio.spec
@ -2,20 +2,18 @@
|
||||
|
||||
Summary: A GNU archiving program
|
||||
Name: cpio
|
||||
Version: 2.9
|
||||
Release: 7%{?dist}
|
||||
Version: 2.9.90
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Applications/Archiving
|
||||
URL: http://www.gnu.org/software/cpio/
|
||||
Source: ftp://ftp.gnu.org/gnu/cpio/cpio-%{version}.tar.gz
|
||||
Source: ftp://ftp.gnu.org/gnu/cpio/cpio-%{version}.tar.bz2
|
||||
Source1: cpio.1
|
||||
Patch1: cpio-2.6-setLocale.patch
|
||||
Patch2: cpio-2.9-rh.patch
|
||||
Patch3: cpio-2.9-chmodRaceC.patch
|
||||
Patch4: cpio-2.9-exitCode.patch
|
||||
Patch5: cpio-2.9-safer_name_suffix.patch
|
||||
Patch6: cpio-2.9-gcc43.patch
|
||||
Patch7: cpio-2.9-dir_perm.patch
|
||||
Patch5: cpio-2.9-dir_perm.patch
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
BuildRequires: texinfo, autoconf, gettext
|
||||
@ -41,9 +39,7 @@ Install cpio if you need a program to manage file archives.
|
||||
%patch2 -p1 -b .rh
|
||||
%patch3 -p1 -b .chmodRaceC
|
||||
%patch4 -p1 -b .exitCode
|
||||
%patch5 -p1 -b .safer_name_suffix
|
||||
%patch6 -p1 -b .gcc43
|
||||
%patch7 -p1 -b .dir_perm
|
||||
%patch5 -p1 -b .dir_perm
|
||||
|
||||
autoheader
|
||||
|
||||
@ -84,6 +80,9 @@ fi
|
||||
%{_infodir}/*.info*
|
||||
|
||||
%changelog
|
||||
* Tue Jun 02 2008 Ondrej Vasik <ovasik@redhat.com> 2.9.90-1
|
||||
- new upstream alpha version 2.9.90 + removed applied patches
|
||||
|
||||
* Mon Mar 03 2008 Radek Brich <rbrich@redhat.com> 2.9-7
|
||||
- fix -dir_perm patch to restore permissions correctly even
|
||||
in passthrough mode -- revert affected code to cpio 2.8 state
|
||||
|
Loading…
Reference in New Issue
Block a user