Update to 0.97 + svn 2226
This commit is contained in:
parent
ebf0cd693d
commit
0b8e8ea5c4
@ -1 +1,2 @@
|
|||||||
corosync-0.95.tar.gz
|
corosync-0.97.tar.gz
|
||||||
|
corosync-trunk.diff
|
||||||
|
@ -1,14 +1,14 @@
|
|||||||
## define alphatag svn1797
|
%define alphatag svn2226
|
||||||
|
|
||||||
Name: corosync
|
Name: corosync
|
||||||
Summary: The Corosync Cluster Engine and Application Programming Interfaces
|
Summary: The Corosync Cluster Engine and Application Programming Interfaces
|
||||||
Version: 0.95
|
Version: 0.97
|
||||||
Release: 2%{?alphatag:.%{alphatag}}%{?dist}
|
Release: 1%{?alphatag:.%{alphatag}}%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: http://www.openais.org
|
URL: http://www.openais.org
|
||||||
Source0: http://developer.osdl.org/dev/openais/downloads/corosync-%{version}/corosync-%{version}.tar.gz
|
Source0: http://developer.osdl.org/dev/openais/downloads/corosync-%{version}/corosync-%{version}.tar.gz
|
||||||
Patch0: fix-pkgconfig.diff
|
Patch0: corosync-trunk.diff
|
||||||
|
|
||||||
# Runtime bits
|
# Runtime bits
|
||||||
Requires: corosynclib = %{version}-%{release}
|
Requires: corosynclib = %{version}-%{release}
|
||||||
@ -20,26 +20,29 @@ Conflicts: openais <= 0.89, openais-devel <= 0.89
|
|||||||
# Setup/build bits
|
# Setup/build bits
|
||||||
%define ais_user_uid 39
|
%define ais_user_uid 39
|
||||||
|
|
||||||
|
%if %{alphatag}
|
||||||
|
%define buildtrunk 1
|
||||||
|
%else
|
||||||
%define buildtrunk 0
|
%define buildtrunk 0
|
||||||
|
%endif
|
||||||
%{?_with_buildtrunk: %define buildtrunk 1}
|
%{?_with_buildtrunk: %define buildtrunk 1}
|
||||||
|
|
||||||
%if %{buildtrunk}
|
%if %{buildtrunk}
|
||||||
BuildRequires: autoconf automake
|
BuildRequires: autoconf automake
|
||||||
%endif
|
%endif
|
||||||
|
BuildRequires: nss-devel
|
||||||
|
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n corosync-%{version}
|
%setup -q -n corosync-%{version}
|
||||||
%patch0 -p1
|
%patch0 -p0
|
||||||
|
|
||||||
%if %{buildtrunk}
|
%if %{buildtrunk}
|
||||||
if [ ! -f configure ]; then
|
./autogen.sh
|
||||||
./autogen.sh
|
|
||||||
fi
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%{_configure} CFLAGS="$(echo '%{optflags}')" \
|
%{_configure} CFLAGS="$(echo '%{optflags}')" \
|
||||||
--prefix=/usr \
|
--prefix=/usr \
|
||||||
--sysconfdir=/etc \
|
--sysconfdir=/etc \
|
||||||
--localstatedir=/var \
|
--localstatedir=/var \
|
||||||
@ -94,7 +97,7 @@ fi
|
|||||||
%{_sbindir}/corosync-cfgtool
|
%{_sbindir}/corosync-cfgtool
|
||||||
%{_sbindir}/corosync-fplay
|
%{_sbindir}/corosync-fplay
|
||||||
%{_sbindir}/corosync-pload
|
%{_sbindir}/corosync-pload
|
||||||
%config(noreplace) /etc/corosync.conf
|
%config(noreplace) /etc/corosync.conf.example
|
||||||
%{_initddir}/corosync
|
%{_initddir}/corosync
|
||||||
%dir %{_libexecdir}/lcrso
|
%dir %{_libexecdir}/lcrso
|
||||||
%{_libexecdir}/lcrso/coroparse.lcrso
|
%{_libexecdir}/lcrso/coroparse.lcrso
|
||||||
@ -108,7 +111,6 @@ fi
|
|||||||
%{_libexecdir}/lcrso/quorum_testquorum.lcrso
|
%{_libexecdir}/lcrso/quorum_testquorum.lcrso
|
||||||
%{_libexecdir}/lcrso/vsf_quorum.lcrso
|
%{_libexecdir}/lcrso/vsf_quorum.lcrso
|
||||||
%{_libexecdir}/lcrso/vsf_ykd.lcrso
|
%{_libexecdir}/lcrso/vsf_ykd.lcrso
|
||||||
%{_libexecdir}/lcrso/quorum.lcrso
|
|
||||||
%{_mandir}/man8/corosync_overview.8*
|
%{_mandir}/man8/corosync_overview.8*
|
||||||
%{_mandir}/man8/corosync-objctl.8*
|
%{_mandir}/man8/corosync-objctl.8*
|
||||||
%{_mandir}/man5/corosync.conf.5*
|
%{_mandir}/man5/corosync.conf.5*
|
||||||
@ -157,6 +159,9 @@ The Corosync Cluster Engine APIs.
|
|||||||
%doc LICENSE README.devmap
|
%doc LICENSE README.devmap
|
||||||
%dir %{_includedir}/corosync/
|
%dir %{_includedir}/corosync/
|
||||||
%{_includedir}/corosync/cs_config.h
|
%{_includedir}/corosync/cs_config.h
|
||||||
|
%{_includedir}/corosync/corodefs.h
|
||||||
|
%{_includedir}/corosync/coroipc_types.h
|
||||||
|
%{_includedir}/corosync/coroipcs.h
|
||||||
%{_includedir}/corosync/coroipcc.h
|
%{_includedir}/corosync/coroipcc.h
|
||||||
%{_includedir}/corosync/cfg.h
|
%{_includedir}/corosync/cfg.h
|
||||||
%{_includedir}/corosync/confdb.h
|
%{_includedir}/corosync/confdb.h
|
||||||
@ -164,7 +169,6 @@ The Corosync Cluster Engine APIs.
|
|||||||
%{_includedir}/corosync/cpg.h
|
%{_includedir}/corosync/cpg.h
|
||||||
%{_includedir}/corosync/evs.h
|
%{_includedir}/corosync/evs.h
|
||||||
%{_includedir}/corosync/hdb.h
|
%{_includedir}/corosync/hdb.h
|
||||||
%{_includedir}/corosync/ipc_gen.h
|
|
||||||
%{_includedir}/corosync/list.h
|
%{_includedir}/corosync/list.h
|
||||||
%{_includedir}/corosync/mar_gen.h
|
%{_includedir}/corosync/mar_gen.h
|
||||||
%{_includedir}/corosync/swab.h
|
%{_includedir}/corosync/swab.h
|
||||||
@ -209,6 +213,18 @@ The Corosync Cluster Engine APIs.
|
|||||||
%{_mandir}/man8/coroipc_overview.8*
|
%{_mandir}/man8/coroipc_overview.8*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 6 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.97-1.svn2226
|
||||||
|
- New upstream release
|
||||||
|
- spec file updates:
|
||||||
|
* Drop pkgconfig fix that's now upstream
|
||||||
|
* Update to svn version 2226
|
||||||
|
* Define buildtrunk if we are using svn snapshots
|
||||||
|
* BuildRequires: nss-devel to enable nss crypto for network communication
|
||||||
|
* Force autogen invokation if buildtrunk is defined
|
||||||
|
* Whitespace cleanup
|
||||||
|
* Stop shipping corosync.conf in favour of a generic example
|
||||||
|
* Update file list
|
||||||
|
|
||||||
* Mon Mar 30 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.95-2
|
* Mon Mar 30 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.95-2
|
||||||
- Backport svn commit 1913 to fix pkgconfig files generation
|
- Backport svn commit 1913 to fix pkgconfig files generation
|
||||||
and unbreak lvm2 build.
|
and unbreak lvm2 build.
|
||||||
|
@ -1,24 +0,0 @@
|
|||||||
diff -Naurd corosync-0.95.orig/pkgconfig/Makefile.am corosync-0.95/pkgconfig/Makefile.am
|
|
||||||
--- corosync-0.95.orig/pkgconfig/Makefile.am 2009-03-22 19:44:33.000000000 +0100
|
|
||||||
+++ corosync-0.95/pkgconfig/Makefile.am 2009-03-30 08:48:32.000000000 +0200
|
|
||||||
@@ -44,7 +44,7 @@
|
|
||||||
-e 's#@PREFIX@#$(exec_prefix)#g' \
|
|
||||||
-e 's#@LIBDIR@#$(libdir)#g' \
|
|
||||||
-e 's#@LIBVERSION@#$(VERSION)#g' \
|
|
||||||
- -e 's#@LIB@#'$@'#g' \
|
|
||||||
+ -e 's#@LIB@#'$(@:lib%=%)'#g' \
|
|
||||||
> $@.pc;
|
|
||||||
touch $@
|
|
||||||
|
|
||||||
diff -Naurd corosync-0.95.orig/pkgconfig/Makefile.in corosync-0.95/pkgconfig/Makefile.in
|
|
||||||
--- corosync-0.95.orig/pkgconfig/Makefile.in 2009-03-23 23:14:38.000000000 +0100
|
|
||||||
+++ corosync-0.95/pkgconfig/Makefile.in 2009-03-30 08:48:56.000000000 +0200
|
|
||||||
@@ -353,7 +353,7 @@
|
|
||||||
-e 's#@PREFIX@#$(exec_prefix)#g' \
|
|
||||||
-e 's#@LIBDIR@#$(libdir)#g' \
|
|
||||||
-e 's#@LIBVERSION@#$(VERSION)#g' \
|
|
||||||
- -e 's#@LIB@#'$@'#g' \
|
|
||||||
+ -e 's#@LIB@#'$(@:lib%=%)'#g' \
|
|
||||||
> $@.pc;
|
|
||||||
touch $@
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user