107 lines
3.2 KiB
Diff
107 lines
3.2 KiB
Diff
diff -urNp coreutils-6.11-orig/tests/test-lib.sh coreutils-6.11/tests/test-lib.sh
|
|
--- coreutils-6.11-orig/tests/test-lib.sh 2008-04-19 23:34:23.000000000 +0200
|
|
+++ coreutils-6.11/tests/test-lib.sh 2008-04-24 14:18:59.000000000 +0200
|
|
@@ -97,8 +97,8 @@ skip_if_()
|
|
|
|
require_selinux_()
|
|
{
|
|
- case `ls -Zd .` in
|
|
- '? .'|'unlabeled .')
|
|
+ case `ls --scontext -d . | cut -f1 -d" "` in
|
|
+ '?'|'unlabeled')
|
|
skip_test_ "this system (or maybe just" \
|
|
"the current file system) lacks SELinux support"
|
|
;;
|
|
diff -urNp coreutils-7.1-orig/src/ls.c coreutils-7.1/src/ls.c
|
|
--- coreutils-7.1-orig/src/ls.c 2009-02-25 13:23:59.000000000 +0100
|
|
+++ coreutils-7.1/src/ls.c 2009-02-25 13:25:20.000000000 +0100
|
|
@@ -38,10 +38,6 @@
|
|
#include <config.h>
|
|
#include <sys/types.h>
|
|
|
|
-#ifdef HAVE_CAP
|
|
-# include <sys/capability.h>
|
|
-#endif
|
|
-
|
|
#if HAVE_TERMIOS_H
|
|
# include <termios.h>
|
|
#endif
|
|
@@ -84,6 +80,10 @@
|
|
#include "system.h"
|
|
#include <fnmatch.h>
|
|
|
|
+#ifdef HAVE_CAP
|
|
+# include <sys/capability.h>
|
|
+#endif
|
|
+
|
|
#include "acl.h"
|
|
#include "argmatch.h"
|
|
#include "dev-ino.h"
|
|
diff -urNp coreutils-8.1-orig/tests/touch/no-dereference coreutils-8.1/tests/touch/no-dereference
|
|
--- coreutils-8.1-orig/tests/touch/no-dereference 2009-10-30 12:51:07.000000000 +0100
|
|
+++ coreutils-8.1/tests/touch/no-dereference 2009-11-27 13:31:10.000000000 +0100
|
|
@@ -46,6 +46,8 @@ test -f nowhere && fail=1
|
|
grep '^#define HAVE_UTIMENSAT' "$CONFIG_HEADER" > /dev/null ||
|
|
grep '^#define HAVE_LUTIMES' "$CONFIG_HEADER" > /dev/null ||
|
|
skip_test_ 'this system lacks the utimensat function'
|
|
+grep '^#define HAVE_WORKINGKOJI' "$CONFIG_HEADER" > /dev/null ||
|
|
+ skip_test_ 'rest of the test disabled due to koji lack of utimensat function'
|
|
|
|
# Changing time of dangling symlink is okay.
|
|
touch -h dangling || fail=1
|
|
diff -urNp coreutils-8.2-orig/gnulib-tests/gnulib.mk coreutils-8.2/gnulib-tests/gnulib.mk
|
|
--- coreutils-8.2-orig/gnulib-tests/gnulib.mk 2009-12-11 17:54:36.850815863 +0100
|
|
+++ coreutils-8.2/gnulib-tests/gnulib.mk 2009-12-11 18:03:01.034460289 +0100
|
|
@@ -233,9 +233,9 @@ EXTRA_DIST += test-chown.h test-chown.c
|
|
|
|
## begin gnulib module cloexec-tests
|
|
|
|
-TESTS += test-cloexec
|
|
-check_PROGRAMS += test-cloexec
|
|
-EXTRA_DIST += test-cloexec.c
|
|
+#TESTS += test-cloexec
|
|
+#check_PROGRAMS += test-cloexec
|
|
+#EXTRA_DIST += test-cloexec.c
|
|
|
|
## end gnulib module cloexec-tests
|
|
|
|
@@ -293,9 +293,9 @@ EXTRA_DIST += test-dirname.c
|
|
|
|
## begin gnulib module dup2-tests
|
|
|
|
-TESTS += test-dup2
|
|
-check_PROGRAMS += test-dup2
|
|
-EXTRA_DIST += test-dup2.c
|
|
+#TESTS += test-dup2
|
|
+#check_PROGRAMS += test-dup2
|
|
+#EXTRA_DIST += test-dup2.c
|
|
|
|
## end gnulib module dup2-tests
|
|
|
|
@@ -337,9 +337,9 @@ EXTRA_DIST += test-exclude.c test-exclud
|
|
|
|
## begin gnulib module fchdir-tests
|
|
|
|
-TESTS += test-fchdir
|
|
-check_PROGRAMS += test-fchdir
|
|
-EXTRA_DIST += test-fchdir.c
|
|
+#TESTS += test-fchdir
|
|
+#check_PROGRAMS += test-fchdir
|
|
+#EXTRA_DIST += test-fchdir.c
|
|
|
|
## end gnulib module fchdir-tests
|
|
|
|
@@ -1463,9 +1463,9 @@ EXTRA_DIST += test-uname.c
|
|
|
|
## begin gnulib module unistd-safer-tests
|
|
|
|
-TESTS += test-dup-safer
|
|
-check_PROGRAMS += test-dup-safer
|
|
-EXTRA_DIST += test-dup-safer.c
|
|
+#TESTS += test-dup-safer
|
|
+#check_PROGRAMS += test-dup-safer
|
|
+#EXTRA_DIST += test-dup-safer.c
|
|
|
|
## end gnulib module unistd-safer-tests
|
|
|