diff --git a/coreutils-9.2-cksum-check.patch b/coreutils-9.2-cksum-check.patch
deleted file mode 100644
index 362bf2e..0000000
--- a/coreutils-9.2-cksum-check.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From b9fa05c7f08581b175d87b94fb751643dda53187 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?P=C3=A1draig=20Brady?=
-Date: Thu, 23 Mar 2023 12:31:24 +0000
-Subject: [PATCH] cksum: fix reporting of failed checks
-
-This applies to all checksumming utilities,
-where we incorrectly report all subsequent files as checking 'OK'
-once any file has passed a digest check.
-The exit status was not impacted, only the printed status.
-
-* src/digest.c (digest_check): Use the correct state variable
-to determine if the _current_ file has passed or not.
-* tests/misc/md5sum.pl: Add a test case.
-Fixes https://bugs.gnu.org/62403
-
-Upstream-commit: 76f2fb627118a26c25003dbd98c22c153b7ee1d2
-Signed-off-by: Kamil Dudka
----
- src/digest.c | 4 ++--
- tests/misc/md5sum.pl | 10 ++++++++++
- 2 files changed, 12 insertions(+), 2 deletions(-)
-
-diff --git a/src/digest.c b/src/digest.c
-index 6ee8a48..ab32968 100644
---- a/src/digest.c
-+++ b/src/digest.c
-@@ -1254,14 +1254,14 @@ digest_check (char const *checkfile_name)
-
- if (!status_only)
- {
-- if ( ! matched_checksums || ! quiet)
-+ if (! match || ! quiet)
- {
- if (needs_escape)
- putchar ('\\');
- print_filename (filename, needs_escape);
- }
-
-- if ( ! matched_checksums)
-+ if (! match)
- printf (": %s\n", _("FAILED"));
- else if (!quiet)
- printf (": %s\n", _("OK"));
-diff --git a/tests/misc/md5sum.pl b/tests/misc/md5sum.pl
-index 186aca9..d712664 100755
---- a/tests/misc/md5sum.pl
-+++ b/tests/misc/md5sum.pl
-@@ -101,6 +101,16 @@ my @Tests =
- . "md5sum: WARNING: 1 line is improperly formatted\n"
- . "md5sum: WARNING: 2 computed checksums did NOT match\n"},
- {EXIT=> 1}],
-+ # Ensure we use appropriate state to track failures (broken in 9.2)
-+ ['check-multifail-state', '--check', '--warn',
-+ {IN=>{'f.md5' =>
-+ "$degenerate f\n"
-+ . "$degenerate g\n"
-+ . "$degenerate f\n" }},
-+ {AUX=> {f=> ''}}, {AUX=> {g=> 'a'}},
-+ {OUT=>"f: OK\ng: FAILED\nf: OK\n"},
-+ {ERR=>"md5sum: WARNING: 1 computed checksum did NOT match\n"},
-+ {EXIT=> 1}],
- # The sha1sum and md5sum drivers share a lot of code.
- # Ensure that md5sum does *not* share the part that makes
- # sha1sum accept BSD format.
---
-2.39.2
-
diff --git a/coreutils-9.2-cp-reflink.patch b/coreutils-9.2-cp-reflink.patch
deleted file mode 100644
index 34718a7..0000000
--- a/coreutils-9.2-cp-reflink.patch
+++ /dev/null
@@ -1,137 +0,0 @@
-From af99eb5e5e89b67ecdc582d4face2a4614d5cda8 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?P=C3=A1draig=20Brady?=
-Date: Thu, 23 Mar 2023 13:19:04 +0000
-Subject: [PATCH] copy: fix --reflink=auto to fallback in more cases
-
-On restricted systems like android or some containers,
-FICLONE could return EPERM, EACCES, or ENOTTY,
-which would have induced the command to fail to copy
-rather than falling back to a more standard copy.
-
-* src/copy.c (is_terminal_failure): A new function refactored
-from handle_clone_fail().
-(is_CLONENOTSUP): Merge in the handling of EACCES, ENOTTY, EPERM
-as they also pertain to determination of whether cloning is supported
-if we ever use this function in that context.
-(handle_clone_fail): Use is_terminal_failure() in all cases,
-so that we assume a terminal failure in less errno cases.
-Addresses https://bugs.gnu.org/62404
-
-Upstream-commit: 093a8b4bfaba60005f14493ce7ef11ed665a0176
-Signed-off-by: Kamil Dudka
----
- src/copy.c | 62 ++++++++++++++++++++++++++++++------------------------
- 1 file changed, 35 insertions(+), 27 deletions(-)
-
-diff --git a/src/copy.c b/src/copy.c
-index 3919787..f8ba058 100644
---- a/src/copy.c
-+++ b/src/copy.c
-@@ -278,15 +278,27 @@ create_hole (int fd, char const *name, bool punch_holes, off_t size)
- }
-
-
--/* Whether the errno from FICLONE, or copy_file_range
-- indicates operation is not supported for this file or file system. */
-+/* Whether the errno indicates the operation is a transient failure.
-+ I.e., a failure that would indicate the operation _is_ supported,
-+ but has failed in a terminal way. */
-+
-+static bool
-+is_terminal_error (int err)
-+{
-+ return err == EIO || err == ENOMEM || err == ENOSPC || err == EDQUOT;
-+}
-+
-+
-+/* Whether the errno from FICLONE, or copy_file_range indicates
-+ the operation is not supported/allowed for this file or process. */
-
- static bool
- is_CLONENOTSUP (int err)
- {
-- return err == ENOSYS || is_ENOTSUP (err)
-+ return err == ENOSYS || err == ENOTTY || is_ENOTSUP (err)
- || err == EINVAL || err == EBADF
-- || err == EXDEV || err == ETXTBSY;
-+ || err == EXDEV || err == ETXTBSY
-+ || err == EPERM || err == EACCES;
- }
-
-
-@@ -339,20 +351,18 @@ sparse_copy (int src_fd, int dest_fd, char **abuf, size_t buf_size,
- {
- copy_debug.offload = COPY_DEBUG_UNSUPPORTED;
-
-- if (is_CLONENOTSUP (errno))
-- break;
--
-- /* copy_file_range might not be enabled in seccomp filters,
-- so retry with a standard copy. EPERM can also occur
-- for immutable files, but that would only be in the edge case
-- where the file is made immutable after creating/truncating,
-+ /* Consider operation unsupported only if no data copied.
-+ For example, EPERM could occur if copy_file_range not enabled
-+ in seccomp filters, so retry with a standard copy. EPERM can
-+ also occur for immutable files, but that would only be in the
-+ edge case where the file is made immutable after creating,
- in which case the (more accurate) error is still shown. */
-- if (errno == EPERM && *total_n_read == 0)
-+ if (*total_n_read == 0 && is_CLONENOTSUP (errno))
- break;
-
- /* ENOENT was seen sometimes across CIFS shares, resulting in
- no data being copied, but subsequent standard copies succeed. */
-- if (errno == ENOENT && *total_n_read == 0)
-+ if (*total_n_read == 0 && errno == ENOENT)
- break;
-
- if (errno == EINTR)
-@@ -1172,17 +1182,15 @@ handle_clone_fail (int dst_dirfd, char const* dst_relname,
- char const* src_name, char const* dst_name,
- int dest_desc, bool new_dst, enum Reflink_type reflink_mode)
- {
-- /* If the clone operation is creating the destination,
-- then don't try and cater for all non transient file system errors,
-- and instead only cater for specific transient errors. */
-- bool transient_failure;
-- if (dest_desc < 0) /* currently for fclonefileat(). */
-- transient_failure = errno == EIO || errno == ENOMEM
-- || errno == ENOSPC || errno == EDQUOT;
-- else /* currently for FICLONE. */
-- transient_failure = ! is_CLONENOTSUP (errno);
--
-- if (reflink_mode == REFLINK_ALWAYS || transient_failure)
-+ /* When the clone operation fails, report failure only with errno values
-+ known to mean trouble when the clone is supported and called properly.
-+ Do not report failure merely because !is_CLONENOTSUP (errno),
-+ as systems may yield oddball errno values here with FICLONE.
-+ Also is_CLONENOTSUP() is not appropriate for the range of errnos
-+ possible from fclonefileat(), so it's more consistent to avoid. */
-+ bool report_failure = is_terminal_error (errno);
-+
-+ if (reflink_mode == REFLINK_ALWAYS || report_failure)
- error (0, errno, _("failed to clone %s from %s"),
- quoteaf_n (0, dst_name), quoteaf_n (1, src_name));
-
-@@ -1190,14 +1198,14 @@ handle_clone_fail (int dst_dirfd, char const* dst_relname,
- but cloned no data. */
- if (new_dst /* currently not for fclonefileat(). */
- && reflink_mode == REFLINK_ALWAYS
-- && ((! transient_failure) || lseek (dest_desc, 0, SEEK_END) == 0)
-+ && ((! report_failure) || lseek (dest_desc, 0, SEEK_END) == 0)
- && unlinkat (dst_dirfd, dst_relname, 0) != 0 && errno != ENOENT)
- error (0, errno, _("cannot remove %s"), quoteaf (dst_name));
-
-- if (! transient_failure)
-+ if (! report_failure)
- copy_debug.reflink = COPY_DEBUG_UNSUPPORTED;
-
-- if (reflink_mode == REFLINK_ALWAYS || transient_failure)
-+ if (reflink_mode == REFLINK_ALWAYS || report_failure)
- return false;
-
- return true;
---
-2.39.2
-
diff --git a/coreutils.spec b/coreutils.spec
index c634298..9900b6a 100644
--- a/coreutils.spec
+++ b/coreutils.spec
@@ -1,7 +1,7 @@
Summary: A set of basic GNU tools commonly used in shell scripts
Name: coreutils
-Version: 9.2
-Release: 4%{?dist}
+Version: 9.3
+Release: 1%{?dist}
License: GPL-3.0-or-later
Url: https://www.gnu.org/software/coreutils/
Source0: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
@@ -14,12 +14,6 @@ Source51: coreutils-provides.inc
Source105: coreutils-colorls.sh
Source106: coreutils-colorls.csh
-# cksum: fix reporting of failed checks (#2180056)
-Patch1: coreutils-9.2-cksum-check.patch
-
-# copy: fix --reflink=auto to fallback in more cases (#2180056)
-Patch2: coreutils-9.2-cp-reflink.patch
-
# do not make coreutils-single depend on /usr/bin/coreutils
%global __requires_exclude ^%{_bindir}/coreutils$
@@ -258,6 +252,9 @@ rm -f $RPM_BUILD_ROOT%{_infodir}/dir
%license COPYING
%changelog
+* Tue Apr 18 2023 Kamil Dudka - 9.3-1
+- new upstream release 9.3
+
* Tue Apr 11 2023 Lukáš Zaoral - 9.2-4
- migrate to SPDX license format
diff --git a/sources b/sources
index 5d14ac2..f5e06f7 100644
--- a/sources
+++ b/sources
@@ -1,2 +1,2 @@
-SHA512 (coreutils-9.2.tar.xz) = 7e3108fefba4ef995cc73c64ac5f4e09827a44649a97ddd624eb61d67ce82da5ed6dc8c0f79d3e269f5cdb7d43877a61ef5b93194dd905bec432a7e31f9f479c
-SHA512 (coreutils-9.2.tar.xz.sig) = 4219f3103d829841a11bf1fe42ae277a44347e555fbbaf48e5e87cce48deb96753cb6d25f2571b88685a164acb9f016ff7ea02346b799ce954599fa0124ef070
+SHA512 (coreutils-9.3.tar.xz) = 242271f212a6860bdc6c8d7e5c4f85ce66c1b48ef781aca9daa56e0fe7c2b7809ef72b4392120219fe5b687637c83ce89ceef8bb35f6274f43f8f968a6901694
+SHA512 (coreutils-9.3.tar.xz.sig) = 522a2072f8ef940228ccdd856a4041c3c16b98e309168ccf2066fe7c1013685ba6cdea8a7317dfa1f4507b37ca016ecedaf54438d4a5007927b0e1a8fd223eb5