New upstream release 7.5, remove already applied patches,defuzz few others
This commit is contained in:
parent
378338cdef
commit
e1052e34a1
@ -1 +1 @@
|
||||
coreutils-7.4.tar.xz
|
||||
coreutils-7.5.tar.xz
|
||||
|
@ -44,13 +44,13 @@ diff -urNp coreutils-7.0.orig/README coreutils-7.0/README
|
||||
link ln logname ls md5sum mkdir mkfifo mknod mktemp mv nice nl nohup
|
||||
od paste pathchk pinky pr printenv printf ptx pwd readlink rm rmdir
|
||||
- runcon seq sha1sum sha224sum sha256sum sha384sum sha512sum shred shuf
|
||||
- sleep sort split stat stty su sum sync tac tail tee test timeout touch tr
|
||||
- true truncate tsort tty uname unexpand uniq unlink uptime users vdir wc who
|
||||
- whoami yes
|
||||
- sleep sort split stat stdbuf stty su sum sync tac tail tee test timeout
|
||||
- touch tr true truncate tsort tty uname unexpand uniq unlink uptime users
|
||||
- vdir wc who whoami yes
|
||||
+ runcon runuser seq sha1sum sha224sum sha256sum sha384sum sha512sum shred
|
||||
+ shuf sleep sort split stat stty su sum sync tac tail tee test timeout touch
|
||||
+ tr true truncate tsort tty uname unexpand uniq unlink uptime users vdir wc
|
||||
+ who whoami yes
|
||||
+ shuf sleep sort split stat stdbuf stty su sum sync tac tail tee test
|
||||
+ timeout touch tr true truncate tsort tty uname unexpand uniq unlink uptime
|
||||
+ users vdir wc who whoami yes
|
||||
|
||||
See the file NEWS for a list of major changes in the current release.
|
||||
|
||||
@ -355,13 +355,13 @@ diff -urNp coreutils-7.0.orig/src/su.c coreutils-7.0/src/su.c
|
||||
+#endif
|
||||
+ );
|
||||
}
|
||||
diff -urNp coreutils-7.0.orig/tests/misc/help-version coreutils-7.0/tests/misc/help-version
|
||||
--- coreutils-7.0.orig/tests/misc/help-version 2008-09-27 19:28:54.000000000 +0200
|
||||
+++ coreutils-7.0/tests/misc/help-version 2009-01-28 18:11:00.321247443 +0100
|
||||
@@ -148,6 +148,7 @@ printf_args=foo
|
||||
seq_args=10
|
||||
diff -urNp coreutils-7.5.orig/tests/misc/help-version coreutils-7.5/tests/misc/help-version
|
||||
--- coreutils-7.5.orig/tests/misc/help-version
|
||||
+++ coreutils-7.5/tests/misc/help-version
|
||||
@@ -150,6 +150,7 @@ printf_args=foo
|
||||
sleep_args=0
|
||||
su_args=--version
|
||||
stdbuf_args="-oL true"
|
||||
+runuser_args=--version
|
||||
timeout_args=--version
|
||||
|
||||
|
@ -7,10 +7,10 @@ diff -urNp coreutils-7.2-orig/gnulib-tests/gnulib.mk coreutils-7.2/gnulib-tests/
|
||||
|
||||
-TESTS += test-memchr
|
||||
-check_PROGRAMS += test-memchr
|
||||
-EXTRA_DIST += test-memchr.c
|
||||
-EXTRA_DIST += test-memchr.c zerosize-ptr.h
|
||||
+#TESTS += test-memchr
|
||||
+#check_PROGRAMS += test-memchr
|
||||
+#EXTRA_DIST += test-memchr.c
|
||||
+#EXTRA_DIST += test-memchr.c zerosize-ptr.h
|
||||
|
||||
## end gnulib module memchr-tests
|
||||
|
||||
|
@ -1,26 +0,0 @@
|
||||
diff -ruNp coreutils-7.4.orig/m4/jm-macros.m4 coreutils-7.4/m4/jm-macros.m4
|
||||
--- coreutils-7.4.orig/m4/jm-macros.m4 2009-08-05 10:27:30.660795719 +0200
|
||||
+++ coreutils-7.4/m4/jm-macros.m4 2009-08-05 10:30:46.912858189 +0200
|
||||
@@ -47,7 +47,21 @@ AC_DEFUN([coreutils_MACROS],
|
||||
AC_CHECK_FUNCS_ONCE([directio])
|
||||
|
||||
# Used by install.c.
|
||||
- AC_CHECK_FUNCS_ONCE([matchpathcon_init_prefix])
|
||||
+ coreutils_saved_libs=$LIBS
|
||||
+ LIBS="$LIBS $LIB_SELINUX"
|
||||
+ AC_CHECK_FUNCS([matchpathcon_init_prefix], [],
|
||||
+ [
|
||||
+ case "$ac_cv_search_setfilecon:$ac_cv_header_selinux_selinux_h" in
|
||||
+ no:*) # SELinux disabled
|
||||
+ ;;
|
||||
+ *:no) # SELinux disabled
|
||||
+ ;;
|
||||
+ *)
|
||||
+ AC_MSG_WARN([SELinux enabled, but matchpathcon_init_prefix not found])
|
||||
+ AC_MSG_WARN([The install utility may run slowly])
|
||||
+ esac
|
||||
+ ])
|
||||
+ LIBS=$coreutils_saved_libs
|
||||
|
||||
# Used by sort.c.
|
||||
AC_CHECK_FUNCS_ONCE([nl_langinfo])
|
@ -1,92 +0,0 @@
|
||||
diff -ruNp coreutils-7.4.orig/src/ls.c coreutils-7.4/src/ls.c
|
||||
--- coreutils-7.4.orig/src/ls.c 2009-08-05 10:14:46.397545653 +0200
|
||||
+++ coreutils-7.4/src/ls.c 2009-08-05 10:20:47.564858256 +0200
|
||||
@@ -2480,6 +2480,19 @@ print_dir (char const *name, char const
|
||||
DEV_INO_PUSH (dir_stat.st_dev, dir_stat.st_ino);
|
||||
}
|
||||
|
||||
+ if (recursive | print_dir_name)
|
||||
+ {
|
||||
+ if (!first)
|
||||
+ DIRED_PUTCHAR ('\n');
|
||||
+ first = false;
|
||||
+ DIRED_INDENT ();
|
||||
+ PUSH_CURRENT_DIRED_POS (&subdired_obstack);
|
||||
+ dired_pos += quote_name (stdout, realname ? realname : name,
|
||||
+ dirname_quoting_options, NULL);
|
||||
+ PUSH_CURRENT_DIRED_POS (&subdired_obstack);
|
||||
+ DIRED_FPUTS_LITERAL (":\n", stdout);
|
||||
+ }
|
||||
+
|
||||
/* Read the directory entries, and insert the subfiles into the `cwd_file'
|
||||
table. */
|
||||
|
||||
@@ -2519,7 +2532,8 @@ print_dir (char const *name, char const
|
||||
ls uses constant memory while processing the entries of
|
||||
this directory. Useful when there are many (millions)
|
||||
of entries in a directory. */
|
||||
- if (format == one_per_line && sort_type == sort_none)
|
||||
+ if (format == one_per_line && sort_type == sort_none
|
||||
+ && !print_block_size && !recursive)
|
||||
{
|
||||
/* We must call sort_files in spite of
|
||||
"sort_type == sort_none" for its initialization
|
||||
@@ -2555,19 +2569,6 @@ print_dir (char const *name, char const
|
||||
if (recursive)
|
||||
extract_dirs_from_files (name, command_line_arg);
|
||||
|
||||
- if (recursive | print_dir_name)
|
||||
- {
|
||||
- if (!first)
|
||||
- DIRED_PUTCHAR ('\n');
|
||||
- first = false;
|
||||
- DIRED_INDENT ();
|
||||
- PUSH_CURRENT_DIRED_POS (&subdired_obstack);
|
||||
- dired_pos += quote_name (stdout, realname ? realname : name,
|
||||
- dirname_quoting_options, NULL);
|
||||
- PUSH_CURRENT_DIRED_POS (&subdired_obstack);
|
||||
- DIRED_FPUTS_LITERAL (":\n", stdout);
|
||||
- }
|
||||
-
|
||||
if (format == long_format || print_block_size)
|
||||
{
|
||||
const char *p;
|
||||
diff -ruNp coreutils-7.4.orig/tests/misc/ls-misc coreutils-7.4/tests/misc/ls-misc
|
||||
--- coreutils-7.4.orig/tests/misc/ls-misc 2009-04-24 14:50:28.000000000 +0200
|
||||
+++ coreutils-7.4/tests/misc/ls-misc 2009-08-05 10:20:47.564858256 +0200
|
||||
@@ -18,6 +18,7 @@
|
||||
use strict;
|
||||
|
||||
(my $program_name = $0) =~ s|.*/||;
|
||||
+my $prog = 'ls';
|
||||
|
||||
# Turn off localization of executable's output.
|
||||
@ENV{qw(LANGUAGE LANG LC_ALL)} = ('C') x 3;
|
||||
@@ -224,6 +225,18 @@ my @Tests =
|
||||
{PRE => sub { mk_file @v_files }},
|
||||
{POST => sub { unlink @v_files }},
|
||||
],
|
||||
+
|
||||
+ # Test for the ls -1U bug fixed in coreutils-7.5.
|
||||
+ # It is triggered only with -1U and with two or more arguments,
|
||||
+ # at least one of which is a nonempty directory.
|
||||
+ ['multi-arg-U1', '-U1 d no-such',
|
||||
+ {OUT => "d:\nf\n"},
|
||||
+ {ERR_SUBST=>'s/ch:.*/ch:/'},
|
||||
+ {ERR => "$prog: cannot access no-such:\n"},
|
||||
+ $mkdir_reg,
|
||||
+ $rmdir_reg,
|
||||
+ {EXIT => 2},
|
||||
+ ],
|
||||
);
|
||||
|
||||
# Start with an unset LS_COLORS environment variable.
|
||||
@@ -232,8 +245,6 @@ delete $ENV{LS_COLORS};
|
||||
my $save_temps = $ENV{SAVE_TEMPS};
|
||||
my $verbose = $ENV{VERBOSE};
|
||||
|
||||
-my $prog = 'ls';
|
||||
-
|
||||
setuid_setup;
|
||||
my $fail = run_tests ($program_name, $prog, \@Tests, $save_temps, $verbose);
|
||||
$fail
|
@ -2089,7 +2089,7 @@ diff -urNp coreutils-6.11-orig/src/join.c coreutils-6.11/src/join.c
|
||||
while (blanks[to_uchar (*a)])
|
||||
a++;
|
||||
@@ -1510,6 +1813,25 @@
|
||||
return strnumcmp (a, b, decimal_point, thousands_sep);
|
||||
: strnumcmp (a, b, decimal_point, thousands_sep));
|
||||
}
|
||||
|
||||
+#if HAVE_MBRTOWC
|
||||
@ -2202,7 +2202,7 @@ diff -urNp coreutils-6.11-orig/src/join.c coreutils-6.11/src/join.c
|
||||
-keycompare (const struct line *a, const struct line *b)
|
||||
+keycompare_uni (const struct line *a, const struct line *b)
|
||||
{
|
||||
struct keyfield const *key = keylist;
|
||||
struct keyfield *key = keylist;
|
||||
|
||||
@@ -1875,6 +2265,181 @@
|
||||
return key->reverse ? -diff : diff;
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: A set of basic GNU tools commonly used in shell scripts
|
||||
Name: coreutils
|
||||
Version: 7.4
|
||||
Release: 6%{?dist}
|
||||
Version: 7.5
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: System Environment/Base
|
||||
Url: http://www.gnu.org/software/coreutils/
|
||||
@ -18,8 +18,6 @@ Source202: coreutils-su-l.pamd
|
||||
Source203: coreutils-runuser-l.pamd
|
||||
|
||||
# From upstream
|
||||
Patch1: coreutils-7.4-ls-1U.patch
|
||||
Patch2: coreutils-7.4-install-SELinux.patch
|
||||
|
||||
# Our patches
|
||||
Patch100: coreutils-6.10-configuration.patch
|
||||
@ -101,8 +99,6 @@ the old GNU fileutils, sh-utils, and textutils packages.
|
||||
%setup -q
|
||||
|
||||
# From upstream
|
||||
%patch1 -p1 -b .ls-1U
|
||||
%patch2 -p1 -b .install-SELinux
|
||||
|
||||
# Our patches
|
||||
%patch100 -p1 -b .configure
|
||||
@ -318,6 +314,10 @@ fi
|
||||
/sbin/runuser
|
||||
|
||||
%changelog
|
||||
* Fri Aug 21 2009 Ondrej Vasik <ovasik@redhat.com> - 7.5-1
|
||||
- New upstream release 7.5, remove already applied patches,
|
||||
defuzz few others
|
||||
|
||||
* Thu Aug 06 2009 Ondrej Vasik <ovasik@redhat.com> - 7.4-6
|
||||
- do process install-info only with info files present(#515970)
|
||||
- BuildRequires for xz, use xz tarball
|
||||
|
Loading…
Reference in New Issue
Block a user