drop build fixes no longer needed
This commit is contained in:
parent
59a39fa268
commit
a4f03c6bc0
@ -1,218 +0,0 @@
|
||||
From 54ef056964da3d0987afd9f1e96b9419db0d653a Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Thu, 1 Dec 2016 14:32:46 +0100
|
||||
Subject: [PATCH] coreutils-6.10-configuration.patch
|
||||
|
||||
TODO: check whether still necessary
|
||||
---
|
||||
gnulib-tests/gnulib.mk | 60 +++++++++++++++++++++----------------------
|
||||
man/local.mk | 2 +-
|
||||
tests/df/skip-duplicates.sh | 3 +++
|
||||
tests/local.mk | 2 +-
|
||||
tests/misc/nohup.sh | 2 ++
|
||||
tests/touch/no-dereference.sh | 2 ++
|
||||
6 files changed, 39 insertions(+), 32 deletions(-)
|
||||
|
||||
diff --git a/gnulib-tests/gnulib.mk b/gnulib-tests/gnulib.mk
|
||||
index fee978f..8f32431 100644
|
||||
--- a/gnulib-tests/gnulib.mk
|
||||
+++ b/gnulib-tests/gnulib.mk
|
||||
@@ -279,9 +279,9 @@ EXTRA_DIST += nap.h test-chown.h test-chown.c signature.h macros.h
|
||||
|
||||
## begin gnulib module cloexec-tests
|
||||
|
||||
-TESTS += test-cloexec
|
||||
-check_PROGRAMS += test-cloexec
|
||||
-EXTRA_DIST += test-cloexec.c macros.h
|
||||
+#TESTS += test-cloexec
|
||||
+#check_PROGRAMS += test-cloexec
|
||||
+#EXTRA_DIST += test-cloexec.c macros.h
|
||||
|
||||
## end gnulib module cloexec-tests
|
||||
|
||||
@@ -392,9 +392,9 @@ EXTRA_DIST += test-dup.c signature.h macros.h
|
||||
|
||||
## begin gnulib module dup2-tests
|
||||
|
||||
-TESTS += test-dup2
|
||||
-check_PROGRAMS += test-dup2
|
||||
-EXTRA_DIST += test-dup2.c signature.h macros.h
|
||||
+#TESTS += test-dup2
|
||||
+#check_PROGRAMS += test-dup2
|
||||
+#EXTRA_DIST += test-dup2.c signature.h macros.h
|
||||
|
||||
## end gnulib module dup2-tests
|
||||
|
||||
@@ -453,10 +453,10 @@ EXTRA_DIST += test-fadvise.c
|
||||
|
||||
## begin gnulib module fchdir-tests
|
||||
|
||||
-TESTS += test-fchdir
|
||||
-check_PROGRAMS += test-fchdir
|
||||
-test_fchdir_LDADD = $(LDADD) $(LIBINTL)
|
||||
-EXTRA_DIST += test-fchdir.c signature.h macros.h
|
||||
+#TESTS += test-fchdir
|
||||
+#check_PROGRAMS += test-fchdir
|
||||
+#test_fchdir_LDADD = $(LDADD) $(LIBINTL)
|
||||
+#EXTRA_DIST += test-fchdir.c signature.h macros.h
|
||||
|
||||
## end gnulib module fchdir-tests
|
||||
|
||||
@@ -900,9 +900,9 @@ EXTRA_DIST += test-getloadavg.c signature.h
|
||||
|
||||
## begin gnulib module getlogin-tests
|
||||
|
||||
-TESTS += test-getlogin
|
||||
-check_PROGRAMS += test-getlogin
|
||||
-EXTRA_DIST += test-getlogin.c signature.h macros.h
|
||||
+#TESTS += test-getlogin
|
||||
+#check_PROGRAMS += test-getlogin
|
||||
+#EXTRA_DIST += test-getlogin.c signature.h macros.h
|
||||
|
||||
## end gnulib module getlogin-tests
|
||||
|
||||
@@ -1148,10 +1148,10 @@ EXTRA_DIST += test-link.h test-link.c signature.h macros.h
|
||||
|
||||
## begin gnulib module linkat-tests
|
||||
|
||||
-TESTS += test-linkat
|
||||
-check_PROGRAMS += test-linkat
|
||||
-test_linkat_LDADD = $(LDADD) @LIBINTL@
|
||||
-EXTRA_DIST += test-link.h test-linkat.c signature.h macros.h
|
||||
+#TESTS += test-linkat
|
||||
+#check_PROGRAMS += test-linkat
|
||||
+#test_linkat_LDADD = $(LDADD) @LIBINTL@
|
||||
+#EXTRA_DIST += test-link.h test-linkat.c signature.h macros.h
|
||||
|
||||
## end gnulib module linkat-tests
|
||||
|
||||
@@ -1360,9 +1360,9 @@ EXTRA_DIST += test-memcoll.c macros.h
|
||||
|
||||
## begin gnulib module memrchr-tests
|
||||
|
||||
-TESTS += test-memrchr
|
||||
-check_PROGRAMS += test-memrchr
|
||||
-EXTRA_DIST += test-memrchr.c zerosize-ptr.h signature.h macros.h
|
||||
+#TESTS += test-memrchr
|
||||
+#check_PROGRAMS += test-memrchr
|
||||
+#EXTRA_DIST += test-memrchr.c zerosize-ptr.h signature.h macros.h
|
||||
|
||||
## end gnulib module memrchr-tests
|
||||
|
||||
@@ -1913,9 +1913,9 @@ EXTRA_DIST += test-statat.c
|
||||
|
||||
## begin gnulib module stdalign-tests
|
||||
|
||||
-TESTS += test-stdalign
|
||||
-check_PROGRAMS += test-stdalign
|
||||
-EXTRA_DIST += test-stdalign.c macros.h
|
||||
+#TESTS += test-stdalign
|
||||
+#check_PROGRAMS += test-stdalign
|
||||
+#EXTRA_DIST += test-stdalign.c macros.h
|
||||
|
||||
## end gnulib module stdalign-tests
|
||||
|
||||
@@ -2270,9 +2270,9 @@ EXTRA_DIST += test-uname.c signature.h macros.h
|
||||
|
||||
## begin gnulib module unistd-safer-tests
|
||||
|
||||
-TESTS += test-dup-safer
|
||||
-check_PROGRAMS += test-dup-safer
|
||||
-EXTRA_DIST += test-dup-safer.c macros.h
|
||||
+#TESTS += test-dup-safer
|
||||
+#check_PROGRAMS += test-dup-safer
|
||||
+#EXTRA_DIST += test-dup-safer.c macros.h
|
||||
|
||||
## end gnulib module unistd-safer-tests
|
||||
|
||||
@@ -2368,10 +2368,10 @@ EXTRA_DIST += test-userspec.c
|
||||
|
||||
## begin gnulib module utimens-tests
|
||||
|
||||
-TESTS += test-utimens
|
||||
-check_PROGRAMS += test-utimens
|
||||
-test_utimens_LDADD = $(LDADD) $(LIB_CLOCK_GETTIME) $(LIB_NANOSLEEP) @LIBINTL@
|
||||
-EXTRA_DIST += nap.h test-futimens.h test-lutimens.h test-utimens.h test-utimens-common.h test-utimens.c macros.h
|
||||
+#TESTS += test-utimens
|
||||
+#check_PROGRAMS += test-utimens
|
||||
+#test_utimens_LDADD = $(LDADD) $(LIB_CLOCK_GETTIME) $(LIB_NANOSLEEP) @LIBINTL@
|
||||
+#EXTRA_DIST += nap.h test-futimens.h test-lutimens.h test-utimens.h test-utimens-common.h test-utimens.c macros.h
|
||||
|
||||
## end gnulib module utimens-tests
|
||||
|
||||
diff --git a/man/local.mk b/man/local.mk
|
||||
index a39bb65..535690c 100644
|
||||
--- a/man/local.mk
|
||||
+++ b/man/local.mk
|
||||
@@ -41,7 +41,7 @@ distclean-local:
|
||||
test x$(srcdir) = x$(builddir) || rm -f $(ALL_MANS)
|
||||
|
||||
# Dependencies common to all man pages. Updated below.
|
||||
-mandeps =
|
||||
+mandeps = $(PROGRAMS)
|
||||
|
||||
# Depend on this to get version number changes.
|
||||
mandeps += .version
|
||||
diff --git a/tests/df/skip-duplicates.sh b/tests/df/skip-duplicates.sh
|
||||
index f349263..9854f8d 100755
|
||||
--- a/tests/df/skip-duplicates.sh
|
||||
+++ b/tests/df/skip-duplicates.sh
|
||||
@@ -26,6 +26,9 @@ require_gcc_shared_
|
||||
df --local --output=target >LOCAL_FS || skip_ 'df fails'
|
||||
grep '^/$' LOCAL_FS || skip_ 'no root file system found'
|
||||
|
||||
+# mark it expensive, to temporarily skip the test in koji
|
||||
+expensive_
|
||||
+
|
||||
# Get real targets to substitute for /NONROOT and /REMOTE below.
|
||||
export CU_NONROOT_FS=$(grep /. LOCAL_FS | head -n1)
|
||||
export CU_REMOTE_FS=$(grep /. LOCAL_FS | tail -n+2 | head -n1)
|
||||
diff --git a/tests/local.mk b/tests/local.mk
|
||||
index 3335002..568944e 100644
|
||||
--- a/tests/local.mk
|
||||
+++ b/tests/local.mk
|
||||
@@ -134,6 +134,7 @@ all_root_tests = \
|
||||
tests/rm/no-give-up.sh \
|
||||
tests/rm/one-file-system.sh \
|
||||
tests/rm/read-only.sh \
|
||||
+ tests/tail-2/inotify-hash-abuse.sh \
|
||||
tests/tail-2/append-only.sh \
|
||||
tests/touch/now-owned-by-other.sh
|
||||
|
||||
@@ -168,7 +169,6 @@ all_tests = \
|
||||
tests/cp/link-heap.sh \
|
||||
tests/cp/no-ctx.sh \
|
||||
tests/misc/tty-eof.pl \
|
||||
- tests/tail-2/inotify-hash-abuse.sh \
|
||||
tests/tail-2/inotify-hash-abuse2.sh \
|
||||
tests/tail-2/F-vs-missing.sh \
|
||||
tests/tail-2/F-vs-rename.sh \
|
||||
diff --git a/tests/misc/nohup.sh b/tests/misc/nohup.sh
|
||||
index 1b43b60..3fd29e7 100755
|
||||
--- a/tests/misc/nohup.sh
|
||||
+++ b/tests/misc/nohup.sh
|
||||
@@ -19,6 +19,8 @@
|
||||
. "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
|
||||
print_ver_ nohup
|
||||
|
||||
+#mark it expensive, to temporarily skip the test in koji
|
||||
+expensive_
|
||||
|
||||
nohup sh -c 'echo stdout; echo stderr 1>&2' 2>err || fail=1
|
||||
|
||||
diff --git a/tests/touch/no-dereference.sh b/tests/touch/no-dereference.sh
|
||||
index 7994638..72b2222 100755
|
||||
--- a/tests/touch/no-dereference.sh
|
||||
+++ b/tests/touch/no-dereference.sh
|
||||
@@ -42,6 +42,8 @@ test -f nowhere && fail=1
|
||||
grep '^#define HAVE_UTIMENSAT 1' "$CONFIG_HEADER" > /dev/null ||
|
||||
grep '^#define HAVE_LUTIMES 1' "$CONFIG_HEADER" > /dev/null ||
|
||||
skip_ 'this system lacks the utimensat function'
|
||||
+grep '^#define HAVE_WORKINGKOJI 1' "$CONFIG_HEADER" > /dev/null ||
|
||||
+ skip_ 'rest of the test disabled due to koji lack of utimensat function'
|
||||
|
||||
# Changing time of dangling symlink is okay.
|
||||
# Skip the test if this fails, but the error text corresponds to
|
||||
--
|
||||
2.7.4
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff -urNp coreutils-8.22-orig/tests/df/df-symlink.sh coreutils-8.22/tests/df/df-symlink.sh
|
||||
--- coreutils-8.22-orig/tests/df/df-symlink.sh 2013-12-04 15:48:30.000000000 +0100
|
||||
+++ coreutils-8.22/tests/df/df-symlink.sh 2013-12-14 18:20:15.822594995 +0100
|
||||
@@ -18,6 +18,9 @@
|
||||
|
||||
. "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
|
||||
print_ver_ df
|
||||
+#df doesn't work correctly on symlinks when on LVM/LUKS filesystem, therefore
|
||||
+#marking expensive_ to disable by default
|
||||
+expensive_
|
||||
|
||||
disk=$(df --out=source '.' | tail -n1) ||
|
||||
skip_ "cannot determine '.' file system"
|
@ -1,7 +1,7 @@
|
||||
Summary: A set of basic GNU tools commonly used in shell scripts
|
||||
Name: coreutils
|
||||
Version: 8.26
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: GPLv3+
|
||||
Group: System Environment/Base
|
||||
Url: http://www.gnu.org/software/coreutils/
|
||||
@ -19,8 +19,6 @@ Source10: coreutils-find-requires.sh
|
||||
# disable the test-lock gnulib test prone to deadlock
|
||||
Patch1: coreutils-8.26-test-lock.patch
|
||||
|
||||
#general patch to workaround koji build system issues
|
||||
Patch100: coreutils-6.10-configuration.patch
|
||||
#add note about no difference between binary/text mode on Linux - md5sum manpage
|
||||
Patch101: coreutils-6.10-manpages.patch
|
||||
# downstream changes to default DIR_COLORS
|
||||
@ -56,8 +54,6 @@ Patch807: coreutils-i18n-sort-human.patch
|
||||
Patch908: coreutils-getgrouplist.patch
|
||||
#Prevent buffer overflow in who(1) (bug #158405).
|
||||
Patch912: coreutils-overflow.patch
|
||||
#Temporarily disable df symlink test, failing
|
||||
Patch913: coreutils-8.22-temporarytestoff.patch
|
||||
|
||||
#SELINUX Patch - implements Redhat changes
|
||||
#(upstream did some SELinux implementation unlike with RedHat patch)
|
||||
@ -301,6 +297,9 @@ fi
|
||||
%license COPYING
|
||||
|
||||
%changelog
|
||||
* Thu Dec 15 2016 Kamil Dudka <kdudka@redhat.com> - 8.26-3
|
||||
- drop build fixes no longer needed
|
||||
|
||||
* Fri Dec 02 2016 Kamil Dudka <kdudka@redhat.com> - 8.26-2
|
||||
- apply patches automatically to ease maintenance
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user